]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- do not include unapplied patches in sources (and get them tagged in cvs)
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - try to use external lrmi and few other libs:
5 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6 # - segfaults on amd64:
7 #   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8 #   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9 #
10 # Conditional build:
11 %bcond_with     directfb        # with DirectFB video output
12 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
13 %bcond_with     ggi             # with ggi video output
14 %bcond_with     nas             # with NAS audio output
15 %bcond_with     svga            # with svgalib video output
16 %bcond_with     osd             # with osd menu support
17 %bcond_without  altivec         # without altivec support
18 %bcond_without  x264            # without x264 support
19 %bcond_with     xmms            # with XMMS inputplugin support
20 %bcond_without  aalib           # without aalib video output
21 %bcond_without  jack            # without JACKD support
22 %bcond_without  alsa            # without ALSA audio output
23 %bcond_without  arts            # without arts audio output
24 %bcond_without  caca            # without libcaca video output
25 %bcond_without  cdparanoia      # without cdparanoia support
26 %bcond_without  dshow           # disable DirectShow support
27 %bcond_without  enca            # disable using ENCA charset oracle library
28 %bcond_without  esd             # disable EsounD sound support
29 %bcond_without  faad            # disable FAAD2 (AAC) support
30 %bcond_without  gif             # disable GIF support
31 %bcond_without  gui             # without GTK+ GUI
32 %bcond_without  joystick        # disable joystick support
33 %bcond_without  libdts          # disable libdts support
34 %bcond_without  libdv           # disable libdv en/decoding support
35 %bcond_without  lirc            # without lirc support
36 %bcond_with     live            # without LIVE555 libraries
37 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
38 %bcond_without  mad             # without mad (audio MPEG) support
39 %bcond_without  pulseaudio              # without pulseaudio output
40 %bcond_without  quicktime       # without binary quicktime dll support
41 %bcond_without  real            # without Real* 8/9 codecs support
42 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
43                                 #  in compile time (advertised by mplayer authors as working faster); in this case
44                                 #  mplayer may not work on machine other then where it was compiled
45 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
46 %bcond_without  smb             # disable Samba (SMB) input support
47 %bcond_without  theora          # without theora support
48 %bcond_without  win32           # without win32 codecs support
49 %bcond_without  vidix           # disable vidix
50 %bcond_without  vorbis          # without Ogg-Vorbis audio support
51 %bcond_without  xvid            # disable XviD codec
52 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
53 %bcond_without  sdl             # disable SDL
54 %bcond_without  doc             # don't build docs (slow)
55 %bcond_with     shared          # experimental libmplayer.so support
56 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
57 %bcond_without  gnomess         # disable controling gnome screensaver
58 %bcond_with     ssse3   # sse3 optimizations (needs binutils >= 2.16.92)
59
60 %ifnarch %{ix86}
61 %undefine       with_win32
62 %undefine       with_quicktime
63 %undefine       with_vidix
64 %endif
65
66 %ifnarch %{ix86} %{x8664} ppc ppc64
67 %undefine       with_runtime
68 %endif
69
70 %if %{_lib} == "lib64"
71 %define         _suf    64
72 %else
73 %define         _suf    32
74 %endif
75
76 %define         subver  rc2
77 %define         rel             5.5
78
79 Summary:        MPlayer - THE Movie Player for UN*X
80 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81 Summary(es.UTF-8):      Otro reproductor de películas
82 Summary(ko.UTF-8):      리눅스용 미디어플레이어
83 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
84 Summary(pt_BR.UTF-8):   Reprodutor de filmes
85 Name:           mplayer
86 Version:        1.0
87 Release:        5.%{subver}.%{rel}
88 # DO NOT increase epoch unless it's really neccessary!
89 # especially such changes like pre7->pre7try2, increase Release instead!
90 # PS: $ rpmvercmp pre7try2 pre7
91 # pre7try2 > pre7
92 Epoch:          3
93 License:        GPL
94 Group:          Applications/Multimedia
95 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{subver}.tar.bz2
96 # Source0-md5:  7e27e535c2d267637df34898f1b91707
97 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
98 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
99 Source5:        g%{name}.desktop
100 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
101 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
102 Source7:        %{name}.png
103 Source8:        %{name}.desktop
104 # http://www.on2.com/gpl/mplayer/
105 Source9:        http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106 # Source9-md5:  2361e56b40f52dfc20131e458e2aed38
107 Patch1:         %{name}-cp1250-fontdesc.patch
108 #Patch2:                %{name}-codec.patch
109 #Patch3:                %{name}-home_etc.patch
110 Patch4:         %{name}-350.patch
111 Patch5:         %{name}-configure.patch
112 # outdated via ffmpeg?
113 Patch6:         %{name}-system-amr.patch
114 Patch8:         %{name}-altivec.patch
115 #Patch10:       %{name}-pcmsplit.patch
116 #Patch13:       %{name}-mythtv.patch
117 Patch14:        %{name}-shared.patch
118 #http://www.openchrome.org/snapshots/mplayer/
119 #Patch15:       %{name}-xvmc.patch
120 Patch17:        %{name}-auto-expand.patch
121 # update
122 #Patch18:       %{name}-gnome-screensaver.patch
123 Patch19:        %{name}-on2flix.patch
124 Patch22:        %{name}-ffmpeg.patch
125 Patch23:        %{name}-live.patch
126 Patch24:        %{name}-fontconfig_sub.patch
127 Patch25:        http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
128 Patch26:        %{name}-check-byteswap.patch
129 Patch27:        http://www.mplayerhq.hu/MPlayer/patches/demux_mov_fix_20080129.diff
130 URL:            http://www.mplayerhq.hu/
131 %{?with_directfb:BuildRequires: DirectFB-devel}
132 BuildRequires:  OpenAL-devel
133 BuildRequires:  OpenGL-devel
134 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
135 %{?with_aalib:BuildRequires:    aalib-devel}
136 %{?with_alsa:BuildRequires:     alsa-lib-devel}
137 %if %{with amr}
138 BuildRequires:  amrnb-devel
139 BuildRequires:  amrwb-devel >= 5.3.0
140 %endif
141 %{?with_arts:BuildRequires:     artsc-devel}
142 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
143 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
144 %{?with_doc:BuildRequires:      docbook-style-xsl}
145 %{?with_dxr3:BuildRequires:     em8300-devel}
146 %{?with_enca:BuildRequires:     enca-devel}
147 %{?with_esd:BuildRequires:      esound-devel}
148 BuildRequires:  faac-devel
149 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
150 BuildRequires:  ffmpeg-devel >= 0.4.9-3.20070626.1.1
151 BuildRequires:  freetype-devel
152 BuildRequires:  fribidi-devel
153 %{?with_vidix:BuildRequires:    vidix-devel}
154 %ifarch ppc
155 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
156 %endif
157 %{?with_gif:BuildRequires:      giflib-devel}
158 %if %{with gui}
159 BuildRequires:  gtk+2-devel
160 %endif
161 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
162 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
163 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
164 BuildRequires:  lame-libs-devel
165 %{?with_caca:BuildRequires:     libcaca-devel}
166 %{?with_libdts:BuildRequires:   libdts-devel}
167 %{?with_libdv:BuildRequires:    libdv-devel}
168 BuildRequires:  libdvdnav-devel
169 %{?with_ggi:BuildRequires:      libggi-devel}
170 BuildRequires:  libjpeg-devel
171 %{?with_mad:BuildRequires:      libmad-devel}
172 BuildRequires:  libmpcdec-devel >= 1.2.1
173 BuildRequires:  libpng-devel
174 %{?with_smb:BuildRequires:      libsmbclient-devel}
175 %{?with_dshow:BuildRequires:    libstdc++-devel}
176 %{?with_theora:BuildRequires:   libtheora-devel}
177 # tremor is used by default, internal as we don't have system one
178 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
179 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060828_2245.1}
180 BuildRequires:  libxslt-progs
181 %{?with_lirc:BuildRequires:     lirc-devel}
182 %{?with_live:BuildRequires:     live}
183 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
184 %{?with_nas:BuildRequires:      nas-devel}
185 BuildRequires:  ncurses-devel
186 BuildRequires:  pkgconfig
187 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
188 BuildRequires:  speex-devel >= 1.1
189 %{?with_svga:BuildRequires:     svgalib-devel}
190 %{?with_xmms:BuildRequires:     xmms-libs}
191 BuildRequires:  xorg-lib-libX11-devel
192 BuildRequires:  xorg-lib-libXext-devel
193 BuildRequires:  xorg-lib-libXinerama-devel
194 BuildRequires:  xorg-lib-libXv-devel
195 BuildRequires:  xorg-lib-libXvMC-devel
196 BuildRequires:  xorg-lib-libXxf86dga-devel
197 BuildRequires:  xorg-lib-libXxf86vm-devel
198 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
199 BuildRequires:  zlib-devel
200 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
201 Requires:       OpenGL
202 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
203
204 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
205 %define         specflags_ia32  -fomit-frame-pointer
206 %if %{with altivec}
207 %define         specflags_ppc   -maltivec
208 %endif
209
210 %description
211 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
212 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
213 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
214 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
215 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
216 optionally with SHM extension, X11 using overlays with the Xvideo
217 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
218 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
219
220 If you want to use win32 codecs install w32codec package.
221
222 %description -l de.UTF-8
223 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
224 Kennzeichnend ist die herausragende Format- und
225 Plattform-Kompatibilität.
226
227 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
228 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
229 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
230 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
231 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
232 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
233 installierte Codecs nicht mit MPlayer kollidieren können.
234
235 %description -l es.UTF-8
236 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
237 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
238 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
239 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
240 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
241 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
242 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
243 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
244 v1.1.7 etc.
245
246 Si quiere usar codecs Win32, instale el paquete w32codec.
247
248 %description -l ko.UTF-8
249 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
250 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
251 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
252 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
253 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
254 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
255 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
256 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
257 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
258
259 %description -l pl.UTF-8
260 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
261 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
262 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
263 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
264 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
265 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
266 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
267
268 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
269
270 %description -l pt_BR.UTF-8
271 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
272 áudio. Diferentes mecanismos de reprodução podem também ser
273 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
274
275 %package -n gmplayer
276 Summary:        MPlayer with GTK+ GUI interface
277 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
278 Group:          X11/Applications/Multimedia
279 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
280 Requires:       %{name}-skin
281 Provides:       %{name} = %{epoch}:%{version}-%{release}
282
283 %description -n gmplayer
284 MPlayer with GUI GTK+ interface.
285
286 %description -n gmplayer -l pl.UTF-8
287 MPlayer z graficznym interfejsem GTK+.
288
289 %package common
290 Summary:        Configuration files and documentation for MPlayer
291 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
292 Group:          Applications/Multimedia
293 Obsoletes:      mplayer-vidix
294
295 %description common
296 Configuration files, man page and HTML documentation for MPlayer.
297
298 %description common -l pl.UTF-8
299 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
300
301 %package -n mencoder
302 Summary:        MEncoder - a movie encoder for Linux
303 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
304 Group:          Applications/Multimedia
305 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
306
307 %description -n mencoder
308 MEncoder is a movie encoder for Linux and is a part of the MPlayer
309 package.
310
311 %description -n mencoder -l pl.UTF-8
312 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
313
314 %prep
315 %setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
316 cp -f etc/codecs.conf etc/codecs.win32.conf
317 %patch1 -p0
318 #%patch2 -p1 -- still needed?
319 ##%patch3 -p1   -- old home_etc behavior
320 %patch4 -p1
321 %patch5 -p1
322 #%patch6 -p1 # - try ffmpeg
323 %patch8 -p1
324 #%%patch10 -p1
325 #%patch13 -p1   # TODO
326 %if %{with shared}
327 %patch14 -p1
328 %endif
329 #%patch15 -p0   # TODO
330 %patch17 -p1
331 %if %{with gnomess}
332 #%patch18 -p1
333 %endif
334
335 # on2flix
336 cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
337 rm -f mencoder-on2flixenglinux/version.diff
338 %patch19 -p1
339 for a in mencoder-on2flixenglinux/*.diff; do
340         patch -p0 < $a
341 done
342
343 %patch22 -p1
344 %patch23 -p1
345 %patch24 -p0
346 cd stream
347 %patch25 -p0
348 cd -
349 %patch26 -p1
350 %patch27 -p0
351
352 %build
353 %if %{with shared}
354 CFLAGS="%{rpmcflags} -fPIC"
355 %else
356 CFLAGS="%{rpmcflags}"
357 %endif
358 CC="%{__cc}"
359 LDFLAGS="%{rpmldflags}"
360 export CC CFLAGS LDFLAGS
361
362 build() {
363 set -x
364         ./configure \
365         %{?debug:--enable-debug=3} \
366         --prefix=%{_prefix} \
367         --confdir=%{_sysconfdir}/mplayer \
368         --with-extraincdir=%{_includedir}/xvid \
369         --with-extralibdir=%{_x_libraries} \
370         --enable-menu \
371         --disable-libavutil_a \
372         --disable-libavcodec_a \
373         --disable-libavformat_a \
374         --disable-libpostproc_a \
375         --enable-libavutil_so \
376         --enable-libavcodec_so \
377         --enable-libavformat_so \
378         --enable-libpostproc_so \
379 %ifnarch %{ix86} %{x8664}
380         --disable-mmx \
381         --disable-mmxext \
382         --disable-3dnow \
383         --disable-3dnowext \
384         --disable-sse \
385         --disable-sse2 \
386         --disable-fastmemcpy \
387 %endif
388         %{!?with_ssse3:--disable-ssse3} \
389 %ifarch ppc
390 %{!?with_altivec:--disable-altivec} \
391 %endif
392 %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
393 %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
394 %{?with_directfb:--enable-directfb} \
395 %{!?with_directfb:--disable-directfb} \
396 %{!?with_dxr3:--disable-dxr3} \
397 %{!?with_ggi:--disable-ggi} \
398 %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
399 %{!?with_live:--disable-live} \
400 %{!?with_lzo:--disable-liblzo} \
401 %{!?with_nas:--disable-nas} \
402 %{!?with_svga:--disable-svga} \
403 %{!?with_aalib:--disable-aa} \
404 %{!?with_jack:--disable-jack} \
405 %{!?with_alsa:--disable-alsa} \
406 %{?with_alsa:--enable-alsa --disable-select} \
407 %{!?with_arts:--disable-arts} \
408 %{!?with_caca:--disable-caca} \
409 %{!?with_cdparanoia:--disable-cdparanoia} \
410 %{!?with_dshow:--disable-dshow} \
411 %{!?with_enca:--disable-enca} \
412 %{!?with_esd:--disable-esd} \
413 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
414 %{?with_faad:--disable-faad-internal} \
415 %{!?with_gif:--disable-gif} \
416 %{?with_joystick:--enable-joystick} \
417 %{!?with_libdv:--disable-libdv} \
418 %{!?with_libdts:--disable-libdts} \
419 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
420 %{!?with_mad:--disable-mad} \
421 %{!?with_pulseaudio:--disable-pulse} \
422 %{!?with_quicktime:--disable-qtx} \
423 %{!?with_real:--disable-real} \
424 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
425 %{!?with_select:--disable-select} \
426 %{!?with_smb:--disable-smb} \
427 %{!?with_win32:--disable-win32dll} \
428 %{!?with_vorbis:--disable-vorbis} \
429 %{?with_osd:--enable-menu} \
430 %{!?with_theora:--disable-theora} \
431 %{!?with_x264:--disable-x264} \
432 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
433 %{!?with_xvid:--disable-xvid} \
434 %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
435 %{?with_vidix:--disable-vidix-internal} \
436 %{!?with_mencoder:--disable-mencoder} \
437         --enable-dga1 \
438         --enable-dga2 \
439         --enable-fbdev \
440         --enable-gl \
441         --enable-mga \
442         --enable-radio \
443         --enable-radio-capture \
444         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
445         --enable-tdfxfb \
446         --enable-vm \
447         --enable-x11 \
448         --enable-xmga \
449         --enable-xv \
450         --enable-xvmc \
451         --enable-dynamic-plugins \
452         --enable-largefiles \
453         --language=all \
454         --codecsdir=%{_libdir}/codecs \
455         --with-xvmclib=XvMCW \
456         "$@"
457
458         %{__make}
459 }
460
461 %if %{with gui}
462 # build GUI version
463 build --enable-gui --disable-mencoder
464 mv -f mplayer gmplayer
465 %{__make} distclean
466 %endif
467
468 # now build regular version
469 build --disable-gui
470
471 %if %{with doc}
472 %{__make} -j1 -C DOCS/xml
473 %endif
474
475 %install
476 rm -rf $RPM_BUILD_ROOT
477 install -d \
478         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
479         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
480         $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
481         $RPM_BUILD_ROOT%{_desktopdir}
482
483 # default config files
484 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
485 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
486
487 # executables
488 %if %{with mencoder}
489 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
490 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
491 %endif
492 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
493 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
494 %if %{with gui}
495 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
496 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
497 %endif
498
499 # fonts
500 rm -f font-*/runme
501 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
502 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
503
504 %if %{with gui}
505 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
506 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
507 %endif
508 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
509 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
510
511 # man pages
512 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
513 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
514 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
515 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
516 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
517 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
518 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
519 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
520 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
521 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
522
523 %clean
524 rm -rf $RPM_BUILD_ROOT
525
526 %post -n gmplayer
527 umask 022
528 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
529
530 %postun -n gmplayer
531 umask 022
532 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
533
534 %files
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_bindir}/mplayer*
537
538 %if %{with gui}
539 %files -n gmplayer
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_bindir}/gmplayer*
542 %{_desktopdir}/gmplayer.desktop
543 %dir %{_datadir}/%{name}/skins
544 #%ghost %{_datadir}/%{name}/skins/default
545 %endif
546
547 %if %{with mencoder}
548 %files -n mencoder
549 %defattr(644,root,root,755)
550 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
551 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
552 %doc DOCS/tech/colorspaces.txt
553 %attr(755,root,root) %{_bindir}/mencoder*
554 %endif
555
556 %files common
557 %defattr(644,root,root,755)
558 %doc DOCS/tech
559 %if %{with win32}
560 %doc etc/codecs.win32.conf
561 %endif
562 %if %{with doc}
563 # HTML and XML-generated docs
564 %doc DOCS/HTML/en
565 %lang(cs) %doc DOCS/HTML/cs
566 %lang(de) %doc DOCS/HTML/de
567 %lang(es) %doc DOCS/HTML/es
568 %lang(fr) %doc DOCS/HTML/fr
569 %lang(hu) %doc DOCS/HTML/hu
570 %lang(pl) %doc DOCS/HTML/pl
571 %lang(ru) %doc DOCS/HTML/ru
572 #%lang(zh_CN) %doc DOCS/zh
573 %endif
574 %doc AUTHORS README
575
576 %dir %{_sysconfdir}/%{name}
577 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
578 %{_mandir}/man1/*
579 %lang(cs) %{_mandir}/cs/man1/*
580 %lang(de) %{_mandir}/de/man1/*
581 %lang(es) %{_mandir}/es/man1/*
582 %lang(fr) %{_mandir}/fr/man1/*
583 %lang(hu) %{_mandir}/hu/man1/*
584 %lang(it) %{_mandir}/it/man1/*
585 %lang(pl) %{_mandir}/pl/man1/*
586 #%lang(sv) %{_mandir}/sv/man1/*
587 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
588 %{_desktopdir}/mplayer.desktop
589 %{_pixmapsdir}/mplayer.png
590 %dir %{_datadir}/%{name}
591 %{_datadir}/%{name}/font*
This page took 0.071102 seconds and 4 git commands to generate.