]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- added on2flixenglinux patches
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - use external vidix?
5 # - try to use external ffmpeg, lrmi and few other libs:
6 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
7 #
8 # Conditional build:
9 %bcond_with     directfb        # with DirectFB video output
10 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
11 %bcond_with     ggi             # with ggi video output
12 %bcond_with     nas             # with NAS audio output
13 %bcond_with     svga            # with svgalib video output
14 %bcond_with     osd             # with osd menu support
15 %bcond_without  altivec         # without altivec support
16 %bcond_without  x264            # without x264 support
17 %bcond_with     xmms            # with XMMS inputplugin support
18 %bcond_without  aalib           # without aalib video output
19 %bcond_without  jack            # without JACKD support
20 %bcond_without  alsa            # without ALSA audio output
21 %bcond_without  arts            # without arts audio output
22 %bcond_without  caca            # without libcaca video output
23 %bcond_without  cdparanoia      # without cdparanoia support
24 %bcond_without  dshow           # disable DirectShow support
25 %bcond_without  enca            # disable using ENCA charset oracle library
26 %bcond_without  esd             # disable EsounD sound support
27 %bcond_without  faad            # disable FAAD2 (AAC) support
28 %bcond_without  gif             # disable GIF support
29 %bcond_without  gui             # without GTK+ GUI
30 %bcond_without  joystick        # disable joystick support
31 %bcond_without  libdts          # disable libdts support
32 %bcond_without  libdv           # disable libdv en/decoding support
33 %bcond_without  lirc            # without lirc support
34 %bcond_without  live            # without live.com libraries
35 %bcond_with     lzo             # with LZO support (requires lzo 1.x)
36 %bcond_without  mad             # without mad (audio MPEG) support
37 %bcond_without  pulseaudio              # without pulseaudio output
38 %bcond_without  quicktime       # without binary quicktime dll support
39 %bcond_without  real            # without Real* 8/9 codecs support
40 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
41                                 #  in compile time (advertised by mplayer authors as working faster); in this case
42                                 #  mplayer may not work on machine other then where it was compiled
43 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
44 %bcond_without  smb             # disable Samba (SMB) input support
45 %bcond_without  theora          # without theora support
46 %bcond_without  win32           # without win32 codecs support
47 %bcond_without  vorbis          # without Ogg-Vorbis audio support
48 %bcond_without  xvid            # disable XviD codec
49 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
50 %bcond_without  sdl             # disable SDL
51 %bcond_without  doc             # don't build docs (slow)
52 %bcond_with     shared          # experimental libmplayer.so support
53 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
54 %bcond_without  gnomess         # disable controling gnome screensaver
55
56 %ifnarch %{ix86}
57 %undefine       with_win32
58 %undefine       with_quicktime
59 %endif
60
61 %ifarch %{x8664}
62 %undefine       with_runtime
63 %endif
64
65 %if %{_lib} == "lib64"
66 %define        _suf    64
67 %else
68 %define        _suf    32
69 %endif
70
71 %define         sname           MPlayer
72 %define         snap            %{nil}
73
74 %define         _rc     rc1
75 %define         _rel    1.2
76 Summary:        MPlayer - THE Movie Player for UN*X
77 Summary(de):    MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
78 Summary(es):    Otro reproductor de películas
79 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
80 Summary(pl):    Odtwarzacz filmów dla systemów uniksowych
81 Summary(pt_BR): Reprodutor de filmes
82 Name:           mplayer
83 Version:        1.0
84 Release:        3.%{_rc}.%{_rel}
85 # DO NOT increase epoch unless it's really neccessary!
86 # especially such changes like pre7->pre7try2, increase Release instead!
87 # PS: $ rpmvercmp pre7try2 pre7
88 # pre7try2 > pre7
89 Epoch:          3
90 License:        GPL
91 Group:          Applications/Multimedia
92 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{_rc}.tar.bz2
93 # Source0-md5:  18c05d88e22c3b815a43ca8d7152ccdc
94 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
95 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
96 Source5:        g%{name}.desktop
97 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
98 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
99 Source7:        %{name}.png
100 Source8:        %{name}.desktop
101 # http://www.on2.com/gpl/mplayer/
102 Source9:        http://www.on2.com/gpl/mplayer/2006-11-29-mencoder-on2flixenglinux.tar.bz2
103 # Source9-md5:  66fd6987f36f0b0cec6a28366ac3141c
104 Patch1:         %{name}-cp1250-fontdesc.patch
105 Patch2:         %{name}-codec.patch
106 Patch3:         %{name}-home_etc.patch
107 Patch4:         %{name}-350.patch
108 Patch5:         %{name}-configure.patch
109 Patch6:         %{name}-system-amr.patch
110 Patch8:         %{name}-altivec.patch
111 Patch10:        %{name}-pcmsplit.patch
112 Patch11:        ffmpeg-x264-symbol.patch
113 Patch12:        %{name}-pulse.patch
114 Patch13:        %{name}-mythtv.patch
115 Patch14:        %{name}-shared.patch
116 #http://www.openchrome.org/snapshots/mplayer/
117 Patch15:        %{name}-xvmc.patch
118 Patch16:        %{name}-kill-mabi_altivec.patch
119 Patch17:        %{name}-auto-expand.patch
120 Patch18:        %{name}-gnome-screensaver.patch
121 Patch19:        %{name}-on2flix.patch
122 URL:            http://www.mplayerhq.hu/
123 %{?with_directfb:BuildRequires: DirectFB-devel}
124 BuildRequires:  OpenAL-devel
125 BuildRequires:  OpenGL-devel
126 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
127 %{?with_aalib:BuildRequires:    aalib-devel}
128 %{?with_alsa:BuildRequires:     alsa-lib-devel}
129 %if %{with amr}
130 BuildRequires:  amrnb-devel
131 BuildRequires:  amrwb-devel >= 5.3.0
132 %endif
133 %{?with_arts:BuildRequires:     artsc-devel}
134 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
135 %{?with_doc:BuildRequires:      docbook-style-xsl}
136 %{?with_dxr3:BuildRequires:     em8300-devel}
137 %{?with_enca:BuildRequires:     enca-devel}
138 %{?with_esd:BuildRequires:      esound-devel}
139 BuildRequires:  faac-devel
140 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
141 BuildRequires:  freetype-devel
142 BuildRequires:  fribidi-devel
143 %ifarch ppc
144 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
145 %endif
146 %{?with_gif:BuildRequires:      giflib-devel}
147 %if %{with gui}
148 BuildRequires:  gtk+2-devel
149 %endif
150 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
151 BuildRequires:  lame-libs-devel
152 %{?with_caca:BuildRequires:     libcaca-devel}
153 %{?with_libdts:BuildRequires:   libdts-devel}
154 %{?with_libdv:BuildRequires:    libdv-devel}
155 BuildRequires:  libdvdnav-devel
156 %{?with_ggi:BuildRequires:      libggi-devel}
157 BuildRequires:  libjpeg-devel
158 %{?with_mad:BuildRequires:      libmad-devel}
159 BuildRequires:  libmpcdec-devel >= 1.2.1
160 BuildRequires:  libpng-devel
161 %{?with_smb:BuildRequires:      libsmbclient-devel}
162 %{?with_dshow:BuildRequires:    libstdc++-devel}
163 %{?with_theora:BuildRequires:   libtheora-devel}
164 # tremor is used by default, internal as we don't have system one
165 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
166 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
167 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060828_2245.1}
168 BuildRequires:  libxslt-progs
169 %{?with_lirc:BuildRequires:     lirc-devel}
170 %{?with_live:BuildRequires:     live}
171 %{?with_lzo:BuildRequires:      lzo-devel < 2.0}
172 %{?with_nas:BuildRequires:      nas-devel}
173 BuildRequires:  ncurses-devel
174 BuildRequires:  pkgconfig
175 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
176 BuildRequires:  speex-devel >= 1.1
177 %{?with_svga:BuildRequires:     svgalib-devel}
178 %{?with_xmms:BuildRequires:     xmms-libs}
179 BuildRequires:  xorg-lib-libX11-devel
180 BuildRequires:  xorg-lib-libXext-devel
181 BuildRequires:  xorg-lib-libXinerama-devel
182 BuildRequires:  xorg-lib-libXv-devel
183 BuildRequires:  xorg-lib-libXvMC-devel
184 BuildRequires:  xorg-lib-libXxf86dga-devel
185 BuildRequires:  xorg-lib-libXxf86vm-devel
186 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
187 BuildRequires:  zlib-devel
188 Requires(post,postun):  /sbin/ldconfig
189 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
190 Requires:       OpenGL
191 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
192
193 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
194 %define         specflags_ia32  -fomit-frame-pointer
195 %if %{with altivec}
196 %define         specflags_ppc   -maltivec
197 %endif
198
199 %description
200 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
201 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
202 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
203 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
204 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
205 optionally with SHM extension, X11 using overlays with the Xvideo
206 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
207 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
208
209 If you want to use win32 codecs install w32codec package.
210
211 %description -l de
212 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
213 Kennzeichnend ist die herausragende Format- und
214 Plattform-Kompatibilität.
215
216 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
217 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
218 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
219 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
220 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
221 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
222 installierte Codecs nicht mit MPlayer kollidieren können.
223
224 %description -l es
225 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
226 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
227 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
228 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
229 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
230 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
231 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
232 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
233 v1.1.7 etc.
234
235 Si quiere usar codecs Win32, instale el paquete w32codec.
236
237 %description -l ko
238 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
239 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
240 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
241 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
242 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
243 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
244 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
245 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
246 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
247
248 %description -l pl
249 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
250 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
251 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
252 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
253 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
254 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
255 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
256
257 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
258
259 %description -l pt_BR
260 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
261 áudio. Diferentes mecanismos de reprodução podem também ser
262 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
263
264 %package -n gmplayer
265 Summary:        MPlayer with GTK+ GUI interface
266 Summary(pl):    MPlayer z graficznym interfejsem GTK+
267 Group:          X11/Applications/Multimedia
268 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
269 Requires:       %{name}-skin
270 Provides:       %{name} = %{epoch}:%{version}-%{release}
271
272 %description -n gmplayer
273 MPlayer with GUI GTK+ interface.
274
275 %description -n gmplayer -l pl
276 MPlayer z graficznym interfejsem GTK+.
277
278 %package common
279 Summary:        Configuration files and documentation for MPlayer
280 Summary(pl):    Pliki konfiguracyjne i dokumentacja dla MPlayera
281 Group:          Applications/Multimedia
282
283 %description common
284 Configuration files, man page and HTML documentation for MPlayer.
285
286 %description common -l pl
287 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
288
289 %package -n mencoder
290 Summary:        MEncoder - a movie encoder for Linux
291 Summary(pl):    MEncoder - koder filmów dla Linuksa
292 Group:          Applications/Multimedia
293 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
294
295 %description -n mencoder
296 MEncoder is a movie encoder for Linux and is a part of the MPlayer
297 package.
298
299 %description -n mencoder -l pl
300 MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
301
302 %prep
303 %setup -q -n %{sname}-%{version}%{_rc} -a3 -a6 -a9
304 cp -f etc/codecs.conf etc/codecs.win32.conf
305 %patch1 -p0
306 ##%patch2 -p1
307 ##%patch3 -p1   -- old home_etc behavior
308 %patch4 -p1
309 %patch5 -p1
310 %patch6 -p1
311 %patch8 -p1
312 #%%patch10 -p1
313 %patch11 -p1
314 %patch12 -p0
315 #%patch13 -p1   # TODO
316 %if %{with shared}
317 %patch14 -p1
318 %endif
319 #%patch15 -p0   # TODO
320 %patch16 -p1
321 %patch17 -p1
322 %if %{with gnomess}
323 %patch18 -p1
324 %endif
325
326 %if 0%{?snap}
327 find . -type d -name CVS -print | xargs rm -rf
328 %endif
329
330 # on2flix
331 cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
332 %patch19 -p1
333 for a in mencoder-on2flixenglinux/*.diff; do
334         patch -p0 < $a
335 done
336
337 %build
338 %if %{with shared}
339 CFLAGS="%{rpmcflags} -fPIC"
340 %else
341 CFLAGS="%{rpmcflags}"
342 %endif
343 CC="%{__cc}"
344 LDFLAGS="%{rpmldflags}"
345 export CC CFLAGS LDFLAGS
346
347 build() {
348 set -x
349         ./configure \
350         %{?debug:--enable-debug=3} \
351         --prefix=%{_prefix} \
352         --confdir=%{_sysconfdir}/mplayer \
353         --with-x11libdir=%{_libdir} \
354         --with-extraincdir=%{_includedir}/xvid \
355         --enable-menu \
356 %ifnarch %{ix86} %{x8664}
357         --disable-mmx \
358         --disable-mmxext \
359         --disable-3dnow \
360         --disable-3dnowext \
361         --disable-sse \
362         --disable-sse2 \
363         --disable-fastmemcpy \
364 %endif
365 %ifarch ppc
366 %{!?with_altivec:--disable-altivec} \
367 %endif
368 %{!?with_amr:--disable-amr_nb --disable-amr_wb} \
369 %{?with_amr:--enable-amr_nb --enable-amr_wb} \
370 %{?with_directfb:--enable-directfb} \
371 %{!?with_directfb:--disable-directfb} \
372 %{!?with_dxr3:--disable-dxr3} \
373 %{!?with_ggi:--disable-ggi} \
374 %{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
375 %{!?with_live:--disable-live} \
376 %{!?with_lzo:--disable-liblzo} \
377 %{!?with_nas:--disable-nas} \
378 %{!?with_svga:--disable-svga} \
379 %{!?with_aalib:--disable-aa} \
380 %{!?with_jack:--disable-jack} \
381 %{!?with_alsa:--disable-alsa} \
382 %{?with_alsa:--enable-alsa --disable-select} \
383 %{!?with_arts:--disable-arts} \
384 %{!?with_caca:--disable-caca} \
385 %{!?with_cdparanoia:--disable-cdparanoia} \
386 %{!?with_dshow:--disable-dshow} \
387 %{!?with_enca:--disable-enca} \
388 %{!?with_esd:--disable-esd} \
389 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
390 %{?with_faad:--disable-faad-internal} \
391 %{!?with_gif:--disable-gif} \
392 %{?with_joystick:--enable-joystick} \
393 %{!?with_libdv:--disable-libdv} \
394 %{!?with_libdts:--disable-libdts} \
395 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
396 %{!?with_mad:--disable-mad} \
397 %{!?with_pulseaudio:--disable-pulseaudio} \
398 %{!?with_quicktime:--disable-qtx} \
399 %{!?with_real:--disable-real} \
400 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
401 %{!?with_select:--disable-select} \
402 %{!?with_smb:--disable-smb} \
403 %{!?with_win32:--disable-win32} \
404 %{!?with_vorbis:--disable-vorbis} \
405 %{?with_osd:--enable-menu} \
406 %{!?with_theora:--disable-theora} \
407 %{!?with_x264:--disable-x264} \
408 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
409 %{!?with_xvid:--disable-xvid} \
410 %{!?with_mencoder:--disable-mencoder} \
411         --enable-dga \
412         --enable-fbdev \
413         --enable-gl \
414         --enable-mga \
415         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
416         --enable-tdfxfb \
417         --enable-vm \
418         --enable-x11 \
419         --enable-xmga \
420         --enable-xv \
421         --enable-xvmc \
422         --enable-dynamic-plugins \
423         --enable-largefiles \
424         --language=all \
425         --with-codecsdir=%{_libdir}/codecs \
426         --with-xvmclib=XvMCW \
427         "$@"
428
429         %{__make}
430 }
431
432 %if %{with gui}
433 # build GUI version
434 build --enable-gui
435 mv -f mplayer gmplayer
436 %{__make} distclean
437 %endif
438
439 # now build regular version
440 build --disable-gui
441
442 %if %{with doc}
443 %{__make} -j1 -C DOCS/xml
444 %endif
445
446 %install
447 rm -rf $RPM_BUILD_ROOT
448 install -d \
449         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
450         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
451         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
452         $RPM_BUILD_ROOT%{_desktopdir}
453
454 # default config files
455 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
456 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
457
458 # executables
459 %if %{with mencoder}
460 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
461 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
462 %endif
463 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
464 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
465 %if %{with gui}
466 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
467 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
468 %endif
469
470 # fonts
471 rm -f font-*/runme
472 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
473 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
474
475 # libraries
476 %ifarch %{ix86}
477 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
478 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
479 %endif
480
481 %if %{with gui}
482 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
483 %endif
484
485 # X-files
486 %if %{with gui}
487 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
488 %endif
489 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
490 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
491
492 # man pages
493 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
494 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
495 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
496 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
497 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
498 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
499 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
500 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
501 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
502 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
503
504 %clean
505 rm -rf $RPM_BUILD_ROOT
506
507 %post
508 umask 022
509 /sbin/ldconfig
510 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
511
512 %postun
513 umask 022
514 /sbin/ldconfig
515 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
516
517 %files
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_bindir}/mplayer*
520
521 %if %{with gui}
522 %files -n gmplayer
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{_bindir}/gmplayer*
525 %{_desktopdir}/gmplayer.desktop
526 %dir %{_datadir}/%{name}/Skin
527 %ghost %{_datadir}/%{name}/Skin/default
528 %endif
529
530 %if %{with mencoder}
531 %files -n mencoder
532 %defattr(644,root,root,755)
533 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
534 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
535 %doc DOCS/tech/colorspaces.txt
536 %attr(755,root,root) %{_bindir}/mencoder*
537 %endif
538
539 %files common
540 %defattr(644,root,root,755)
541 # HTML and XML-generated docs
542 %doc DOCS/HTML/en
543 %doc DOCS/tech
544 %if %{with win32}
545 %doc etc/codecs.win32.conf
546 %endif
547 %lang(cs) %doc DOCS/HTML/cs
548 %lang(de) %doc DOCS/HTML/de
549 %lang(es) %doc DOCS/HTML/es
550 %lang(fr) %doc DOCS/HTML/fr
551 %lang(hu) %doc DOCS/HTML/hu
552 %lang(pl) %doc DOCS/HTML/pl
553 %lang(ru) %doc DOCS/HTML/ru
554 %lang(zh_CN) %doc DOCS/zh
555 %doc AUTHORS ChangeLog README
556
557 %ifarch %{ix86}
558 %attr(755,root,root) %{_libdir}/libdha.so.*.*
559 %attr(755,root,root) %{_libdir}/mplayer
560 %endif
561 %dir %{_sysconfdir}/%{name}
562 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
563 %{_mandir}/man1/*
564 %lang(cs) %{_mandir}/cs/man1/*
565 %lang(de) %{_mandir}/de/man1/*
566 %lang(es) %{_mandir}/es/man1/*
567 %lang(fr) %{_mandir}/fr/man1/*
568 %lang(hu) %{_mandir}/hu/man1/*
569 %lang(it) %{_mandir}/it/man1/*
570 %lang(pl) %{_mandir}/pl/man1/*
571 %lang(sv) %{_mandir}/sv/man1/*
572 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
573 %{_desktopdir}/mplayer.desktop
574 %{_pixmapsdir}/*
575 %dir %{_datadir}/%{name}
576 %{_datadir}/%{name}/font*
This page took 0.263619 seconds and 4 git commands to generate.