]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- face the truth: lzo 2 and polypaudio 0.8 are not supported yet
[packages/mplayer.git] / mplayer.spec
1 #
2 # TODO:
3 # - update for lzo 2
4 # - update for polypaudio 0.8
5 # - use external lrmi and few other libs:
6 #   http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
7 #
8 # Conditional build:
9 %bcond_with     directfb        # with DirectFB video output
10 %bcond_with     divx4linux      # with divx4linux a/v support (binaries, instead of included OpenDivx)
11 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
12 %bcond_with     ggi             # with ggi video output
13 %bcond_with     nas             # with NAS audio output
14 %bcond_with     svga            # with svgalib video output
15 %bcond_with     osd             # with osd menu support
16 %bcond_with     altivec         # with altivec support (altivec code brakes image in mpeg4, and may segfault on others)
17 %bcond_with     x264            # with x264 support (needs newer libx264 snap)
18 %bcond_with     xmms            # with XMMS inputplugin support
19 %bcond_without  aalib           # without aalib video output
20 %bcond_without  jack            # without JACKD support
21 %bcond_without  alsa            # without ALSA audio output
22 %bcond_without  arts            # without arts audio output
23 %bcond_without  caca            # without libcaca video output
24 %bcond_without  cdparanoia      # without cdparanoia support
25 %bcond_without  dshow           # disable DirectShow support
26 %bcond_without  enca            # disable using ENCA charset oracle library
27 %bcond_without  esd             # disable EsounD sound support
28 %bcond_without  faad            # disable FAAD2 (AAC) support
29 %bcond_without  gif             # disable GIF support
30 %bcond_without  gui             # without GTK+ GUI
31 %bcond_without  joystick        # disable joystick support
32 %bcond_without  libdts          # disable libdts support
33 %bcond_without  libdv           # disable libdv en/decoding support
34 %bcond_without  lirc            # without lirc support
35 %bcond_without  live            # without live.com libraries
36 %bcond_with     lzo             # with LZO support (requires lzo 1.x)
37 %bcond_without  mad             # without mad (audio MPEG) support
38 %bcond_with     polyp           # with polyp audio output (requires polypaudio 0.6 or 0.7)
39 %bcond_without  quicktime       # without binary quicktime dll support
40 %bcond_without  real            # without Real* 8/9 codecs support
41 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
42                                 #  in compile time (advertised by mplayer authors as working faster); in this case
43                                 #  mplayer may not work on machine other then where it was compiled
44 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
45 %bcond_without  smb             # disable Samba (SMB) input support
46 %bcond_without  theora          # without theora support
47 %bcond_without  win32           # without win32 codecs support
48 %bcond_without  vorbis          # without Ogg-Vorbis audio support
49 %bcond_without  xvid            # disable XviD codec
50 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
51 %bcond_without  sdl             # disable SDL
52 %bcond_without  doc             # don't build docs (slow)
53 %bcond_with     gtk2            # EXPERIMENTAL support for GTK+ version 2
54 %bcond_with     shared          # experimental libmplayer.so support
55
56 %ifnarch %{ix86}
57 %undefine       with_win32
58 %undefine       with_quicktime
59 %endif
60
61 %ifarch %{x8664}
62 %undefine       with_runtime
63 %endif
64
65 %if %{_lib} == "lib64"
66 %define        _suf    64
67 %else
68 %define        _suf    32
69 %endif
70
71 # set it to 0, or 1
72 %define         snapshot        0
73
74 %define         sname           MPlayer
75 %define         snap            %{nil}
76
77 %define         pre             pre7try2
78
79 Summary:        MPlayer - THE Movie Player for UN*X
80 Summary(de):    MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81 Summary(es):    Otro reproductor de películas
82 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
83 Summary(pl):    Odtwarzacz filmów dla systemów uniksowych
84 Summary(pt_BR): Reprodutor de filmes
85 Name:           mplayer
86 Version:        1.0
87 %define         _rel    2.2
88 #Release:       2.%{pre}.%{_rel}
89 Release:        2.pre7try3.%{_rel}
90 # DO NOT increase epoch unless it's really neccessary!
91 # especially such changes like pre7->pre7try2, increase Release instead!
92 # PS: $ rpmvercmp pre7try2 pre7
93 # pre7try2 > pre7
94 Epoch:          3
95 License:        GPL
96 Group:          Applications/Multimedia
97 %if %{snapshot}
98 #Source0:       ftp://ftp1.mplayerhq.hu/MPlayer/cvs/%{sname}-%{snap}.tar.bz2
99 #Source0:       %{name}-%{snap}.tar.bz2
100 #Source1:       libavcodec-%{snap}.tar.bz2
101 %else
102 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{pre}.tar.bz2
103 # Source0-md5:  aaca4fd327176c1afb463f0f047ef6f4
104 %endif
105 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
106 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
107 Source5:        g%{name}.desktop
108 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
109 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
110 Source7:        %{name}.png
111 Source8:        %{name}.desktop
112 Patch0:         %{name}-no_libnsl.patch
113 Patch1:         %{name}-cp1250-fontdesc.patch
114 Patch2:         %{name}-codec.patch
115 Patch3:         %{name}-home_etc.patch
116 Patch4:         %{name}-350.patch
117 Patch5:         %{name}-configure.patch
118 Patch6:         %{name}-gtk+2.patch
119 Patch7:         %{name}-alpha.patch
120 Patch8:         %{name}-altivec.patch
121 Patch9:         %{name}-assembly.patch
122 Patch10:        %{name}-pcmsplit.patch
123 Patch11:        %{name}-bio2jack.patch
124 Patch12:        %{name}-x86_64-detection.patch
125 Patch13:        %{name}-mythtv.patch
126 Patch14:        %{name}-shared.patch
127 Patch15:        %{name}-xvmc.patch
128 Patch16:        %{name}-kill-mabi_altivec.patch
129 Patch17:        %{name}-gcc4.patch
130 Patch18:        http://www.mplayerhq.hu/MPlayer/patches/demuxer_h_fix_20060212.diff
131 Patch19:        %{name}-CVE-2005-4048.patch
132 #http://www.openchrome.org/snapshots/mplayer/
133 URL:            http://www.mplayerhq.hu/
134 %{?with_directfb:BuildRequires: DirectFB-devel}
135 BuildRequires:  OpenGL-devel
136 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
137 %{?with_aalib:BuildRequires:    aalib-devel}
138 %{?with_alsa:BuildRequires:     alsa-lib-devel}
139 %{?with_arts:BuildRequires:     artsc-devel}
140 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
141 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.01.20020418}
142 %{?with_doc:BuildRequires:      docbook-style-xsl}
143 %{?with_dxr3:BuildRequires:     em8300-devel}
144 %{?with_enca:BuildRequires:     enca-devel}
145 %{?with_esd:BuildRequires:      esound-devel}
146 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
147 BuildRequires:  freetype-devel
148 %ifarch ppc
149 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
150 %endif
151 %{?with_gif:BuildRequires:      giflib-devel}
152 %if %{with gui}
153 BuildRequires:  gtk+%{?with_gtk2:2}-devel
154 %endif
155 BuildRequires:  lame-libs-devel
156 %{?with_jack:BuildRequires:     libbio2jack-devel >= 0.8-2}
157 %{?with_caca:BuildRequires:     libcaca-devel}
158 %{?with_libdts:BuildRequires:   libdts-devel}
159 %{?with_libdv:BuildRequires:    libdv-devel}
160 %{?with_ggi:BuildRequires:      libggi-devel}
161 BuildRequires:  libjpeg-devel
162 %{?with_mad:BuildRequires:      libmad-devel}
163 BuildRequires:  libpng-devel
164 %{?with_smb:BuildRequires:      libsmbclient-devel}
165 %{?with_dshow:BuildRequires:    libstdc++-devel}
166 %{?with_theora:BuildRequires:   libtheora-devel}
167 %{?with_vorbis:BuildRequires:   libvorbis-devel}
168 %{?with_x264:BuildRequires:     libx264-devel > 0.1.2-1.20051023}
169 BuildRequires:  libxslt-progs
170 %{?with_lirc:BuildRequires:     lirc-devel}
171 %{?with_live:BuildRequires:     live}
172 %{?with_lzo:BuildRequires:      lzo-devel < 2.0}
173 %{?with_nas:BuildRequires:      nas-devel}
174 BuildRequires:  ncurses-devel
175 BuildRequires:  pkgconfig
176 %{?with_polyp:BuildRequires:    polypaudio-devel >= 0.6}
177 %{?with_polyp:BuildRequires:    polypaudio-devel < 0.8}
178 %{?with_svga:BuildRequires:     svgalib-devel}
179 %{?with_xmms:BuildRequires:     xmms-libs}
180 BuildRequires:  xorg-lib-libXvMC-devel
181 BuildRequires:  xorg-lib-libX11-devel
182 BuildRequires:  xorg-lib-libXext-devel
183 BuildRequires:  xorg-lib-libXinerama-devel
184 BuildRequires:  xorg-lib-libXv-devel
185 BuildRequires:  xorg-lib-libXxf86dga-devel
186 BuildRequires:  xorg-lib-libXxf86vm-devel
187 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
188 BuildRequires:  zlib-devel
189 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
190 Requires(post,postun):  /sbin/ldconfig
191 Requires:       OpenGL
192 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
193
194 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
195 %define         specflags_ia32  -fomit-frame-pointer
196 %define         specflags_alpha -mmax
197 %if %{with altivec}
198 %define         specflags_ppc   -maltivec
199 %endif
200
201 %description
202 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
203 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
204 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
205 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
206 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
207 optionally with SHM extension, X11 using overlays with the Xvideo
208 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
209 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
210
211 If you want to use win32 codecs install w32codec package.
212
213 %description -l de
214 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
215 Kennzeichnend ist die herausragende Format- und
216 Plattform-Kompatibilität.
217
218 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
219 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
220 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
221 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
222 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
223 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
224 installierte Codecs nicht mit MPlayer kollidieren können.
225
226 %description -l es
227 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
228 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
229 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
230 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
231 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
232 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
233 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
234 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
235 v1.1.7 etc.
236
237 Si quiere usar codecs Win32, instale el paquete w32codec.
238
239 %description -l ko
240 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
241 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
242 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
243 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
244 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
245 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
246 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
247 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
248 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
249
250 %description -l pl
251 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
252 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
253 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
254 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
255 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
256 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
257 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
258
259 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
260
261 %description -l pt_BR
262 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
263 áudio. Diferentes mecanismos de reprodução podem também ser
264 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
265
266 %package -n gmplayer
267 Summary:        MPlayer with GTK+ GUI interface
268 Summary(pl):    MPlayer z graficznym interfejsem GTK+
269 Group:          X11/Applications/Multimedia
270 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
271 Requires:       %{name}-skin
272 Provides:       %{name} = %{epoch}:%{version}-%{release}
273
274 %description -n gmplayer
275 MPlayer with GUI GTK+ interface.
276
277 %description -n gmplayer -l pl
278 MPlayer z graficznym interfejsem GTK+.
279
280 %package common
281 Summary:        Configuration files and documentation for MPlayer
282 Summary(pl):    Pliki konfiguracyjne i dokumentacja dla MPlayera
283 Group:          Applications/Multimedia
284
285 %description common
286 Configuration files, man page and HTML documentation for MPlayer.
287
288 %description common -l pl
289 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
290
291 %package -n mencoder
292 Summary:        MEncoder - a movie encoder for Linux
293 Summary(pl):    MEncoder - koder filmów dla Linuksa
294 Group:          Applications/Multimedia
295 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
296
297 %description -n mencoder
298 MEncoder is a movie encoder for Linux and is a part of the MPlayer
299 package.
300
301 %description -n mencoder -l pl
302 MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
303
304 %prep
305 %if %{snapshot}
306 %setup -q -n %{name}-%{snap} -a 1 -a 3 -a 6
307 %else
308 %setup -q -n %{sname}-%{version}%{pre} -a 3 -a 6
309 %endif
310
311 cp -f etc/codecs.conf etc/codecs.win32.conf
312 %patch0 -p1
313 %patch1 -p0
314 ##%patch2 -p1
315 ##%patch3 -p1   -- old home_etc behavior
316 %patch4 -p1
317 %patch5 -p1
318 %if %{with gtk2}
319 %patch6 -p1
320 %endif
321 %patch7 -p1
322 %patch8 -p1
323 %patch9 -p1
324 #%%patch10 -p1
325 %patch11 -p1
326 %patch12 -p1
327 %patch13 -p1
328 %if %{with shared}
329 %patch14 -p1
330 %endif
331 %patch15 -p0
332 %patch16 -p1
333 %patch17 -p1
334 %patch18 -p0
335 %patch19 -p1
336
337 # kill evil file, hackery not needed with llh
338 echo > osdep/kerneltwosix.h
339
340 find . -type d -name CVS -print | xargs rm -rf
341
342 %build
343 %if %{with shared}
344 CFLAGS="%{rpmcflags} -fPIC"
345 LDFLAGS="%{rpmldflags} -wl,--as-needed"
346 %else
347 CFLAGS="%{rpmcflags}"
348 LDFLAGS="%{rpmldflags}"
349 %endif
350 CC="%{__cc}"
351 export CC CFLAGS
352
353 build() {
354 set -x
355         ./configure \
356         %{?debug:--enable-debug=3} \
357         --prefix=%{_prefix} \
358         --confdir=%{_sysconfdir}/mplayer \
359         --with-x11incdir=%{_includedir} \
360         --with-x11libdir=%{_libdir} \
361         --with-extraincdir=%{_includedir}/xvid \
362         --enable-menu \
363 %ifnarch %{ix86} %{x8664}
364         --disable-mmx \
365         --disable-mmx2 \
366         --disable-3dnow \
367         --disable-3dnowex \
368         --disable-sse \
369         --disable-sse2 \
370         --disable-fastmemcpy \
371 %endif
372 %ifarch ppc
373 %{!?with_altivec:--disable-altivec} \
374 %endif
375 %{?with_directfb:--enable-directfb} \
376 %{!?with_directfb:--disable-directfb} \
377 %{!?with_divx4linux:--disable-divx4linux} \
378 %{?with_divx4linux:--with-extraincdir=/usr/include/divx} \
379 %{!?with_dxr3:--disable-dxr3} \
380 %{!?with_ggi:--disable-ggi} \
381 %{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
382 %{!?with_live:--disable-live} \
383 %{!?with_lzo:--disable-liblzo} \
384 %{!?with_nas:--disable-nas} \
385 %{!?with_svga:--disable-svga} \
386 %{!?with_aalib:--disable-aa} \
387 %{!?with_jack:--disable-jack} \
388 %{!?with_alsa:--disable-alsa} \
389 %{?with_alsa:--enable-alsa --disable-select} \
390 %{!?with_arts:--disable-arts} \
391 %{!?with_caca:--disable-caca} \
392 %{!?with_cdparanoia:--disable-cdparanoia} \
393 %{!?with_dshow:--disable-dshow} \
394 %{!?with_enca:--disable-enca} \
395 %{!?with_esd:--disable-esd} \
396 %{!?with_faad:--disable-external-faad --disable-internal-faad}%{?with_faad:--enable-external-faad} \
397 %{!?with_gif:--disable-gif} \
398 %{?with_joystick:--enable-joystick} \
399 %{!?with_libdv:--disable-libdv} \
400 %{!?with_libdts:--disable-libdts} \
401 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
402 %{!?with_mad:--disable-mad} \
403 %{!?with_polyp:--disable-polyp} \
404 %{!?with_quicktime:--disable-qtx} \
405 %{!?with_real:--disable-real} \
406 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
407 %{!?with_select:--disable-select} \
408 %{!?with_smb:--disable-smb} \
409 %{!?with_win32:--disable-win32} \
410 %{!?with_vorbis:--disable-vorbis} \
411 %{?with_osd:--enable-menu} \
412 %{!?with_theora:--disable-theora} \
413 %{!?with_x264:--disable-x264} \
414 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
415 %{!?with_xvid:--disable-xvid} \
416 %{!?with_mencoder:--disable-mencoder} \
417         --enable-dga \
418         --enable-fbdev \
419         --enable-gl \
420         --enable-mga \
421         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
422         --enable-tdfxfb \
423         --enable-vm \
424         --enable-x11 \
425         --enable-xmga \
426         --enable-xv \
427         --enable-xvmc \
428         --enable-dynamic-plugins \
429         --enable-largefiles \
430         --language=all \
431         --with-codecsdir=%{_libdir}/codecs \
432         --with-xvmclib=XvMCW \
433         "$@"
434
435         %{__make}
436 }
437
438 %if %{with gui}
439 # build GUI version
440 build --enable-gui
441 mv -f mplayer gmplayer
442 %{__make} clean
443 %endif
444
445 # now build regular version
446 build --disable-gui
447
448 %if %{with doc}
449 %{__make} -j1 -C DOCS/xml
450 %endif
451
452 %install
453 rm -rf $RPM_BUILD_ROOT
454 install -d \
455         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
456         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
457         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
458         $RPM_BUILD_ROOT%{_desktopdir}
459
460 # default config files
461 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
462 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
463
464 # executables
465 %if %{with mencoder}
466 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
467 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
468 %endif
469 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
470 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
471 %if %{with gui}
472 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
473 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
474 %endif
475
476 # fonts
477 rm -f font-*/runme
478 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
479 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
480
481 # libraries
482 %ifarch %{ix86}
483 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
484 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
485 %endif
486
487 %if %{with gui}
488 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
489 %endif
490
491 # X-files
492 %if %{with gui}
493 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
494 %endif
495 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
496 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
497
498 # man pages
499 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
500 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
501 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
502 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
503 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
504 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
505 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
506 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
507 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
508 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
509
510 %clean
511 rm -rf $RPM_BUILD_ROOT
512
513 %post
514 umask 022
515 /sbin/ldconfig
516 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
517
518 %postun
519 umask 022
520 /sbin/ldconfig
521 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
522
523 %files
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_bindir}/mplayer*
526
527 %if %{with gui}
528 %files -n gmplayer
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_bindir}/gmplayer*
531 %{_desktopdir}/gmplayer.desktop
532 %dir %{_datadir}/%{name}/Skin
533 %ghost %{_datadir}/%{name}/Skin/default
534 %endif
535
536 %files -n mencoder
537 %defattr(644,root,root,755)
538 %doc DOCS/tech/encoding-tips.txt DOCS/tech/swscaler_filters.txt
539 %doc DOCS/tech/swscaler_methods.txt DOCS/tech/colorspaces.txt
540 %attr(755,root,root) %{_bindir}/mencoder*
541
542 %files common
543 %defattr(644,root,root,755)
544 # some useful tech docs
545 %doc DOCS/tech/hwac3.txt DOCS/tech/mpsub.sub DOCS/tech/slave.txt
546 %doc DOCS/tech/subcp.txt
547
548 # HTML and XML-generated docs
549 %doc DOCS/HTML/en
550 %doc DOCS/tech
551 %if %{with win32}
552 %doc etc/codecs.win32.conf
553 %endif
554 %lang(de) %doc DOCS/de
555 %lang(es) %doc DOCS/HTML/es
556 %lang(fr) %doc DOCS/HTML/fr
557 %lang(hu) %doc DOCS/HTML/hu
558 %lang(it) %doc DOCS/it
559 %lang(pl) %doc DOCS/HTML/pl
560 %lang(ru) %doc DOCS/HTML/ru
561 %lang(zh_CN) %doc DOCS/zh
562 %doc README AUTHORS ChangeLog
563
564 %ifarch %{ix86}
565 %attr(755,root,root) %{_libdir}/libdha.so.*.*
566 %attr(755,root,root) %{_libdir}/mplayer
567 %endif
568 %dir %{_sysconfdir}/%{name}
569 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
570 %{_mandir}/man1/*
571 %lang(cs) %{_mandir}/cs/man1/*
572 %lang(de) %{_mandir}/de/man1/*
573 %lang(es) %{_mandir}/es/man1/*
574 %lang(fr) %{_mandir}/fr/man1/*
575 %lang(hu) %{_mandir}/hu/man1/*
576 %lang(it) %{_mandir}/it/man1/*
577 %lang(pl) %{_mandir}/pl/man1/*
578 %lang(sv) %{_mandir}/sv/man1/*
579 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
580 %{_desktopdir}/mplayer.desktop
581 %{_pixmapsdir}/*
582 %dir %{_datadir}/%{name}
583 %{_datadir}/%{name}/font*
This page took 0.067924 seconds and 4 git commands to generate.