]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- use bio2jack system header.
[packages/mplayer.git] / mplayer.spec
1 #
2 # TODO:
3 # - use external lrmi and few other libs:
4 #   http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
5 #
6 # Conditional build:
7 %bcond_with     directfb        # with DirectFB video output
8 %bcond_with     divx4linux      # with divx4linux a/v support (binaries, instead of included OpenDivx)
9 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
10 %bcond_with     ggi             # with ggi video output
11 %bcond_with     nas             # with NAS audio output
12 %bcond_with     svga            # with svgalib video output
13 %bcond_with     osd             # with osd menu support
14 %bcond_with     altivec         # with altivec support (won't run w/o altivec due to instruction used in CPU detection(?))
15 %bcond_with     xmms            # with XMMS inputplugin support
16 %bcond_without  aalib           # without aalib video output
17 %bcond_without  jack            # without JACKD support
18 %bcond_without  alsa            # without ALSA audio output
19 %bcond_without  arts            # without arts audio output
20 %bcond_without  caca            # without libcaca video output
21 %bcond_without  dshow           # disable DirectShow support
22 %bcond_without  gui             # without GTK+ GUI
23 %bcond_without  joystick        # disable joystick support
24 %bcond_without  libdv           # disable libdv en/decoding support
25 %bcond_without  lirc            # without lirc support
26 %bcond_without  live            # without live.com libraries
27 %bcond_without  mad             # without mad (audio MPEG) support
28 %bcond_without  polyp           # without polyp audio output
29 %bcond_without  quicktime       # without binary quicktime dll support
30 %bcond_without  real            # without Real* 8/9 codecs support
31 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
32                                 #  in compile time (advertised by mplayer authors as working faster); in this case
33                                 #  mplayer may not work on machine other then where it was compiled
34 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
35 %bcond_without  smb             # disable Samba (SMB) input support
36 %bcond_without  theora          # without theora support
37 %bcond_without  win32           # without win32 codecs support
38 %bcond_without  vorbis          # without Ogg-Vorbis audio support
39 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
40 %bcond_without  libdts          # disable libdts support
41 %bcond_without  sdl             # disable SDL
42 %bcond_without  docs            # don't build docs (slow)
43 %bcond_with     gtk2            # EXPERIMENTAL support for GTK+ version 2
44 %bcond_with     xlibs
45 %bcond_with     shared  # experimental libmplayer.so support
46
47 %ifnarch %{ix86}
48 %undefine       with_win32
49 %undefine       with_quicktime
50 %endif
51
52 %ifarch %{x8664}
53 %undefine       with_runtime
54 %endif
55
56 # set it to 0, or 1
57 %define         snapshot        0
58
59 %define         sname           MPlayer
60 %define         snap            %{nil}
61
62 %define         pre             pre7try2
63
64 Summary:        MPlayer - THE Movie Player for UN*X
65 Summary(es):    Otro reproductor de películas
66 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
67 Summary(pl):    Odtwarzacz filmów dla systemów uniksowych
68 Summary(pt_BR): Reprodutor de filmes
69 Name:           mplayer
70 Version:        1.0
71 %define         _rel    5
72 Release:        2.%{pre}.%{_rel}
73 # DO NOT increase epoch unless it's really neccessary!
74 # especially such changes like pre7->pre7try2, increase Release instead!
75 # PS: $ rpmvercmp pre7try2 pre7
76 # pre7try2 > pre7
77 Epoch:          3
78 License:        GPL
79 Group:          Applications/Multimedia
80 %if %{snapshot}
81 #Source0:       ftp://ftp1.mplayerhq.hu/MPlayer/cvs/%{sname}-%{snap}.tar.bz2
82 #Source0:       %{name}-%{snap}.tar.bz2
83 #Source1:       libavcodec-%{snap}.tar.bz2
84 %else
85 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{pre}.tar.bz2
86 # Source0-md5:  aaca4fd327176c1afb463f0f047ef6f4
87 %endif
88 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
89 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
90 Source5:        g%{name}.desktop
91 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
92 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
93 Source7:        %{name}.png
94 Source8:        %{name}.desktop
95 Patch0:         %{name}-no_libnsl.patch
96 Patch1:         %{name}-cp1250-fontdesc.patch
97 Patch2:         %{name}-codec.patch
98 Patch3:         %{name}-home_etc.patch
99 Patch4:         %{name}-350.patch
100 Patch5:         %{name}-configure.patch
101 Patch6:         %{name}-gtk+2.patch
102 Patch7:         %{name}-alpha.patch
103 Patch8:         %{name}-altivec.patch
104 Patch9:         %{name}-assembly.patch
105 Patch10:        %{name}-pcmsplit.patch
106 Patch11:        %{name}-bio2jack.patch
107 Patch12:        %{name}-x86_64-detection.patch
108 Patch13:        %{name}-mythtv.patch
109 Patch14:        %{name}-shared.patch
110 Patch15:        %{name}-jack.patch
111 URL:            http://www.mplayerhq.hu/
112 %{?with_directfb:BuildRequires: DirectFB-devel}
113 BuildRequires:  OpenGL-devel
114 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
115 %if %{with xlibs}
116 BuildRequires:  libXv-devel
117 %else
118 BuildRequires:  XFree86-devel >= 4.0.2
119 %endif
120 %{?with_aalib:BuildRequires:    aalib-devel}
121 %{?with_alsa:BuildRequires:     alsa-lib-devel}
122 %{?with_arts:BuildRequires:     artsc-devel}
123 BuildRequires:  audiofile-devel
124 BuildRequires:  cdparanoia-III-devel
125 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.01.20020418}
126 BuildRequires:  docbook-style-xsl
127 %{?with_dxr3:BuildRequires:     em8300-devel}
128 BuildRequires:  enca-devel
129 BuildRequires:  esound-devel
130 BuildRequires:  faad2-devel >= 2.0
131 BuildRequires:  freetype-devel
132 %ifarch ppc
133 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
134 %endif
135 %if %{with gui}
136 BuildRequires:  gtk+%{?with_gtk2:2}-devel
137 %endif
138 BuildRequires:  lame-libs-devel
139 %{?with_jack:BuildRequires:     libbio2jack-devel}
140 %{?with_caca:BuildRequires:     libcaca-devel}
141 %{?with_libdts:BuildRequires:   libdts-devel}
142 %{?with_libdv:BuildRequires:    libdv-devel}
143 %{?with_ggi:BuildRequires:      libggi-devel}
144 BuildRequires:  libjpeg-devel
145 %{?with_mad:BuildRequires:      libmad-devel}
146 BuildRequires:  libpng-devel
147 %{?with_smb:BuildRequires:      libsmbclient-devel}
148 %{?with_dshow:BuildRequires:    libstdc++-devel}
149 %{?with_theora:BuildRequires:   libtheora-devel}
150 %{?with_vorbis:BuildRequires:   libvorbis-devel}
151 BuildRequires:  libungif-devel
152 BuildRequires:  libxslt-progs
153 %{?with_lirc:BuildRequires:     lirc-devel}
154 %{?with_live:BuildRequires:     live}
155 BuildRequires:  lzo-devel
156 %{?with_nas:BuildRequires:      nas-devel}
157 BuildRequires:  ncurses-devel
158 BuildRequires:  pkgconfig
159 %{?with_polyp:BuildRequires:    polypaudio-devel}
160 %{?with_svga:BuildRequires:     svgalib-devel}
161 %{?with_xmms:BuildRequires:     xmms-libs}
162 BuildRequires:  xvid-devel >= 1:0.9.0
163 BuildRequires:  zlib-devel
164 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
165 Requires(post,postun):  /sbin/ldconfig
166 Requires:       OpenGL
167 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
168
169 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
170 %define         specflags       -fomit-frame-pointer
171 %define         specflags_alpha -mmax
172 %if %{with altivec}
173 %define         specflags_ppc   -maltivec -mabi=altivec
174 %endif
175
176 %description
177 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
178 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
179 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
180 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
181 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
182 optionally with SHM extension, X11 using overlays with the Xvideo
183 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
184 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
185
186 If you want to use win32 codecs install w32codec package.
187
188 %description -l es
189 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
190 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
191 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
192 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
193 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
194 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
195 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
196 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
197 v1.1.7 etc.
198
199 Si quiere usar codecs Win32, instale el paquete w32codec.
200
201 %description -l ko
202 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
203 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
204 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
205 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
206 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
207 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
208 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
209 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
210 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
211
212 %description -l pl
213 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
214 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
215 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
216 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
217 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
218 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
219 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
220
221 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
222
223 %description -l pt_BR
224 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
225 áudio. Diferentes mecanismos de reprodução podem também ser
226 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
227
228 %package -n gmplayer
229 Summary:        MPlayer with GTK+ GUI interface
230 Summary(pl):    MPlayer z graficznym interfejsem GTK+
231 Group:          X11/Applications/Multimedia
232 Requires:       %{name}-skin
233 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
234 Provides:       %{name} = %{epoch}:%{version}-%{release}
235
236 %description -n gmplayer
237 MPlayer with GUI GTK+ interface.
238
239 %description -n gmplayer -l pl
240 MPlayer z graficznym interfejsem GTK+.
241
242 %package common
243 Summary:        Configuration files and documentation for MPlayer
244 Summary(pl):    Pliki konfiguracyjne i dokumentacja dla MPlayera
245 Group:          Applications/Multimedia
246 Requires:       %{name} = %{epoch}:%{version}-%{release}
247
248 %description common
249 Configuration files, man page and HTML documentation for MPlayer.
250
251 %description common -l pl
252 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
253
254 %package -n mencoder
255 Summary:        MEncoder - a movie encoder for Linux
256 Summary(pl):    MEncoder - koder filmów dla Linuksa
257 Group:          Applications/Multimedia
258 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
259
260 %description -n mencoder
261 MEncoder is a movie encoder for Linux and is a part of the MPlayer
262 package.
263
264 %description -n mencoder -l pl
265 MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
266
267 %prep
268 %if %{snapshot}
269 %setup -q -n %{name}-%{snap} -a 1 -a 3 -a 6
270 %else
271 %setup -q -n %{sname}-%{version}%{pre} -a 3 -a 6
272 %endif
273
274 cp -f etc/codecs.conf etc/codecs.win32.conf
275 %patch0 -p1
276 %patch1 -p0
277 ##%patch2 -p1
278 ##%patch3 -p1   -- old home_etc behavior
279 %patch4 -p1
280 %patch5 -p1
281 %if %{with gtk2}
282 %patch6 -p1
283 %endif
284 %patch7 -p1
285 %patch8 -p1
286 %patch9 -p1
287 #%%patch10 -p1
288 %patch11 -p1
289 %patch12 -p1
290 %patch13 -p1
291 %if %{with shared}
292 %patch14 -p1
293 %endif
294 %patch15 -p1
295
296 # kill evil file, hackery not needed with llh
297 echo > osdep/kerneltwosix.h
298
299 find . -type d -name CVS -print | xargs rm -rf
300
301 %build
302 %if %{with shared}
303 CFLAGS="%{rpmcflags} -fPIC"
304 LDFLAGS="%{rpmldflags} -wl,--as-needed"
305 %else
306 CFLAGS="%{rpmcflags}"
307 LDFLAGS="%{rpmldflags}"
308 %endif
309 CC="%{__cc}"
310 export CC CFLAGS
311
312 build() {
313 set -x
314         ./configure \
315         %{?debug:--enable-debug=3} \
316         --prefix=%{_prefix} \
317         --confdir=%{_sysconfdir}/mplayer \
318         --with-x11incdir=%{_prefix}/X11R6/include \
319         --with-extraincdir=%{_includedir}/xvid \
320         --enable-menu \
321 %ifnarch %{ix86} %{x8664}
322         --disable-mmx \
323         --disable-mmx2 \
324         --disable-3dnow \
325         --disable-3dnowex \
326         --disable-sse \
327         --disable-sse2 \
328         --disable-fastmemcpy \
329 %endif
330 %ifarch ppc
331 %{!?with_altivec:--disable-altivec} \
332 %endif
333 %{?with_directfb:--enable-directfb} \
334 %{!?with_directfb:--disable-directfb} \
335 %{!?with_divx4linux:--disable-divx4linux} \
336 %{?with_divx4linux:--with-extraincdir=/usr/include/divx} \
337 %{!?with_dxr3:--disable-dxr3} \
338 %{!?with_ggi:--disable-ggi} \
339 %{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
340 %{!?with_live:--disable-live} \
341 %{!?with_nas:--disable-nas} \
342 %{!?with_svga:--disable-svga} \
343 %{!?with_aalib:--disable-aa} \
344 %{!?with_jack:--disable-jack} \
345 %{!?with_alsa:--disable-alsa} \
346 %{?with_alsa:--enable-alsa --disable-select} \
347 %{!?with_arts:--disable-arts} \
348 %{!?with_caca:--disable-caca} \
349 %{!?with_dshow:--disable-dshow} \
350 %{?with_joystick:--enable-joystick} \
351 %{!?with_libdv:--disable-libdv} \
352 %{!?with_libdts:--disable-libdts} \
353 %{!?with_lirc:--disable-lirc} \
354 %{!?with_mad:--disable-mad} \
355 %{!?with_polyp:--disable-polyp} \
356 %{!?with_quicktime:--disable-qtx} \
357 %{!?with_real:--disable-real} \
358 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
359 %{!?with_select:--disable-select} \
360 %{!?with_smb:--disable-smb} \
361 %{!?with_win32:--disable-win32} \
362 %{!?with_vorbis:--disable-vorbis} \
363 %{?with_osd:--enable-menu} \
364 %{!?with_theora:--disable-theora} \
365 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
366 %{!?with_mencoder:--disable-mencoder} \
367         --enable-external-faad \
368         --enable-dga \
369         --enable-fbdev \
370         --enable-gl \
371         --enable-mga \
372         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
373         --enable-tdfxfb \
374         --enable-vm \
375         --enable-x11 \
376         --enable-xmga \
377         --enable-xv \
378         --enable-xvmc \
379         --enable-xvid \
380         --enable-largefiles \
381         --language=all \
382         --with-codecsdir=%{_libdir}/codecs \
383         --enable-dynamic-plugins \
384         "$@"
385
386         %{__make}
387 }
388
389 %if %{with gui}
390 # build GUI version
391 build --enable-gui
392 mv -f mplayer gmplayer
393 %{__make} clean
394 %endif
395
396 # now build regular version
397 build --disable-gui
398
399 %if %{with docs}
400 %{__make} -j1 -C DOCS/xml
401 %endif
402
403 %install
404 rm -rf $RPM_BUILD_ROOT
405 install -d \
406         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
407         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
408         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
409         $RPM_BUILD_ROOT%{_desktopdir}
410
411 # default config files
412 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
413 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
414
415 # executables
416 %if %{with mencoder}
417 install mencoder $RPM_BUILD_ROOT%{_bindir}
418 %endif
419 install mplayer $RPM_BUILD_ROOT%{_bindir}
420 %if %{with gui}
421 install gmplayer $RPM_BUILD_ROOT%{_bindir}
422 %endif
423
424 # fonts
425 rm -f font-*/runme
426 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
427 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
428
429 # libraries
430 %ifarch %{ix86}
431 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
432 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
433 %endif
434
435 %if %{with gui}
436 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
437 %endif
438
439 # X-files
440 %if %{with gui}
441 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
442 %endif
443 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
444 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
445
446 # man pages
447 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
448 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
449 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
450 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
451 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
452 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
453 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
454 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
455 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
456 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
457
458 %clean
459 rm -rf $RPM_BUILD_ROOT
460
461 %post
462 umask 022
463 /sbin/ldconfig
464 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
465
466 %postun
467 umask 022
468 /sbin/ldconfig
469 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
470
471 %files
472 %defattr(644,root,root,755)
473 %attr(755,root,root) %{_bindir}/mplayer
474
475 %if %{with gui}
476 %files -n gmplayer
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_bindir}/gmplayer
479 %{_desktopdir}/gmplayer.desktop
480 %dir %{_datadir}/%{name}/Skin
481 %ghost %{_datadir}/%{name}/Skin/default
482 %endif
483
484 %files -n mencoder
485 %defattr(644,root,root,755)
486 %doc DOCS/tech/encoding-tips.txt DOCS/tech/swscaler_filters.txt
487 %doc DOCS/tech/swscaler_methods.txt DOCS/tech/colorspaces.txt
488 %attr(755,root,root) %{_bindir}/mencoder
489
490 %files common
491 %defattr(644,root,root,755)
492 # some useful tech docs
493 %doc DOCS/tech/hwac3.txt DOCS/tech/mpsub.sub DOCS/tech/slave.txt
494 %doc DOCS/tech/subcp.txt
495
496 # HTML and XML-generated docs
497 %doc DOCS/HTML/en
498 %doc DOCS/tech
499 %if %{with win32}
500 %doc etc/codecs.win32.conf
501 %endif
502 %lang(de) %doc DOCS/de
503 %lang(es) %doc DOCS/HTML/es
504 %lang(fr) %doc DOCS/HTML/fr
505 %lang(hu) %doc DOCS/HTML/hu
506 %lang(it) %doc DOCS/it
507 %lang(pl) %doc DOCS/HTML/pl
508 %lang(ru) %doc DOCS/HTML/ru
509 %lang(zh_CN) %doc DOCS/zh
510 %doc README AUTHORS ChangeLog
511
512 %ifarch %{ix86}
513 %attr(755,root,root) %{_libdir}/libdha.so.*.*
514 %attr(755,root,root) %{_libdir}/mplayer
515 %endif
516 %dir %{_sysconfdir}/%{name}
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
518 %{_mandir}/man1/*
519 %lang(cs) %{_mandir}/cs/man1/*
520 %lang(de) %{_mandir}/de/man1/*
521 %lang(es) %{_mandir}/es/man1/*
522 %lang(fr) %{_mandir}/fr/man1/*
523 %lang(hu) %{_mandir}/hu/man1/*
524 %lang(it) %{_mandir}/it/man1/*
525 %lang(pl) %{_mandir}/pl/man1/*
526 %lang(sv) %{_mandir}/sv/man1/*
527 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
528 %{_desktopdir}/mplayer.desktop
529 %{_pixmapsdir}/*
530 %dir %{_datadir}/%{name}
531 %{_datadir}/%{name}/font*
This page took 1.947572 seconds and 4 git commands to generate.