]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- -vidix subpackage
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - use external vidix?
5 # - try to use external ffmpeg, lrmi and few other libs:
6 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
7 #
8 # Conditional build:
9 %bcond_with     directfb        # with DirectFB video output
10 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
11 %bcond_with     ggi             # with ggi video output
12 %bcond_with     nas             # with NAS audio output
13 %bcond_with     svga            # with svgalib video output
14 %bcond_with     osd             # with osd menu support
15 %bcond_without  altivec         # without altivec support
16 %bcond_without  x264            # without x264 support
17 %bcond_with     xmms            # with XMMS inputplugin support
18 %bcond_without  aalib           # without aalib video output
19 %bcond_without  jack            # without JACKD support
20 %bcond_without  alsa            # without ALSA audio output
21 %bcond_without  arts            # without arts audio output
22 %bcond_without  caca            # without libcaca video output
23 %bcond_without  cdparanoia      # without cdparanoia support
24 %bcond_without  dshow           # disable DirectShow support
25 %bcond_without  enca            # disable using ENCA charset oracle library
26 %bcond_without  esd             # disable EsounD sound support
27 %bcond_without  faad            # disable FAAD2 (AAC) support
28 %bcond_without  gif             # disable GIF support
29 %bcond_without  gui             # without GTK+ GUI
30 %bcond_without  joystick        # disable joystick support
31 %bcond_without  libdts          # disable libdts support
32 %bcond_without  libdv           # disable libdv en/decoding support
33 %bcond_without  lirc            # without lirc support
34 %bcond_without  live            # without live.com libraries
35 %bcond_with     lzo             # with LZO support (requires lzo 1.x)
36 %bcond_without  mad             # without mad (audio MPEG) support
37 %bcond_without  pulseaudio              # without pulseaudio output
38 %bcond_without  quicktime       # without binary quicktime dll support
39 %bcond_without  real            # without Real* 8/9 codecs support
40 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
41                                 #  in compile time (advertised by mplayer authors as working faster); in this case
42                                 #  mplayer may not work on machine other then where it was compiled
43 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
44 %bcond_without  smb             # disable Samba (SMB) input support
45 %bcond_without  theora          # without theora support
46 %bcond_without  win32           # without win32 codecs support
47 %bcond_without  vorbis          # without Ogg-Vorbis audio support
48 %bcond_without  xvid            # disable XviD codec
49 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
50 %bcond_without  sdl             # disable SDL
51 %bcond_without  doc             # don't build docs (slow)
52 %bcond_with     shared          # experimental libmplayer.so support
53 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
54 %bcond_without  gnomess         # disable controling gnome screensaver
55
56 %ifnarch %{ix86}
57 %undefine       with_win32
58 %undefine       with_quicktime
59 %endif
60
61 %ifarch %{x8664}
62 %undefine       with_runtime
63 %endif
64
65 %if %{_lib} == "lib64"
66 %define        _suf    64
67 %else
68 %define        _suf    32
69 %endif
70
71 %define         sname           MPlayer
72 %define         snap            %{nil}
73
74 %define         _rc     rc1
75 %define         _rel    1.3
76 Summary:        MPlayer - THE Movie Player for UN*X
77 Summary(de):    MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
78 Summary(es):    Otro reproductor de películas
79 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
80 Summary(pl):    Odtwarzacz filmów dla systemów uniksowych
81 Summary(pt_BR): Reprodutor de filmes
82 Name:           mplayer
83 Version:        1.0
84 Release:        3.%{_rc}.%{_rel}
85 # DO NOT increase epoch unless it's really neccessary!
86 # especially such changes like pre7->pre7try2, increase Release instead!
87 # PS: $ rpmvercmp pre7try2 pre7
88 # pre7try2 > pre7
89 Epoch:          3
90 License:        GPL
91 Group:          Applications/Multimedia
92 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{_rc}.tar.bz2
93 # Source0-md5:  18c05d88e22c3b815a43ca8d7152ccdc
94 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
95 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
96 Source5:        g%{name}.desktop
97 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
98 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
99 Source7:        %{name}.png
100 Source8:        %{name}.desktop
101 # http://www.on2.com/gpl/mplayer/
102 Source9:        http://www.on2.com/gpl/mplayer/2006-11-29-mencoder-on2flixenglinux.tar.bz2
103 # Source9-md5:  66fd6987f36f0b0cec6a28366ac3141c
104 Patch1:         %{name}-cp1250-fontdesc.patch
105 Patch2:         %{name}-codec.patch
106 Patch3:         %{name}-home_etc.patch
107 Patch4:         %{name}-350.patch
108 Patch5:         %{name}-configure.patch
109 Patch6:         %{name}-system-amr.patch
110 Patch8:         %{name}-altivec.patch
111 Patch10:        %{name}-pcmsplit.patch
112 Patch11:        ffmpeg-x264-symbol.patch
113 Patch12:        %{name}-pulse.patch
114 Patch13:        %{name}-mythtv.patch
115 Patch14:        %{name}-shared.patch
116 #http://www.openchrome.org/snapshots/mplayer/
117 Patch15:        %{name}-xvmc.patch
118 Patch16:        %{name}-kill-mabi_altivec.patch
119 Patch17:        %{name}-auto-expand.patch
120 Patch18:        %{name}-gnome-screensaver.patch
121 Patch19:        %{name}-on2flix.patch
122 URL:            http://www.mplayerhq.hu/
123 %{?with_directfb:BuildRequires: DirectFB-devel}
124 BuildRequires:  OpenAL-devel
125 BuildRequires:  OpenGL-devel
126 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
127 %{?with_aalib:BuildRequires:    aalib-devel}
128 %{?with_alsa:BuildRequires:     alsa-lib-devel}
129 %if %{with amr}
130 BuildRequires:  amrnb-devel
131 BuildRequires:  amrwb-devel >= 5.3.0
132 %endif
133 %{?with_arts:BuildRequires:     artsc-devel}
134 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
135 %{?with_doc:BuildRequires:      docbook-style-xsl}
136 %{?with_dxr3:BuildRequires:     em8300-devel}
137 %{?with_enca:BuildRequires:     enca-devel}
138 %{?with_esd:BuildRequires:      esound-devel}
139 BuildRequires:  faac-devel
140 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
141 BuildRequires:  freetype-devel
142 BuildRequires:  fribidi-devel
143 %ifarch ppc
144 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
145 %endif
146 %{?with_gif:BuildRequires:      giflib-devel}
147 %if %{with gui}
148 BuildRequires:  gtk+2-devel
149 %endif
150 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
151 BuildRequires:  lame-libs-devel
152 %{?with_caca:BuildRequires:     libcaca-devel}
153 %{?with_libdts:BuildRequires:   libdts-devel}
154 %{?with_libdv:BuildRequires:    libdv-devel}
155 BuildRequires:  libdvdnav-devel
156 %{?with_ggi:BuildRequires:      libggi-devel}
157 BuildRequires:  libjpeg-devel
158 %{?with_mad:BuildRequires:      libmad-devel}
159 BuildRequires:  libmpcdec-devel >= 1.2.1
160 BuildRequires:  libpng-devel
161 %{?with_smb:BuildRequires:      libsmbclient-devel}
162 %{?with_dshow:BuildRequires:    libstdc++-devel}
163 %{?with_theora:BuildRequires:   libtheora-devel}
164 # tremor is used by default, internal as we don't have system one
165 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
166 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
167 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060828_2245.1}
168 BuildRequires:  libxslt-progs
169 %{?with_lirc:BuildRequires:     lirc-devel}
170 %{?with_live:BuildRequires:     live}
171 %{?with_lzo:BuildRequires:      lzo-devel < 2.0}
172 %{?with_nas:BuildRequires:      nas-devel}
173 BuildRequires:  ncurses-devel
174 BuildRequires:  pkgconfig
175 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
176 BuildRequires:  speex-devel >= 1.1
177 %{?with_svga:BuildRequires:     svgalib-devel}
178 %{?with_xmms:BuildRequires:     xmms-libs}
179 BuildRequires:  xorg-lib-libX11-devel
180 BuildRequires:  xorg-lib-libXext-devel
181 BuildRequires:  xorg-lib-libXinerama-devel
182 BuildRequires:  xorg-lib-libXv-devel
183 BuildRequires:  xorg-lib-libXvMC-devel
184 BuildRequires:  xorg-lib-libXxf86dga-devel
185 BuildRequires:  xorg-lib-libXxf86vm-devel
186 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
187 BuildRequires:  zlib-devel
188 Requires(post,postun):  /sbin/ldconfig
189 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
190 Requires:       OpenGL
191 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
192
193 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
194 %define         specflags_ia32  -fomit-frame-pointer
195 %if %{with altivec}
196 %define         specflags_ppc   -maltivec
197 %endif
198
199 %description
200 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
201 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
202 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
203 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
204 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
205 optionally with SHM extension, X11 using overlays with the Xvideo
206 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
207 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
208
209 If you want to use win32 codecs install w32codec package.
210
211 %description -l de
212 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
213 Kennzeichnend ist die herausragende Format- und
214 Plattform-Kompatibilität.
215
216 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
217 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
218 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
219 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
220 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
221 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
222 installierte Codecs nicht mit MPlayer kollidieren können.
223
224 %description -l es
225 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
226 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
227 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
228 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
229 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
230 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
231 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
232 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
233 v1.1.7 etc.
234
235 Si quiere usar codecs Win32, instale el paquete w32codec.
236
237 %description -l ko
238 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
239 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
240 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
241 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
242 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
243 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
244 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
245 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
246 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
247
248 %description -l pl
249 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
250 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
251 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
252 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
253 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
254 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
255 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
256
257 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
258
259 %description -l pt_BR
260 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
261 áudio. Diferentes mecanismos de reprodução podem também ser
262 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
263
264 %package -n gmplayer
265 Summary:        MPlayer with GTK+ GUI interface
266 Summary(pl):    MPlayer z graficznym interfejsem GTK+
267 Group:          X11/Applications/Multimedia
268 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
269 Requires:       %{name}-skin
270 Provides:       %{name} = %{epoch}:%{version}-%{release}
271
272 %description -n gmplayer
273 MPlayer with GUI GTK+ interface.
274
275 %description -n gmplayer -l pl
276 MPlayer z graficznym interfejsem GTK+.
277
278 %package common
279 Summary:        Configuration files and documentation for MPlayer
280 Summary(pl):    Pliki konfiguracyjne i dokumentacja dla MPlayera
281 Group:          Applications/Multimedia
282
283 %description common
284 Configuration files, man page and HTML documentation for MPlayer.
285
286 %description common -l pl
287 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
288
289 %package -n mencoder
290 Summary:        MEncoder - a movie encoder for Linux
291 Summary(pl):    MEncoder - koder filmów dla Linuksa
292 Group:          Applications/Multimedia
293 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
294
295 %description -n mencoder
296 MEncoder is a movie encoder for Linux and is a part of the MPlayer
297 package.
298
299 %description -n mencoder -l pl
300 MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
301
302 %package vidix
303 Summary:        VIDeo Interface for *nIX
304 Group:          Applications/Multimedia
305 Requires:       mplayer-common = %{epoch}:%{version}-%{release}
306
307 %description vidix
308 VIDIX is the abbreviation for VIDeo Interface for *niX. VIDIX was
309 designed and introduced as an interface for fast user-space drivers
310 providing DGA everywhere where it's possible (unlike X11). I hope that
311 these drivers will be as portable as X11 (not only on *nix).
312 - What is it: It's a portable successor of mga_vid technology, but
313   it's located in user-space.
314 - Unlike X11 it provides DGA everywhere it's possible
315 - Unlike v4l it provides interface for video playback
316 - Unlike linux's drivers it uses the math library
317
318 This package contains drivers for:
319 - 3DLabs GLINT R3/Permedia3
320 - ATI Mach64
321 - ATI Radeon
322 - ATI Rage128
323 - Matrox Gxxx series (using BES and CRTC2)
324 - nVidia chips (experimental)
325 - SiS chips (experimental)
326 - S3 Savage chips (experimental)
327 - Trident Cyberblade i1
328 - VIA CLE266
329
330 %prep
331 %setup -q -n %{sname}-%{version}%{_rc} -a3 -a6 -a9
332 cp -f etc/codecs.conf etc/codecs.win32.conf
333 %patch1 -p0
334 ##%patch2 -p1
335 ##%patch3 -p1   -- old home_etc behavior
336 %patch4 -p1
337 %patch5 -p1
338 %patch6 -p1
339 %patch8 -p1
340 #%%patch10 -p1
341 %patch11 -p1
342 %patch12 -p0
343 #%patch13 -p1   # TODO
344 %if %{with shared}
345 %patch14 -p1
346 %endif
347 #%patch15 -p0   # TODO
348 %patch16 -p1
349 %patch17 -p1
350 %if %{with gnomess}
351 %patch18 -p1
352 %endif
353
354 %if 0%{?snap}
355 find . -type d -name CVS -print | xargs rm -rf
356 %endif
357
358 # on2flix
359 cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
360 %patch19 -p1
361 for a in mencoder-on2flixenglinux/*.diff; do
362         patch -p0 < $a
363 done
364
365 %build
366 %if %{with shared}
367 CFLAGS="%{rpmcflags} -fPIC"
368 %else
369 CFLAGS="%{rpmcflags}"
370 %endif
371 CC="%{__cc}"
372 LDFLAGS="%{rpmldflags}"
373 export CC CFLAGS LDFLAGS
374
375 build() {
376 set -x
377         ./configure \
378         %{?debug:--enable-debug=3} \
379         --prefix=%{_prefix} \
380         --confdir=%{_sysconfdir}/mplayer \
381         --with-x11libdir=%{_libdir} \
382         --with-extraincdir=%{_includedir}/xvid \
383         --enable-menu \
384 %ifnarch %{ix86} %{x8664}
385         --disable-mmx \
386         --disable-mmxext \
387         --disable-3dnow \
388         --disable-3dnowext \
389         --disable-sse \
390         --disable-sse2 \
391         --disable-fastmemcpy \
392 %endif
393 %ifarch ppc
394 %{!?with_altivec:--disable-altivec} \
395 %endif
396 %{!?with_amr:--disable-amr_nb --disable-amr_wb} \
397 %{?with_amr:--enable-amr_nb --enable-amr_wb} \
398 %{?with_directfb:--enable-directfb} \
399 %{!?with_directfb:--disable-directfb} \
400 %{!?with_dxr3:--disable-dxr3} \
401 %{!?with_ggi:--disable-ggi} \
402 %{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
403 %{!?with_live:--disable-live} \
404 %{!?with_lzo:--disable-liblzo} \
405 %{!?with_nas:--disable-nas} \
406 %{!?with_svga:--disable-svga} \
407 %{!?with_aalib:--disable-aa} \
408 %{!?with_jack:--disable-jack} \
409 %{!?with_alsa:--disable-alsa} \
410 %{?with_alsa:--enable-alsa --disable-select} \
411 %{!?with_arts:--disable-arts} \
412 %{!?with_caca:--disable-caca} \
413 %{!?with_cdparanoia:--disable-cdparanoia} \
414 %{!?with_dshow:--disable-dshow} \
415 %{!?with_enca:--disable-enca} \
416 %{!?with_esd:--disable-esd} \
417 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
418 %{?with_faad:--disable-faad-internal} \
419 %{!?with_gif:--disable-gif} \
420 %{?with_joystick:--enable-joystick} \
421 %{!?with_libdv:--disable-libdv} \
422 %{!?with_libdts:--disable-libdts} \
423 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
424 %{!?with_mad:--disable-mad} \
425 %{!?with_pulseaudio:--disable-pulseaudio} \
426 %{!?with_quicktime:--disable-qtx} \
427 %{!?with_real:--disable-real} \
428 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
429 %{!?with_select:--disable-select} \
430 %{!?with_smb:--disable-smb} \
431 %{!?with_win32:--disable-win32} \
432 %{!?with_vorbis:--disable-vorbis} \
433 %{?with_osd:--enable-menu} \
434 %{!?with_theora:--disable-theora} \
435 %{!?with_x264:--disable-x264} \
436 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
437 %{!?with_xvid:--disable-xvid} \
438 %{!?with_mencoder:--disable-mencoder} \
439         --enable-dga \
440         --enable-fbdev \
441         --enable-gl \
442         --enable-mga \
443         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
444         --enable-tdfxfb \
445         --enable-vm \
446         --enable-x11 \
447         --enable-xmga \
448         --enable-xv \
449         --enable-xvmc \
450         --enable-dynamic-plugins \
451         --enable-largefiles \
452         --language=all \
453         --with-codecsdir=%{_libdir}/codecs \
454         --with-xvmclib=XvMCW \
455         "$@"
456
457         %{__make}
458 }
459
460 %if %{with gui}
461 # build GUI version
462 build --enable-gui
463 mv -f mplayer gmplayer
464 %{__make} distclean
465 %endif
466
467 # now build regular version
468 build --disable-gui
469
470 %if %{with doc}
471 %{__make} -j1 -C DOCS/xml
472 %endif
473
474 %install
475 rm -rf $RPM_BUILD_ROOT
476 install -d \
477         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
478         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
479         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
480         $RPM_BUILD_ROOT%{_desktopdir}
481
482 # default config files
483 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
484 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
485
486 # executables
487 %if %{with mencoder}
488 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
489 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
490 %endif
491 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
492 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
493 %if %{with gui}
494 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
495 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
496 %endif
497
498 # fonts
499 rm -f font-*/runme
500 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
501 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
502
503 # libraries
504 %ifarch %{ix86}
505 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
506 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
507 %endif
508
509 %if %{with gui}
510 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
511 %endif
512
513 # X-files
514 %if %{with gui}
515 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
516 %endif
517 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
518 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
519
520 # man pages
521 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
522 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
523 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
524 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
525 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
526 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
527 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
528 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
529 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
530 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
531
532 %clean
533 rm -rf $RPM_BUILD_ROOT
534
535 %post -n gmplayer
536 umask 022
537 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
538
539 %postun -n gmplayer
540 umask 022
541 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
542
543 %post vidix -p /sbin/ldconfig
544 %postun vidix -p /sbin/ldconfig
545
546 %files
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_bindir}/mplayer*
549
550 %if %{with gui}
551 %files -n gmplayer
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_bindir}/gmplayer*
554 %{_desktopdir}/gmplayer.desktop
555 %dir %{_datadir}/%{name}/Skin
556 %ghost %{_datadir}/%{name}/Skin/default
557 %endif
558
559 %if %{with mencoder}
560 %files -n mencoder
561 %defattr(644,root,root,755)
562 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
563 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
564 %doc DOCS/tech/colorspaces.txt
565 %attr(755,root,root) %{_bindir}/mencoder*
566 %endif
567
568 %files common
569 %defattr(644,root,root,755)
570 # HTML and XML-generated docs
571 %doc DOCS/HTML/en
572 %doc DOCS/tech
573 %if %{with win32}
574 %doc etc/codecs.win32.conf
575 %endif
576 %lang(cs) %doc DOCS/HTML/cs
577 %lang(de) %doc DOCS/HTML/de
578 %lang(es) %doc DOCS/HTML/es
579 %lang(fr) %doc DOCS/HTML/fr
580 %lang(hu) %doc DOCS/HTML/hu
581 %lang(pl) %doc DOCS/HTML/pl
582 %lang(ru) %doc DOCS/HTML/ru
583 %lang(zh_CN) %doc DOCS/zh
584 %doc AUTHORS ChangeLog README
585
586 %dir %{_sysconfdir}/%{name}
587 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
588 %{_mandir}/man1/*
589 %lang(cs) %{_mandir}/cs/man1/*
590 %lang(de) %{_mandir}/de/man1/*
591 %lang(es) %{_mandir}/es/man1/*
592 %lang(fr) %{_mandir}/fr/man1/*
593 %lang(hu) %{_mandir}/hu/man1/*
594 %lang(it) %{_mandir}/it/man1/*
595 %lang(pl) %{_mandir}/pl/man1/*
596 %lang(sv) %{_mandir}/sv/man1/*
597 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
598 %{_desktopdir}/mplayer.desktop
599 %{_pixmapsdir}/*
600 %dir %{_datadir}/%{name}
601 %{_datadir}/%{name}/font*
602
603 %ifarch %{ix86}
604 %files vidix
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/libdha.so.*.*
607 %dir %{_libdir}/mplayer
608 %dir %{_libdir}/mplayer/vidix
609 %attr(755,root,root) %{_libdir}/mplayer/vidix/cyberblade_vid.so
610 %attr(755,root,root) %{_libdir}/mplayer/vidix/mach64_vid.so
611 %attr(755,root,root) %{_libdir}/mplayer/vidix/mga_crtc2_vid.so
612 %attr(755,root,root) %{_libdir}/mplayer/vidix/mga_vid.so
613 %attr(755,root,root) %{_libdir}/mplayer/vidix/nvidia_vid.so
614 %attr(755,root,root) %{_libdir}/mplayer/vidix/pm3_vid.so
615 %attr(755,root,root) %{_libdir}/mplayer/vidix/radeon_vid.so
616 %attr(755,root,root) %{_libdir}/mplayer/vidix/rage128_vid.so
617 %attr(755,root,root) %{_libdir}/mplayer/vidix/savage_vid.so
618 %attr(755,root,root) %{_libdir}/mplayer/vidix/sis_vid.so
619 %attr(755,root,root) %{_libdir}/mplayer/vidix/unichrome_vid.so
620 %endif
This page took 0.100807 seconds and 4 git commands to generate.