]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- add R - Blue is default skin for gmplayer
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - try to use external lrmi and few other libs:
5 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6 # - segfaults on amd64:
7 #   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8 #   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9 #
10 # Conditional build:
11 %bcond_with     directfb        # with DirectFB video output
12 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
13 %bcond_with     ggi             # with ggi video output
14 %bcond_with     nas             # with NAS audio output
15 %bcond_with     svga            # with svgalib video output
16 %bcond_with     osd             # with osd menu support
17 %bcond_without  altivec         # without altivec support
18 %bcond_without  x264            # without x264 support
19 %bcond_with     xmms            # with XMMS inputplugin support
20 %bcond_without  aalib           # without aalib video output
21 %bcond_without  jack            # without JACKD support
22 %bcond_without  alsa            # without ALSA audio output
23 %bcond_without  arts            # without arts audio output
24 %bcond_without  caca            # without libcaca video output
25 %bcond_without  cdparanoia      # without cdparanoia support
26 %bcond_without  dshow           # disable DirectShow support
27 %bcond_without  enca            # disable using ENCA charset oracle library
28 %bcond_without  esd             # disable EsounD sound support
29 %bcond_without  faad            # disable FAAD2 (AAC) support
30 %bcond_without  gif             # disable GIF support
31 %bcond_without  gui             # without GTK+ GUI
32 %bcond_without  joystick        # disable joystick support
33 %bcond_without  libdts          # disable libdts support
34 %bcond_without  libdv           # disable libdv en/decoding support
35 %bcond_without  lirc            # without lirc support
36 %bcond_with     live            # without LIVE555 libraries
37 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
38 %bcond_without  mad             # without mad (audio MPEG) support
39 %bcond_without  pulseaudio              # without pulseaudio output
40 %bcond_without  quicktime       # without binary quicktime dll support
41 %bcond_without  real            # without Real* 8/9 codecs support
42 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
43                                 #  in compile time (advertised by mplayer authors as working faster); in this case
44                                 #  mplayer may not work on machine other then where it was compiled
45 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
46 %bcond_without  smb             # disable Samba (SMB) input support
47 %bcond_without  theora          # without theora support
48 %bcond_without  win32           # without win32 codecs support
49 %bcond_without  vidix           # disable vidix
50 %bcond_without  vorbis          # without Ogg-Vorbis audio support
51 %bcond_without  xvid            # disable XviD codec
52 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
53 %bcond_without  sdl             # disable SDL
54 %bcond_without  doc             # don't build docs (slow)
55 %bcond_with     shared          # experimental libmplayer.so support
56 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
57 %bcond_without  gnomess         # disable controling gnome screensaver
58 %bcond_with     ssse3   # sse3 optimizations (needs binutils >= 2.16.92)
59
60 %ifnarch %{ix86}
61 %undefine       with_win32
62 %undefine       with_quicktime
63 %undefine       with_vidix
64 %endif
65
66 %ifarch %{x8664}
67 %undefine       with_runtime
68 %endif
69
70 %if %{_lib} == "lib64"
71 %define        _suf    64
72 %else
73 %define        _suf    32
74 %endif
75
76 %define         _rel    0.1
77 %define         _rc     rc2
78
79 Summary:        MPlayer - THE Movie Player for UN*X
80 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81 Summary(es.UTF-8):      Otro reproductor de películas
82 Summary(ko.UTF-8):      리눅스용 미디어플레이어
83 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
84 Summary(pt_BR.UTF-8):   Reprodutor de filmes
85 Name:           mplayer
86 Version:        1.0
87 Release:        5.%{_rc}.%{_rel}
88 # DO NOT increase epoch unless it's really neccessary!
89 # especially such changes like pre7->pre7try2, increase Release instead!
90 # PS: $ rpmvercmp pre7try2 pre7
91 # pre7try2 > pre7
92 Epoch:          3
93 License:        GPL
94 Group:          Applications/Multimedia
95 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{_rc}.tar.bz2
96 # Source0-md5:  7e27e535c2d267637df34898f1b91707
97 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
98 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
99 Source5:        g%{name}.desktop
100 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
101 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
102 Source7:        %{name}.png
103 Source8:        %{name}.desktop
104 # http://www.on2.com/gpl/mplayer/
105 Source9:        http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106 # Source9-md5:  2361e56b40f52dfc20131e458e2aed38
107 Patch1:         %{name}-cp1250-fontdesc.patch
108 Patch2:         %{name}-codec.patch
109 Patch3:         %{name}-home_etc.patch
110 Patch4:         %{name}-350.patch
111 Patch5:         %{name}-configure.patch
112 #Patch6:                %{name}-system-amr.patch # outdated via ffmpeg?
113 Patch8:         %{name}-altivec.patch
114 Patch10:        %{name}-pcmsplit.patch
115 Patch13:        %{name}-mythtv.patch
116 Patch14:        %{name}-shared.patch
117 #http://www.openchrome.org/snapshots/mplayer/
118 Patch15:        %{name}-xvmc.patch
119 Patch17:        %{name}-auto-expand.patch
120 #Patch18:       %{name}-gnome-screensaver.patch # update
121 Patch19:        %{name}-on2flix.patch
122 Patch22:        %{name}-ffmpeg.patch
123 Patch23:        %{name}-live.patch
124 Patch24:        %{name}-fontconfig_sub.patch
125 URL:            http://www.mplayerhq.hu/
126 %{?with_directfb:BuildRequires: DirectFB-devel}
127 BuildRequires:  OpenAL-devel
128 BuildRequires:  OpenGL-devel
129 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
130 %{?with_aalib:BuildRequires:    aalib-devel}
131 %{?with_alsa:BuildRequires:     alsa-lib-devel}
132 %if %{with amr}
133 BuildRequires:  amrnb-devel
134 BuildRequires:  amrwb-devel >= 5.3.0
135 %endif
136 %{?with_arts:BuildRequires:     artsc-devel}
137 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
138 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
139 %{?with_doc:BuildRequires:      docbook-style-xsl}
140 %{?with_dxr3:BuildRequires:     em8300-devel}
141 %{?with_enca:BuildRequires:     enca-devel}
142 %{?with_esd:BuildRequires:      esound-devel}
143 BuildRequires:  faac-devel
144 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
145 BuildRequires:  ffmpeg-devel >= 0.4.9-3.20070626.1.1
146 BuildRequires:  freetype-devel
147 BuildRequires:  fribidi-devel
148 %{?with_vidix:BuildRequires:    vidix-devel}
149 %ifarch ppc
150 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
151 %endif
152 %{?with_gif:BuildRequires:      giflib-devel}
153 %if %{with gui}
154 BuildRequires:  gtk+2-devel
155 %endif
156 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
157 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
158 BuildRequires:  lame-libs-devel
159 %{?with_caca:BuildRequires:     libcaca-devel}
160 %{?with_libdts:BuildRequires:   libdts-devel}
161 %{?with_libdv:BuildRequires:    libdv-devel}
162 BuildRequires:  libdvdnav-devel
163 %{?with_ggi:BuildRequires:      libggi-devel}
164 BuildRequires:  libjpeg-devel
165 %{?with_mad:BuildRequires:      libmad-devel}
166 BuildRequires:  libmpcdec-devel >= 1.2.1
167 BuildRequires:  libpng-devel
168 %{?with_smb:BuildRequires:      libsmbclient-devel}
169 %{?with_dshow:BuildRequires:    libstdc++-devel}
170 %{?with_theora:BuildRequires:   libtheora-devel}
171 # tremor is used by default, internal as we don't have system one
172 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
173 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060828_2245.1}
174 BuildRequires:  libxslt-progs
175 %{?with_lirc:BuildRequires:     lirc-devel}
176 %{?with_live:BuildRequires:     live}
177 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
178 %{?with_nas:BuildRequires:      nas-devel}
179 BuildRequires:  ncurses-devel
180 BuildRequires:  pkgconfig
181 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
182 BuildRequires:  speex-devel >= 1.1
183 %{?with_svga:BuildRequires:     svgalib-devel}
184 %{?with_xmms:BuildRequires:     xmms-libs}
185 BuildRequires:  xorg-lib-libX11-devel
186 BuildRequires:  xorg-lib-libXext-devel
187 BuildRequires:  xorg-lib-libXinerama-devel
188 BuildRequires:  xorg-lib-libXv-devel
189 BuildRequires:  xorg-lib-libXvMC-devel
190 BuildRequires:  xorg-lib-libXxf86dga-devel
191 BuildRequires:  xorg-lib-libXxf86vm-devel
192 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
193 BuildRequires:  zlib-devel
194 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
195 Requires:       OpenGL
196 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
197
198 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
199 %define         specflags_ia32  -fomit-frame-pointer
200 %if %{with altivec}
201 %define         specflags_ppc   -maltivec
202 %endif
203
204 %description
205 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
206 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
207 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
208 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
209 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
210 optionally with SHM extension, X11 using overlays with the Xvideo
211 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
212 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
213
214 If you want to use win32 codecs install w32codec package.
215
216 %description -l de.UTF-8
217 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
218 Kennzeichnend ist die herausragende Format- und
219 Plattform-Kompatibilität.
220
221 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
222 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
223 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
224 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
225 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
226 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
227 installierte Codecs nicht mit MPlayer kollidieren können.
228
229 %description -l es.UTF-8
230 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
231 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
232 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
233 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
234 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
235 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
236 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
237 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
238 v1.1.7 etc.
239
240 Si quiere usar codecs Win32, instale el paquete w32codec.
241
242 %description -l ko.UTF-8
243 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
244 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
245 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
246 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
247 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
248 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
249 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
250 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
251 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
252
253 %description -l pl.UTF-8
254 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
255 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
256 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
257 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
258 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
259 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
260 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
261
262 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
263
264 %description -l pt_BR.UTF-8
265 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
266 áudio. Diferentes mecanismos de reprodução podem também ser
267 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
268
269 %package -n gmplayer
270 Summary:        MPlayer with GTK+ GUI interface
271 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
272 Group:          X11/Applications/Multimedia
273 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
274 Requires:       %{name}-skin
275 Requires:       %{name}-skin-Blue
276 Provides:       %{name} = %{epoch}:%{version}-%{release}
277
278 %description -n gmplayer
279 MPlayer with GUI GTK+ interface.
280
281 %description -n gmplayer -l pl.UTF-8
282 MPlayer z graficznym interfejsem GTK+.
283
284 %package common
285 Summary:        Configuration files and documentation for MPlayer
286 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
287 Group:          Applications/Multimedia
288 Obsoletes:      mplayer-vidix
289
290 %description common
291 Configuration files, man page and HTML documentation for MPlayer.
292
293 %description common -l pl.UTF-8
294 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
295
296 %package -n mencoder
297 Summary:        MEncoder - a movie encoder for Linux
298 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
299 Group:          Applications/Multimedia
300 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
301
302 %description -n mencoder
303 MEncoder is a movie encoder for Linux and is a part of the MPlayer
304 package.
305
306 %description -n mencoder -l pl.UTF-8
307 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
308
309 %prep
310 %setup -q -n MPlayer-%{version}%{_rc} -a3 -a6 -a9
311 cp -f etc/codecs.conf etc/codecs.win32.conf
312 %patch1 -p0
313 ##%patch2 -p1
314 ##%patch3 -p1   -- old home_etc behavior
315 %patch4 -p1
316 %patch5 -p1
317 #%patch6 -p1 # - try ffmpeg
318 %patch8 -p1
319 #%%patch10 -p1
320 #%patch13 -p1   # TODO
321 %if %{with shared}
322 %patch14 -p1
323 %endif
324 #%patch15 -p0   # TODO
325 %patch17 -p1
326 %if %{with gnomess}
327 #%patch18 -p1
328 %endif
329
330 # on2flix
331 cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
332 rm -f mencoder-on2flixenglinux/version.diff
333 %patch19 -p1
334 for a in mencoder-on2flixenglinux/*.diff; do
335         patch -p0 < $a
336 done
337
338 %patch22 -p1
339 %patch23 -p1
340 %patch24 -p0
341
342 %build
343 %if %{with shared}
344 CFLAGS="%{rpmcflags} -fPIC"
345 %else
346 CFLAGS="%{rpmcflags}"
347 %endif
348 CC="%{__cc}"
349 LDFLAGS="%{rpmldflags}"
350 export CC CFLAGS LDFLAGS
351
352 build() {
353 set -x
354         ./configure \
355         %{?debug:--enable-debug=3} \
356         --prefix=%{_prefix} \
357         --confdir=%{_sysconfdir}/mplayer \
358         --with-extraincdir=%{_includedir}/xvid \
359         --with-extralibdir=%{_x_libraries} \
360         --enable-menu \
361         --disable-libavutil_a \
362         --disable-libavcodec_a \
363         --disable-libavformat_a \
364         --disable-libpostproc_a \
365         --enable-libavutil_so \
366         --enable-libavcodec_so \
367         --enable-libavformat_so \
368         --enable-libpostproc_so \
369 %ifnarch %{ix86} %{x8664}
370         --disable-mmx \
371         --disable-mmxext \
372         --disable-3dnow \
373         --disable-3dnowext \
374         --disable-sse \
375         --disable-sse2 \
376         --disable-fastmemcpy \
377 %endif
378         %{!?with_ssse3:--disable-ssse3} \
379 %ifarch ppc
380 %{!?with_altivec:--disable-altivec} \
381 %endif
382 %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
383 %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
384 %{?with_directfb:--enable-directfb} \
385 %{!?with_directfb:--disable-directfb} \
386 %{!?with_dxr3:--disable-dxr3} \
387 %{!?with_ggi:--disable-ggi} \
388 %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
389 %{!?with_live:--disable-live} \
390 %{!?with_lzo:--disable-liblzo} \
391 %{!?with_nas:--disable-nas} \
392 %{!?with_svga:--disable-svga} \
393 %{!?with_aalib:--disable-aa} \
394 %{!?with_jack:--disable-jack} \
395 %{!?with_alsa:--disable-alsa} \
396 %{?with_alsa:--enable-alsa --disable-select} \
397 %{!?with_arts:--disable-arts} \
398 %{!?with_caca:--disable-caca} \
399 %{!?with_cdparanoia:--disable-cdparanoia} \
400 %{!?with_dshow:--disable-dshow} \
401 %{!?with_enca:--disable-enca} \
402 %{!?with_esd:--disable-esd} \
403 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
404 %{?with_faad:--disable-faad-internal} \
405 %{!?with_gif:--disable-gif} \
406 %{?with_joystick:--enable-joystick} \
407 %{!?with_libdv:--disable-libdv} \
408 %{!?with_libdts:--disable-libdts} \
409 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
410 %{!?with_mad:--disable-mad} \
411 %{!?with_pulseaudio:--disable-pulse} \
412 %{!?with_quicktime:--disable-qtx} \
413 %{!?with_real:--disable-real} \
414 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
415 %{!?with_select:--disable-select} \
416 %{!?with_smb:--disable-smb} \
417 %{!?with_win32:--disable-win32dll} \
418 %{!?with_vorbis:--disable-vorbis} \
419 %{?with_osd:--enable-menu} \
420 %{!?with_theora:--disable-theora} \
421 %{!?with_x264:--disable-x264} \
422 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
423 %{!?with_xvid:--disable-xvid} \
424 %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
425 %{?with_vidix:--disable-vidix-internal} \
426 %{!?with_mencoder:--disable-mencoder} \
427         --enable-dga1 \
428         --enable-dga2 \
429         --enable-fbdev \
430         --enable-gl \
431         --enable-mga \
432         --enable-radio \
433         --enable-radio-capture \
434         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
435         --enable-tdfxfb \
436         --enable-vm \
437         --enable-x11 \
438         --enable-xmga \
439         --enable-xv \
440         --enable-xvmc \
441         --enable-dynamic-plugins \
442         --enable-largefiles \
443         --language=all \
444         --codecsdir=%{_libdir}/codecs \
445         --with-xvmclib=XvMCW \
446         "$@"
447
448         %{__make}
449 }
450
451 %if %{with gui}
452 # build GUI version
453 build --enable-gui --disable-mencoder
454 mv -f mplayer gmplayer
455 %{__make} distclean
456 %endif
457
458 # now build regular version
459 build --disable-gui
460
461 %if %{with doc}
462 %{__make} -C DOCS/xml
463 %endif
464
465 %install
466 rm -rf $RPM_BUILD_ROOT
467 install -d \
468         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
469         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
470         $RPM_BUILD_ROOT%{_datadir}/mplayer/Skin \
471         $RPM_BUILD_ROOT%{_desktopdir}
472
473 # default config files
474 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
475 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
476
477 # executables
478 %if %{with mencoder}
479 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
480 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
481 %endif
482 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
483 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
484 %if %{with gui}
485 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
486 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
487 %endif
488
489 # fonts
490 rm -f font-*/runme
491 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
492 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
493
494 %if %{with gui}
495 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
496 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
497 %endif
498 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
499 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
500
501 # man pages
502 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
503 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
504 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
505 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
506 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
507 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
508 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
509 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
510 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
511 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
512
513 %clean
514 rm -rf $RPM_BUILD_ROOT
515
516 %post -n gmplayer
517 umask 022
518 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
519
520 %postun -n gmplayer
521 umask 022
522 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
523
524 %files
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_bindir}/mplayer*
527
528 %if %{with gui}
529 %files -n gmplayer
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_bindir}/gmplayer*
532 %{_desktopdir}/gmplayer.desktop
533 %dir %{_datadir}/%{name}/Skin
534 %ghost %{_datadir}/%{name}/Skin/default
535 %endif
536
537 %if %{with mencoder}
538 %files -n mencoder
539 %defattr(644,root,root,755)
540 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
541 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
542 %doc DOCS/tech/colorspaces.txt
543 %attr(755,root,root) %{_bindir}/mencoder*
544 %endif
545
546 %files common
547 %defattr(644,root,root,755)
548 %doc DOCS/tech
549 %if %{with win32}
550 %doc etc/codecs.win32.conf
551 %endif
552 %if %{with doc}
553 # HTML and XML-generated docs
554 %doc DOCS/HTML/en
555 %lang(cs) %doc DOCS/HTML/cs
556 %lang(de) %doc DOCS/HTML/de
557 %lang(es) %doc DOCS/HTML/es
558 %lang(fr) %doc DOCS/HTML/fr
559 %lang(hu) %doc DOCS/HTML/hu
560 %lang(pl) %doc DOCS/HTML/pl
561 %lang(ru) %doc DOCS/HTML/ru
562 #%lang(zh_CN) %doc DOCS/zh
563 %endif
564 %doc AUTHORS README
565
566 %dir %{_sysconfdir}/%{name}
567 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
568 %{_mandir}/man1/*
569 %lang(cs) %{_mandir}/cs/man1/*
570 %lang(de) %{_mandir}/de/man1/*
571 %lang(es) %{_mandir}/es/man1/*
572 %lang(fr) %{_mandir}/fr/man1/*
573 %lang(hu) %{_mandir}/hu/man1/*
574 %lang(it) %{_mandir}/it/man1/*
575 %lang(pl) %{_mandir}/pl/man1/*
576 #%lang(sv) %{_mandir}/sv/man1/*
577 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
578 %{_desktopdir}/mplayer.desktop
579 %{_pixmapsdir}/mplayer.png
580 %dir %{_datadir}/%{name}
581 %{_datadir}/%{name}/font*
This page took 0.070566 seconds and 4 git commands to generate.