]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- rel 2
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 %bcond_with     directfb        # with DirectFB video output
4 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
5 %bcond_with     ggi             # with ggi video output
6 %bcond_with     nas             # with NAS audio output
7 %bcond_with     svga            # with svgalib video output
8 %bcond_without  osd             # with osd menu support
9 %bcond_without  altivec         # without altivec support
10 %bcond_without  x264            # without x264 support
11 %bcond_with     xmms            # with XMMS inputplugin support
12 %bcond_without  aalib           # without aalib video output
13 %bcond_without  jack            # without JACKD support
14 %bcond_without  alsa            # without ALSA audio output
15 %bcond_with     arts            # with arts audio output
16 %bcond_without  caca            # without libcaca video output
17 %bcond_without  cdparanoia      # without cdparanoia support
18 %bcond_without  dvdnav          # without dvdnav support
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_with     esd             # enable EsounD sound support
21 %bcond_without  faad            # disable FAAD2 (AAC) support
22 %bcond_without  gif             # disable GIF support
23 %bcond_without  gui             # without GTK+ GUI
24 %bcond_without  joystick        # disable joystick support
25 %bcond_without  libdts          # disable libdts support
26 %bcond_without  libdv           # disable libdv en/decoding support
27 %bcond_without  lirc            # without lirc support
28 %bcond_without  live            # without LIVE555 libraries
29 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
30 %bcond_without  mad             # without mad (audio MPEG) support
31 %bcond_without  pulseaudio      # without pulseaudio output
32 %bcond_without  quicktime       # without binary quicktime dll support
33 %bcond_without  real            # without Real* 8/9 codecs support
34 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
35                                 #  in compile time (advertised by mplayer authors as working faster); in this case
36                                 #  mplayer may not work on machine other then where it was compiled
37 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
38 %bcond_without  smb             # disable Samba (SMB) input support
39 %bcond_without  theora          # without theora support
40 %bcond_without  win32           # without win32 codecs support
41 %bcond_without  vdpau           # disable vdpau
42 %bcond_without  vidix           # disable vidix
43 %bcond_without  vorbis          # without Ogg-Vorbis audio support
44 %bcond_with     system_vorbis   # use system libvorbis instead of internal tremor
45 %bcond_without  xvid            # disable XviD codec
46 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
47 %bcond_without  sdl             # disable SDL
48 %bcond_without  doc             # don't build docs (slow)
49 %bcond_with     shared          # experimental libmplayer.so support
50 %bcond_without  amr             # enable Adaptive Multi Rate (AMR) speech codec support
51 %bcond_without  gnomess         # disable controling gnome screensaver
52 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
53 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
54 %bcond_with     on2             # with patches from On2 Flix Engine for Linux
55 %if "%{pld_release}" == "ac"
56 %bcond_with             hidden_visibility       # no gcc hidden visibility
57 %else
58 %bcond_without  hidden_visibility       # no gcc hidden visibility
59 %endif
60
61 %if %{with alsa}
62 %undefine       with_select
63 %endif
64
65 %if %{without vorbis}
66 %undefine       with_system_vorbis
67 %endif
68
69 %ifnarch %{ix86}
70 %undefine       with_win32
71 %undefine       with_quicktime
72 %undefine       with_vidix
73 %endif
74
75 %ifnarch %{ix86} %{x8664} ppc ppc64
76 %undefine       with_runtime
77 %endif
78
79 %ifnarch %{ix86} %{x8664}
80 %undefine       with_vdpau
81 %endif
82
83 %ifnarch ppc
84 %undefine       with_altivec
85 %endif
86
87 %if %{_lib} == "lib64"
88 %define         _suf    64
89 %else
90 %define         _suf    32
91 %endif
92
93 %define         subver  rc5
94 %define         svnver  32923
95 %define         rel     2
96 Summary:        MPlayer - THE Movie Player for UN*X
97 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
98 Summary(es.UTF-8):      Otro reproductor de películas
99 Summary(ko.UTF-8):      리눅스용 미디어플레이어
100 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
101 Summary(pt_BR.UTF-8):   Reprodutor de filmes
102 Name:           mplayer
103 Version:        1.0
104 Release:        5.%{subver}_svn%{svnver}.%{rel}
105 # DO NOT increase epoch unless it's really neccessary!
106 # especially such changes like pre7->pre7try2, increase Release instead!
107 # PS: $ rpmvercmp pre7try2 pre7
108 # pre7try2 > pre7
109 Epoch:          3
110 License:        GPL
111 Group:          Applications/Multimedia
112 # svn export svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
113 # tar -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
114 # for ffmpeg git://git.videolan.org/ffmpeg.git
115 Source0:        http://carme.pld-linux.org/~cactus/snaps/mplayer/%{name}-r%{svnver}.tar.xz
116 # Source0-md5:  8de311873d5a9342387197b0a16c7756
117 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
118 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
119 Source5:        g%{name}.desktop
120 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
121 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
122 Source7:        %{name}.png
123 Source8:        %{name}.desktop
124 # http://www.on2.com/gpl/mplayer/
125 Source9:        http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
126 # Source9-md5:  07774a2663a8fda07c308df0c6569b56
127
128 # build (configure / Makefile) related:
129 Patch10:        %{name}-ldflags.patch
130 Patch11:        %{name}-altivec.patch
131 Patch12:        %{name}-check-byteswap.patch
132 Patch13:        %{name}-visibility-hidden-fix.patch
133 Patch14:        %{name}-ffmpeg.patch
134 Patch15:        %{name}-shared_live.patch
135 Patch16:        %{name}-shared.patch
136
137 # codecs, outputs, demuxers:
138 Patch20:        %{name}-auto-expand.patch
139 Patch21:        %{name}-release_directfb.patch
140
141 # goodies:
142 Patch30:        %{name}-cp1250-fontdesc.patch
143 Patch31:        %{name}-350.patch
144 # update, hard to fix right now because of gnome bug 579430:
145 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
146 #Patch32:       %{name}-gnome-screensaver.patch
147
148 Patch100:       %{name}-on2flix.patch
149 Patch101:       %{name}-link.patch
150
151 URL:            http://www.mplayerhq.hu/
152 %{?with_directfb:BuildRequires: DirectFB-devel}
153 BuildRequires:  OpenAL-devel
154 BuildRequires:  OpenGL-devel
155 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
156 %{?with_aalib:BuildRequires:    aalib-devel}
157 %{?with_alsa:BuildRequires:     alsa-lib-devel}
158 %{?with_arts:BuildRequires:     artsc-devel}
159 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
160 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
161 BuildRequires:  dirac-devel
162 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
163 %{?with_doc:BuildRequires:      docbook-style-xsl}
164 %{?with_dxr3:BuildRequires:     em8300-devel}
165 %{?with_enca:BuildRequires:     enca-devel}
166 %{?with_esd:BuildRequires:      esound-devel}
167 BuildRequires:  faac-devel
168 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
169 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
170 BuildRequires:  freetype-devel >= 2.0.9
171 BuildRequires:  fribidi-devel
172 BuildRequires:  tar >= 1:1.22
173 %{?with_vidix:BuildRequires:    vidix-devel}
174 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
175 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
176 %{?with_gif:BuildRequires:      giflib-devel}
177 %{?with_gui:BuildRequires:      gtk+2-devel}
178 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
179 BuildRequires:  lame-libs-devel
180 %{?with_caca:BuildRequires:     libcaca-devel}
181 %{?with_libdts:BuildRequires:   libdts-devel}
182 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
183 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
184 %{?with_ggi:BuildRequires:      libggi-devel}
185 BuildRequires:  libjpeg-devel
186 %{?with_mad:BuildRequires:      libmad-devel}
187 BuildRequires:  libmng-devel
188 BuildRequires:  libmpcdec-devel >= 1.2.1
189 BuildRequires:  libpng-devel
190 %{?with_smb:BuildRequires:      libsmbclient-devel}
191 %{?with_theora:BuildRequires:   libtheora-devel}
192 %{?with_vdpau:BuildRequires:    libvdpau-devel}
193 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
194 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
195 BuildRequires:  libxslt-progs
196 %{?with_lirc:BuildRequires:     lirc-devel}
197 %{?with_live:BuildRequires:     live-devel}
198 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
199 %{?with_nas:BuildRequires:      nas-devel}
200 BuildRequires:  ncurses-devel
201 %{?with_amr:BuildRequires:      opencore-amr-devel}
202 BuildRequires:  pkgconfig
203 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
204 BuildRequires:  rpm >= 4.4.9-56
205 BuildRequires:  rpmbuild(macros) >= 1.527
206 BuildRequires:  schroedinger-devel
207 BuildRequires:  speex-devel >= 1.1
208 %{?with_svga:BuildRequires:     svgalib-devel}
209 BuildRequires:  twolame-devel
210 %{?with_xmms:BuildRequires:     xmms-devel}
211 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
212 %ifarch %{ix86} %{x8664}
213 BuildRequires:  yasm
214 %endif
215 BuildRequires:  zlib-devel
216 %if "%{pld_release}" == "ac"
217 BuildRequires:  XFree86-devel >= 4.0.2
218 %else
219 BuildRequires:  xorg-lib-libX11-devel
220 BuildRequires:  xorg-lib-libXScrnSaver-devel
221 BuildRequires:  xorg-lib-libXext-devel
222 BuildRequires:  xorg-lib-libXinerama-devel
223 BuildRequires:  xorg-lib-libXv-devel
224 BuildRequires:  xorg-lib-libXvMC-devel
225 BuildRequires:  xorg-lib-libXxf86dga-devel
226 BuildRequires:  xorg-lib-libXxf86vm-devel
227 %endif
228 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
229 Requires:       OpenGL
230 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
231
232 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
233 %define         specflags_ia32  -fomit-frame-pointer
234 %if %{with altivec}
235 %define         specflags_ppc   -maltivec
236 %endif
237
238 %if "%{pld_release}" == "ac"
239 %ifarch ppc
240 %define         __cc    gcc4
241 %endif
242 %endif
243
244 %description
245 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
246 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
247 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
248 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
249 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
250 optionally with SHM extension, X11 using overlays with the Xvideo
251 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
252 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
253
254 If you want to use win32 codecs install w32codec package.
255
256 %description -l de.UTF-8
257 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
258 Kennzeichnend ist die herausragende Format- und
259 Plattform-Kompatibilität.
260
261 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
262 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
263 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
264 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
265 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
266 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
267 installierte Codecs nicht mit MPlayer kollidieren können.
268
269 %description -l es.UTF-8
270 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
271 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
272 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
273 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
274 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
275 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
276 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
277 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
278 v1.1.7 etc.
279
280 Si quiere usar codecs Win32, instale el paquete w32codec.
281
282 %description -l ko.UTF-8
283 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
284 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
285 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
286 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
287 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
288 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
289 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
290 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
291 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
292
293 %description -l pl.UTF-8
294 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
295 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
296 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
297 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
298 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
299 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
300 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
301
302 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
303
304 %description -l pt_BR.UTF-8
305 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
306 áudio. Diferentes mecanismos de reprodução podem também ser
307 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
308
309 %package -n gmplayer
310 Summary:        MPlayer with GTK+ GUI interface
311 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
312 Group:          X11/Applications/Multimedia
313 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
314 Requires:       %{name}-skin
315
316 %description -n gmplayer
317 MPlayer with GUI GTK+ interface.
318
319 %description -n gmplayer -l pl.UTF-8
320 MPlayer z graficznym interfejsem GTK+.
321
322 %package common
323 Summary:        Configuration files and documentation for MPlayer
324 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
325 Group:          Applications/Multimedia
326 Suggests:       unrar
327 Obsoletes:      mplayer-vidix
328
329 %description common
330 Configuration files, man page and HTML documentation for MPlayer.
331
332 %description common -l pl.UTF-8
333 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
334
335 %package -n mencoder
336 Summary:        MEncoder - a movie encoder for Linux
337 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
338 Group:          Applications/Multimedia
339 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
340
341 %description -n mencoder
342 MEncoder is a movie encoder for Linux and is a part of the MPlayer
343 package.
344
345 %description -n mencoder -l pl.UTF-8
346 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
347
348 %prep
349 %setup -q -n %{name}-r%{svnver} -a3 -a6 -a9
350 cp -f etc/codecs.conf etc/codecs.win32.conf
351
352 # build (configure / Makefile) related:
353 %patch10 -p1
354 %patch11 -p1
355 %patch12 -p1
356 %patch13 -p1
357 %{?with_system_ffmpeg:%patch14 -p1}
358 %{?with_live:%patch15 -p1}
359 %{?with_shared:%patch16 -p1}
360
361 # codecs, outputs, demuxers:
362 %patch20 -p1
363 %patch21 -p1
364
365 # goodies:
366 %patch30 -p0
367 %patch31 -p1
368 #%{with_gnomess:%patch32 -p1}
369
370 # on2flix
371 mv mencoder-on2flixenglinux{-*-*-*,}
372 %if %{with on2}
373 #%%patch100 -p1
374 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
375 # remove broken patches:
376 # - first set does not apply
377 # - second set beakes build
378 for PATCH in    asf-correct_movielength avi_check_idxflags \
379                 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
380                 mencoder_07_demux_update_pts mencoder_10_correct_pts \
381                 mpegvideo-revert_r18381 \
382                 \
383                 reduce_spurious_logging
384 do
385         rm mencoder-on2flixenglinux/patch/$PATCH.diff
386 done
387 for a in mencoder-on2flixenglinux/patch/*.diff; do
388         patch -p0 < $a
389 done
390 %endif
391
392 %patch101 -p1
393
394 # Set version
395 %if "x%{svnver}" != "x%{nil}"
396         echo "SVN-r%{svnver}%{?with_on2:-on2}" > VERSION
397 %endif
398
399 cat etc/example.conf > etc/mplayer.conf
400 cat <<'CONFIGADD' >> etc/mplayer.conf
401
402 ######################
403 # PLD Linux Defaults #
404 ######################
405 [default]
406
407 # alternate solution for CP1250-encoded subtitles
408 fontconfig = yes
409 subcp = cp1250
410
411 # ...or if you prefer native bitmap fonts shipped with mplayer
412 #fontconfig = no
413 #subcp = iso-8859-1
414
415 # Standard location
416 unrarexec = "%{_bindir}/unrar"
417
418 CONFIGADD
419
420 %if %{with system_ffmpeg}
421 # using external ffmpeg, but mplayer adds these to includepath
422 rm -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
423 %endif
424
425 # *** HOT FIXES ***
426
427 # typo, fixed in recent svn
428 sed 's/STREAM_NONCACHEABLE/STREAM_NON_CACHEABLE/' -i stream/stream_live555.c
429
430 # mjpeg encoder is required for Zoran hardware
431 sed '/_libavencoders="MPEG/s/"$/ MJPEG_ENCODER"/' -i configure
432
433 %build
434 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
435 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
436 %{?with_live:CFLAGS="$CFLAGS -I/usr/include/liveMedia"}
437
438 build() {
439         set -x
440
441         ./configure \
442         %{?debug:--enable-debug=3} \
443         --prefix=%{_prefix} \
444         --confdir=%{_sysconfdir}/mplayer \
445         --cc="%{__cc}" \
446         --extra-cflags="$CFLAGS" \
447         --real-ldflags="%{rpmldflags}" \
448         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
449 %if %{with system_ffmpeg}
450         --disable-libavutil_a \
451         --disable-libavcodec_a \
452         --disable-libavformat_a \
453         --disable-libpostproc_a \
454         --enable-libavutil_so \
455         --enable-libavcodec_so \
456         --enable-libavformat_so \
457         --enable-libpostproc_so \
458 %endif
459 %ifnarch %{ix86} %{x8664}
460         --disable-mmx \
461         --disable-mmxext \
462         --disable-3dnow \
463         --disable-3dnowext \
464         --disable-sse \
465         --disable-sse2 \
466         --disable-fastmemcpy \
467 %endif
468         %{__disable ssse3} \
469 %ifarch ppc
470         %{__disable altivec} \
471 %endif
472         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
473         %{__enable_disable directfb} \
474         %{__disable dxr3} \
475         %{__disable ggi} \
476         %{__disable live} \
477         %{__disable lzo liblzo} \
478         %{__disable nas} \
479         %{__disable svga} \
480         %{__disable aalib aa} \
481         %{__disable jack} \
482         %{__enable_disable alsa} \
483         %{__disable arts} \
484         %{__disable caca} \
485         %{__disable cdparanoia} \
486         %{__disable enca} \
487         %{__disable esd} \
488         %{__disable faad} \
489         %{__disable gif} \
490         %{__enable joystick} \
491         %{__disable libdv} \
492         %{__disable libdts libdca} \
493         %{__enable_disable lirc} \
494         %{__disable mad} \
495         %{__disable pulseaudio pulse} \
496         %{__disable quicktime qtx} \
497         %{__disable real} \
498         %{__enable_disable runtime runtime-cpudetection} \
499         %{__disable select} \
500         %{__disable smb} \
501         %{__disable win32 win32dll} \
502         %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis} \
503         %{__disable_if system_vorbis tremor-internal} \
504         %{__enable osd menu} \
505         %{__disable theora} \
506         %{__disable x264} \
507         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
508         %{__disable xvid} \
509         %{__disable vidix} \
510         %{__disable vdpau} \
511         %{__disable mencoder} \
512         --enable-dga1 \
513         --enable-dga2 \
514         %{__enable_disable dvdnav} \
515         --enable-fbdev \
516         --enable-gl \
517         --enable-mga \
518         --enable-radio \
519         --enable-radio-capture \
520         %{__enable_disable sdl} \
521         --enable-tdfxfb \
522         --enable-vm \
523         --enable-x11 \
524         --enable-xmga \
525         --enable-xv \
526         --enable-xvmc \
527         --with-xvmclib=XvMCW \
528         --enable-zr \
529         --enable-unrarexec \
530         --enable-dynamic-plugins \
531         --enable-largefiles \
532         --language=all \
533         --codecsdir=%{_libdir}/codecs \
534         "$@"
535
536         %{__make}
537 }
538
539 %if %{with gui}
540 # build GUI version
541 build --enable-gui --disable-mencoder
542 mv -f mplayer gmplayer
543 %{__make} distclean
544 %endif
545
546 # now build regular version
547 build --disable-gui
548
549 %if %{with doc}
550 %{__make} -j1 -C DOCS/xml
551 %endif
552
553 %install
554 rm -rf $RPM_BUILD_ROOT
555 install -d \
556         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
557         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
558         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
559         $RPM_BUILD_ROOT%{_desktopdir}
560
561 # default config files
562 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
563
564 # executables
565 %if %{with mencoder}
566 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
567 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
568 %endif
569 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
570 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
571 %if %{with gui}
572 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
573 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
574 %endif
575
576 %if %{with shared}
577 install -d $RPM_BUILD_ROOT%{_libdir}
578 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
579 %endif
580
581 # fonts
582 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
583 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
584
585 %if %{with gui}
586 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
587 %endif
588 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
589 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
590 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
591
592 # man pages
593 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
594 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
595 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
596 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
597 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
598 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
599 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
600 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
601 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
602 #install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
603
604 %clean
605 rm -rf $RPM_BUILD_ROOT
606
607 %post -n gmplayer
608 umask 022
609 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
610
611 %postun -n gmplayer
612 umask 022
613 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
614
615 %files
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/mplayer*
618
619 %if %{with gui}
620 %files -n gmplayer
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/gmplayer*
623 %{_desktopdir}/gmplayer.desktop
624 %endif
625
626 %if %{with mencoder}
627 %files -n mencoder
628 %defattr(644,root,root,755)
629 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
630 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
631 %doc DOCS/tech/colorspaces.txt
632 %attr(755,root,root) %{_bindir}/mencoder*
633 %endif
634
635 %files common
636 %defattr(644,root,root,755)
637 %doc DOCS/tech
638 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
639 %if %{with win32}
640 %doc etc/codecs.win32.conf
641 %endif
642 %if %{with doc}
643 # HTML and XML-generated docs
644 %doc DOCS/HTML/en
645 %lang(cs) %doc DOCS/HTML/cs
646 %lang(de) %doc DOCS/HTML/de
647 %lang(es) %doc DOCS/HTML/es
648 %lang(fr) %doc DOCS/HTML/fr
649 %lang(hu) %doc DOCS/HTML/hu
650 %lang(pl) %doc DOCS/HTML/pl
651 %lang(ru) %doc DOCS/HTML/ru
652 #%lang(zh_CN) %doc DOCS/zh
653 %endif
654 %doc AUTHORS README
655
656 %dir %{_sysconfdir}/%{name}
657 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
658 %{_mandir}/man1/*
659 %lang(cs) %{_mandir}/cs/man1/*
660 %lang(de) %{_mandir}/de/man1/*
661 %lang(es) %{_mandir}/es/man1/*
662 %lang(fr) %{_mandir}/fr/man1/*
663 %lang(hu) %{_mandir}/hu/man1/*
664 %lang(it) %{_mandir}/it/man1/*
665 %lang(pl) %{_mandir}/pl/man1/*
666 #%lang(sv) %{_mandir}/sv/man1/*
667 #%lang(zh_CN) %{_mandir}/zh_CN/man1/*
668 %{_desktopdir}/mplayer.desktop
669 %{_pixmapsdir}/mplayer.png
670 %dir %{_datadir}/%{name}
671 %{_datadir}/%{name}/font*
672 %dir %{_datadir}/%{name}/skins
673 %ghost %{_datadir}/%{name}/skins/default
This page took 0.079103 seconds and 4 git commands to generate.