]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- added bcond_without libdts
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 %bcond_with     directfb        # with DirectFB video output
4 %bcond_with     divx4linux      # with divx4linux a/v support (binaries, instead
5                                 #  of included OpenDivx)
6
7 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
8 %bcond_with     ggi             # with ggi video output
9 %bcond_with     live            # enable use of live.com libraries
10 %bcond_with     nas             # with NAS audio output
11 %bcond_with     svga            # with svgalib video output
12 %bcond_with     osd             # with osd menu support
13
14 %bcond_with     altivec         # with altivec support (won't run w/o altivec
15                                 # due to instruction used in CPU detection(?))
16
17 %bcond_with     xmms            # with XMMS inputplugin support
18
19 %bcond_without  aalib           # without aalib video output
20 %bcond_without  jack            # without JACKD support
21 %bcond_without  alsa            # without ALSA audio output
22 %bcond_without  arts            # without arts audio output
23 %bcond_without  caca            # without libcaca video output
24 %bcond_without  dshow           # disable DirectShow support
25 %bcond_without  gui             # without GTK+ GUI
26 %bcond_without  joystick        # disable joystick support
27 %bcond_without  libdv           # disable libdv en/decoding support
28 %bcond_without  lirc            # without lirc support
29 %bcond_without  mad             # without mad (audio MPEG) support
30 %bcond_without  polyp           # without polyp audio output
31 %bcond_without  quicktime       # without binary quicktime dll support
32 %bcond_without  real            # without Real* 8/9 codecs support
33 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
34                                 #  in compile time (advertised by mplayer
35                                 #  authors as working faster); in this case
36                                 #  mplayer may not work on machine other then
37                                 #  where it was compiled
38 %bcond_without  select          # disable audio select() support (for example
39                                 # required this option ALSA or Vortex2 driver)
40 %bcond_without  smb             # disable Samba (SMB) input support
41 %bcond_without  theora          # without theora support
42 %bcond_without  win32           # without win32 codecs support
43 %bcond_without  vorbis          # without Ogg-Vorbis audio support
44 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
45 %bcond_without  libdts          # disable libdts support
46
47 %bcond_with     gtk2            # EXPERIMENTAL support for GTK+ version 2
48 %bcond_with     xlibs
49
50 %ifnarch %{ix86}
51 %undefine       with_win32
52 %undefine       with_quicktime
53 %endif
54
55 # set it to 0, or 1
56 %define         snapshot        0
57
58 %define         sname           MPlayer
59 %define         snap            %{nil}
60
61 %define         pre             pre7
62
63 Summary:        Yet another movie player
64 Summary(es):    Otro reproductor de películas
65 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
66 Summary(pl):    Jeszcze jeden odtwarzacz filmów
67 Summary(pt_BR): Reprodutor de filmes
68 Name:           mplayer
69 Version:        1.0
70 Release:        1.%{pre}.1
71 Epoch:          2
72 License:        GPL
73 Group:          X11/Applications/Multimedia
74 %if %{snapshot}
75 #Source0:       ftp://ftp1.mplayerhq.hu/%{sname}/cvs/%{sname}-%{snap}.tar.bz2
76 #Source0:       %{name}-%{snap}.tar.bz2
77 #Source1:       libavcodec-%{snap}.tar.bz2
78 %else
79 Source0:        ftp://ftp1.mplayerhq.hu/%{sname}/releases/%{sname}-%{version}%{pre}.tar.bz2
80 # Source0-md5:  5fadd6957d3aab989cd760ff38fb8fdf
81 %endif
82 Source3:        ftp://ftp1.mplayerhq.hu/%{sname}/releases/fonts/font-arial-iso-8859-2.tar.bz2
83 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
84 Source4:        ftp://ftp1.mplayerhq.hu/%{sname}/Skin/Blue-1.4.tar.bz2
85 # Source4-md5:  05dd8e4f11a715c9e5d2abf1cdeb907c
86 Source5:        g%{name}.desktop
87 Source6:        ftp://ftp1.mplayerhq.hu/%{sname}/releases/fonts/font-arial-iso-8859-1.tar.bz2
88 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
89 Source7:        %{name}.png
90 Patch0:         %{name}-no_libnsl.patch
91 Patch1:         %{name}-cp1250-fontdesc.patch
92 Patch2:         %{name}-codec.patch
93 Patch3:         %{name}-home_etc.patch
94 Patch4:         %{name}-350.patch
95 Patch5:         %{name}-configure.patch
96 Patch6:         %{name}-gtk+2.patch
97 Patch7:         %{name}-alpha.patch
98 Patch8:         %{name}-altivec.patch
99 Patch9:         %{name}-assembly.patch
100 Patch10:        %{name}-pcmsplit.patch
101 Patch11:        %{name}-bio2jack.patch
102 URL:            http://www.mplayerhq.hu/
103 %{?with_directfb:BuildRequires: DirectFB-devel}
104 BuildRequires:  OpenGL-devel
105 BuildRequires:  SDL-devel >= 1.1.7
106 %if %{with xlibs}
107 BuildRequires:  libXv-devel
108 %else
109 BuildRequires:  XFree86-devel >= 4.0.2
110 %endif
111 %{?with_aalib:BuildRequires:    aalib-devel}
112 %{?with_alsa:BuildRequires:     alsa-lib-devel}
113 %{?with_arts:BuildRequires:     artsc-devel}
114 BuildRequires:  audiofile-devel
115 BuildRequires:  cdparanoia-III-devel
116 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.01.20020418}
117 %{?with_dxr3:BuildRequires:     em8300-devel}
118 BuildRequires:  enca-devel
119 BuildRequires:  esound-devel
120 BuildRequires:  faad2-devel >= 2.0
121 BuildRequires:  freetype-devel
122 %ifarch ppc
123 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
124 %endif
125 %if %{with gui}
126 BuildRequires:  gtk+%{?with_gtk2:2}-devel
127 %endif
128 BuildRequires:  lame-libs-devel
129 %{?with_jack:BuildRequires:     libbio2jack-devel}
130 %{?with_caca:BuildRequires:     libcaca-devel}
131 %{?with_libdts:BuildRequires:   libdts-devel}
132 %{?with_libdv:BuildRequires:    libdv-devel}
133 %{?with_ggi:BuildRequires:      libggi-devel}
134 BuildRequires:  libjpeg-devel
135 %{?with_mad:BuildRequires:      libmad-devel}
136 BuildRequires:  libpng-devel
137 %{?with_smb:BuildRequires:      libsmbclient-devel}
138 %{?with_dshow:BuildRequires:    libstdc++-devel}
139 %{?with_theora:BuildRequires:   libtheora-devel}
140 %{?with_vorbis:BuildRequires:   libvorbis-devel}
141 BuildRequires:  libungif-devel
142 BuildRequires:  libxslt-progs
143 %{?with_lirc:BuildRequires:     lirc-devel}
144 %{?with_live:BuildRequires:     live}
145 BuildRequires:  lzo-devel
146 %{?with_nas:BuildRequires:      nas-devel}
147 BuildRequires:  ncurses-devel
148 %{?with_polyp:BuildRequires:    polypaudio-devel}
149 %{?with_svga:BuildRequires:     svgalib-devel}
150 %{?with_xmms:BuildRequires:     xmms-libs}
151 BuildRequires:  xvid-devel >= 1:0.9.0
152 BuildRequires:  zlib-devel
153 Requires(post,postun):  /sbin/ldconfig
154 Requires:       OpenGL
155 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
156
157 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
158 %define         specflags       -fomit-frame-pointer
159 %define         specflags_alpha -mmax
160 %if %{with altivec}
161 %define         specflags_ppc   -maltivec -mabi=altivec
162 %endif
163
164 %description
165 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
166 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
167 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
168 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
169 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
170 optionally with SHM extension, X11 using overlays with the Xvideo
171 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
172 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
173
174 If you want to use win32 codecs install w32codec package.
175
176 %description -l es
177 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
178 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
179 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
180 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
181 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
182 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
183 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
184 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
185 v1.1.7 etc.
186
187 Si quiere usar codecs Win32, instale el paquete w32codec.
188
189 %description -l ko
190 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
191 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
192 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
193 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
194 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
195 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
196 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
197 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
198 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
199
200 %description -l pl
201 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
202 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
203 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
204 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
205 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
206 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
207 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
208
209 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
210
211 %description -l pt_BR
212 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
213 áudio. Diferentes mecanismos de reprodução podem também ser
214 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
215
216 %prep
217 %if %{snapshot}
218 %setup -q -n %{name}-%{snap} -a 1 -a 3 -a 6
219 %else
220 %setup -q -n %{sname}-%{version}%{pre} -a 3 -a 6
221 %endif
222
223 cp -f etc/codecs.conf etc/codecs.win32.conf
224 %patch0 -p1
225 %patch1 -p0
226 ##%patch2 -p1
227 ##%patch3 -p1   -- old home_etc behavior
228 %patch4 -p1
229 %patch5 -p1
230 %if %{with gtk2}
231 %patch6 -p1
232 %endif
233 %patch7 -p1
234 %patch8 -p1
235 %patch9 -p1
236 #%%patch10 -p1
237 %patch11 -p1
238
239 # kill evil file, hackery not needed with llh
240 echo > osdep/kerneltwosix.h
241
242 find . -type d -name CVS -print | xargs rm -rf
243
244 %build
245 CFLAGS="%{rpmcflags}"
246 CC="%{__cc}"
247 export CC CFLAGS
248 ./configure \
249         --prefix=%{_prefix} \
250         --confdir=%{_sysconfdir}/mplayer \
251         --with-x11incdir=%{_prefix}/X11R6/include \
252         --with-extraincdir=%{_includedir}/xvid \
253 %ifnarch %{ix86}
254         --disable-mmx \
255         --disable-mmx2 \
256         --disable-3dnow \
257         --disable-3dnowex \
258         --disable-sse \
259         --disable-sse2 \
260         --disable-fastmemcpy \
261 %endif
262 %ifarch ppc
263 %{!?with_altivec:--disable-altivec} \
264 %endif
265 %{!?with_directfb:--disable-directfb} \
266 %{!?with_divx4linux:--disable-divx4linux} \
267 %{?with_divx4linux:--with-extraincdir=/usr/include/divx} \
268 %{!?with_dxr3:--disable-dxr3} \
269 %{!?with_ggi:--disable-ggi} \
270 %{?with_live:--enable-live --with-livelibdir=/usr/lib/liveMedia --with-extraincdir=/usr/include/liveMedia } \
271 %{!?with_live:--disable-live} \
272 %{!?with_nas:--disable-nas} \
273 %{!?with_svga:--disable-svga} \
274 %{!?with_aalib:--disable-aa} \
275 %{!?with_jack:--disable-jack} \
276 %{!?with_alsa:--disable-alsa} \
277 %{?with_alsa:--enable-alsa --disable-select} \
278 %{!?with_arts:--disable-arts} \
279 %{!?with_caca:--disable-caca} \
280 %{!?with_dshow:--disable-dshow} \
281 %{?with_gui:--enable-gui} \
282 %{?with_joystick:--enable-joystick} \
283 %{!?with_libdv:--disable-libdv} \
284 %{!?with_libdts:--disable-libdts} \
285 %{!?with_lirc:--disable-lirc} \
286 %{!?with_mad:--disable-mad} \
287 %{!?with_polyp:--disable-polyp} \
288 %{!?with_quicktime:--disable-qtx} \
289 %{!?with_real:--disable-real} \
290 %{!?with_runtime:--disable-runtime-cpudetection} \
291 %{?with_runtime:--enable-runtime-cpudetection} \
292 %{!?with_select:--disable-select} \
293 %{!?with_smb:--disable-smb} \
294 %{!?with_win32:--disable-win32} \
295 %{!?with_vorbis:--disable-vorbis} \
296 %{?with_osd:--enable-menu} \
297 %{!?with_theora:--disable-theora} \
298 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
299 %{!?with_mencoder:--disable-mencoder} \
300         --enable-external-faad \
301         --enable-dga \
302         --enable-fbdev \
303         --enable-gl \
304         --enable-mga \
305         --enable-sdl \
306         --enable-tdfxfb \
307         --enable-vm \
308         --enable-x11 \
309         --enable-xmga \
310         --enable-xv \
311         --enable-xvmc \
312         --enable-xvid \
313         --enable-largefiles \
314         --language=all \
315         --with-codecsdir=%{_libdir}/codecs \
316         --enable-dynamic-plugins
317
318 %{__make}
319
320 %{__make} -C DOCS/xml
321
322 %install
323 rm -rf $RPM_BUILD_ROOT
324 install -d \
325         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
326         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
327         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
328         $RPM_BUILD_ROOT%{_desktopdir}
329
330 # default config files
331 awk '/Delete this default/{a++};{if(!a){print}}' etc/example.conf > etc/mplayer.conf
332 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
333
334 # executables
335 %if %{with mencoder}
336 install mencoder $RPM_BUILD_ROOT%{_bindir}
337 %endif
338 install mplayer $RPM_BUILD_ROOT%{_bindir}
339 ln -sf mplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer
340
341 # fonts
342 rm -f font-*/runme
343 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
344 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
345
346 # skin
347 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_datadir}/mplayer/Skin
348 rm -rf $RPM_BUILD_ROOT%{_datadir}/mplayer/Skin/*/CVS
349
350 # libraries
351 %ifarch %{ix86}
352 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
353 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
354 %endif
355
356 # X-files
357 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
358 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
359
360 # man pages
361 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
362 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
363 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
364 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
365 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
366 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
367 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
368 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
369 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
370 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
371
372 %clean
373 rm -rf $RPM_BUILD_ROOT
374
375 %post
376 umask 022
377 /sbin/ldconfig
378 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
379
380 %postun
381 umask 022
382 /sbin/ldconfig
383 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
384
385 %files
386 %defattr(644,root,root,755)
387 %doc DOCS/HTML/en/*.html DOCS/tech %{?with_win32:etc/codecs.win32.conf}
388 %lang(de) %doc DOCS/de
389 %lang(es) %doc DOCS/HTML/es
390 %lang(fr) %doc DOCS/HTML/fr
391 %lang(hu) %doc DOCS/HTML/hu
392 %lang(it) %doc DOCS/it
393 %lang(pl) %doc DOCS/HTML/pl
394 %lang(ru) %doc DOCS/HTML/ru
395 %lang(zh_CN) %doc DOCS/zh
396 %doc README AUTHORS ChangeLog
397 %attr(755,root,root) %{_bindir}/*
398 %ifarch %{ix86}
399 %attr(755,root,root) %{_libdir}/libdha.so.*.*
400 %attr(755,root,root) %{_libdir}/mplayer
401 %endif
402 %{_datadir}/mplayer
403 %dir %{_sysconfdir}/mplayer
404 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/mplayer/*.conf
405 %{_mandir}/man1/*
406 %lang(cs) %{_mandir}/cs/man1/*
407 %lang(de) %{_mandir}/de/man1/*
408 %lang(es) %{_mandir}/es/man1/*
409 %lang(fr) %{_mandir}/fr/man1/*
410 %lang(hu) %{_mandir}/hu/man1/*
411 %lang(it) %{_mandir}/it/man1/*
412 %lang(pl) %{_mandir}/pl/man1/*
413 %lang(sv) %{_mandir}/sv/man1/*
414 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
415 %if %{with gui}
416 %{_desktopdir}/*
417 %{_pixmapsdir}/*
418 %endif
This page took 1.180011 seconds and 4 git commands to generate.