]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- R: mplayer-skin-Blue - because this is default skin in spec
[packages/mplayer.git] / mplayer.spec
1 # TODO:
2 # - nut support (http://www.nut.hu/ - currently down, but see svn.mplayerhq.hu/nut/)
3 # - update for lzo 2
4 # - try to use external lrmi and few other libs:
5 #   http://www.cyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
6 # - segfaults on amd64:
7 #   mencoder -oac pcm -af dummy -ovc raw -vf format=yv12 -of ogg -mc 0 -quiet -o /tmp/out1 l.avi
8 #   avi: RIFF (little-endian) data, AVI, 480 x 360, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)
9 #
10 # Conditional build:
11 %bcond_with     directfb        # with DirectFB video output
12 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
13 %bcond_with     ggi             # with ggi video output
14 %bcond_with     nas             # with NAS audio output
15 %bcond_with     svga            # with svgalib video output
16 %bcond_with     osd             # with osd menu support
17 %bcond_without  altivec         # without altivec support
18 %bcond_without  x264            # without x264 support
19 %bcond_with     xmms            # with XMMS inputplugin support
20 %bcond_without  aalib           # without aalib video output
21 %bcond_without  jack            # without JACKD support
22 %bcond_without  alsa            # without ALSA audio output
23 %bcond_without  arts            # without arts audio output
24 %bcond_without  caca            # without libcaca video output
25 %bcond_without  cdparanoia      # without cdparanoia support
26 %bcond_without  dshow           # disable DirectShow support
27 %bcond_without  enca            # disable using ENCA charset oracle library
28 %bcond_without  esd             # disable EsounD sound support
29 %bcond_without  faad            # disable FAAD2 (AAC) support
30 %bcond_without  gif             # disable GIF support
31 %bcond_without  gui             # without GTK+ GUI
32 %bcond_without  joystick        # disable joystick support
33 %bcond_without  libdts          # disable libdts support
34 %bcond_without  libdv           # disable libdv en/decoding support
35 %bcond_without  lirc            # without lirc support
36 %bcond_with     live            # without LIVE555 libraries
37 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
38 %bcond_without  mad             # without mad (audio MPEG) support
39 %bcond_without  pulseaudio              # without pulseaudio output
40 %bcond_without  quicktime       # without binary quicktime dll support
41 %bcond_without  real            # without Real* 8/9 codecs support
42 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
43                                 #  in compile time (advertised by mplayer authors as working faster); in this case
44                                 #  mplayer may not work on machine other then where it was compiled
45 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
46 %bcond_without  smb             # disable Samba (SMB) input support
47 %bcond_without  theora          # without theora support
48 %bcond_without  win32           # without win32 codecs support
49 %bcond_without  vidix           # disable vidix
50 %bcond_without  vorbis          # without Ogg-Vorbis audio support
51 %bcond_without  xvid            # disable XviD codec
52 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
53 %bcond_without  sdl             # disable SDL
54 %bcond_without  doc             # don't build docs (slow)
55 %bcond_with     shared          # experimental libmplayer.so support
56 %bcond_with     amr             # enable 3GPP Adaptive Multi Rate (AMR) speech codec support
57 %bcond_without  gnomess         # disable controling gnome screensaver
58 %bcond_with     ssse3   # sse3 optimizations (needs binutils >= 2.16.92)
59
60 %ifnarch %{ix86}
61 %undefine       with_win32
62 %undefine       with_quicktime
63 %undefine       with_vidix
64 %endif
65
66 %ifarch %{x8664} sparc sparc64
67 %undefine       with_runtime
68 %endif
69
70 %if %{_lib} == "lib64"
71 %define        _suf    64
72 %else
73 %define        _suf    32
74 %endif
75
76 %define         rel             2
77 %define         subver  rc2
78
79 Summary:        MPlayer - THE Movie Player for UN*X
80 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81 Summary(es.UTF-8):      Otro reproductor de películas
82 Summary(ko.UTF-8):      리눅스용 미디어플레이어
83 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
84 Summary(pt_BR.UTF-8):   Reprodutor de filmes
85 Name:           mplayer
86 Version:        1.0
87 Release:        5.%{subver}.%{rel}
88 # DO NOT increase epoch unless it's really neccessary!
89 # especially such changes like pre7->pre7try2, increase Release instead!
90 # PS: $ rpmvercmp pre7try2 pre7
91 # pre7try2 > pre7
92 Epoch:          3
93 License:        GPL
94 Group:          Applications/Multimedia
95 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{subver}.tar.bz2
96 # Source0-md5:  7e27e535c2d267637df34898f1b91707
97 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
98 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
99 Source5:        g%{name}.desktop
100 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
101 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
102 Source7:        %{name}.png
103 Source8:        %{name}.desktop
104 # http://www.on2.com/gpl/mplayer/
105 Source9:        http://www.on2.com/gpl/mplayer/2007-10-09-mencoder-on2flixenglinux.tar.bz2
106 # Source9-md5:  2361e56b40f52dfc20131e458e2aed38
107 Patch1:         %{name}-cp1250-fontdesc.patch
108 #Patch2:                %{name}-codec.patch
109 #Patch3:                %{name}-home_etc.patch
110 Patch4:         %{name}-350.patch
111 Patch5:         %{name}-configure.patch
112 #Patch6:                %{name}-system-amr.patch # outdated via ffmpeg?
113 Patch8:         %{name}-altivec.patch
114 #Patch10:       %{name}-pcmsplit.patch
115 #Patch13:       %{name}-mythtv.patch
116 Patch14:        %{name}-shared.patch
117 #http://www.openchrome.org/snapshots/mplayer/
118 #Patch15:       %{name}-xvmc.patch
119 Patch17:        %{name}-auto-expand.patch
120 #Patch18:       %{name}-gnome-screensaver.patch # update
121 Patch19:        %{name}-on2flix.patch
122 Patch22:        %{name}-ffmpeg.patch
123 Patch23:        %{name}-live.patch
124 Patch24:        %{name}-fontconfig_sub.patch
125 Patch25:        http://www.mplayerhq.hu/MPlayer/patches/stream_cddb_fix_20080120.diff
126 URL:            http://www.mplayerhq.hu/
127 %{?with_directfb:BuildRequires: DirectFB-devel}
128 BuildRequires:  OpenAL-devel
129 BuildRequires:  OpenGL-devel
130 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
131 %{?with_aalib:BuildRequires:    aalib-devel}
132 %{?with_alsa:BuildRequires:     alsa-lib-devel}
133 %if %{with amr}
134 BuildRequires:  amrnb-devel
135 BuildRequires:  amrwb-devel >= 5.3.0
136 %endif
137 %{?with_arts:BuildRequires:     artsc-devel}
138 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
139 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
140 %{?with_doc:BuildRequires:      docbook-style-xsl}
141 %{?with_dxr3:BuildRequires:     em8300-devel}
142 %{?with_enca:BuildRequires:     enca-devel}
143 %{?with_esd:BuildRequires:      esound-devel}
144 BuildRequires:  faac-devel
145 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
146 BuildRequires:  ffmpeg-devel >= 0.4.9-3.20070626.1.1
147 BuildRequires:  freetype-devel
148 BuildRequires:  fribidi-devel
149 %{?with_vidix:BuildRequires:    vidix-devel}
150 %ifarch ppc
151 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
152 %endif
153 %{?with_gif:BuildRequires:      giflib-devel}
154 %if %{with gui}
155 BuildRequires:  gtk+2-devel
156 Requires:       mplayer-skin-Blue
157 %endif
158 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
159 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
160 BuildRequires:  lame-libs-devel
161 %{?with_caca:BuildRequires:     libcaca-devel}
162 %{?with_libdts:BuildRequires:   libdts-devel}
163 %{?with_libdv:BuildRequires:    libdv-devel}
164 BuildRequires:  libdvdnav-devel
165 %{?with_ggi:BuildRequires:      libggi-devel}
166 BuildRequires:  libjpeg-devel
167 %{?with_mad:BuildRequires:      libmad-devel}
168 BuildRequires:  libmpcdec-devel >= 1.2.1
169 BuildRequires:  libpng-devel
170 %{?with_smb:BuildRequires:      libsmbclient-devel}
171 %{?with_dshow:BuildRequires:    libstdc++-devel}
172 %{?with_theora:BuildRequires:   libtheora-devel}
173 # tremor is used by default, internal as we don't have system one
174 #%{?with_vorbis:BuildRequires:  libvorbis-devel}
175 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060828_2245.1}
176 BuildRequires:  libxslt-progs
177 %{?with_lirc:BuildRequires:     lirc-devel}
178 %{?with_live:BuildRequires:     live}
179 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
180 %{?with_nas:BuildRequires:      nas-devel}
181 BuildRequires:  ncurses-devel
182 BuildRequires:  pkgconfig
183 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
184 BuildRequires:  speex-devel >= 1.1
185 %{?with_svga:BuildRequires:     svgalib-devel}
186 %{?with_xmms:BuildRequires:     xmms-libs}
187 BuildRequires:  xorg-lib-libX11-devel
188 BuildRequires:  xorg-lib-libXext-devel
189 BuildRequires:  xorg-lib-libXinerama-devel
190 BuildRequires:  xorg-lib-libXv-devel
191 BuildRequires:  xorg-lib-libXvMC-devel
192 BuildRequires:  xorg-lib-libXxf86dga-devel
193 BuildRequires:  xorg-lib-libXxf86vm-devel
194 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
195 BuildRequires:  zlib-devel
196 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
197 Requires:       OpenGL
198 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
199
200 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
201 %define         specflags_ia32  -fomit-frame-pointer
202 %if %{with altivec}
203 %define         specflags_ppc   -maltivec
204 %endif
205
206 %description
207 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
208 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
209 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
210 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
211 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
212 optionally with SHM extension, X11 using overlays with the Xvideo
213 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
214 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
215
216 If you want to use win32 codecs install w32codec package.
217
218 %description -l de.UTF-8
219 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
220 Kennzeichnend ist die herausragende Format- und
221 Plattform-Kompatibilität.
222
223 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
224 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
225 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
226 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
227 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
228 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
229 installierte Codecs nicht mit MPlayer kollidieren können.
230
231 %description -l es.UTF-8
232 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
233 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
234 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
235 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
236 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
237 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
238 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
239 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
240 v1.1.7 etc.
241
242 Si quiere usar codecs Win32, instale el paquete w32codec.
243
244 %description -l ko.UTF-8
245 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
246 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
247 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
248 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
249 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
250 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
251 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
252 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
253 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
254
255 %description -l pl.UTF-8
256 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
257 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
258 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
259 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
260 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
261 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
262 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
263
264 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
265
266 %description -l pt_BR.UTF-8
267 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
268 áudio. Diferentes mecanismos de reprodução podem também ser
269 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
270
271 %package -n gmplayer
272 Summary:        MPlayer with GTK+ GUI interface
273 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
274 Group:          X11/Applications/Multimedia
275 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
276 Requires:       %{name}-skin
277 Provides:       %{name} = %{epoch}:%{version}-%{release}
278
279 %description -n gmplayer
280 MPlayer with GUI GTK+ interface.
281
282 %description -n gmplayer -l pl.UTF-8
283 MPlayer z graficznym interfejsem GTK+.
284
285 %package common
286 Summary:        Configuration files and documentation for MPlayer
287 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
288 Group:          Applications/Multimedia
289 Obsoletes:      mplayer-vidix
290
291 %description common
292 Configuration files, man page and HTML documentation for MPlayer.
293
294 %description common -l pl.UTF-8
295 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
296
297 %package -n mencoder
298 Summary:        MEncoder - a movie encoder for Linux
299 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
300 Group:          Applications/Multimedia
301 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
302
303 %description -n mencoder
304 MEncoder is a movie encoder for Linux and is a part of the MPlayer
305 package.
306
307 %description -n mencoder -l pl.UTF-8
308 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
309
310 %prep
311 %setup -q -n MPlayer-%{version}%{subver} -a3 -a6 -a9
312 cp -f etc/codecs.conf etc/codecs.win32.conf
313 %patch1 -p0
314 #%patch2 -p1
315 ##%patch3 -p1   -- old home_etc behavior
316 %patch4 -p1
317 %patch5 -p1
318 #%patch6 -p1 # - try ffmpeg
319 %patch8 -p1
320 #%%patch10 -p1
321 #%patch13 -p1   # TODO
322 %if %{with shared}
323 %patch14 -p1
324 %endif
325 #%patch15 -p0   # TODO
326 %patch17 -p1
327 %if %{with gnomess}
328 #%patch18 -p1
329 %endif
330
331 # on2flix
332 cp -a mencoder-on2flixenglinux/new_files/libmpdemux/* libmpdemux
333 rm -f mencoder-on2flixenglinux/version.diff
334 %patch19 -p1
335 for a in mencoder-on2flixenglinux/*.diff; do
336         patch -p0 < $a
337 done
338
339 %patch22 -p1
340 %patch23 -p1
341 %patch24 -p0
342 cd stream
343 %patch25 -p0
344 cd -
345
346 %build
347 %if %{with shared}
348 CFLAGS="%{rpmcflags} -fPIC"
349 %else
350 CFLAGS="%{rpmcflags}"
351 %endif
352 CC="%{__cc}"
353 LDFLAGS="%{rpmldflags}"
354 export CC CFLAGS LDFLAGS
355
356 build() {
357 set -x
358         ./configure \
359         %{?debug:--enable-debug=3} \
360         --prefix=%{_prefix} \
361         --confdir=%{_sysconfdir}/mplayer \
362         --with-extraincdir=%{_includedir}/xvid \
363         --with-extralibdir=%{_x_libraries} \
364         --enable-menu \
365         --disable-libavutil_a \
366         --disable-libavcodec_a \
367         --disable-libavformat_a \
368         --disable-libpostproc_a \
369         --enable-libavutil_so \
370         --enable-libavcodec_so \
371         --enable-libavformat_so \
372         --enable-libpostproc_so \
373 %ifnarch %{ix86} %{x8664}
374         --disable-mmx \
375         --disable-mmxext \
376         --disable-3dnow \
377         --disable-3dnowext \
378         --disable-sse \
379         --disable-sse2 \
380         --disable-fastmemcpy \
381 %endif
382         %{!?with_ssse3:--disable-ssse3} \
383 %ifarch ppc
384 %{!?with_altivec:--disable-altivec} \
385 %endif
386 %{!?with_amr:--disable-libamr_nb --disable-libamr_wb} \
387 %{?with_amr:--enable-libamr_nb --enable-libamr_wb} \
388 %{?with_directfb:--enable-directfb} \
389 %{!?with_directfb:--disable-directfb} \
390 %{!?with_dxr3:--disable-dxr3} \
391 %{!?with_ggi:--disable-ggi} \
392 %{?with_live:--enable-live --with-extraincdir=/usr/include/liveMedia} \
393 %{!?with_live:--disable-live} \
394 %{!?with_lzo:--disable-liblzo} \
395 %{!?with_nas:--disable-nas} \
396 %{!?with_svga:--disable-svga} \
397 %{!?with_aalib:--disable-aa} \
398 %{!?with_jack:--disable-jack} \
399 %{!?with_alsa:--disable-alsa} \
400 %{?with_alsa:--enable-alsa --disable-select} \
401 %{!?with_arts:--disable-arts} \
402 %{!?with_caca:--disable-caca} \
403 %{!?with_cdparanoia:--disable-cdparanoia} \
404 %{!?with_dshow:--disable-dshow} \
405 %{!?with_enca:--disable-enca} \
406 %{!?with_esd:--disable-esd} \
407 %{!?with_faad:--disable-faad-external --disable-faad-internal} \
408 %{?with_faad:--disable-faad-internal} \
409 %{!?with_gif:--disable-gif} \
410 %{?with_joystick:--enable-joystick} \
411 %{!?with_libdv:--disable-libdv} \
412 %{!?with_libdts:--disable-libdts} \
413 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
414 %{!?with_mad:--disable-mad} \
415 %{!?with_pulseaudio:--disable-pulse} \
416 %{!?with_quicktime:--disable-qtx} \
417 %{!?with_real:--disable-real} \
418 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
419 %{!?with_select:--disable-select} \
420 %{!?with_smb:--disable-smb} \
421 %{!?with_win32:--disable-win32dll} \
422 %{!?with_vorbis:--disable-vorbis} \
423 %{?with_osd:--enable-menu} \
424 %{!?with_theora:--disable-theora} \
425 %{!?with_x264:--disable-x264} \
426 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
427 %{!?with_xvid:--disable-xvid} \
428 %{!?with_vidix:--disable-vidix-external --disable-vidix-internal} \
429 %{?with_vidix:--disable-vidix-internal} \
430 %{!?with_mencoder:--disable-mencoder} \
431         --enable-dga1 \
432         --enable-dga2 \
433         --enable-fbdev \
434         --enable-gl \
435         --enable-mga \
436         --enable-radio \
437         --enable-radio-capture \
438         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
439         --enable-tdfxfb \
440         --enable-vm \
441         --enable-x11 \
442         --enable-xmga \
443         --enable-xv \
444         --enable-xvmc \
445         --enable-dynamic-plugins \
446         --enable-largefiles \
447         --language=all \
448         --codecsdir=%{_libdir}/codecs \
449         --with-xvmclib=XvMCW \
450         "$@"
451
452         %{__make}
453 }
454
455 %if %{with gui}
456 # build GUI version
457 build --enable-gui --disable-mencoder
458 mv -f mplayer gmplayer
459 %{__make} distclean
460 %endif
461
462 # now build regular version
463 build --disable-gui
464
465 %if %{with doc}
466 %{__make} -j1 -C DOCS/xml
467 %endif
468
469 %install
470 rm -rf $RPM_BUILD_ROOT
471 install -d \
472         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
473         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
474         $RPM_BUILD_ROOT%{_datadir}/mplayer/skins \
475         $RPM_BUILD_ROOT%{_desktopdir}
476
477 # default config files
478 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
479 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
480
481 # executables
482 %if %{with mencoder}
483 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
484 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
485 %endif
486 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
487 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
488 %if %{with gui}
489 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
490 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
491 %endif
492
493 # fonts
494 rm -f font-*/runme
495 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
496 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
497
498 %if %{with gui}
499 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
500 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
501 %endif
502 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
503 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
504
505 # man pages
506 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
507 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
508 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
509 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
510 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
511 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
512 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
513 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
514 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
515 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
516
517 %clean
518 rm -rf $RPM_BUILD_ROOT
519
520 %post -n gmplayer
521 umask 022
522 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
523
524 %postun -n gmplayer
525 umask 022
526 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
527
528 %files
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_bindir}/mplayer*
531
532 %if %{with gui}
533 %files -n gmplayer
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_bindir}/gmplayer*
536 %{_desktopdir}/gmplayer.desktop
537 %dir %{_datadir}/%{name}/skins
538 %ghost %{_datadir}/%{name}/skins/default
539 %endif
540
541 %if %{with mencoder}
542 %files -n mencoder
543 %defattr(644,root,root,755)
544 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
545 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
546 %doc DOCS/tech/colorspaces.txt
547 %attr(755,root,root) %{_bindir}/mencoder*
548 %endif
549
550 %files common
551 %defattr(644,root,root,755)
552 %doc DOCS/tech
553 %if %{with win32}
554 %doc etc/codecs.win32.conf
555 %endif
556 %if %{with doc}
557 # HTML and XML-generated docs
558 %doc DOCS/HTML/en
559 %lang(cs) %doc DOCS/HTML/cs
560 %lang(de) %doc DOCS/HTML/de
561 %lang(es) %doc DOCS/HTML/es
562 %lang(fr) %doc DOCS/HTML/fr
563 %lang(hu) %doc DOCS/HTML/hu
564 %lang(pl) %doc DOCS/HTML/pl
565 %lang(ru) %doc DOCS/HTML/ru
566 #%lang(zh_CN) %doc DOCS/zh
567 %endif
568 %doc AUTHORS README
569
570 %dir %{_sysconfdir}/%{name}
571 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
572 %{_mandir}/man1/*
573 %lang(cs) %{_mandir}/cs/man1/*
574 %lang(de) %{_mandir}/de/man1/*
575 %lang(es) %{_mandir}/es/man1/*
576 %lang(fr) %{_mandir}/fr/man1/*
577 %lang(hu) %{_mandir}/hu/man1/*
578 %lang(it) %{_mandir}/it/man1/*
579 %lang(pl) %{_mandir}/pl/man1/*
580 #%lang(sv) %{_mandir}/sv/man1/*
581 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
582 %{_desktopdir}/mplayer.desktop
583 %{_pixmapsdir}/mplayer.png
584 %dir %{_datadir}/%{name}
585 %{_datadir}/%{name}/font*
This page took 0.07918 seconds and 4 git commands to generate.