]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- gcc checking was disabled by mistake
[packages/mplayer.git] / mplayer.spec
1 #
2 # TODO:
3 # - update for lzo 2
4 # - update for polypaudio 0.8
5 # - use external lrmi and few other libs:
6 #   http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
7 #
8 # Conditional build:
9 %bcond_with     directfb        # with DirectFB video output
10 %bcond_with     divx4linux      # with divx4linux a/v support (binaries, instead of included OpenDivx)
11 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
12 %bcond_with     ggi             # with ggi video output
13 %bcond_with     nas             # with NAS audio output
14 %bcond_with     svga            # with svgalib video output
15 %bcond_with     osd             # with osd menu support
16 %bcond_with     altivec         # with altivec support (altivec code brakes image in mpeg4, and may segfault on others)
17 %bcond_without  x264            # without x264 support (needs newer libx264 snap)
18 %bcond_with     xmms            # with XMMS inputplugin support
19 %bcond_without  aalib           # without aalib video output
20 %bcond_without  jack            # without JACKD support
21 %bcond_without  alsa            # without ALSA audio output
22 %bcond_without  arts            # without arts audio output
23 %bcond_without  caca            # without libcaca video output
24 %bcond_without  cdparanoia      # without cdparanoia support
25 %bcond_without  dshow           # disable DirectShow support
26 %bcond_without  enca            # disable using ENCA charset oracle library
27 %bcond_without  esd             # disable EsounD sound support
28 %bcond_without  faad            # disable FAAD2 (AAC) support
29 %bcond_without  gif             # disable GIF support
30 %bcond_without  gui             # without GTK+ GUI
31 %bcond_without  joystick        # disable joystick support
32 %bcond_without  libdts          # disable libdts support
33 %bcond_without  libdv           # disable libdv en/decoding support
34 %bcond_without  lirc            # without lirc support
35 %bcond_without  live            # without live.com libraries
36 %bcond_with     lzo             # with LZO support (requires lzo 1.x)
37 %bcond_without  mad             # without mad (audio MPEG) support
38 %bcond_with     polyp           # with polyp audio output (requires polypaudio 0.6 or 0.7)
39 %bcond_without  quicktime       # without binary quicktime dll support
40 %bcond_without  real            # without Real* 8/9 codecs support
41 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
42                                 #  in compile time (advertised by mplayer authors as working faster); in this case
43                                 #  mplayer may not work on machine other then where it was compiled
44 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
45 %bcond_without  smb             # disable Samba (SMB) input support
46 %bcond_without  theora          # without theora support
47 %bcond_without  win32           # without win32 codecs support
48 %bcond_without  vorbis          # without Ogg-Vorbis audio support
49 %bcond_without  xvid            # disable XviD codec
50 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
51 %bcond_without  sdl             # disable SDL
52 %bcond_without  doc             # don't build docs (slow)
53 %bcond_with     shared          # experimental libmplayer.so support
54 %bcond_without  amr             # don't build 3GPP Adaptive Multi Rate (AMR) speech codec
55
56 %ifnarch %{ix86}
57 %undefine       with_win32
58 %undefine       with_quicktime
59 %endif
60
61 %ifarch %{x8664}
62 %undefine       with_runtime
63 %endif
64
65 %if %{_lib} == "lib64"
66 %define        _suf    64
67 %else
68 %define        _suf    32
69 %endif
70
71 # set it to 0, or 1
72 %define         snapshot        0
73
74 %define         sname           MPlayer
75 %define         snap            %{nil}
76
77 %define         pre             pre8
78
79 Summary:        MPlayer - THE Movie Player for UN*X
80 Summary(de):    MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
81 Summary(es):    Otro reproductor de películas
82 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
83 Summary(pl):    Odtwarzacz filmów dla systemów uniksowych
84 Summary(pt_BR): Reprodutor de filmes
85 Name:           mplayer
86 Version:        1.0
87 %define         _rel    1
88 Release:        3.%{pre}.%{_rel}
89 # DO NOT increase epoch unless it's really neccessary!
90 # especially such changes like pre7->pre7try2, increase Release instead!
91 # PS: $ rpmvercmp pre7try2 pre7
92 # pre7try2 > pre7
93 Epoch:          3
94 License:        GPL
95 Group:          Applications/Multimedia
96 %if %{snapshot}
97 #Source0:       ftp://ftp1.mplayerhq.hu/MPlayer/cvs/%{sname}-%{snap}.tar.bz2
98 #Source0:       %{name}-%{snap}.tar.bz2
99 #Source1:       libavcodec-%{snap}.tar.bz2
100 %else
101 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{pre}.tar.bz2
102 # Source0-md5:  f82bb2bc51b6cd5e5dd96f88f6f98582
103 %endif
104 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
105 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
106 Source5:        g%{name}.desktop
107 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
108 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
109 Source7:        %{name}.png
110 Source8:        %{name}.desktop
111 # AMR WB FLOAT
112 Source10:       http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26204-530.zip
113 # Source10-md5: 988060bdb18b5d64b8bd82c3507d2420
114 # AMR NB FLOAT
115 Source11:       http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26104-540.zip
116 # Source11-md5: 4dcbeb2bc28bf86e7131fe4cae3e0dec
117 Patch0:         %{name}-no_libnsl.patch
118 Patch1:         %{name}-cp1250-fontdesc.patch
119 Patch2:         %{name}-codec.patch
120 Patch3:         %{name}-home_etc.patch
121 Patch4:         %{name}-350.patch
122 Patch5:         %{name}-configure.patch
123 Patch8:         %{name}-altivec.patch
124 Patch10:        %{name}-pcmsplit.patch
125 Patch11:        %{name}-bio2jack.patch
126 Patch12:        %{name}-x86_64-detection.patch
127 Patch13:        %{name}-mythtv.patch
128 Patch14:        %{name}-shared.patch
129 Patch15:        %{name}-xvmc.patch
130 Patch16:        %{name}-kill-mabi_altivec.patch
131 #http://www.openchrome.org/snapshots/mplayer/
132 URL:            http://www.mplayerhq.hu/
133 %{?with_directfb:BuildRequires: DirectFB-devel}
134 BuildRequires:  OpenAL-devel
135 BuildRequires:  OpenGL-devel
136 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
137 %{?with_aalib:BuildRequires:    aalib-devel}
138 %{?with_alsa:BuildRequires:     alsa-lib-devel}
139 %{?with_arts:BuildRequires:     artsc-devel}
140 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
141 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.01.20020418}
142 %{?with_doc:BuildRequires:      docbook-style-xsl}
143 %{?with_dxr3:BuildRequires:     em8300-devel}
144 %{?with_enca:BuildRequires:     enca-devel}
145 %{?with_esd:BuildRequires:      esound-devel}
146 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
147 BuildRequires:  freetype-devel
148 %ifarch ppc
149 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
150 %endif
151 %{?with_gif:BuildRequires:      giflib-devel}
152 %if %{with gui}
153 BuildRequires:  gtk+2-devel
154 %endif
155 BuildRequires:  lame-libs-devel
156 %{?with_jack:BuildRequires:     libbio2jack-devel >= 0.8-2}
157 %{?with_caca:BuildRequires:     libcaca-devel}
158 %{?with_libdts:BuildRequires:   libdts-devel}
159 %{?with_libdv:BuildRequires:    libdv-devel}
160 %{?with_ggi:BuildRequires:      libggi-devel}
161 BuildRequires:  libjpeg-devel
162 %{?with_mad:BuildRequires:      libmad-devel}
163 BuildRequires:  libpng-devel
164 %{?with_smb:BuildRequires:      libsmbclient-devel}
165 %{?with_dshow:BuildRequires:    libstdc++-devel}
166 %{?with_theora:BuildRequires:   libtheora-devel}
167 %{?with_vorbis:BuildRequires:   libvorbis-devel}
168 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.2-1.20060430_2245.1}
169 BuildRequires:  libxslt-progs
170 %{?with_lirc:BuildRequires:     lirc-devel}
171 %{?with_live:BuildRequires:     live}
172 %{?with_lzo:BuildRequires:      lzo-devel < 2.0}
173 %{?with_nas:BuildRequires:      nas-devel}
174 BuildRequires:  ncurses-devel
175 BuildRequires:  pkgconfig
176 %{?with_polyp:BuildRequires:    polypaudio-devel >= 0.6}
177 %{?with_polyp:BuildRequires:    polypaudio-devel < 0.8}
178 BuildRequires:  speex-devel >= 1.1
179 %{?with_svga:BuildRequires:     svgalib-devel}
180 %{?with_xmms:BuildRequires:     xmms-libs}
181 BuildRequires:  xorg-lib-libXvMC-devel
182 BuildRequires:  xorg-lib-libX11-devel
183 BuildRequires:  xorg-lib-libXext-devel
184 BuildRequires:  xorg-lib-libXinerama-devel
185 BuildRequires:  xorg-lib-libXv-devel
186 BuildRequires:  xorg-lib-libXxf86dga-devel
187 BuildRequires:  xorg-lib-libXxf86vm-devel
188 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
189 BuildRequires:  zlib-devel
190 %{?with_amr:BuildRequires:      unzip}
191 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
192 Requires(post,postun):  /sbin/ldconfig
193 Requires:       OpenGL
194 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
195
196 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
197 %define         specflags_ia32  -fomit-frame-pointer
198 %define         specflags_alpha -mmax
199 %if %{with altivec}
200 %define         specflags_ppc   -maltivec
201 %endif
202
203 %description
204 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
205 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
206 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
207 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
208 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
209 optionally with SHM extension, X11 using overlays with the Xvideo
210 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
211 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
212
213 If you want to use win32 codecs install w32codec package.
214
215 %description -l de
216 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
217 Kennzeichnend ist die herausragende Format- und
218 Plattform-Kompatibilität.
219
220 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
221 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
222 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
223 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
224 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
225 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
226 installierte Codecs nicht mit MPlayer kollidieren können.
227
228 %description -l es
229 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
230 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
231 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
232 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
233 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
234 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
235 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
236 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
237 v1.1.7 etc.
238
239 Si quiere usar codecs Win32, instale el paquete w32codec.
240
241 %description -l ko
242 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
243 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
244 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
245 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
246 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
247 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
248 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
249 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
250 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
251
252 %description -l pl
253 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
254 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
255 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
256 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
257 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
258 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
259 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
260
261 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
262
263 %description -l pt_BR
264 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
265 áudio. Diferentes mecanismos de reprodução podem também ser
266 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
267
268 %package -n gmplayer
269 Summary:        MPlayer with GTK+ GUI interface
270 Summary(pl):    MPlayer z graficznym interfejsem GTK+
271 Group:          X11/Applications/Multimedia
272 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
273 Requires:       %{name}-skin
274 Provides:       %{name} = %{epoch}:%{version}-%{release}
275
276 %description -n gmplayer
277 MPlayer with GUI GTK+ interface.
278
279 %description -n gmplayer -l pl
280 MPlayer z graficznym interfejsem GTK+.
281
282 %package common
283 Summary:        Configuration files and documentation for MPlayer
284 Summary(pl):    Pliki konfiguracyjne i dokumentacja dla MPlayera
285 Group:          Applications/Multimedia
286
287 %description common
288 Configuration files, man page and HTML documentation for MPlayer.
289
290 %description common -l pl
291 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
292
293 %package -n mencoder
294 Summary:        MEncoder - a movie encoder for Linux
295 Summary(pl):    MEncoder - koder filmów dla Linuksa
296 Group:          Applications/Multimedia
297 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
298
299 %description -n mencoder
300 MEncoder is a movie encoder for Linux and is a part of the MPlayer
301 package.
302
303 %description -n mencoder -l pl
304 MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
305
306 %prep
307 %if %{snapshot}
308 %setup -q -n %{name}-%{snap} -a 1 -a 3 -a 6
309 %else
310 %setup -q -n %{sname}-%{version}%{pre} -a 3 -a 6
311 %endif
312
313 %if %{with amr}
314 cd libavcodec
315 mkdir amrwb_float
316 mkdir amr
317 mkdir amr_float
318 # put 26204-xxx.zip into libavcodec/amrwb_float
319 cd amrwb_float
320 unzip -j %{SOURCE10}
321 unzip -j 26204-530_ANSI-C_source_code.zip
322 # put 26104-xxx.zip into libavcodec/amr_float
323 cd ../amr_float
324 unzip -j %{SOURCE11}
325 unzip -j 26104-540_ANSI_C_source_code.zip
326 cd ../..
327 %endif
328
329 cp -f etc/codecs.conf etc/codecs.win32.conf
330 #%patch0 -p1
331 %patch1 -p0
332 ##%patch2 -p1
333 ##%patch3 -p1   -- old home_etc behavior
334 %patch4 -p1
335 %patch5 -p1
336 %patch8 -p1
337 #%%patch10 -p1
338 #%patch11 -p1   # maybe TODO, JACK audio output rewritten without bio2jack
339 #%patch12 -p1   # seems obsolete
340 #%patch13 -p1   # TODO
341 %if %{with shared}
342 %patch14 -p1
343 %endif
344 #%patch15 -p0   # TODO
345 %patch16 -p1
346
347 # kill evil file, hackery not needed with llh
348 echo > osdep/kerneltwosix.h
349
350 find . -type d -name CVS -print | xargs rm -rf
351
352 %build
353 %if %{with shared}
354 CFLAGS="%{rpmcflags} -fPIC"
355 LDFLAGS="%{rpmldflags} -wl,--as-needed"
356 %else
357 CFLAGS="%{rpmcflags}"
358 LDFLAGS="%{rpmldflags}"
359 %endif
360 CC="%{__cc}"
361 export CC CFLAGS
362
363 build() {
364 set -x
365         ./configure \
366         %{?debug:--enable-debug=3} \
367         --prefix=%{_prefix} \
368         --confdir=%{_sysconfdir}/mplayer \
369         --with-x11incdir=%{_includedir} \
370         --with-x11libdir=%{_libdir} \
371         --with-extraincdir=%{_includedir}/xvid \
372         --enable-menu \
373 %ifnarch %{ix86} %{x8664}
374         --disable-mmx \
375         --disable-3dnow \
376         --disable-sse \
377         --disable-sse2 \
378         --disable-fastmemcpy \
379 %endif
380 %ifarch ppc
381 %{!?with_altivec:--disable-altivec} \
382 %endif
383 %{?with_directfb:--enable-directfb} \
384 %{!?with_directfb:--disable-directfb} \
385 %{!?with_divx4linux:--disable-divx4linux} \
386 %{?with_divx4linux:--with-extraincdir=/usr/include/divx} \
387 %{!?with_dxr3:--disable-dxr3} \
388 %{!?with_ggi:--disable-ggi} \
389 %{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
390 %{!?with_live:--disable-live} \
391 %{!?with_lzo:--disable-liblzo} \
392 %{!?with_nas:--disable-nas} \
393 %{!?with_svga:--disable-svga} \
394 %{!?with_aalib:--disable-aa} \
395 %{!?with_jack:--disable-jack} \
396 %{!?with_alsa:--disable-alsa} \
397 %{?with_alsa:--enable-alsa --disable-select} \
398 %{!?with_arts:--disable-arts} \
399 %{!?with_caca:--disable-caca} \
400 %{!?with_cdparanoia:--disable-cdparanoia} \
401 %{!?with_dshow:--disable-dshow} \
402 %{!?with_enca:--disable-enca} \
403 %{!?with_esd:--disable-esd} \
404 %{!?with_faad:--disable-external-faad --disable-internal-faad}%{?with_faad:--enable-external-faad} \
405 %{!?with_gif:--disable-gif} \
406 %{?with_joystick:--enable-joystick} \
407 %{!?with_libdv:--disable-libdv} \
408 %{!?with_libdts:--disable-libdts} \
409 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
410 %{!?with_mad:--disable-mad} \
411 %{!?with_polyp:--disable-polyp} \
412 %{!?with_quicktime:--disable-qtx} \
413 %{!?with_real:--disable-real} \
414 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
415 %{!?with_select:--disable-select} \
416 %{!?with_smb:--disable-smb} \
417 %{!?with_win32:--disable-win32} \
418 %{!?with_vorbis:--disable-vorbis} \
419 %{?with_osd:--enable-menu} \
420 %{!?with_theora:--disable-theora} \
421 %{!?with_x264:--disable-x264} \
422 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
423 %{!?with_xvid:--disable-xvid} \
424 %{!?with_mencoder:--disable-mencoder} \
425         --enable-dga \
426         --enable-fbdev \
427         --enable-gl \
428         --enable-mga \
429         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
430         --enable-tdfxfb \
431         --enable-vm \
432         --enable-x11 \
433         --enable-xmga \
434         --enable-xv \
435         --enable-xvmc \
436         --enable-dynamic-plugins \
437         --enable-largefiles \
438         --language=all \
439         --with-codecsdir=%{_libdir}/codecs \
440         --with-xvmclib=XvMCW \
441         "$@"
442
443         %{__make}
444 }
445
446 %if %{with gui}
447 # build GUI version
448 build --enable-gui
449 mv -f mplayer gmplayer
450 %{__make} distclean
451 %endif
452
453 # now build regular version
454 build --disable-gui
455
456 %if %{with doc}
457 %{__make} -j1 -C DOCS/xml
458 %endif
459
460 %install
461 rm -rf $RPM_BUILD_ROOT
462 install -d \
463         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
464         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
465         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
466         $RPM_BUILD_ROOT%{_desktopdir}
467
468 # default config files
469 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
470 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
471
472 # executables
473 %if %{with mencoder}
474 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
475 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
476 %endif
477 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
478 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
479 %if %{with gui}
480 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
481 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
482 %endif
483
484 # fonts
485 rm -f font-*/runme
486 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
487 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
488
489 # libraries
490 %ifarch %{ix86}
491 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
492 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
493 %endif
494
495 %if %{with gui}
496 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
497 %endif
498
499 # X-files
500 %if %{with gui}
501 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
502 %endif
503 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
504 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
505
506 # man pages
507 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
508 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
509 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
510 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
511 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
512 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
513 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
514 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
515 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
516 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
517
518 %clean
519 rm -rf $RPM_BUILD_ROOT
520
521 %post
522 umask 022
523 /sbin/ldconfig
524 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
525
526 %postun
527 umask 022
528 /sbin/ldconfig
529 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
530
531 %files
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_bindir}/mplayer*
534
535 %if %{with gui}
536 %files -n gmplayer
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_bindir}/gmplayer*
539 %{_desktopdir}/gmplayer.desktop
540 %dir %{_datadir}/%{name}/Skin
541 %ghost %{_datadir}/%{name}/Skin/default
542 %endif
543
544 %files -n mencoder
545 %defattr(644,root,root,755)
546 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
547 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
548 %doc DOCS/tech/colorspaces.txt
549 %attr(755,root,root) %{_bindir}/mencoder*
550
551 %files common
552 %defattr(644,root,root,755)
553 # HTML and XML-generated docs
554 %doc DOCS/HTML/en
555 %doc DOCS/tech
556 %if %{with win32}
557 %doc etc/codecs.win32.conf
558 %endif
559 %lang(de) %doc DOCS/HTML/de
560 %lang(es) %doc DOCS/HTML/es
561 %lang(fr) %doc DOCS/HTML/fr
562 %lang(hu) %doc DOCS/HTML/hu
563 %lang(it) %doc DOCS/it
564 %lang(pl) %doc DOCS/HTML/pl
565 %lang(ru) %doc DOCS/HTML/ru
566 %lang(zh_CN) %doc DOCS/zh
567 %doc AUTHORS ChangeLog README
568
569 %ifarch %{ix86}
570 %attr(755,root,root) %{_libdir}/libdha.so.*.*
571 %attr(755,root,root) %{_libdir}/mplayer
572 %endif
573 %dir %{_sysconfdir}/%{name}
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
575 %{_mandir}/man1/*
576 %lang(cs) %{_mandir}/cs/man1/*
577 %lang(de) %{_mandir}/de/man1/*
578 %lang(es) %{_mandir}/es/man1/*
579 %lang(fr) %{_mandir}/fr/man1/*
580 %lang(hu) %{_mandir}/hu/man1/*
581 %lang(it) %{_mandir}/it/man1/*
582 %lang(pl) %{_mandir}/pl/man1/*
583 %lang(sv) %{_mandir}/sv/man1/*
584 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
585 %{_desktopdir}/mplayer.desktop
586 %{_pixmapsdir}/*
587 %dir %{_datadir}/%{name}
588 %{_datadir}/%{name}/font*
This page took 0.082608 seconds and 4 git commands to generate.