]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- rel .2.1
[packages/mplayer.git] / mplayer.spec
1 #
2 # TODO:
3 # - use external lrmi and few other libs:
4 #   http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
5 #
6 # Conditional build:
7 %bcond_with     directfb        # with DirectFB video output
8 %bcond_with     divx4linux      # with divx4linux a/v support (binaries, instead of included OpenDivx)
9 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
10 %bcond_with     ggi             # with ggi video output
11 %bcond_with     nas             # with NAS audio output
12 %bcond_with     svga            # with svgalib video output
13 %bcond_with     osd             # with osd menu support
14 %bcond_with     altivec         # with altivec support (altivec code brakes image in mpeg4, and may segfault on others)
15 %bcond_with     xmms            # with XMMS inputplugin support
16 %bcond_without  aalib           # without aalib video output
17 %bcond_without  jack            # without JACKD support
18 %bcond_without  alsa            # without ALSA audio output
19 %bcond_without  arts            # without arts audio output
20 %bcond_without  caca            # without libcaca video output
21 %bcond_without  dshow           # disable DirectShow support
22 %bcond_without  gui             # without GTK+ GUI
23 %bcond_without  joystick        # disable joystick support
24 %bcond_without  libdv           # disable libdv en/decoding support
25 %bcond_without  lirc            # without lirc support
26 %bcond_without  live            # without live.com libraries
27 %bcond_without  mad             # without mad (audio MPEG) support
28 %bcond_without  polyp           # without polyp audio output
29 %bcond_without  quicktime       # without binary quicktime dll support
30 %bcond_without  real            # without Real* 8/9 codecs support
31 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
32                                 #  in compile time (advertised by mplayer authors as working faster); in this case
33                                 #  mplayer may not work on machine other then where it was compiled
34 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
35 %bcond_without  smb             # disable Samba (SMB) input support
36 %bcond_without  theora          # without theora support
37 %bcond_without  win32           # without win32 codecs support
38 %bcond_without  vorbis          # without Ogg-Vorbis audio support
39 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
40 %bcond_without  libdts          # disable libdts support
41 %bcond_without  sdl             # disable SDL
42 %bcond_without  doc             # don't build docs (slow)
43 %bcond_with     gtk2            # EXPERIMENTAL support for GTK+ version 2
44 %bcond_with     shared          # experimental libmplayer.so support
45
46 %ifnarch %{ix86}
47 %undefine       with_win32
48 %undefine       with_quicktime
49 %endif
50
51 %ifarch %{x8664}
52 %undefine       with_runtime
53 %endif
54 # set it to 0, or 1
55 %define         snapshot        0
56
57 %define         sname           MPlayer
58 %define         snap            %{nil}
59
60 %define         pre             pre7try2
61
62 Summary:        MPlayer - THE Movie Player for UN*X
63 Summary(de):    MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
64 Summary(es):    Otro reproductor de películas
65 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
66 Summary(pl):    Odtwarzacz filmów dla systemów uniksowych
67 Summary(pt_BR): Reprodutor de filmes
68 Name:           mplayer
69 Version:        1.0
70 %define         _rel    2.1
71 #Release:       2.%{pre}.%{_rel}
72 Release:        2.pre7try3.%{_rel}
73 # DO NOT increase epoch unless it's really neccessary!
74 # especially such changes like pre7->pre7try2, increase Release instead!
75 # PS: $ rpmvercmp pre7try2 pre7
76 # pre7try2 > pre7
77 Epoch:          3
78 License:        GPL
79 Group:          Applications/Multimedia
80 %if %{snapshot}
81 #Source0:       ftp://ftp1.mplayerhq.hu/MPlayer/cvs/%{sname}-%{snap}.tar.bz2
82 #Source0:       %{name}-%{snap}.tar.bz2
83 #Source1:       libavcodec-%{snap}.tar.bz2
84 %else
85 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{pre}.tar.bz2
86 # Source0-md5:  aaca4fd327176c1afb463f0f047ef6f4
87 %endif
88 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
89 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
90 Source5:        g%{name}.desktop
91 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
92 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
93 Source7:        %{name}.png
94 Source8:        %{name}.desktop
95 Patch0:         %{name}-no_libnsl.patch
96 Patch1:         %{name}-cp1250-fontdesc.patch
97 Patch2:         %{name}-codec.patch
98 Patch3:         %{name}-home_etc.patch
99 Patch4:         %{name}-350.patch
100 Patch5:         %{name}-configure.patch
101 Patch6:         %{name}-gtk+2.patch
102 Patch7:         %{name}-alpha.patch
103 Patch8:         %{name}-altivec.patch
104 Patch9:         %{name}-assembly.patch
105 Patch10:        %{name}-pcmsplit.patch
106 Patch11:        %{name}-bio2jack.patch
107 Patch12:        %{name}-x86_64-detection.patch
108 Patch13:        %{name}-mythtv.patch
109 Patch14:        %{name}-shared.patch
110 Patch15:        %{name}-xvmc.patch
111 Patch16:        %{name}-kill-mabi_altivec.patch
112 Patch17:        %{name}-gcc4.patch
113 Patch18:        http://www.mplayerhq.hu/MPlayer/patches/demuxer_h_fix_20060212.diff
114 Patch19:        %{name}-CVE-2005-4048.patch
115 #http://www.openchrome.org/snapshots/mplayer/
116 URL:            http://www.mplayerhq.hu/
117 %{?with_directfb:BuildRequires: DirectFB-devel}
118 BuildRequires:  OpenGL-devel
119 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
120 %{?with_aalib:BuildRequires:    aalib-devel}
121 %{?with_alsa:BuildRequires:     alsa-lib-devel}
122 %{?with_arts:BuildRequires:     artsc-devel}
123 BuildRequires:  audiofile-devel
124 BuildRequires:  cdparanoia-III-devel
125 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.01.20020418}
126 %{?with_doc:BuildRequires:      docbook-style-xsl}
127 %{?with_dxr3:BuildRequires:     em8300-devel}
128 BuildRequires:  enca-devel
129 BuildRequires:  esound-devel
130 BuildRequires:  faad2-devel >= 2.0
131 BuildRequires:  freetype-devel
132 %ifarch ppc
133 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
134 %endif
135 %if %{with gui}
136 BuildRequires:  gtk+%{?with_gtk2:2}-devel
137 %endif
138 BuildRequires:  lame-libs-devel
139 %{?with_jack:BuildRequires:     libbio2jack-devel}
140 %{?with_caca:BuildRequires:     libcaca-devel}
141 %{?with_libdts:BuildRequires:   libdts-devel}
142 %{?with_libdv:BuildRequires:    libdv-devel}
143 %{?with_ggi:BuildRequires:      libggi-devel}
144 BuildRequires:  libjpeg-devel
145 %{?with_mad:BuildRequires:      libmad-devel}
146 BuildRequires:  libpng-devel
147 %{?with_smb:BuildRequires:      libsmbclient-devel}
148 %{?with_dshow:BuildRequires:    libstdc++-devel}
149 %{?with_theora:BuildRequires:   libtheora-devel}
150 %{?with_vorbis:BuildRequires:   libvorbis-devel}
151 BuildRequires:  giflib-devel
152 BuildRequires:  libxslt-progs
153 %{?with_lirc:BuildRequires:     lirc-devel}
154 %{?with_live:BuildRequires:     live}
155 BuildRequires:  lzo-devel
156 %{?with_nas:BuildRequires:      nas-devel}
157 BuildRequires:  ncurses-devel
158 BuildRequires:  pkgconfig
159 %{?with_polyp:BuildRequires:    polypaudio-devel}
160 %{?with_svga:BuildRequires:     svgalib-devel}
161 %{?with_xmms:BuildRequires:     xmms-libs}
162 BuildRequires:  xorg-lib-libXvMC-devel
163 BuildRequires:  xvid-devel >= 1:0.9.0
164 BuildRequires:  zlib-devel
165 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
166 Requires(post,postun):  /sbin/ldconfig
167 Requires:       OpenGL
168 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
169
170 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
171 %define         specflags_ia32  -fomit-frame-pointer
172 %define         specflags_alpha -mmax
173 %if %{with altivec}
174 %define         specflags_ppc   -maltivec
175 %endif
176
177 %description
178 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
179 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
180 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
181 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
182 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
183 optionally with SHM extension, X11 using overlays with the Xvideo
184 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
185 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
186
187 If you want to use win32 codecs install w32codec package.
188
189 %description -l de
190 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
191 Kennzeichnend ist die herausragende Format- und
192 Plattform-Kompatibilität.
193
194 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
195 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
196 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
197 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
198 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
199 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
200 installierte Codecs nicht mit MPlayer kollidieren können.
201
202 %description -l es
203 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
204 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
205 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
206 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
207 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
208 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
209 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
210 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
211 v1.1.7 etc.
212
213 Si quiere usar codecs Win32, instale el paquete w32codec.
214
215 %description -l ko
216 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
217 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
218 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
219 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
220 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
221 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
222 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
223 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
224 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
225
226 %description -l pl
227 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
228 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
229 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
230 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
231 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
232 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
233 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
234
235 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
236
237 %description -l pt_BR
238 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
239 áudio. Diferentes mecanismos de reprodução podem também ser
240 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
241
242 %package -n gmplayer
243 Summary:        MPlayer with GTK+ GUI interface
244 Summary(pl):    MPlayer z graficznym interfejsem GTK+
245 Group:          X11/Applications/Multimedia
246 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
247 Requires:       %{name}-skin
248 Provides:       %{name} = %{epoch}:%{version}-%{release}
249
250 %description -n gmplayer
251 MPlayer with GUI GTK+ interface.
252
253 %description -n gmplayer -l pl
254 MPlayer z graficznym interfejsem GTK+.
255
256 %package common
257 Summary:        Configuration files and documentation for MPlayer
258 Summary(pl):    Pliki konfiguracyjne i dokumentacja dla MPlayera
259 Group:          Applications/Multimedia
260 Requires:       %{name} = %{epoch}:%{version}-%{release}
261
262 %description common
263 Configuration files, man page and HTML documentation for MPlayer.
264
265 %description common -l pl
266 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
267
268 %package -n mencoder
269 Summary:        MEncoder - a movie encoder for Linux
270 Summary(pl):    MEncoder - koder filmów dla Linuksa
271 Group:          Applications/Multimedia
272 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
273
274 %description -n mencoder
275 MEncoder is a movie encoder for Linux and is a part of the MPlayer
276 package.
277
278 %description -n mencoder -l pl
279 MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
280
281 %prep
282 %if %{snapshot}
283 %setup -q -n %{name}-%{snap} -a 1 -a 3 -a 6
284 %else
285 %setup -q -n %{sname}-%{version}%{pre} -a 3 -a 6
286 %endif
287
288 cp -f etc/codecs.conf etc/codecs.win32.conf
289 %patch0 -p1
290 %patch1 -p0
291 ##%patch2 -p1
292 ##%patch3 -p1   -- old home_etc behavior
293 %patch4 -p1
294 %patch5 -p1
295 %if %{with gtk2}
296 %patch6 -p1
297 %endif
298 %patch7 -p1
299 %patch8 -p1
300 %patch9 -p1
301 #%%patch10 -p1
302 %patch11 -p1
303 %patch12 -p1
304 %patch13 -p1
305 %if %{with shared}
306 %patch14 -p1
307 %endif
308 %patch15 -p0
309 %patch16 -p1
310 %patch17 -p1
311 %patch18 -p0
312 %patch19 -p1
313
314 # kill evil file, hackery not needed with llh
315 echo > osdep/kerneltwosix.h
316
317 find . -type d -name CVS -print | xargs rm -rf
318
319 %build
320 %if %{with shared}
321 CFLAGS="%{rpmcflags} -fPIC"
322 LDFLAGS="%{rpmldflags} -wl,--as-needed"
323 %else
324 CFLAGS="%{rpmcflags}"
325 LDFLAGS="%{rpmldflags}"
326 %endif
327 CC="%{__cc}"
328 export CC CFLAGS
329
330 build() {
331 set -x
332         ./configure \
333         %{?debug:--enable-debug=3} \
334         --prefix=%{_prefix} \
335         --confdir=%{_sysconfdir}/mplayer \
336         --with-x11incdir=%{_includedir} \
337         --with-x11libdir=%{_libdir} \
338         --with-extraincdir=%{_includedir}/xvid \
339         --enable-menu \
340 %ifnarch %{ix86} %{x8664}
341         --disable-mmx \
342         --disable-mmx2 \
343         --disable-3dnow \
344         --disable-3dnowex \
345         --disable-sse \
346         --disable-sse2 \
347         --disable-fastmemcpy \
348 %endif
349 %ifarch ppc
350 %{!?with_altivec:--disable-altivec} \
351 %endif
352 %{?with_directfb:--enable-directfb} \
353 %{!?with_directfb:--disable-directfb} \
354 %{!?with_divx4linux:--disable-divx4linux} \
355 %{?with_divx4linux:--with-extraincdir=/usr/include/divx} \
356 %{!?with_dxr3:--disable-dxr3} \
357 %{!?with_ggi:--disable-ggi} \
358 %{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
359 %{!?with_live:--disable-live} \
360 %{!?with_nas:--disable-nas} \
361 %{!?with_svga:--disable-svga} \
362 %{!?with_aalib:--disable-aa} \
363 %{!?with_jack:--disable-jack} \
364 %{!?with_alsa:--disable-alsa} \
365 %{?with_alsa:--enable-alsa --disable-select} \
366 %{!?with_arts:--disable-arts} \
367 %{!?with_caca:--disable-caca} \
368 %{!?with_dshow:--disable-dshow} \
369 %{?with_joystick:--enable-joystick} \
370 %{!?with_libdv:--disable-libdv} \
371 %{!?with_libdts:--disable-libdts} \
372 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
373 %{!?with_mad:--disable-mad} \
374 %{!?with_polyp:--disable-polyp} \
375 %{!?with_quicktime:--disable-qtx} \
376 %{!?with_real:--disable-real} \
377 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
378 %{!?with_select:--disable-select} \
379 %{!?with_smb:--disable-smb} \
380 %{!?with_win32:--disable-win32} \
381 %{!?with_vorbis:--disable-vorbis} \
382 %{?with_osd:--enable-menu} \
383 %{!?with_theora:--disable-theora} \
384 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
385 %{!?with_mencoder:--disable-mencoder} \
386         --enable-external-faad \
387         --enable-dga \
388         --enable-fbdev \
389         --enable-gl \
390         --enable-mga \
391         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
392         --enable-tdfxfb \
393         --enable-vm \
394         --enable-x11 \
395         --enable-xmga \
396         --enable-xv \
397         --enable-xvmc \
398         --with-xvmclib=XvMCW \
399         --enable-xvid \
400         --enable-largefiles \
401         --language=all \
402         --with-codecsdir=%{_libdir}/codecs \
403         --enable-dynamic-plugins \
404         "$@"
405
406         %{__make}
407 }
408
409 %if %{with gui}
410 # build GUI version
411 build --enable-gui
412 mv -f mplayer gmplayer
413 %{__make} clean
414 %endif
415
416 # now build regular version
417 build --disable-gui
418
419 %if %{with doc}
420 %{__make} -j1 -C DOCS/xml
421 %endif
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425 install -d \
426         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
427         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
428         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
429         $RPM_BUILD_ROOT%{_desktopdir}
430
431 # default config files
432 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
433 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
434
435 # executables
436 %if %{with mencoder}
437 install mencoder $RPM_BUILD_ROOT%{_bindir}
438 %endif
439 install mplayer $RPM_BUILD_ROOT%{_bindir}
440 %if %{with gui}
441 install gmplayer $RPM_BUILD_ROOT%{_bindir}
442 %endif
443
444 # fonts
445 rm -f font-*/runme
446 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
447 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
448
449 # libraries
450 %ifarch %{ix86}
451 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
452 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
453 %endif
454
455 %if %{with gui}
456 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
457 %endif
458
459 # X-files
460 %if %{with gui}
461 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
462 %endif
463 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
464 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
465
466 # man pages
467 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
468 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
469 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
470 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
471 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
472 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
473 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
474 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
475 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
476 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
477
478 %clean
479 rm -rf $RPM_BUILD_ROOT
480
481 %post
482 umask 022
483 /sbin/ldconfig
484 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
485
486 %postun
487 umask 022
488 /sbin/ldconfig
489 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
490
491 %files
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_bindir}/mplayer
494
495 %if %{with gui}
496 %files -n gmplayer
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_bindir}/gmplayer
499 %{_desktopdir}/gmplayer.desktop
500 %dir %{_datadir}/%{name}/Skin
501 %ghost %{_datadir}/%{name}/Skin/default
502 %endif
503
504 %files -n mencoder
505 %defattr(644,root,root,755)
506 %doc DOCS/tech/encoding-tips.txt DOCS/tech/swscaler_filters.txt
507 %doc DOCS/tech/swscaler_methods.txt DOCS/tech/colorspaces.txt
508 %attr(755,root,root) %{_bindir}/mencoder
509
510 %files common
511 %defattr(644,root,root,755)
512 # some useful tech docs
513 %doc DOCS/tech/hwac3.txt DOCS/tech/mpsub.sub DOCS/tech/slave.txt
514 %doc DOCS/tech/subcp.txt
515
516 # HTML and XML-generated docs
517 %doc DOCS/HTML/en
518 %doc DOCS/tech
519 %if %{with win32}
520 %doc etc/codecs.win32.conf
521 %endif
522 %lang(de) %doc DOCS/de
523 %lang(es) %doc DOCS/HTML/es
524 %lang(fr) %doc DOCS/HTML/fr
525 %lang(hu) %doc DOCS/HTML/hu
526 %lang(it) %doc DOCS/it
527 %lang(pl) %doc DOCS/HTML/pl
528 %lang(ru) %doc DOCS/HTML/ru
529 %lang(zh_CN) %doc DOCS/zh
530 %doc README AUTHORS ChangeLog
531
532 %ifarch %{ix86}
533 %attr(755,root,root) %{_libdir}/libdha.so.*.*
534 %attr(755,root,root) %{_libdir}/mplayer
535 %endif
536 %dir %{_sysconfdir}/%{name}
537 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
538 %{_mandir}/man1/*
539 %lang(cs) %{_mandir}/cs/man1/*
540 %lang(de) %{_mandir}/de/man1/*
541 %lang(es) %{_mandir}/es/man1/*
542 %lang(fr) %{_mandir}/fr/man1/*
543 %lang(hu) %{_mandir}/hu/man1/*
544 %lang(it) %{_mandir}/it/man1/*
545 %lang(pl) %{_mandir}/pl/man1/*
546 %lang(sv) %{_mandir}/sv/man1/*
547 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
548 %{_desktopdir}/mplayer.desktop
549 %{_pixmapsdir}/*
550 %dir %{_datadir}/%{name}
551 %{_datadir}/%{name}/font*
This page took 0.078734 seconds and 3 git commands to generate.