]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- release 3
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 %bcond_with     directfb        # with DirectFB video output
4 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
5 %bcond_with     ggi             # with ggi video output
6 %bcond_with     nas             # with NAS audio output
7 %bcond_with     svga            # with svgalib video output
8 %bcond_without  osd             # with osd menu support
9 %bcond_without  altivec         # without altivec support
10 %bcond_without  x264            # without x264 support
11 %bcond_with     xmms            # with XMMS inputplugin support
12 %bcond_without  aalib           # without aalib video output
13 %bcond_without  jack            # without JACKD support
14 %bcond_without  alsa            # without ALSA audio output
15 %bcond_with     arts            # with arts audio output
16 %bcond_without  caca            # without libcaca video output
17 %bcond_without  cdparanoia      # without cdparanoia support
18 %bcond_without  dvdnav          # without dvdnav support
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_with     esd             # enable EsounD sound support
21 %bcond_without  faad            # disable FAAD2 (AAC) support
22 %bcond_without  gif             # disable GIF support
23 %bcond_without  gui             # without GTK+ GUI
24 %bcond_without  joystick        # disable joystick support
25 %bcond_without  libdts          # disable libdts support
26 %bcond_without  libdv           # disable libdv en/decoding support
27 %bcond_without  lirc            # without lirc support
28 %bcond_without  live            # without LIVE555 libraries
29 %bcond_without  lzo             # with LZO support (requires lzo 2.x)
30 %bcond_without  mad             # without mad (audio MPEG) support
31 %bcond_without  pulseaudio      # without pulseaudio output
32 %bcond_without  quicktime       # without binary quicktime dll support
33 %bcond_without  real            # without Real* 8/9 codecs support
34 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
35                                 #  in compile time (advertised by mplayer authors as working faster); in this case
36                                 #  mplayer may not work on machine other then where it was compiled
37 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
38 %bcond_without  smb             # disable Samba (SMB) input support
39 %bcond_without  theora          # without theora support
40 %bcond_without  win32           # without win32 codecs support
41 %bcond_without  vdpau           # disable vdpau
42 %bcond_without  vidix           # disable vidix
43 %bcond_without  vorbis          # without Ogg-Vorbis audio support
44 %bcond_with     system_vorbis   # use system libvorbis instead of internal tremor
45 %bcond_without  xvid            # disable XviD codec
46 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
47 %bcond_without  sdl             # disable SDL
48 %bcond_without  doc             # don't build docs (slow)
49 %bcond_with     shared          # experimental libmplayer.so support
50 %bcond_without  amr             # enable Adaptive Multi Rate (AMR) speech codec support
51 %bcond_without  gnomess         # disable controling gnome screensaver
52 %bcond_without  ssse3           # sse3 optimizations (needs binutils >= 2.16.92)
53 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
54 %bcond_with     on2             # with patches from On2 Flix Engine for Linux
55 %if "%{pld_release}" == "ac"
56 %bcond_with             hidden_visibility       # no gcc hidden visibility
57 %else
58 %bcond_without  hidden_visibility       # no gcc hidden visibility
59 %endif
60
61 %if %{with alsa}
62 %undefine       with_select
63 %endif
64
65 %if %{without vorbis}
66 %undefine       with_system_vorbis
67 %endif
68
69 %ifnarch %{ix86}
70 %undefine       with_win32
71 %undefine       with_quicktime
72 %undefine       with_vidix
73 %endif
74
75 %ifnarch %{ix86} %{x8664} ppc ppc64
76 %undefine       with_runtime
77 %endif
78
79 %if %{_lib} == "lib64"
80 %define         _suf    64
81 %else
82 %define         _suf    32
83 %endif
84
85 %define         subver  rc4
86 %define         svnver  31097
87 %define         rel     3
88
89 Summary:        MPlayer - THE Movie Player for UN*X
90 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
91 Summary(es.UTF-8):      Otro reproductor de películas
92 Summary(ko.UTF-8):      리눅스용 미디어플레이어
93 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
94 Summary(pt_BR.UTF-8):   Reprodutor de filmes
95 Name:           mplayer
96 Version:        1.0
97 Release:        5.%{subver}_svn%{svnver}.%{rel}
98 # DO NOT increase epoch unless it's really neccessary!
99 # especially such changes like pre7->pre7try2, increase Release instead!
100 # PS: $ rpmvercmp pre7try2 pre7
101 # pre7try2 > pre7
102 Epoch:          3
103 License:        GPL
104 Group:          Applications/Multimedia
105 # svn co svn://svn.mplayerhq.hu/mplayer/trunk mplayer-rXXX
106 # tar --exclude-vcs -cvJf mplayer-rXXX.tar.xz mplayer-rXXX
107 Source0:        %{name}-r%{svnver}.tar.xz
108 # Source0-md5:  7e70fb6582890c60329b8fb5f34423d5
109 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
110 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
111 Source5:        g%{name}.desktop
112 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
113 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
114 Source7:        %{name}.png
115 Source8:        %{name}.desktop
116 # http://www.on2.com/gpl/mplayer/
117 Source9:        http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
118 # Source9-md5:  07774a2663a8fda07c308df0c6569b56
119
120 # build (configure / Makefile) related:
121 Patch10:        %{name}-ldflags.patch
122 Patch11:        %{name}-altivec.patch
123 Patch12:        %{name}-check-byteswap.patch
124 Patch13:        %{name}-visibility-hidden-fix.patch
125 Patch14:        %{name}-ffmpeg.patch
126 Patch15:        %{name}-shared_live.patch
127 Patch16:        %{name}-shared.patch
128
129 # codecs, outputs, demuxers:
130 Patch20:        %{name}-auto-expand.patch
131 Patch21:        %{name}-release_directfb.patch
132
133 # goodies:
134 Patch30:        %{name}-cp1250-fontdesc.patch
135 Patch31:        %{name}-350.patch
136 # update, hard to fix right now because of gnome bug 579430:
137 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
138 #Patch32:       %{name}-gnome-screensaver.patch
139
140 Patch100:       %{name}-on2flix.patch
141
142 URL:            http://www.mplayerhq.hu/
143 %{?with_directfb:BuildRequires: DirectFB-devel}
144 BuildRequires:  OpenAL-devel
145 BuildRequires:  OpenGL-devel
146 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
147 %{?with_aalib:BuildRequires:    aalib-devel}
148 %{?with_alsa:BuildRequires:     alsa-lib-devel}
149 %{?with_arts:BuildRequires:     artsc-devel}
150 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
151 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
152 BuildRequires:  dirac-devel
153 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
154 %{?with_doc:BuildRequires:      docbook-style-xsl}
155 %{?with_dxr3:BuildRequires:     em8300-devel}
156 %{?with_enca:BuildRequires:     enca-devel}
157 %{?with_esd:BuildRequires:      esound-devel}
158 BuildRequires:  faac-devel
159 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
160 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
161 BuildRequires:  freetype-devel >= 2.0.9
162 BuildRequires:  fribidi-devel
163 BuildRequires:  tar >= 1:1.22
164 %{?with_vidix:BuildRequires:    vidix-devel}
165 %ifarch ppc
166 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
167 %endif
168 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
169 %{?with_gif:BuildRequires:      giflib-devel}
170 %{?with_gui:BuildRequires:      gtk+2-devel}
171 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
172 %{?with_jack:%requires_eq       jack-audio-connection-kit-libs}
173 BuildRequires:  lame-libs-devel
174 %{?with_caca:BuildRequires:     libcaca-devel}
175 %{?with_libdts:BuildRequires:   libdts-devel}
176 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
177 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
178 %{?with_ggi:BuildRequires:      libggi-devel}
179 BuildRequires:  libjpeg-devel
180 %{?with_mad:BuildRequires:      libmad-devel}
181 BuildRequires:  libmng-devel
182 BuildRequires:  libmpcdec-devel >= 1.2.1
183 BuildRequires:  libpng-devel
184 %{?with_smb:BuildRequires:      libsmbclient-devel}
185 %{?with_theora:BuildRequires:   libtheora-devel}
186 %{?with_vdpau:BuildRequires:    libvdpau-devel}
187 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
188 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
189 BuildRequires:  libxslt-progs
190 %{?with_lirc:BuildRequires:     lirc-devel}
191 %{?with_live:BuildRequires:     live-devel}
192 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
193 %{?with_nas:BuildRequires:      nas-devel}
194 BuildRequires:  ncurses-devel
195 %{?with_amr:BuildRequires:      opencore-amr-devel}
196 BuildRequires:  pkgconfig
197 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
198 BuildRequires:  rpm >= 4.4.9-56
199 BuildRequires:  rpmbuild(macros) >= 1.527
200 BuildRequires:  schroedinger-devel
201 BuildRequires:  speex-devel >= 1.1
202 %{?with_svga:BuildRequires:     svgalib-devel}
203 BuildRequires:  twolame-devel
204 %{?with_xmms:BuildRequires:     xmms-devel}
205 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
206 %ifarch %{ix86} %{x8664}
207 BuildRequires:  yasm
208 %endif
209 BuildRequires:  zlib-devel
210 %if "%{pld_release}" == "ac"
211 BuildRequires:  XFree86-devel >= 4.0.2
212 %else
213 BuildRequires:  xorg-lib-libX11-devel
214 BuildRequires:  xorg-lib-libXScrnSaver-devel
215 BuildRequires:  xorg-lib-libXext-devel
216 BuildRequires:  xorg-lib-libXinerama-devel
217 BuildRequires:  xorg-lib-libXv-devel
218 BuildRequires:  xorg-lib-libXvMC-devel
219 BuildRequires:  xorg-lib-libXxf86dga-devel
220 BuildRequires:  xorg-lib-libXxf86vm-devel
221 %endif
222 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
223 Requires:       OpenGL
224 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
225
226 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
227 %define         specflags_ia32  -fomit-frame-pointer
228 %if %{with altivec}
229 %define         specflags_ppc   -maltivec
230 %endif
231
232 %description
233 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
234 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
235 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
236 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
237 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
238 optionally with SHM extension, X11 using overlays with the Xvideo
239 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
240 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
241
242 If you want to use win32 codecs install w32codec package.
243
244 %description -l de.UTF-8
245 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
246 Kennzeichnend ist die herausragende Format- und
247 Plattform-Kompatibilität.
248
249 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
250 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
251 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
252 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
253 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
254 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
255 installierte Codecs nicht mit MPlayer kollidieren können.
256
257 %description -l es.UTF-8
258 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
259 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
260 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
261 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
262 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
263 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
264 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
265 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
266 v1.1.7 etc.
267
268 Si quiere usar codecs Win32, instale el paquete w32codec.
269
270 %description -l ko.UTF-8
271 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
272 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
273 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
274 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
275 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
276 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
277 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
278 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
279 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
280
281 %description -l pl.UTF-8
282 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
283 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
284 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
285 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
286 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
287 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
288 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
289
290 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
291
292 %description -l pt_BR.UTF-8
293 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
294 áudio. Diferentes mecanismos de reprodução podem também ser
295 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
296
297 %package -n gmplayer
298 Summary:        MPlayer with GTK+ GUI interface
299 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
300 Group:          X11/Applications/Multimedia
301 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
302 Requires:       %{name}-skin
303
304 %description -n gmplayer
305 MPlayer with GUI GTK+ interface.
306
307 %description -n gmplayer -l pl.UTF-8
308 MPlayer z graficznym interfejsem GTK+.
309
310 %package common
311 Summary:        Configuration files and documentation for MPlayer
312 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
313 Group:          Applications/Multimedia
314 Suggests:       unrar
315 Obsoletes:      mplayer-vidix
316
317 %description common
318 Configuration files, man page and HTML documentation for MPlayer.
319
320 %description common -l pl.UTF-8
321 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
322
323 %package -n mencoder
324 Summary:        MEncoder - a movie encoder for Linux
325 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
326 Group:          Applications/Multimedia
327 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
328
329 %description -n mencoder
330 MEncoder is a movie encoder for Linux and is a part of the MPlayer
331 package.
332
333 %description -n mencoder -l pl.UTF-8
334 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
335
336 %prep
337 %setup -q -n %{name}-r%{svnver} -a3 -a6 -a9
338 cp -f etc/codecs.conf etc/codecs.win32.conf
339
340 # build (configure / Makefile) related:
341 %patch10 -p1
342 %patch11 -p1
343 %patch12 -p1
344 %patch13 -p1
345 %{?with_system_ffmpeg:%patch14 -p1}
346 %{?with_live:%patch15 -p1}
347 %{?with_shared:%patch16 -p1}
348
349 # codecs, outputs, demuxers:
350 %patch20 -p1
351 %patch21 -p1
352
353 # goodies:
354 %patch30 -p0
355 %patch31 -p1
356 #%{with_gnomess:%patch32 -p1}
357
358 # on2flix
359 mv mencoder-on2flixenglinux{-*-*-*,}
360 %if %{with on2}
361 #%%patch100 -p1
362 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
363 # remove broken patches:
364 # - first set does not apply
365 # - second set beakes build
366 for PATCH in    asf-correct_movielength avi_check_idxflags \
367                 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
368                 mencoder_07_demux_update_pts mencoder_10_correct_pts \
369                 mpegvideo-revert_r18381 \
370                 \
371                 reduce_spurious_logging
372 do
373         rm mencoder-on2flixenglinux/patch/$PATCH.diff
374 done
375 for a in mencoder-on2flixenglinux/patch/*.diff; do
376         patch -p0 < $a
377 done
378 %endif
379
380 # Set version
381 %if "x%{svnver}" != "x%{nil}"
382         echo "SVN-r%{svnver}%{?with_on2:-on2}" > VERSION
383 %endif
384
385 cat etc/example.conf > etc/mplayer.conf
386 cat <<'CONFIGADD' >> etc/mplayer.conf
387
388 ######################
389 # PLD Linux Defaults #
390 ######################
391 [default]
392
393 # alternate solution for CP1250-encoded subtitles
394 fontconfig = yes
395 subcp = cp1250
396
397 # ...or if you prefer native bitmap fonts shipped with mplayer
398 #fontconfig = no
399 #subcp = iso-8859-1
400
401 # Standard location
402 unrarexec = "%{_bindir}/unrar"
403
404 CONFIGADD
405
406 %if %{with system_ffmpeg}
407 # using external ffmpeg, but mplayer adds these to includepath
408 rm -r libavcodec libavdevice libavformat libavutil libpostproc libswscale
409 %endif
410
411 # *** HOT FIXES ***
412
413 # typo, fixed in recent svn
414 sed 's/STREAM_NONCACHEABLE/STREAM_NON_CACHEABLE/' -i stream/stream_live555.c
415
416 # mjpeg encoder is required for Zoran hardware
417 sed '/_libavencoders="MPEG/s/"$/ MJPEG_ENCODER"/' -i configure
418
419 %build
420 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
421 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb}"
422 %{?with_live:CFLAGS="$CFLAGS -I/usr/include/liveMedia"}
423
424 build() {
425         set -x
426
427         ./configure \
428         %{?debug:--enable-debug=3} \
429         --prefix=%{_prefix} \
430         --confdir=%{_sysconfdir}/mplayer \
431         --cc="%{__cc}" \
432         --extra-cflags="$CFLAGS" \
433         --real-ldflags="%{rpmldflags}" \
434         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
435 %if %{with system_ffmpeg}
436         --disable-libavutil_a \
437         --disable-libavcodec_a \
438         --disable-libavformat_a \
439         --disable-libpostproc_a \
440         --enable-libavutil_so \
441         --enable-libavcodec_so \
442         --enable-libavformat_so \
443         --enable-libpostproc_so \
444 %endif
445 %ifnarch %{ix86} %{x8664}
446         --disable-mmx \
447         --disable-mmxext \
448         --disable-3dnow \
449         --disable-3dnowext \
450         --disable-sse \
451         --disable-sse2 \
452         --disable-fastmemcpy \
453 %endif
454         %{__disable ssse3} \
455 %ifarch ppc
456         %{__disable altivec} \
457 %endif
458         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
459         %{__enable_disable directfb} \
460         %{__disable dxr3} \
461         %{__disable ggi} \
462         %{__disable live} \
463         %{__disable lzo liblzo} \
464         %{__disable nas} \
465         %{__disable svga} \
466         %{__disable aalib aa} \
467         %{__disable jack} \
468         %{__enable_disable alsa} \
469         %{__disable arts} \
470         %{__disable caca} \
471         %{__disable cdparanoia} \
472         %{__disable enca} \
473         %{__disable esd} \
474         --disable-faad-internal \
475         %{__disable faad} \
476         %{__disable gif} \
477         %{__enable joystick} \
478         %{__disable libdv} \
479         %{__disable libdts libdca} \
480         %{__enable_disable lirc} \
481         %{__disable mad} \
482         %{__disable pulseaudio pulse} \
483         %{__disable quicktime qtx} \
484         %{__disable real} \
485         %{__enable_disable runtime runtime-cpudetection} \
486         %{__disable select} \
487         %{__disable smb} \
488         %{__disable win32 win32dll} \
489         %{__disable vorbis tremor-internal} --disable-tremor %{__disable vorbis libvorbis} \
490         %{__disable_if system_vorbis tremor-internal} \
491         %{__enable osd menu} \
492         %{__disable theora} \
493         %{__disable x264} \
494         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
495         %{__disable xvid} \
496         %{__disable vidix} \
497         %{__disable vdpau} \
498         %{__disable mencoder} \
499         --enable-dga1 \
500         --enable-dga2 \
501         %{__enable_disable dvdnav} \
502         --enable-fbdev \
503         --enable-gl \
504         --enable-mga \
505         --enable-radio \
506         --enable-radio-capture \
507         %{__enable_disable sdl} \
508         --enable-tdfxfb \
509         --enable-vm \
510         --enable-x11 \
511         --enable-xmga \
512         --enable-xv \
513         --enable-xvmc \
514         --with-xvmclib=XvMCW \
515         --enable-zr \
516         --enable-unrarexec \
517         --enable-dynamic-plugins \
518         --enable-largefiles \
519         --language=all \
520         --codecsdir=%{_libdir}/codecs \
521         "$@"
522
523         %{__make}
524 }
525
526 %if %{with gui}
527 # build GUI version
528 build --enable-gui --disable-mencoder
529 mv -f mplayer gmplayer
530 %{__make} distclean
531 %endif
532
533 # now build regular version
534 build --disable-gui
535
536 %if %{with doc}
537 %{__make} -j1 -C DOCS/xml
538 %endif
539
540 %install
541 rm -rf $RPM_BUILD_ROOT
542 install -d \
543         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
544         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
545         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
546         $RPM_BUILD_ROOT%{_desktopdir}
547
548 # default config files
549 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
550
551 # executables
552 %if %{with mencoder}
553 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
554 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
555 %endif
556 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
557 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
558 %if %{with gui}
559 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
560 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
561 %endif
562
563 %if %{with shared}
564 install -d $RPM_BUILD_ROOT%{_libdir}
565 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
566 %endif
567
568 # fonts
569 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
570 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
571
572 %if %{with gui}
573 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
574 %endif
575 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
576 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
577 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
578
579 # man pages
580 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
581 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
582 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
583 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
584 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
585 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
586 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
587 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
588 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
589 #install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
590
591 %clean
592 rm -rf $RPM_BUILD_ROOT
593
594 %post -n gmplayer
595 umask 022
596 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
597
598 %postun -n gmplayer
599 umask 022
600 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
601
602 %files
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_bindir}/mplayer*
605
606 %if %{with gui}
607 %files -n gmplayer
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_bindir}/gmplayer*
610 %{_desktopdir}/gmplayer.desktop
611 %endif
612
613 %if %{with mencoder}
614 %files -n mencoder
615 %defattr(644,root,root,755)
616 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
617 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
618 %doc DOCS/tech/colorspaces.txt
619 %attr(755,root,root) %{_bindir}/mencoder*
620 %endif
621
622 %files common
623 %defattr(644,root,root,755)
624 %doc DOCS/tech
625 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
626 %if %{with win32}
627 %doc etc/codecs.win32.conf
628 %endif
629 %if %{with doc}
630 # HTML and XML-generated docs
631 %doc DOCS/HTML/en
632 %lang(cs) %doc DOCS/HTML/cs
633 %lang(de) %doc DOCS/HTML/de
634 %lang(es) %doc DOCS/HTML/es
635 %lang(fr) %doc DOCS/HTML/fr
636 %lang(hu) %doc DOCS/HTML/hu
637 %lang(pl) %doc DOCS/HTML/pl
638 %lang(ru) %doc DOCS/HTML/ru
639 #%lang(zh_CN) %doc DOCS/zh
640 %endif
641 %doc AUTHORS README
642
643 %dir %{_sysconfdir}/%{name}
644 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
645 %{_mandir}/man1/*
646 %lang(cs) %{_mandir}/cs/man1/*
647 %lang(de) %{_mandir}/de/man1/*
648 %lang(es) %{_mandir}/es/man1/*
649 %lang(fr) %{_mandir}/fr/man1/*
650 %lang(hu) %{_mandir}/hu/man1/*
651 %lang(it) %{_mandir}/it/man1/*
652 %lang(pl) %{_mandir}/pl/man1/*
653 #%lang(sv) %{_mandir}/sv/man1/*
654 #%lang(zh_CN) %{_mandir}/zh_CN/man1/*
655 %{_desktopdir}/mplayer.desktop
656 %{_pixmapsdir}/mplayer.png
657 %dir %{_datadir}/%{name}
658 %{_datadir}/%{name}/font*
659 %dir %{_datadir}/%{name}/skins
660 %ghost %{_datadir}/%{name}/skins/default
This page took 0.065141 seconds and 3 git commands to generate.