]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- multiarch support
[packages/mplayer.git] / mplayer.spec
1 #
2 # TODO:
3 # - use external lrmi and few other libs:
4 #   http://www.gocyberlink.com/english/products/powercinema/pcm-linux/license/mplayer-10_copyright.htm
5 #
6 # Conditional build:
7 %bcond_with     directfb        # with DirectFB video output
8 %bcond_with     divx4linux      # with divx4linux a/v support (binaries, instead of included OpenDivx)
9 %bcond_with     dxr3            # enable use of DXR3/H+ hardware MPEG decoder
10 %bcond_with     ggi             # with ggi video output
11 %bcond_with     nas             # with NAS audio output
12 %bcond_with     svga            # with svgalib video output
13 %bcond_with     osd             # with osd menu support
14 %bcond_with     altivec         # with altivec support (altivec code brakes image in mpeg4, and may segfault on others)
15 %bcond_with     xmms            # with XMMS inputplugin support
16 %bcond_without  aalib           # without aalib video output
17 %bcond_without  jack            # without JACKD support
18 %bcond_without  alsa            # without ALSA audio output
19 %bcond_without  arts            # without arts audio output
20 %bcond_without  caca            # without libcaca video output
21 %bcond_without  cdparanoia      # without cdparanoia support
22 %bcond_without  dshow           # disable DirectShow support
23 %bcond_without  enca            # disable using ENCA charset oracle library
24 %bcond_without  esd             # disable EsounD sound support
25 %bcond_without  faad            # disable FAAD2 (AAC) support
26 %bcond_without  gif             # disable GIF support
27 %bcond_without  gui             # without GTK+ GUI
28 %bcond_without  joystick        # disable joystick support
29 %bcond_without  libdts          # disable libdts support
30 %bcond_without  libdv           # disable libdv en/decoding support
31 %bcond_without  lirc            # without lirc support
32 %bcond_without  live            # without live.com libraries
33 %bcond_without  mad             # without mad (audio MPEG) support
34 %bcond_without  polyp           # without polyp audio output
35 %bcond_without  quicktime       # without binary quicktime dll support
36 %bcond_without  real            # without Real* 8/9 codecs support
37 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
38                                 #  in compile time (advertised by mplayer authors as working faster); in this case
39                                 #  mplayer may not work on machine other then where it was compiled
40 %bcond_without  select          # disable audio select() support (for example required this option ALSA or Vortex2 driver)
41 %bcond_without  smb             # disable Samba (SMB) input support
42 %bcond_without  theora          # without theora support
43 %bcond_without  win32           # without win32 codecs support
44 %bcond_without  vorbis          # without Ogg-Vorbis audio support
45 %bcond_without  xvid            # disable XviD codec
46 %bcond_without  mencoder        # disable mencoder (a/v encoder) compilation
47 %bcond_without  sdl             # disable SDL
48 %bcond_without  doc             # don't build docs (slow)
49 %bcond_with     gtk2            # EXPERIMENTAL support for GTK+ version 2
50 %bcond_with     shared          # experimental libmplayer.so support
51
52 %ifnarch %{ix86}
53 %undefine       with_win32
54 %undefine       with_quicktime
55 %endif
56
57 %ifarch %{x8664}
58 %undefine       with_runtime
59 %endif
60
61 %if %{_lib} == "lib64"
62 %define        _suf    64
63 %else
64 %define        _suf    32
65 %endif
66
67 # set it to 0, or 1
68 %define         snapshot        0
69
70 %define         sname           MPlayer
71 %define         snap            %{nil}
72
73 %define         pre             pre7try2
74
75 Summary:        MPlayer - THE Movie Player for UN*X
76 Summary(de):    MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
77 Summary(es):    Otro reproductor de películas
78 Summary(ko):    ¸®´ª½º¿ë ¹Ìµð¾îÇ÷¹À̾î
79 Summary(pl):    Odtwarzacz filmów dla systemów uniksowych
80 Summary(pt_BR): Reprodutor de filmes
81 Name:           mplayer
82 Version:        1.0
83 %define         _rel    2.1
84 #Release:       2.%{pre}.%{_rel}
85 Release:        2.pre7try3.%{_rel}
86 # DO NOT increase epoch unless it's really neccessary!
87 # especially such changes like pre7->pre7try2, increase Release instead!
88 # PS: $ rpmvercmp pre7try2 pre7
89 # pre7try2 > pre7
90 Epoch:          3
91 License:        GPL
92 Group:          Applications/Multimedia
93 %if %{snapshot}
94 #Source0:       ftp://ftp1.mplayerhq.hu/MPlayer/cvs/%{sname}-%{snap}.tar.bz2
95 #Source0:       %{name}-%{snap}.tar.bz2
96 #Source1:       libavcodec-%{snap}.tar.bz2
97 %else
98 Source0:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/%{sname}-%{version}%{pre}.tar.bz2
99 # Source0-md5:  aaca4fd327176c1afb463f0f047ef6f4
100 %endif
101 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
102 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
103 Source5:        g%{name}.desktop
104 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
105 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
106 Source7:        %{name}.png
107 Source8:        %{name}.desktop
108 Patch0:         %{name}-no_libnsl.patch
109 Patch1:         %{name}-cp1250-fontdesc.patch
110 Patch2:         %{name}-codec.patch
111 Patch3:         %{name}-home_etc.patch
112 Patch4:         %{name}-350.patch
113 Patch5:         %{name}-configure.patch
114 Patch6:         %{name}-gtk+2.patch
115 Patch7:         %{name}-alpha.patch
116 Patch8:         %{name}-altivec.patch
117 Patch9:         %{name}-assembly.patch
118 Patch10:        %{name}-pcmsplit.patch
119 Patch11:        %{name}-bio2jack.patch
120 Patch12:        %{name}-x86_64-detection.patch
121 Patch13:        %{name}-mythtv.patch
122 Patch14:        %{name}-shared.patch
123 Patch15:        %{name}-xvmc.patch
124 Patch16:        %{name}-kill-mabi_altivec.patch
125 Patch17:        %{name}-gcc4.patch
126 Patch18:        http://www.mplayerhq.hu/MPlayer/patches/demuxer_h_fix_20060212.diff
127 Patch19:        %{name}-CVE-2005-4048.patch
128 #http://www.openchrome.org/snapshots/mplayer/
129 URL:            http://www.mplayerhq.hu/
130 %{?with_directfb:BuildRequires: DirectFB-devel}
131 BuildRequires:  OpenGL-devel
132 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
133 %{?with_aalib:BuildRequires:    aalib-devel}
134 %{?with_alsa:BuildRequires:     alsa-lib-devel}
135 %{?with_arts:BuildRequires:     artsc-devel}
136 %{?with_cdparanoia:BuildRequires:       cdparanoia-III-devel}
137 %{?with_divx4linux:BuildRequires:       divx4linux-devel >= 1:5.01.20020418}
138 %{?with_doc:BuildRequires:      docbook-style-xsl}
139 %{?with_dxr3:BuildRequires:     em8300-devel}
140 %{?with_enca:BuildRequires:     enca-devel}
141 %{?with_esd:BuildRequires:      esound-devel}
142 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
143 BuildRequires:  freetype-devel
144 %ifarch ppc
145 %{?with_altivec:BuildRequires:  gcc >= 5:3.3.2-3}
146 %endif
147 %{?with_gif:BuildRequires:      giflib-devel}
148 %if %{with gui}
149 BuildRequires:  gtk+%{?with_gtk2:2}-devel
150 %endif
151 BuildRequires:  lame-libs-devel
152 %{?with_jack:BuildRequires:     libbio2jack-devel}
153 %{?with_caca:BuildRequires:     libcaca-devel}
154 %{?with_libdts:BuildRequires:   libdts-devel}
155 %{?with_libdv:BuildRequires:    libdv-devel}
156 %{?with_ggi:BuildRequires:      libggi-devel}
157 BuildRequires:  libjpeg-devel
158 %{?with_mad:BuildRequires:      libmad-devel}
159 BuildRequires:  libpng-devel
160 %{?with_smb:BuildRequires:      libsmbclient-devel}
161 %{?with_dshow:BuildRequires:    libstdc++-devel}
162 %{?with_theora:BuildRequires:   libtheora-devel}
163 %{?with_vorbis:BuildRequires:   libvorbis-devel}
164 BuildRequires:  libxslt-progs
165 %{?with_lirc:BuildRequires:     lirc-devel}
166 %{?with_live:BuildRequires:     live}
167 BuildRequires:  lzo-devel
168 %{?with_nas:BuildRequires:      nas-devel}
169 BuildRequires:  ncurses-devel
170 BuildRequires:  pkgconfig
171 %{?with_polyp:BuildRequires:    polypaudio-devel}
172 %{?with_svga:BuildRequires:     svgalib-devel}
173 %{?with_xmms:BuildRequires:     xmms-libs}
174 BuildRequires:  xorg-lib-libXvMC-devel
175 BuildRequires:  xorg-lib-libX11-devel
176 BuildRequires:  xorg-lib-libXext-devel
177 BuildRequires:  xorg-lib-libXinerama-devel
178 BuildRequires:  xorg-lib-libXv-devel
179 BuildRequires:  xorg-lib-libXxf86dga-devel
180 BuildRequires:  xorg-lib-libXxf86vm-devel
181 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
182 BuildRequires:  zlib-devel
183 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
184 Requires(post,postun):  /sbin/ldconfig
185 Requires:       OpenGL
186 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
187
188 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
189 %define         specflags_ia32  -fomit-frame-pointer
190 %define         specflags_alpha -mmax
191 %if %{with altivec}
192 %define         specflags_ppc   -maltivec
193 %endif
194
195 %description
196 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
197 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
198 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
199 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
200 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
201 optionally with SHM extension, X11 using overlays with the Xvideo
202 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
203 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
204
205 If you want to use win32 codecs install w32codec package.
206
207 %description -l de
208 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
209 Kennzeichnend ist die herausragende Format- und
210 Plattform-Kompatibilität.
211
212 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
213 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
214 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
215 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
216 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
217 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
218 installierte Codecs nicht mit MPlayer kollidieren können.
219
220 %description -l es
221 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
222 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
223 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
224 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
225 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
226 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
227 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
228 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
229 v1.1.7 etc.
230
231 Si quiere usar codecs Win32, instale el paquete w32codec.
232
233 %description -l ko
234 MPlayer´Â ¸®´ª½º¿ë ¹«ºñÇ÷¹À̾îÀÔ´Ï´Ù. ´ëºÎºÐÀÇ mpeg, avi ±×¸®°í asf
235 ÆÄÀÏÀ» Àç»ýÇÕ´Ï´Ù. VCD, DVD, ½É Áö¾î DivX±îÁö º¼ ¼ö ÀÖ½À´Ï´Ù.
236 MPlayerÀÇ ¶Ç ´Ù¸¥ Å« Æ¯Â¡Àº Ãâ·Â µå¶óÀ̹ö°¡ ´Ù¾çÇϴٴ °ÍÀÔ´Ï´Ù. X11,
237 Xv, DGA, OpenGL, SVGAlib, fbdev¿Í ÀÛµ¿Çϸç, SDLÀ̳ª
238 (Matrox/3dfx/SisµîÀÇ) Æ¯Á¤ Ä«µå¿¡ Á¾¼ÓµÈ ·Î¿ì·¹ º§ µå¶óÀ̹öµéµµ »ç¿ëÇÒ
239 ¼ö ÀÖ½À´Ï´Ù. ´ëºÎºÐÀÇ Ãâ·Â µå¶óÀ̹öµéÀº ¼ÒÇÁÆ®¿þ¾î È¤Àº Çϵå¿þ¾îÀûÀÎ
240 Å©±âÁ¶Àý (scaling)À» Áö¿øÇϹǷÎ, Àüüȭ¸éÀ¸·Î ¿µ»óÀ» °¨»óÇÒ ¼ö
241 ÀÖ½À´Ï´Ù. »Ó¸¸¾Æ´Ï¶ó, Çѱ¹¾î, ¿µ¾î, Çë°¡¸®¾î, Ã¼ÄÚ¾î, ·¯½Ã¾Æ¾îµîÀÇ
242 ºÎµå·¯¿î(antialiased) ÀÚ¸·ÆùÆ®µµ »ç¿ëÇÒ ¼ö ÀÖ½À´Ï´Ù.
243
244 %description -l pl
245 Odtwarzacz wideo. Wspierane formaty wej¶ciowe: VCD (VideoCD), MPEG1/2,
246 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
247 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
248 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
249 Wspierane urz±dzenia wyj¶ciowe: Matrox G200/G400, X11 opcjonalnie z
250 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
251 G400 u¿ywaj±c framebuffera, Voodoo2/3, SDL v1.1.7 itp.
252
253 Je¶li chcesz u¿ywaæ kodeków win32, zainstaluj pakiet w32codec.
254
255 %description -l pt_BR
256 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
257 áudio. Diferentes mecanismos de reprodução podem também ser
258 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
259
260 %package -n gmplayer
261 Summary:        MPlayer with GTK+ GUI interface
262 Summary(pl):    MPlayer z graficznym interfejsem GTK+
263 Group:          X11/Applications/Multimedia
264 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
265 Requires:       %{name}-skin
266 Provides:       %{name} = %{epoch}:%{version}-%{release}
267
268 %description -n gmplayer
269 MPlayer with GUI GTK+ interface.
270
271 %description -n gmplayer -l pl
272 MPlayer z graficznym interfejsem GTK+.
273
274 %package common
275 Summary:        Configuration files and documentation for MPlayer
276 Summary(pl):    Pliki konfiguracyjne i dokumentacja dla MPlayera
277 Group:          Applications/Multimedia
278 Requires:       %{name} = %{epoch}:%{version}-%{release}
279
280 %description common
281 Configuration files, man page and HTML documentation for MPlayer.
282
283 %description common -l pl
284 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
285
286 %package -n mencoder
287 Summary:        MEncoder - a movie encoder for Linux
288 Summary(pl):    MEncoder - koder filmów dla Linuksa
289 Group:          Applications/Multimedia
290 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
291
292 %description -n mencoder
293 MEncoder is a movie encoder for Linux and is a part of the MPlayer
294 package.
295
296 %description -n mencoder -l pl
297 MEncoder to koder filmów dla Linuksa bêd±cy czê¶ci± pakietu MPlayer.
298
299 %prep
300 %if %{snapshot}
301 %setup -q -n %{name}-%{snap} -a 1 -a 3 -a 6
302 %else
303 %setup -q -n %{sname}-%{version}%{pre} -a 3 -a 6
304 %endif
305
306 cp -f etc/codecs.conf etc/codecs.win32.conf
307 %patch0 -p1
308 %patch1 -p0
309 ##%patch2 -p1
310 ##%patch3 -p1   -- old home_etc behavior
311 %patch4 -p1
312 %patch5 -p1
313 %if %{with gtk2}
314 %patch6 -p1
315 %endif
316 %patch7 -p1
317 %patch8 -p1
318 %patch9 -p1
319 #%%patch10 -p1
320 %patch11 -p1
321 %patch12 -p1
322 %patch13 -p1
323 %if %{with shared}
324 %patch14 -p1
325 %endif
326 %patch15 -p0
327 %patch16 -p1
328 %patch17 -p1
329 %patch18 -p0
330 %patch19 -p1
331
332 # kill evil file, hackery not needed with llh
333 echo > osdep/kerneltwosix.h
334
335 find . -type d -name CVS -print | xargs rm -rf
336
337 %build
338 %if %{with shared}
339 CFLAGS="%{rpmcflags} -fPIC"
340 LDFLAGS="%{rpmldflags} -wl,--as-needed"
341 %else
342 CFLAGS="%{rpmcflags}"
343 LDFLAGS="%{rpmldflags}"
344 %endif
345 CC="%{__cc}"
346 export CC CFLAGS
347
348 build() {
349 set -x
350         ./configure \
351         %{?debug:--enable-debug=3} \
352         --prefix=%{_prefix} \
353         --confdir=%{_sysconfdir}/mplayer \
354         --with-x11incdir=%{_includedir} \
355         --with-x11libdir=%{_libdir} \
356         --with-extraincdir=%{_includedir}/xvid \
357         --enable-menu \
358 %ifnarch %{ix86} %{x8664}
359         --disable-mmx \
360         --disable-mmx2 \
361         --disable-3dnow \
362         --disable-3dnowex \
363         --disable-sse \
364         --disable-sse2 \
365         --disable-fastmemcpy \
366 %endif
367 %ifarch ppc
368 %{!?with_altivec:--disable-altivec} \
369 %endif
370 %{?with_directfb:--enable-directfb} \
371 %{!?with_directfb:--disable-directfb} \
372 %{!?with_divx4linux:--disable-divx4linux} \
373 %{?with_divx4linux:--with-extraincdir=/usr/include/divx} \
374 %{!?with_dxr3:--disable-dxr3} \
375 %{!?with_ggi:--disable-ggi} \
376 %{?with_live:--enable-live --with-livelibdir=%{_libdir}/liveMedia --with-extraincdir=/usr/include/liveMedia} \
377 %{!?with_live:--disable-live} \
378 %{!?with_nas:--disable-nas} \
379 %{!?with_svga:--disable-svga} \
380 %{!?with_aalib:--disable-aa} \
381 %{!?with_jack:--disable-jack} \
382 %{!?with_alsa:--disable-alsa} \
383 %{?with_alsa:--enable-alsa --disable-select} \
384 %{!?with_arts:--disable-arts} \
385 %{!?with_caca:--disable-caca} \
386 %{!?with_cdparanoia:--disable-cdparanoia} \
387 %{!?with_dshow:--disable-dshow} \
388 %{!?with_enca:--disable-enca} \
389 %{!?with_esd:--disable-esd} \
390 %{!?with_faad:--disable-external-faad --disable-internal-faad}%{?with_faad:--enable-external-faad} \
391 %{!?with_gif:--disable-gif} \
392 %{?with_joystick:--enable-joystick} \
393 %{!?with_libdv:--disable-libdv} \
394 %{!?with_libdts:--disable-libdts} \
395 --%{?with_lirc:en}%{!?with_lirc:dis}able-lirc \
396 %{!?with_mad:--disable-mad} \
397 %{!?with_polyp:--disable-polyp} \
398 %{!?with_quicktime:--disable-qtx} \
399 %{!?with_real:--disable-real} \
400 --%{?with_runtime:en}%{!?with_runtime:dis}able-runtime-cpudetection \
401 %{!?with_select:--disable-select} \
402 %{!?with_smb:--disable-smb} \
403 %{!?with_win32:--disable-win32} \
404 %{!?with_vorbis:--disable-vorbis} \
405 %{?with_osd:--enable-menu} \
406 %{!?with_theora:--disable-theora} \
407 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
408 %{!?with_xvid:--disable-xvid} \
409 %{!?with_mencoder:--disable-mencoder} \
410         --enable-dga \
411         --enable-fbdev \
412         --enable-gl \
413         --enable-mga \
414         --%{?with_sdl:en}%{!?with_sdl:dis}able-sdl \
415         --enable-tdfxfb \
416         --enable-vm \
417         --enable-x11 \
418         --enable-xmga \
419         --enable-xv \
420         --enable-xvmc \
421         --enable-dynamic-plugins \
422         --enable-largefiles \
423         --language=all \
424         --with-codecsdir=%{_libdir}/codecs \
425         --with-xvmclib=XvMCW \
426         "$@"
427
428         %{__make}
429 }
430
431 %if %{with gui}
432 # build GUI version
433 build --enable-gui
434 mv -f mplayer gmplayer
435 %{__make} clean
436 %endif
437
438 # now build regular version
439 build --disable-gui
440
441 %if %{with doc}
442 %{__make} -j1 -C DOCS/xml
443 %endif
444
445 %install
446 rm -rf $RPM_BUILD_ROOT
447 install -d \
448         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
449         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
450         $RPM_BUILD_ROOT{%{_datadir}/mplayer/Skin,%{_libdir}/mplayer/vidix} \
451         $RPM_BUILD_ROOT%{_desktopdir}
452
453 # default config files
454 sed -e '/Delete this default/d' etc/example.conf > etc/mplayer.conf
455 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
456
457 # executables
458 %if %{with mencoder}
459 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{_suf}
460 ln -sf mencoder%{_suf} $RPM_BUILD_ROOT%{_bindir}/mencoder
461 %endif
462 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{_suf}
463 ln -sf mplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/mplayer
464 %if %{with gui}
465 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{_suf}
466 ln -sf gmplayer%{_suf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
467 %endif
468
469 # fonts
470 rm -f font-*/runme
471 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
472 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
473
474 # libraries
475 %ifarch %{ix86}
476 install libdha/libdha.so.1.0 $RPM_BUILD_ROOT%{_libdir}
477 install vidix/drivers/*.so $RPM_BUILD_ROOT%{_libdir}/mplayer/vidix
478 %endif
479
480 %if %{with gui}
481 ln -s Blue $RPM_BUILD_ROOT%{_datadir}/%{name}/Skin/default
482 %endif
483
484 # X-files
485 %if %{with gui}
486 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
487 %endif
488 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
489 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
490
491 # man pages
492 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
493 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
494 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
495 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
496 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
497 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
498 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
499 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
500 install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
501 install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
502
503 %clean
504 rm -rf $RPM_BUILD_ROOT
505
506 %post
507 umask 022
508 /sbin/ldconfig
509 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
510
511 %postun
512 umask 022
513 /sbin/ldconfig
514 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
515
516 %files
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_bindir}/mplayer*
519
520 %if %{with gui}
521 %files -n gmplayer
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_bindir}/gmplayer*
524 %{_desktopdir}/gmplayer.desktop
525 %dir %{_datadir}/%{name}/Skin
526 %ghost %{_datadir}/%{name}/Skin/default
527 %endif
528
529 %files -n mencoder
530 %defattr(644,root,root,755)
531 %doc DOCS/tech/encoding-tips.txt DOCS/tech/swscaler_filters.txt
532 %doc DOCS/tech/swscaler_methods.txt DOCS/tech/colorspaces.txt
533 %attr(755,root,root) %{_bindir}/mencoder*
534
535 %files common
536 %defattr(644,root,root,755)
537 # some useful tech docs
538 %doc DOCS/tech/hwac3.txt DOCS/tech/mpsub.sub DOCS/tech/slave.txt
539 %doc DOCS/tech/subcp.txt
540
541 # HTML and XML-generated docs
542 %doc DOCS/HTML/en
543 %doc DOCS/tech
544 %if %{with win32}
545 %doc etc/codecs.win32.conf
546 %endif
547 %lang(de) %doc DOCS/de
548 %lang(es) %doc DOCS/HTML/es
549 %lang(fr) %doc DOCS/HTML/fr
550 %lang(hu) %doc DOCS/HTML/hu
551 %lang(it) %doc DOCS/it
552 %lang(pl) %doc DOCS/HTML/pl
553 %lang(ru) %doc DOCS/HTML/ru
554 %lang(zh_CN) %doc DOCS/zh
555 %doc README AUTHORS ChangeLog
556
557 %ifarch %{ix86}
558 %attr(755,root,root) %{_libdir}/libdha.so.*.*
559 %attr(755,root,root) %{_libdir}/mplayer
560 %endif
561 %dir %{_sysconfdir}/%{name}
562 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
563 %{_mandir}/man1/*
564 %lang(cs) %{_mandir}/cs/man1/*
565 %lang(de) %{_mandir}/de/man1/*
566 %lang(es) %{_mandir}/es/man1/*
567 %lang(fr) %{_mandir}/fr/man1/*
568 %lang(hu) %{_mandir}/hu/man1/*
569 %lang(it) %{_mandir}/it/man1/*
570 %lang(pl) %{_mandir}/pl/man1/*
571 %lang(sv) %{_mandir}/sv/man1/*
572 %lang(zh_CN) %{_mandir}/zh_CN/man1/*
573 %{_desktopdir}/mplayer.desktop
574 %{_pixmapsdir}/*
575 %dir %{_datadir}/%{name}
576 %{_datadir}/%{name}/font*
This page took 0.108889 seconds and 3 git commands to generate.