]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
3b9d344a1bea83ebcf3d1ff75ef308182005a5b3
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 # - CPU optimization:
4 %bcond_without  altivec         # PPC altivec support
5 %bcond_without  ssse3           # SSSE3 optimizations (needs binutils >= 2.16.92)
6 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
7                                 #  in compile time (advertised by mplayer authors as working faster); in this case
8                                 #  mplayer may not work on machine other then where it was compiled
9 %bcond_without  hidden_visibility       # no gcc hidden visibility
10 %bcond_without  verbose         # disable verbose build
11 # - general features:
12 %bcond_without  bluray          # Blu-ray support
13 %bcond_without  cdio            # libcdio support
14 %bcond_without  cdparanoia      # cdparanoia support (when libcdio not enabled)
15 %bcond_without  doc             # don't build docs (slow)
16 %bcond_without  dvdnav          # dvdnav support
17 %bcond_without  system_dvdcss   # system libdvdcss library (instead of internal copy)
18 %bcond_without  system_dvdread  # system libdvdread library (instead of internal copy)
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_without  gui             # without GTK+ GUI
21 %bcond_without  joystick        # joystick support
22 %bcond_without  lirc            # lirc support
23 %bcond_without  live            # LIVE555 Streaming Media support
24 %bcond_without  mencoder        # mencoder (a/v encoder) compilation
25 %bcond_without  nemesi          # NeMeSi Streaming Media support
26 %bcond_without  osd             # osd menu support
27 %bcond_without  rtmp            # RTMPDump Streaming Media support
28 %bcond_with     shared          # experimental libmplayer.so support
29 %bcond_without  smb             # Samba (SMB) input support
30 %bcond_without  vstream         # TiVo vstream client support
31 # - codecs:
32 %bcond_without  amr             # Adaptive Multi Rate (AMR) speech codec support
33 %bcond_without  bs2b            # BS2B audio filter support
34 %bcond_without  crystalhd       # CrystalHD support
35 %bcond_without  faad            # FAAD2 (AAC) support
36 %bcond_without  gif             # GIF support
37 %bcond_without  ladspa          # LADSPA plugin support
38 %bcond_without  libdts          # libdts support
39 %bcond_without  libdv           # libdv en/decoding support
40 %bcond_without  lzo             # LZO support (requires lzo 2.x)
41 %bcond_without  mad             # mad (audio MPEG) support
42 %bcond_without  mpg123          # libmpg123 MP3 decoding support
43 %bcond_with     musepack        # libmpcdec support (deprecated in favour of libavcodec)
44 %bcond_without  openjpeg        # OpenJPEG (JPEG2000) input/output support
45 %bcond_without  quicktime       # binary quicktime dll support
46 %bcond_without  real            # Real* 8/9 codecs support
47 %bcond_without  vorbis          # Ogg Vorbis audio support (both tremor and libvorbis)
48 %bcond_with     tremor          # use tremor instead of libvorbis
49 %bcond_without  theora          # Ogg Theora video support
50 %bcond_without  win32           # Win32 codecs support
51 %bcond_without  x264            # x264 support
52 %bcond_with     xmms            # XMMS inputplugin support
53 %bcond_without  xvid            # XviD codec
54 %bcond_with     system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
55 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
56 # - video output:
57 %bcond_without  aalib           # aalib video output
58 %bcond_without  caca            # libcaca video output
59 %bcond_with     directfb        # DirectFB video output
60 %bcond_with     dxr2            # DXR2 (hardware MPEG decoder) video output
61 %bcond_with     dxr3            # DXR3/H+ (hardware MPEG decoder) video output
62 %bcond_with     ggi             # GGI video output
63 %bcond_without  sdl             # SDL video output
64 %bcond_with     svga            # svgalib video output
65 %bcond_without  vdpau           # VDPAU acceleration
66 %bcond_without  vidix           # VIDIX video drivers
67 %bcond_with     zr              # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
68 %bcond_with     gnomess         # controling gnome screensaver [patch not updated]
69 # - audio output:
70 %bcond_without  alsa            # ALSA audio output
71 %bcond_with     arts            # aRts audio output
72 %bcond_with     esd             # EsounD sound support
73 %bcond_without  jack            # JACKD support
74 %bcond_with     nas             # NAS audio output
75 %bcond_without  pulseaudio      # pulseaudio output
76 %bcond_without  select          # audio select() support (required e.g. for ALSA or Vortex2 driver)
77
78 %if %{with alsa}
79 %undefine       with_select
80 %endif
81 %if %{without vorbis}
82 %undefine       with_tremor
83 %endif
84
85 %ifnarch %{ix86}
86 %undefine       with_win32
87 %undefine       with_quicktime
88 %undefine       with_vidix
89 %endif
90 %ifnarch %{ix86} %{x8664} ppc ppc64
91 %undefine       with_runtime
92 %endif
93 %ifnarch %{ix86} %{x8664}
94 %undefine       with_vdpau
95 %endif
96 %ifnarch ppc
97 %undefine       with_altivec
98 %endif
99 %ifnarch i686 pentium4 athlon %{x8664}
100 %undefine       with_crystalhd
101 %endif
102
103 %if "%{_lib}" != "lib"
104 %define         binsuf  %(lib=%{_lib} ; echo ${lib#lib})
105 %else
106 %ifarch %{ix86} ppc sparc sparcv9 s390
107 %define         binsuf  32
108 %else
109 %define         binsuf  %{nil}
110 %endif
111 %endif
112
113 %if 0
114 # date from directory inside of tarball (like mplayer-export-2014-04-29)
115 %define snap    2018-05-22
116 %define ssnap   %(echo %{snap} | tr -d -)
117 %endif
118 Summary:        MPlayer - THE Movie Player for UN*X
119 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
120 Summary(es.UTF-8):      Otro reproductor de películas
121 Summary(ko.UTF-8):      리눅스용 미디어플레이어
122 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
123 Summary(pt_BR.UTF-8):   Reprodutor de filmes
124 Name:           mplayer
125 Version:        1.5
126 Release:        1
127 # DO NOT increase epoch unless it's really neccessary!
128 # especially such changes like pre7->pre7try2, increase Release instead!
129 # PS: $ rpmvercmp pre7try2 pre7
130 # pre7try2 > pre7
131 Epoch:          3
132 License:        GPL
133 Group:          Applications/Multimedia
134 # Source0:      http://mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
135 Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
136 # Source0-md5:  0419b64db24b6db0943dbc6afece7c44
137 %if 0
138 Source1:        http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
139 # Source1-md5:  b1b71cc56b15da49cee1ede9a7b8134e
140 %endif
141 Source2:        http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
142 # Source2-md5:  1ecd31d17b51f16332b1fcc7da36b312
143 Source3:        http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
144 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
145 Source4:        http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-7.tar.bz2
146 # Source4-md5:  956a9d9ea51970e057f0deb7b2e25889
147 Source5:        g%{name}.desktop
148 Source7:        %{name}.png
149 Source8:        %{name}.desktop
150
151 # build (configure / Makefile) related:
152 Patch10:        %{name}-ldflags.patch
153 Patch11:        %{name}-altivec.patch
154 Patch12:        %{name}-check-byteswap.patch
155 Patch13:        %{name}-visibility-hidden-fix.patch
156 Patch14:        cflags.patch
157 Patch15:        %{name}-live555-async.patch
158 Patch16:        %{name}-live555-config.patch
159 Patch17:        %{name}-gsm.patch
160
161 Patch19:        %{name}-shared.patch
162 Patch20:        %{name}-vstream.patch
163
164 # codecs, outputs, demuxers:
165 Patch21:        %{name}-auto-expand.patch
166 Patch22:        %{name}-release_directfb.patch
167
168 # goodies:
169 Patch30:        %{name}-cp1250-fontdesc.patch
170 Patch31:        %{name}-350.patch
171 # update, hard to fix right now because of gnome bug 579430:
172 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
173 #Patch32:       %{name}-gnome-screensaver.patch
174
175 Patch101:       %{name}-link.patch
176
177 URL:            http://www.mplayerhq.hu/
178 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
179 BuildRequires:  EGL-devel
180 BuildRequires:  OpenAL-devel
181 BuildRequires:  OpenGL-GLX-devel
182 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
183 # checked, but seems actually not used
184 #%{?with_sdl:BuildRequires:     SDL_image-devel}
185 BuildRequires:  a52dec-libs-devel
186 %{?with_aalib:BuildRequires:    aalib-devel}
187 %{?with_alsa:BuildRequires:     alsa-lib-devel}
188 BuildRequires:  aom-devel
189 %{?with_arts:BuildRequires:     artsc-devel}
190 BuildRequires:  binutils >= 2.10.1
191 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
192 BuildRequires:  bzip2-devel
193 #%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
194 BuildRequires:  dav1d-devel
195 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
196 %{?with_doc:BuildRequires:      docbook-dtd45-xml}
197 %{?with_doc:BuildRequires:      docbook-style-xsl}
198 %{?with_dxr2:BuildRequires:     dxr2-driver-devel}
199 %{?with_dxr3:BuildRequires:     em8300-devel}
200 %{?with_enca:BuildRequires:     enca-devel}
201 %{?with_esd:BuildRequires:      esound-devel}
202 BuildRequires:  faac-devel
203 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
204 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 5.1}
205 BuildRequires:  fontconfig-devel >= 1:2.4.2
206 BuildRequires:  freetype-devel >= 1:2.2.1
207 BuildRequires:  fribidi-devel
208 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
209 %{?with_gif:BuildRequires:      giflib-devel}
210 %{?with_gui:BuildRequires:      glib2-devel >= 1:2.6.0}
211 BuildRequires:  gnutls-devel
212 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
213 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
214 %{?with_ladspa:BuildRequires:   ladspa-devel}
215 BuildRequires:  lame-libs-devel
216 BuildRequires:  libass-devel >= 0.9.10
217 %{?with_bluray:BuildRequires:   libbluray-devel}
218 %{?with_bs2b:BuildRequires:     libbs2b-devel >= 3.0.0}
219 %{?with_caca:BuildRequires:     libcaca-devel}
220 %{?with_cdio:BuildRequires:     libcdio-paranoia-devel}
221 %{?with_crystalhd:BuildRequires:        libcrystalhd-devel}
222 %{?with_libdts:BuildRequires:   libdts-devel}
223 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
224 #%{?with_system_dvdcss:BuildRequires:   libdvdcss-devel}
225 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
226 %{?with_system_dvdread:BuildRequires:   libdvdread-devel >= 4.1}
227 %{?with_ggi:BuildRequires:      libggi-devel}
228 %{?with_ggi:BuildRequires:      libggiwmh-devel}
229 BuildRequires:  libgsm-devel
230 BuildRequires:  libjpeg-devel
231 %{?with_mad:BuildRequires:      libmad-devel}
232 BuildRequires:  libmng-devel
233 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
234 %{?with_system_libmpeg2:BuildRequires:  libmpeg2-devel}
235 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
236 %{?with_nemesi:BuildRequires:   libnemesi-devel >= 0.6.3}
237 BuildRequires:  libnut-devel
238 BuildRequires:  libpng-devel
239 %{?with_rtmp:BuildRequires:     librtmp-devel}
240 %{?with_smb:BuildRequires:      libsmbclient-devel}
241 %{?with_theora:BuildRequires:   libtheora-devel}
242 %{?with_vdpau:BuildRequires:    libvdpau-devel}
243 %if %{with vorbis} && %{without tremor}
244 BuildRequires:  libvorbis-devel
245 %endif
246 BuildRequires:  libvpx-devel
247 # build >= 118
248 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
249 BuildRequires:  libxml2-devel >= 2.0
250 BuildRequires:  libxslt-progs
251 # with v4l2 headers
252 BuildRequires:  linux-libc-headers >= 7:2.6.22
253 %{?with_lirc:BuildRequires:     lirc-devel}
254 %{?with_live:BuildRequires:     live-devel >= 2:2011.01.10}
255 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
256 %{?with_nas:BuildRequires:      nas-devel}
257 BuildRequires:  ncurses-devel
258 %{?with_amr:BuildRequires:      opencore-amr-devel}
259 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
260 BuildRequires:  opus-devel
261 BuildRequires:  pkgconfig
262 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
263 BuildRequires:  rpm >= 4.4.9-56
264 BuildRequires:  rpmbuild(macros) >= 1.527
265 BuildRequires:  speex-devel >= 1.1
266 %{?with_svga:BuildRequires:     svgalib-devel}
267 BuildRequires:  tar >= 1:1.22
268 %{?with_tremor:BuildRequires:   tremor-devel}
269 BuildRequires:  twolame-devel
270 %{?with_vidix:BuildRequires:    vidix-devel}
271 %{?with_vstream:BuildRequires:  vstream-client-devel}
272 BuildRequires:  webrtc-libilbc-devel
273 %{?with_xmms:BuildRequires:     xmms-devel}
274 BuildRequires:  xorg-lib-libX11-devel
275 BuildRequires:  xorg-lib-libXScrnSaver-devel
276 BuildRequires:  xorg-lib-libXext-devel
277 BuildRequires:  xorg-lib-libXinerama-devel
278 BuildRequires:  xorg-lib-libXv-devel
279 BuildRequires:  xorg-lib-libXvMC-devel
280 BuildRequires:  xorg-lib-libXxf86dga-devel
281 BuildRequires:  xorg-lib-libXxf86vm-devel
282 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
283 BuildRequires:  xz
284 %ifarch %{ix86} %{x8664}
285 BuildRequires:  yasm
286 %endif
287 BuildRequires:  zlib-devel
288 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
289 %{?with_openjpeg:Requires:      openjpeg2 >= 2.1.0}
290 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
291
292 %define         specflags_ia32  -fomit-frame-pointer
293 %if %{with altivec}
294 %define         specflags_ppc   -maltivec
295 %endif
296
297 %description
298 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
299 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
300 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
301 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
302 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
303 optionally with SHM extension, X11 using overlays with the Xvideo
304 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
305 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
306
307 If you want to use win32 codecs install w32codec package.
308
309 %description -l de.UTF-8
310 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
311 Kennzeichnend ist die herausragende Format- und
312 Plattform-Kompatibilität.
313
314 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
315 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
316 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
317 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
318 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
319 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
320 installierte Codecs nicht mit MPlayer kollidieren können.
321
322 %description -l es.UTF-8
323 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
324 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
325 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
326 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
327 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
328 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
329 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
330 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
331 v1.1.7 etc.
332
333 Si quiere usar codecs Win32, instale el paquete w32codec.
334
335 %description -l ko.UTF-8
336 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
337 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
338 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
339 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
340 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
341 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
342 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
343 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
344 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
345
346 %description -l pl.UTF-8
347 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
348 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
349 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
350 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
351 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
352 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
353 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
354
355 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
356
357 %description -l pt_BR.UTF-8
358 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
359 áudio. Diferentes mecanismos de reprodução podem também ser
360 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
361
362 %package -n gmplayer
363 Summary:        MPlayer with GTK+ GUI interface
364 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
365 Group:          X11/Applications/Multimedia
366 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
367 Requires:       %{name}-skin
368
369 %description -n gmplayer
370 MPlayer with GUI GTK+ interface.
371
372 %description -n gmplayer -l pl.UTF-8
373 MPlayer z graficznym interfejsem GTK+.
374
375 %package common
376 Summary:        Configuration files and documentation for MPlayer
377 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
378 Group:          Applications/Multimedia
379 Suggests:       unrar
380 Obsoletes:      mplayer-vidix < 1.0-3.rc1.2
381
382 %description common
383 Configuration files, man page and HTML documentation for MPlayer.
384
385 %description common -l pl.UTF-8
386 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
387
388 %package doc
389 Summary:        HTML documentation for MPlayer
390 Summary(pl.UTF-8):      Dokumentacja do MPlayera w formacie HTML
391 Group:          Documentation
392
393 %description doc
394 HTML Documentation for MPlayer.
395
396 %description doc -l pl.UTF-8
397 Dokumentacja do MPlayera w formacie HTML.
398
399 %package -n mencoder
400 Summary:        MEncoder - a movie encoder for Linux
401 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
402 Group:          Applications/Multimedia
403 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
404
405 %description -n mencoder
406 MEncoder is a movie encoder for Linux and is a part of the MPlayer
407 package.
408
409 %description -n mencoder -l pl.UTF-8
410 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
411
412 %prep
413 %if 0%{?snap:1}
414 %setup -q -n %{name}-export-%{snap} -a1 -a2 -a3 -a4
415 %else
416 %setup -q -n MPlayer-%{version} -a2 -a3 -a4
417 %endif
418 cp -f etc/codecs.conf etc/codecs.win32.conf
419
420 # build (configure / Makefile) related:
421 %patch10 -p1
422 %patch11 -p1
423 %patch12 -p1
424 %patch13 -p1
425 %patch14 -p1
426 %patch15 -p1
427 %patch16 -p1
428 %patch17 -p1
429
430 %{?with_shared:%patch19 -p1}
431 %patch20 -p1
432
433 # codecs, outputs, demuxers:
434 %patch21 -p1
435 %patch22 -p1
436
437 # goodies:
438 %patch30 -p0
439 %patch31 -p1
440 #%{with_gnomess:%patch32 -p1}
441
442 %patch101 -p1
443
444 cat etc/example.conf > etc/mplayer.conf
445 cat <<'CONFIGADD' >> etc/mplayer.conf
446
447 ######################
448 # PLD Linux Defaults #
449 ######################
450 [default]
451
452 # alternate solution for CP1250-encoded subtitles
453 fontconfig = yes
454 subcp = cp1250
455
456 # ...or if you prefer native bitmap fonts shipped with mplayer
457 #fontconfig = no
458 #subcp = iso-8859-1
459
460 # Standard location
461 unrarexec = "%{_bindir}/unrar"
462
463 # Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
464 joystick=no
465
466 CONFIGADD
467
468 %if %{with system_ffmpeg}
469 # using external ffmpeg, but mplayer adds these to includepath
470 %{__rm} -rf ffmpeg
471 %endif
472
473 %build
474 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
475 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb: -I%{_includedir}/directfb} -DHAVE_GSM_H=1"
476
477 # NOTE:
478 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
479 # - toolame is obsolete predecessor of twolame
480 # - libcdio-paranoia is preferred over cdparanoia-III libs
481 build() {
482         set -x
483
484         ./configure \
485         %{?debug:--enable-debug=3} \
486         --prefix=%{_prefix} \
487         --codecsdir=%{_libdir}/codecs \
488         --confdir=%{_sysconfdir}/mplayer \
489         --cc="%{__cc}" \
490         --extra-cflags="$CFLAGS" \
491         --real-ldflags="%{rpmldflags}" \
492         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
493         --language=all \
494 %if %{with system_ffmpeg}
495         --disable-ffmpeg_a \
496 %endif
497 %ifnarch %{ix86} %{x8664}
498         --disable-3dnow \
499         --disable-3dnowext \
500         --disable-fastmemcpy \
501         --disable-mmx \
502         --disable-mmxext \
503         --disable-sse \
504         --disable-sse2 \
505 %endif
506         %{__disable ssse3} \
507 %ifarch ppc
508         %{__disable altivec} \
509 %endif
510         %{__disable aalib aa} \
511         %{__enable_disable alsa} \
512         %{__disable arts} \
513         %{__disable bluray} \
514         %{__disable caca} \
515         %{__disable cdparanoia} \
516         --enable-dga1 \
517         --enable-dga2 \
518         %{__enable_disable directfb} \
519         %{__enable_disable dvdnav} \
520         %{__disable system_dvdread dvdread-internal} \
521         %{__disable dxr2} \
522         %{__disable dxr3} \
523         --enable-dynamic-plugins \
524         %{__disable enca} \
525         %{__disable esd} \
526         %{__disable faad} \
527         --enable-fbdev \
528         %{__disable gif} \
529         --enable-gl \
530         %{__disable ggi} \
531         %{__disable jack} \
532         %{__enable joystick} \
533         %{__disable cdio libcdio} \
534         %{__disable ladspa} \
535         %{__disable bs2b libbs2b} \
536         %{__disable libdts libdca} \
537         %{__disable libdv} \
538         %{__enable_disable live} \
539         %{__disable system_dvdcss libdvdcss-internal} \
540         %{__disable lzo liblzo} \
541         %{__disable system_libmpeg2 libmpeg2-internal} \
542         %{__disable nemesi} \
543         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
544         %{__disable openjpeg} \
545         %{__disable rtmp librtmp} \
546         %{__disable vorbis libvorbis} \
547         %{__enable_disable lirc} \
548         --disable-lircc \
549         %{__disable live} \
550         %{__disable mad} \
551         %{__disable mencoder} \
552         %{__enable osd menu} \
553         --enable-mga \
554         %{__disable mpg123} \
555         %{__enable musepack} \
556         %{__disable nas} \
557         %{__disable pulseaudio pulse} \
558         %{__disable quicktime qtx} \
559         --enable-radio \
560         --enable-radio-capture \
561         %{__disable real} \
562         %{__enable_disable runtime runtime-cpudetection} \
563         %{__enable_disable sdl} \
564         %{__disable select} \
565         --enable-s3fb \
566         %{__disable smb} \
567         %{__disable svga} \
568         --enable-tdfxfb \
569         --enable-tdfxvid \
570         %{__disable theora} \
571         --disable-toolame \
572         %{!?with_tremor:--disable-tremor} \
573         --enable-unrarexec \
574         %{__disable vdpau} \
575         %{__disable vidix} \
576         %{__disable vstream} \
577         --enable-vm \
578 %ifarch ppc
579         --enable-wii \
580 %endif
581         %{__disable win32 win32dll} \
582         --enable-x11 \
583         %{__disable x264} \
584         --enable-xmga \
585         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
586         --enable-xv \
587         %{__disable xvid} \
588         --enable-xvmc --with-xvmclib=XvMCW \
589         %{__enable_disable zr} \
590         "$@"
591
592         %{__make} %{?with_verbose:V=1}
593 }
594
595 %if %{with gui}
596 # build GUI version
597 build --enable-gui --disable-mencoder
598 %{__mv} mplayer gmplayer
599 %{__make} distclean
600 %endif
601
602 # now build regular version
603 build --disable-gui
604
605 %if %{with doc}
606 %{__make} -j1 doc
607 %endif
608
609 %install
610 rm -rf $RPM_BUILD_ROOT
611 install -d \
612         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
613         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
614         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
615         $RPM_BUILD_ROOT%{_desktopdir}
616
617 # default config files
618 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
619
620 # executables
621 for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
622 install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
623 %if "%{binsuf}" != ""
624 ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
625 %endif
626 done
627
628 %if %{with shared}
629 install -d $RPM_BUILD_ROOT%{_libdir}
630 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
631 %endif
632
633 # fonts
634 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
635 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
636
637 %if %{with gui}
638 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
639 %endif
640 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
641 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
642 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
643
644 # man pages
645 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
646 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
647 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
648 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
649 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
650 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
651 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
652 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
653 install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
654 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
655 install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
656
657 %clean
658 rm -rf $RPM_BUILD_ROOT
659
660 %post -n gmplayer
661 umask 022
662 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
663
664 %postun -n gmplayer
665 umask 022
666 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
667
668 %files
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/mplayer*
671
672 %if %{with gui}
673 %files -n gmplayer
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/gmplayer*
676 %{_desktopdir}/gmplayer.desktop
677 %endif
678
679 %if %{with mencoder}
680 %files -n mencoder
681 %defattr(644,root,root,755)
682 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
683 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
684 %doc DOCS/tech/colorspaces.txt
685 %attr(755,root,root) %{_bindir}/mencoder*
686 %endif
687
688 %if %{with doc}
689 %files doc
690 %defattr(644,root,root,755)
691 %doc DOCS/tech
692 # HTML and XML-generated docs
693 %doc DOCS/HTML/en
694 %lang(cs) %doc DOCS/HTML/cs
695 %lang(de) %doc DOCS/HTML/de
696 %lang(es) %doc DOCS/HTML/es
697 %lang(fr) %doc DOCS/HTML/fr
698 %lang(hu) %doc DOCS/HTML/hu
699 %lang(it) %doc DOCS/HTML/it
700 %lang(pl) %doc DOCS/HTML/pl
701 %lang(ru) %doc DOCS/HTML/ru
702 %lang(zh_CN) %doc DOCS/HTML/zh_CN
703 %endif
704
705 %files common
706 %defattr(644,root,root,755)
707 %doc AUTHORS README
708 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
709 %if %{with win32}
710 %doc etc/codecs.win32.conf
711 %endif
712
713 %dir %{_sysconfdir}/%{name}
714 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
715 %{_mandir}/man1/mplayer.1*
716 %lang(cs) %{_mandir}/cs/man1/mplayer.1*
717 %lang(de) %{_mandir}/de/man1/mplayer.1*
718 %lang(es) %{_mandir}/es/man1/mplayer.1*
719 %lang(fr) %{_mandir}/fr/man1/mplayer.1*
720 %lang(hu) %{_mandir}/hu/man1/mplayer.1*
721 %lang(it) %{_mandir}/it/man1/mplayer.1*
722 %lang(pl) %{_mandir}/pl/man1/mplayer.1*
723 %lang(ru) %{_mandir}/ru/man1/mplayer.1*
724 #%lang(sv) %{_mandir}/sv/man1/mplayer.1*
725 %lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
726 %{_desktopdir}/mplayer.desktop
727 %{_pixmapsdir}/mplayer.png
728 %dir %{_datadir}/%{name}
729 %{_datadir}/%{name}/font*
730 %dir %{_datadir}/%{name}/skins
731 %ghost %{_datadir}/%{name}/skins/default
This page took 0.073137 seconds and 2 git commands to generate.