]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- up to 20170709
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 # - CPU optimization:
4 %bcond_without  altivec         # PPC altivec support
5 %bcond_without  ssse3           # SSSE3 optimizations (needs binutils >= 2.16.92)
6 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
7                                 #  in compile time (advertised by mplayer authors as working faster); in this case
8                                 #  mplayer may not work on machine other then where it was compiled
9 %bcond_without  hidden_visibility       # no gcc hidden visibility
10 %bcond_without  verbose         # disable verbose build
11 # - general features:
12 %bcond_without  bluray          # Blu-ray support
13 %bcond_without  cdio            # libcdio support
14 %bcond_without  cdparanoia      # cdparanoia support (when libcdio not enabled)
15 %bcond_without  doc             # don't build docs (slow)
16 %bcond_without  dvdnav          # dvdnav support
17 %bcond_without  system_dvdcss   # system libdvdcss library (instead of internal copy)
18 %bcond_without  system_dvdread  # system libdvdread library (instead of internal copy)
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_without  gui             # without GTK+ GUI
21 %bcond_without  joystick        # joystick support
22 %bcond_without  lirc            # lirc support
23 %bcond_without  live            # LIVE555 Streaming Media support
24 %bcond_without  mencoder        # mencoder (a/v encoder) compilation
25 %bcond_without  nemesi          # NeMeSi Streaming Media support
26 %bcond_with     on2             # patches from On2 Flix Engine for Linux
27 %bcond_without  osd             # osd menu support
28 %bcond_without  rtmp            # RTMPDump Streaming Media support
29 %bcond_with     shared          # experimental libmplayer.so support
30 %bcond_without  smb             # Samba (SMB) input support
31 %bcond_without  vstream         # TiVo vstream client support
32 # - codecs:
33 %bcond_without  amr             # Adaptive Multi Rate (AMR) speech codec support
34 %bcond_without  bs2b            # BS2B audio filter support
35 %bcond_without  crystalhd       # CrystalHD support
36 %bcond_without  faad            # FAAD2 (AAC) support
37 %bcond_without  gif             # GIF support
38 %bcond_without  ladspa          # LADSPA plugin support
39 %bcond_without  libdts          # libdts support
40 %bcond_without  libdv           # libdv en/decoding support
41 %bcond_without  lzo             # LZO support (requires lzo 2.x)
42 %bcond_without  mad             # mad (audio MPEG) support
43 %bcond_without  mpg123          # libmpg123 MP3 decoding support
44 %bcond_with     musepack        # libmpcdec support (deprecated in favour of libavcodec)
45 %bcond_without  openjpeg        # OpenJPEG (JPEG2000) input/output support
46 %bcond_without  quicktime       # binary quicktime dll support
47 %bcond_without  real            # Real* 8/9 codecs support
48 %bcond_without  vorbis          # Ogg Vorbis audio support (both tremor and libvorbis)
49 %bcond_with     tremor          # use tremor instead of libvorbis
50 %bcond_without  theora          # Ogg Theora video support
51 %bcond_without  win32           # Win32 codecs support
52 %bcond_without  x264            # x264 support
53 %bcond_with     xmms            # XMMS inputplugin support
54 %bcond_without  xvid            # XviD codec
55 %bcond_with     system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
56 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
57 # - video output:
58 %bcond_without  aalib           # aalib video output
59 %bcond_without  caca            # libcaca video output
60 %bcond_with     directfb        # DirectFB video output
61 %bcond_with     dxr2            # DXR2 (hardware MPEG decoder) video output
62 %bcond_with     dxr3            # DXR3/H+ (hardware MPEG decoder) video output
63 %bcond_with     ggi             # GGI video output
64 %bcond_without  sdl             # SDL video output
65 %bcond_with     svga            # svgalib video output
66 %bcond_without  vdpau           # VDPAU acceleration
67 %bcond_without  vidix           # VIDIX video drivers
68 %bcond_with     zr              # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
69 %bcond_with     gnomess         # controling gnome screensaver [patch not updated]
70 # - audio output:
71 %bcond_without  alsa            # ALSA audio output
72 %bcond_with     arts            # aRts audio output
73 %bcond_with     esd             # EsounD sound support
74 %bcond_without  jack            # JACKD support
75 %bcond_with     nas             # NAS audio output
76 %bcond_without  pulseaudio      # pulseaudio output
77 %bcond_without  select          # audio select() support (required e.g. for ALSA or Vortex2 driver)
78
79 %if %{with alsa}
80 %undefine       with_select
81 %endif
82 %if %{without vorbis}
83 %undefine       with_tremor
84 %endif
85
86 %ifnarch %{ix86}
87 %undefine       with_win32
88 %undefine       with_quicktime
89 %undefine       with_vidix
90 %endif
91 %ifnarch %{ix86} %{x8664} ppc ppc64
92 %undefine       with_runtime
93 %endif
94 %ifnarch %{ix86} %{x8664}
95 %undefine       with_vdpau
96 %endif
97 %ifnarch ppc
98 %undefine       with_altivec
99 %endif
100 %ifnarch i686 pentium4 athlon %{x8664}
101 %undefine       with_crystalhd
102 %endif
103
104 %if %{_lib} != "lib"
105 %define         binsuf  %(lib=%{_lib} ; echo ${lib#lib})
106 %else
107 %ifarch %{ix86} ppc sparc sparcv9 s390
108 %define         binsuf  32
109 %else
110 %define         binsuf  %{nil}
111 %endif
112 %endif
113
114 # date from directory inside of tarball (like mplayer-export-2014-04-29)
115 %define snap    2017-07-09
116 %define ssnap   %(echo %{snap} | tr -d -)
117 %define rel     1
118 Summary:        MPlayer - THE Movie Player for UN*X
119 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
120 Summary(es.UTF-8):      Otro reproductor de películas
121 Summary(ko.UTF-8):      리눅스용 미디어플레이어
122 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
123 Summary(pt_BR.UTF-8):   Reprodutor de filmes
124 Name:           mplayer
125 Version:        1.3
126 Release:        1.%{ssnap}.%{rel}
127 # DO NOT increase epoch unless it's really neccessary!
128 # especially such changes like pre7->pre7try2, increase Release instead!
129 # PS: $ rpmvercmp pre7try2 pre7
130 # pre7try2 > pre7
131 Epoch:          3
132 License:        GPL
133 Group:          Applications/Multimedia
134 # Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
135 Source0:        ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
136 # Source0-md5:  d5d7bb7176682afccd64ef855ae65e8d
137 Source1:        http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
138 # Source1-md5:  20eb6a5caa8fd874e90033b54fc39ac0
139 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
140 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
141 Source5:        g%{name}.desktop
142 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
143 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
144 Source7:        %{name}.png
145 Source8:        %{name}.desktop
146 # http://www.on2.com/gpl/mplayer/
147 Source9:        http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
148 # Source9-md5:  07774a2663a8fda07c308df0c6569b56
149
150 # build (configure / Makefile) related:
151 Patch10:        %{name}-ldflags.patch
152 Patch11:        %{name}-altivec.patch
153 Patch12:        %{name}-check-byteswap.patch
154 Patch13:        %{name}-visibility-hidden-fix.patch
155
156 Patch15:        %{name}-live555-async.patch
157
158 Patch17:        %{name}-gsm.patch
159 Patch18:        %{name}-openjpeg.patch
160 Patch19:        %{name}-shared.patch
161 Patch20:        %{name}-vstream.patch
162
163 # codecs, outputs, demuxers:
164 Patch21:        %{name}-auto-expand.patch
165 Patch22:        %{name}-release_directfb.patch
166
167 # goodies:
168 Patch30:        %{name}-cp1250-fontdesc.patch
169 Patch31:        %{name}-350.patch
170 # update, hard to fix right now because of gnome bug 579430:
171 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
172 #Patch32:       %{name}-gnome-screensaver.patch
173
174 Patch100:       %{name}-on2flix.patch
175 Patch101:       %{name}-link.patch
176
177 URL:            http://www.mplayerhq.hu/
178 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
179 BuildRequires:  EGL-devel
180 BuildRequires:  OpenAL-devel
181 BuildRequires:  OpenGL-GLX-devel
182 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
183 # checked, but seems actually not used
184 #%{?with_sdl:BuildRequires:     SDL_image-devel}
185 BuildRequires:  a52dec-libs-devel
186 %{?with_aalib:BuildRequires:    aalib-devel}
187 %{?with_alsa:BuildRequires:     alsa-lib-devel}
188 %{?with_arts:BuildRequires:     artsc-devel}
189 BuildRequires:  binutils >= 2.10.1
190 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
191 BuildRequires:  bzip2-devel
192 #%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
193 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
194 BuildRequires:  dirac-devel
195 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
196 %{?with_doc:BuildRequires:      docbook-style-xsl}
197 %{?with_dxr2:BuildRequires:     dxr2-driver-devel}
198 %{?with_dxr3:BuildRequires:     em8300-devel}
199 %{?with_enca:BuildRequires:     enca-devel}
200 %{?with_esd:BuildRequires:      esound-devel}
201 BuildRequires:  faac-devel
202 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
203 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
204 BuildRequires:  fontconfig-devel >= 1:2.4.2
205 BuildRequires:  freetype-devel >= 1:2.2.1
206 BuildRequires:  fribidi-devel
207 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
208 %{?with_gif:BuildRequires:      giflib-devel}
209 %{?with_gui:BuildRequires:      glib2-devel >= 1:2.6.0}
210 BuildRequires:  gnutls-devel
211 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
212 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
213 %{?with_ladspa:BuildRequires:   ladspa-devel}
214 BuildRequires:  lame-libs-devel
215 BuildRequires:  libass-devel >= 0.9.10
216 %{?with_bluray:BuildRequires:   libbluray-devel}
217 %{?with_bs2b:BuildRequires:     libbs2b-devel >= 3.0.0}
218 %{?with_caca:BuildRequires:     libcaca-devel}
219 %{?with_cdio:BuildRequires:     libcdio-paranoia-devel}
220 %{?with_crystalhd:BuildRequires:        libcrystalhd-devel}
221 %{?with_libdts:BuildRequires:   libdts-devel}
222 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
223 #%{?with_system_dvdcss:BuildRequires:   libdvdcss-devel}
224 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
225 %{?with_system_dvdread:BuildRequires:   libdvdread-devel >= 4.1}
226 %{?with_ggi:BuildRequires:      libggi-devel}
227 %{?with_ggi:BuildRequires:      libggiwmh-devel}
228 BuildRequires:  libgsm-devel
229 BuildRequires:  libjpeg-devel
230 %{?with_mad:BuildRequires:      libmad-devel}
231 BuildRequires:  libmng-devel
232 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
233 %{?with_system_libmpeg2:BuildRequires:  libmpeg2-devel}
234 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
235 %{?with_nemesi:BuildRequires:   libnemesi-devel >= 0.6.3}
236 BuildRequires:  libnut-devel
237 BuildRequires:  libpng-devel
238 %{?with_rtmp:BuildRequires:     librtmp-devel}
239 %{?with_smb:BuildRequires:      libsmbclient-devel}
240 %{?with_theora:BuildRequires:   libtheora-devel}
241 %{?with_vdpau:BuildRequires:    libvdpau-devel}
242 %if %{with vorbis} && %{without tremor}
243 BuildRequires:  libvorbis-devel
244 %endif
245 BuildRequires:  libvpx-devel
246 # build >= 118
247 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
248 BuildRequires:  libxslt-progs
249 # with v4l2 headers
250 BuildRequires:  linux-libc-headers >= 7:2.6.22
251 %{?with_lirc:BuildRequires:     lirc-devel}
252 %{?with_live:BuildRequires:     live-devel >= 2:2011.01.10}
253 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
254 %{?with_nas:BuildRequires:      nas-devel}
255 BuildRequires:  ncurses-devel
256 %{?with_amr:BuildRequires:      opencore-amr-devel}
257 %{?with_openjpeg:BuildRequires: openjpeg-devel}
258 BuildRequires:  opus-devel
259 BuildRequires:  pkgconfig
260 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
261 BuildRequires:  rpm >= 4.4.9-56
262 BuildRequires:  rpmbuild(macros) >= 1.527
263 BuildRequires:  schroedinger-devel
264 BuildRequires:  speex-devel >= 1.1
265 %{?with_svga:BuildRequires:     svgalib-devel}
266 BuildRequires:  tar >= 1:1.22
267 %{?with_tremor:BuildRequires:   tremor-devel}
268 BuildRequires:  twolame-devel
269 %{?with_vidix:BuildRequires:    vidix-devel}
270 %{?with_vstream:BuildRequires:  vstream-client-devel}
271 BuildRequires:  webrtc-libilbc-devel
272 %{?with_xmms:BuildRequires:     xmms-devel}
273 BuildRequires:  xorg-lib-libX11-devel
274 BuildRequires:  xorg-lib-libXScrnSaver-devel
275 BuildRequires:  xorg-lib-libXext-devel
276 BuildRequires:  xorg-lib-libXinerama-devel
277 BuildRequires:  xorg-lib-libXv-devel
278 BuildRequires:  xorg-lib-libXvMC-devel
279 BuildRequires:  xorg-lib-libXxf86dga-devel
280 BuildRequires:  xorg-lib-libXxf86vm-devel
281 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
282 BuildRequires:  xz
283 %ifarch %{ix86} %{x8664}
284 BuildRequires:  yasm
285 %endif
286 BuildRequires:  zlib-devel
287 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
288 Requires:       OpenGL
289 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
290
291 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
292 %define         specflags_ia32  -fomit-frame-pointer
293 %if %{with altivec}
294 %define         specflags_ppc   -maltivec
295 %endif
296
297 %description
298 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
299 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
300 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
301 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
302 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
303 optionally with SHM extension, X11 using overlays with the Xvideo
304 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
305 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
306
307 If you want to use win32 codecs install w32codec package.
308
309 %description -l de.UTF-8
310 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
311 Kennzeichnend ist die herausragende Format- und
312 Plattform-Kompatibilität.
313
314 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
315 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
316 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
317 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
318 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
319 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
320 installierte Codecs nicht mit MPlayer kollidieren können.
321
322 %description -l es.UTF-8
323 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
324 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
325 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
326 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
327 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
328 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
329 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
330 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
331 v1.1.7 etc.
332
333 Si quiere usar codecs Win32, instale el paquete w32codec.
334
335 %description -l ko.UTF-8
336 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
337 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
338 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
339 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
340 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
341 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
342 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
343 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
344 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
345
346 %description -l pl.UTF-8
347 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
348 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
349 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
350 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
351 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
352 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
353 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
354
355 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
356
357 %description -l pt_BR.UTF-8
358 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
359 áudio. Diferentes mecanismos de reprodução podem também ser
360 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
361
362 %package -n gmplayer
363 Summary:        MPlayer with GTK+ GUI interface
364 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
365 Group:          X11/Applications/Multimedia
366 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
367 Requires:       %{name}-skin
368
369 %description -n gmplayer
370 MPlayer with GUI GTK+ interface.
371
372 %description -n gmplayer -l pl.UTF-8
373 MPlayer z graficznym interfejsem GTK+.
374
375 %package common
376 Summary:        Configuration files and documentation for MPlayer
377 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
378 Group:          Applications/Multimedia
379 Suggests:       unrar
380 Obsoletes:      mplayer-vidix
381
382 %description common
383 Configuration files, man page and HTML documentation for MPlayer.
384
385 %description common -l pl.UTF-8
386 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
387
388 %package doc
389 Summary:        HTML documentation for MPlayer
390 Summary(pl.UTF-8):      Dokumentacja do MPlayera w formacie HTML
391 Group:          Documentation
392
393 %description doc
394 HTML Documentation for MPlayer.
395
396 %description doc -l pl.UTF-8
397 Dokumentacja do MPlayera w formacie HTML.
398
399 %package -n mencoder
400 Summary:        MEncoder - a movie encoder for Linux
401 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
402 Group:          Applications/Multimedia
403 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
404
405 %description -n mencoder
406 MEncoder is a movie encoder for Linux and is a part of the MPlayer
407 package.
408
409 %description -n mencoder -l pl.UTF-8
410 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
411
412 %prep
413 %setup -q -n %{name}-export-%{snap} -a1 -a3 -a6 -a9
414 cp -f etc/codecs.conf etc/codecs.win32.conf
415
416 # build (configure / Makefile) related:
417 %patch10 -p1
418 %patch11 -p1
419 %patch12 -p1
420 %patch13 -p1
421
422 %patch15 -p1
423
424 %patch17 -p1
425 %patch18 -p1
426 %{?with_shared:%patch19 -p1}
427 %patch20 -p1
428
429 # codecs, outputs, demuxers:
430 %patch21 -p1
431 %patch22 -p1
432
433 # goodies:
434 %patch30 -p0
435 %patch31 -p1
436 #%{with_gnomess:%patch32 -p1}
437
438 # on2flix
439 mv mencoder-on2flixenglinux{-*-*-*,}
440 %if %{with on2}
441 #%%patch100 -p1
442 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
443 # remove broken patches:
444 # - first set does not apply
445 # - second set beakes build
446 for PATCH in    asf-correct_movielength avi_check_idxflags \
447                 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
448                 mencoder_07_demux_update_pts mencoder_10_correct_pts \
449                 mpegvideo-revert_r18381 \
450                 \
451                 reduce_spurious_logging
452 do
453         rm mencoder-on2flixenglinux/patch/$PATCH.diff
454 done
455 for a in mencoder-on2flixenglinux/patch/*.diff; do
456         patch -p0 < $a
457 done
458 %endif
459
460 %patch101 -p1
461
462 cat etc/example.conf > etc/mplayer.conf
463 cat <<'CONFIGADD' >> etc/mplayer.conf
464
465 ######################
466 # PLD Linux Defaults #
467 ######################
468 [default]
469
470 # alternate solution for CP1250-encoded subtitles
471 fontconfig = yes
472 subcp = cp1250
473
474 # ...or if you prefer native bitmap fonts shipped with mplayer
475 #fontconfig = no
476 #subcp = iso-8859-1
477
478 # Standard location
479 unrarexec = "%{_bindir}/unrar"
480
481 # Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
482 joystick=no
483
484 CONFIGADD
485
486 %if %{with system_ffmpeg}
487 # using external ffmpeg, but mplayer adds these to includepath
488 %{__rm} -rf ffmpeg
489 %endif
490
491 %build
492 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
493 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
494
495 # NOTE:
496 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
497 # - toolame is obsolete predecessor of twolame
498 # - libcdio-paranoia is preferred over cdparanoia-III libs
499 build() {
500         set -x
501
502         ./configure \
503         %{?debug:--enable-debug=3} \
504         --prefix=%{_prefix} \
505         --codecsdir=%{_libdir}/codecs \
506         --confdir=%{_sysconfdir}/mplayer \
507         --cc="%{__cc}" \
508         --extra-cflags="$CFLAGS" \
509         --real-ldflags="%{rpmldflags}" \
510         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
511         --language=all \
512 %if %{with system_ffmpeg}
513         --disable-ffmpeg_a \
514 %endif
515 %ifnarch %{ix86} %{x8664}
516         --disable-3dnow \
517         --disable-3dnowext \
518         --disable-fastmemcpy \
519         --disable-mmx \
520         --disable-mmxext \
521         --disable-sse \
522         --disable-sse2 \
523 %endif
524         %{__disable ssse3} \
525 %ifarch ppc
526         %{__disable altivec} \
527 %endif
528         %{__disable aalib aa} \
529         %{__enable_disable alsa} \
530         %{__disable arts} \
531         %{__disable bluray} \
532         %{__disable caca} \
533         %{__disable cdparanoia} \
534         --enable-dga1 \
535         --enable-dga2 \
536         %{__enable_disable directfb} \
537         %{__enable_disable dvdnav} \
538         %{__disable system_dvdread dvdread-internal} \
539         %{__disable dxr2} \
540         %{__disable dxr3} \
541         --enable-dynamic-plugins \
542         %{__disable enca} \
543         %{__disable esd} \
544         %{__disable faad} \
545         --enable-fbdev \
546         %{__disable gif} \
547         --enable-gl \
548         %{__disable ggi} \
549         %{__disable jack} \
550         %{__enable joystick} \
551         %{__disable cdio libcdio} \
552         %{__disable ladspa} \
553         %{__disable bs2b libbs2b} \
554         %{__disable libdts libdca} \
555         %{__disable libdv} \
556         %{__disable system_dvdcss libdvdcss-internal} \
557         %{__disable lzo liblzo} \
558         %{__disable system_libmpeg2 libmpeg2-internal} \
559         %{__disable nemesi} \
560         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
561         %{__disable openjpeg} \
562         %{__disable rtmp librtmp} \
563         %{__disable vorbis libvorbis} \
564         %{__enable_disable lirc} \
565         --disable-lircc \
566         %{__disable live} \
567         %{__disable mad} \
568         %{__disable mencoder} \
569         %{__enable osd menu} \
570         --enable-mga \
571         %{__disable mpg123} \
572         %{__enable musepack} \
573         %{__disable nas} \
574         %{__disable pulseaudio pulse} \
575         %{__disable quicktime qtx} \
576         --enable-radio \
577         --enable-radio-capture \
578         %{__disable real} \
579         %{__enable_disable runtime runtime-cpudetection} \
580         %{__enable_disable sdl} \
581         %{__disable select} \
582         --enable-s3fb \
583         %{__disable smb} \
584         %{__disable svga} \
585         --enable-tdfxfb \
586         --enable-tdfxvid \
587         %{__disable theora} \
588         --disable-toolame \
589         %{!?with_tremor:--disable-tremor} \
590         --enable-unrarexec \
591         %{__disable vdpau} \
592         %{__disable vidix} \
593         %{__disable vstream} \
594         --enable-vm \
595 %ifarch ppc
596         --enable-wii \
597 %endif
598         %{__disable win32 win32dll} \
599         --enable-x11 \
600         %{__disable x264} \
601         --enable-xmga \
602         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
603         --enable-xv \
604         %{__disable xvid} \
605         --enable-xvmc --with-xvmclib=XvMCW \
606         %{__enable_disable zr} \
607         "$@"
608
609         %{__make} %{?with_verbose:V=1}
610 }
611
612 %if %{with gui}
613 # build GUI version
614 build --enable-gui --disable-mencoder
615 mv -f mplayer gmplayer
616 %{__make} distclean
617 %endif
618
619 # now build regular version
620 build --disable-gui
621
622 %if %{with doc}
623 %{__make} -j1 doc
624 %endif
625
626 %install
627 rm -rf $RPM_BUILD_ROOT
628 install -d \
629         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
630         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
631         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
632         $RPM_BUILD_ROOT%{_desktopdir}
633
634 # default config files
635 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
636
637 # executables
638 for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
639 install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
640 %if "%{binsuf}" != ""
641 ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
642 %endif
643 done
644
645 %if %{with shared}
646 install -d $RPM_BUILD_ROOT%{_libdir}
647 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
648 %endif
649
650 # fonts
651 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
652 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
653
654 %if %{with gui}
655 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
656 %endif
657 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
658 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
659 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
660
661 # man pages
662 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
663 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
664 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
665 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
666 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
667 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
668 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
669 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
670 install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
671 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
672 install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
673
674 %clean
675 rm -rf $RPM_BUILD_ROOT
676
677 %post -n gmplayer
678 umask 022
679 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
680
681 %postun -n gmplayer
682 umask 022
683 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
684
685 %files
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_bindir}/mplayer*
688
689 %if %{with gui}
690 %files -n gmplayer
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_bindir}/gmplayer*
693 %{_desktopdir}/gmplayer.desktop
694 %endif
695
696 %if %{with mencoder}
697 %files -n mencoder
698 %defattr(644,root,root,755)
699 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
700 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
701 %doc DOCS/tech/colorspaces.txt
702 %attr(755,root,root) %{_bindir}/mencoder*
703 %endif
704
705 %if %{with doc}
706 %files doc
707 %defattr(644,root,root,755)
708 %doc DOCS/tech
709 # HTML and XML-generated docs
710 %doc DOCS/HTML/en
711 %lang(cs) %doc DOCS/HTML/cs
712 %lang(de) %doc DOCS/HTML/de
713 %lang(es) %doc DOCS/HTML/es
714 %lang(fr) %doc DOCS/HTML/fr
715 %lang(hu) %doc DOCS/HTML/hu
716 %lang(pl) %doc DOCS/HTML/pl
717 %lang(ru) %doc DOCS/HTML/ru
718 #%lang(zh_CN) %doc DOCS/zh
719 %endif
720
721 %files common
722 %defattr(644,root,root,755)
723 %doc AUTHORS README
724 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
725 %if %{with win32}
726 %doc etc/codecs.win32.conf
727 %endif
728
729 %dir %{_sysconfdir}/%{name}
730 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
731 %{_mandir}/man1/mplayer.1*
732 %lang(cs) %{_mandir}/cs/man1/mplayer.1*
733 %lang(de) %{_mandir}/de/man1/mplayer.1*
734 %lang(es) %{_mandir}/es/man1/mplayer.1*
735 %lang(fr) %{_mandir}/fr/man1/mplayer.1*
736 %lang(hu) %{_mandir}/hu/man1/mplayer.1*
737 %lang(it) %{_mandir}/it/man1/mplayer.1*
738 %lang(pl) %{_mandir}/pl/man1/mplayer.1*
739 %lang(ru) %{_mandir}/ru/man1/mplayer.1*
740 #%lang(sv) %{_mandir}/sv/man1/mplayer.1*
741 %lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
742 %{_desktopdir}/mplayer.desktop
743 %{_pixmapsdir}/mplayer.png
744 %dir %{_datadir}/%{name}
745 %{_datadir}/%{name}/font*
746 %dir %{_datadir}/%{name}/skins
747 %ghost %{_datadir}/%{name}/skins/default
This page took 0.204214 seconds and 3 git commands to generate.