]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- up to 20141203 snap
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 # - CPU optimization:
4 %bcond_without  altivec         # PPC altivec support
5 %bcond_without  ssse3           # SSSE3 optimizations (needs binutils >= 2.16.92)
6 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
7                                 #  in compile time (advertised by mplayer authors as working faster); in this case
8                                 #  mplayer may not work on machine other then where it was compiled
9 %bcond_without  hidden_visibility       # no gcc hidden visibility
10 %bcond_without  verbose         # disable verbose build
11 # - general features:
12 %bcond_without  bluray          # Blu-ray support
13 %bcond_without  cdio            # libcdio support
14 %bcond_without  cdparanoia      # cdparanoia support (when libcdio not enabled)
15 %bcond_without  doc             # don't build docs (slow)
16 %bcond_without  dvdnav          # dvdnav support
17 %bcond_without  system_dvdcss   # system libdvdcss library (instead of internal copy)
18 %bcond_without  system_dvdread  # system libdvdread library (instead of internal copy)
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_without  gui             # without GTK+ GUI
21 %bcond_without  joystick        # joystick support
22 %bcond_without  lirc            # lirc support
23 %bcond_without  live            # LIVE555 Streaming Media support
24 %bcond_without  mencoder        # mencoder (a/v encoder) compilation
25 %bcond_without  nemesi          # NeMeSi Streaming Media support
26 %bcond_with     on2             # patches from On2 Flix Engine for Linux
27 %bcond_without  osd             # osd menu support
28 %bcond_without  rtmp            # RTMPDump Streaming Media support
29 %bcond_with     shared          # experimental libmplayer.so support
30 %bcond_without  smb             # Samba (SMB) input support
31 %bcond_without  vstream         # TiVo vstream client support
32 # - codecs:
33 %bcond_without  amr             # Adaptive Multi Rate (AMR) speech codec support
34 %bcond_without  bs2b            # BS2B audio filter support
35 %bcond_without  crystalhd       # CrystalHD support
36 %bcond_without  faad            # FAAD2 (AAC) support
37 %bcond_without  gif             # GIF support
38 %bcond_without  ladspa          # LADSPA plugin support
39 %bcond_without  libdts          # libdts support
40 %bcond_without  libdv           # libdv en/decoding support
41 %bcond_without  lzo             # LZO support (requires lzo 2.x)
42 %bcond_without  mad             # mad (audio MPEG) support
43 %bcond_without  mpg123          # libmpg123 MP3 decoding support
44 %bcond_with     musepack        # libmpcdec support (derecated in favour of libavcodec)
45 %bcond_without  openjpeg        # OpenJPEG (JPEG2000) input/output support
46 %bcond_without  quicktime       # binary quicktime dll support
47 %bcond_without  real            # Real* 8/9 codecs support
48 %bcond_without  vorbis          # Ogg Vorbis audio support (both tremor and libvorbis)
49 %bcond_with     system_vorbis   # use system libvorbis instead of internal tremor
50 %bcond_without  theora          # Ogg Theora video support
51 %bcond_without  win32           # Win32 codecs support
52 %bcond_without  x264            # x264 support
53 %bcond_with     xmms            # XMMS inputplugin support
54 %bcond_without  xvid            # XviD codec
55 %bcond_with     system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
56 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
57 # - video output:
58 %bcond_without  aalib           # aalib video output
59 %bcond_without  caca            # libcaca video output
60 %bcond_with     directfb        # DirectFB video output
61 %bcond_with     dxr2            # DXR2 (hardware MPEG decoder) video output
62 %bcond_with     dxr3            # DXR3/H+ (hardware MPEG decoder) video output
63 %bcond_with     ggi             # GGI video output
64 %bcond_without  sdl             # SDL video output
65 %bcond_with     svga            # svgalib video output
66 %bcond_without  vdpau           # VDPAU acceleration
67 %bcond_without  vidix           # VIDIX video drivers
68 %bcond_with     zr              # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
69 %bcond_with     gnomess         # controling gnome screensaver [patch not updated]
70 # - audio output:
71 %bcond_without  alsa            # ALSA audio output
72 %bcond_with     arts            # aRts audio output
73 %bcond_with     esd             # EsounD sound support
74 %bcond_without  jack            # JACKD support
75 %bcond_with     nas             # NAS audio output
76 %bcond_without  pulseaudio      # pulseaudio output
77 %bcond_without  select          # audio select() support (required e.g. for ALSA or Vortex2 driver)
78
79 %if %{with alsa}
80 %undefine       with_select
81 %endif
82 %if %{without vorbis}
83 %undefine       with_system_vorbis
84 %endif
85
86 %ifnarch %{ix86}
87 %undefine       with_win32
88 %undefine       with_quicktime
89 %undefine       with_vidix
90 %endif
91 %ifnarch %{ix86} %{x8664} ppc ppc64
92 %undefine       with_runtime
93 %endif
94 %ifnarch %{ix86} %{x8664}
95 %undefine       with_vdpau
96 %endif
97 %ifnarch ppc
98 %undefine       with_altivec
99 %endif
100 %ifnarch i686 pentium4 athlon %{x8664}
101 %undefine       with_crystalhd
102 %endif
103
104 %if %{_lib} == "lib64"
105 %define         binsuf  64
106 %else
107 %define         binsuf  32
108 %endif
109
110 # date from directory inside of tarball (like mplayer-export-2014-04-29)
111 %define snap    2014-12-03
112 %define ssnap   %(echo %{snap} | tr -d -)
113 %define rel     3
114 Summary:        MPlayer - THE Movie Player for UN*X
115 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
116 Summary(es.UTF-8):      Otro reproductor de películas
117 Summary(ko.UTF-8):      리눅스용 미디어플레이어
118 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
119 Summary(pt_BR.UTF-8):   Reprodutor de filmes
120 Name:           mplayer
121 Version:        1.1.1
122 Release:        6.%{ssnap}.%{rel}
123 # DO NOT increase epoch unless it's really neccessary!
124 # especially such changes like pre7->pre7try2, increase Release instead!
125 # PS: $ rpmvercmp pre7try2 pre7
126 # pre7try2 > pre7
127 Epoch:          3
128 License:        GPL
129 Group:          Applications/Multimedia
130 # Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
131 Source0:        ftp://ftp.mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
132 # Source0-md5:  2f37d5e386a7ce98fec54636602e7a58
133 Source1:        http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
134 # Source1-md5:  25e00ca99eda7bb54546ce7c10b78464
135 Source3:        ftp://ftp1.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
136 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
137 Source5:        g%{name}.desktop
138 Source6:        ftp://ftp2.mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
139 # Source6-md5:  1ecd31d17b51f16332b1fcc7da36b312
140 Source7:        %{name}.png
141 Source8:        %{name}.desktop
142 # http://www.on2.com/gpl/mplayer/
143 Source9:        http://support.on2.com/gpl/mplayer/2009-10-08-mencoder-on2flixenglinux.tar.bz2
144 # Source9-md5:  07774a2663a8fda07c308df0c6569b56
145
146 # build (configure / Makefile) related:
147 Patch10:        %{name}-ldflags.patch
148 Patch11:        %{name}-altivec.patch
149 Patch12:        %{name}-check-byteswap.patch
150 Patch13:        %{name}-visibility-hidden-fix.patch
151
152 Patch15:        %{name}-live555-async.patch
153 Patch16:        %{name}-libcdio.patch
154 Patch17:        %{name}-gsm.patch
155 Patch18:        %{name}-openjpeg.patch
156 Patch19:        %{name}-shared.patch
157 Patch20:        %{name}-vstream.patch
158 Patch23:        vstream-format-security.patch
159
160 # codecs, outputs, demuxers:
161 Patch21:        %{name}-auto-expand.patch
162 Patch22:        %{name}-release_directfb.patch
163
164 # goodies:
165 Patch30:        %{name}-cp1250-fontdesc.patch
166 Patch31:        %{name}-350.patch
167 # update, hard to fix right now because of gnome bug 579430:
168 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
169 #Patch32:       %{name}-gnome-screensaver.patch
170
171 Patch100:       %{name}-on2flix.patch
172 Patch101:       %{name}-link.patch
173
174 URL:            http://www.mplayerhq.hu/
175 %{?with_directfb:BuildRequires: DirectFB-devel}
176 BuildRequires:  OpenAL-devel
177 BuildRequires:  OpenGL-devel
178 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
179 BuildRequires:  a52dec-libs-devel
180 %{?with_aalib:BuildRequires:    aalib-devel}
181 %{?with_alsa:BuildRequires:     alsa-lib-devel}
182 %{?with_arts:BuildRequires:     artsc-devel}
183 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
184 BuildRequires:  bzip2-devel
185 #%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
186 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
187 BuildRequires:  dirac-devel
188 %{?with_doc:BuildRequires:      docbook-dtd412-xml}
189 %{?with_doc:BuildRequires:      docbook-style-xsl}
190 %{?with_dxr2:BuildRequires:     dxr2-driver-devel}
191 %{?with_dxr3:BuildRequires:     em8300-devel}
192 %{?with_enca:BuildRequires:     enca-devel}
193 %{?with_esd:BuildRequires:      esound-devel}
194 BuildRequires:  faac-devel
195 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
196 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 0.4.9-4.20081024.3}
197 BuildRequires:  fontconfig-devel >= 1:2.4.2
198 BuildRequires:  freetype-devel >= 1:2.2.1
199 BuildRequires:  fribidi-devel
200 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
201 %{?with_gif:BuildRequires:      giflib-devel}
202 %{?with_gui:BuildRequires:      gtk+2-devel}
203 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
204 %{?with_ladspa:BuildRequires:   ladspa-devel}
205 BuildRequires:  lame-libs-devel
206 BuildRequires:  libass-devel >= 0.9.10
207 %{?with_bluray:BuildRequires:   libbluray-devel}
208 %{?with_bs2b:BuildRequires:     libbs2b-devel >= 3.0.0}
209 %{?with_caca:BuildRequires:     libcaca-devel}
210 %{?with_cdio:BuildRequires:     libcdio-paranoia-devel}
211 %{?with_crystalhd:BuildRequires:        libcrystalhd-devel}
212 %{?with_libdts:BuildRequires:   libdts-devel}
213 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
214 #%{?with_system_dvdcss:BuildRequires:   libdvdcss-devel}
215 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
216 %{?with_system_dvdread:BuildRequires:   libdvdread-devel >= 4.1}
217 %{?with_ggi:BuildRequires:      libggi-devel}
218 %{?with_ggi:BuildRequires:      libggiwmh-devel}
219 BuildRequires:  libgsm-devel
220 BuildRequires:  libjpeg-devel
221 %{?with_mad:BuildRequires:      libmad-devel}
222 BuildRequires:  libmng-devel
223 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
224 %{?with_system_libmpeg2:BuildRequires:  libmpeg2-devel}
225 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
226 %{?with_nemesi:BuildRequires:   libnemesi-devel >= 0.6.3}
227 BuildRequires:  libnut-devel
228 BuildRequires:  libpng-devel
229 %{?with_rtmp:BuildRequires:     librtmp-devel}
230 %{?with_smb:BuildRequires:      libsmbclient-devel}
231 %{?with_theora:BuildRequires:   libtheora-devel}
232 %{?with_vdpau:BuildRequires:    libvdpau-devel}
233 %{?with_system_vorbis:BuildRequires:    libvorbis-devel}
234 BuildRequires:  libvpx-devel
235 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
236 BuildRequires:  libxslt-progs
237 %{?with_lirc:BuildRequires:     lirc-devel}
238 %{?with_live:BuildRequires:     live-devel >= 2:2011.01.10}
239 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
240 %{?with_nas:BuildRequires:      nas-devel}
241 BuildRequires:  ncurses-devel
242 %{?with_amr:BuildRequires:      opencore-amr-devel}
243 %{?with_openjpeg:BuildRequires: openjpeg-devel}
244 BuildRequires:  pkgconfig
245 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
246 BuildRequires:  rpm >= 4.4.9-56
247 BuildRequires:  rpmbuild(macros) >= 1.527
248 BuildRequires:  schroedinger-devel
249 BuildRequires:  speex-devel >= 1.1
250 %{?with_svga:BuildRequires:     svgalib-devel}
251 BuildRequires:  tar >= 1:1.22
252 BuildRequires:  twolame-devel
253 %{?with_vidix:BuildRequires:    vidix-devel}
254 %{?with_vstream:BuildRequires:  vstream-client-devel}
255 %{?with_xmms:BuildRequires:     xmms-devel}
256 BuildRequires:  xorg-lib-libX11-devel
257 BuildRequires:  xorg-lib-libXScrnSaver-devel
258 BuildRequires:  xorg-lib-libXext-devel
259 BuildRequires:  xorg-lib-libXinerama-devel
260 BuildRequires:  xorg-lib-libXv-devel
261 BuildRequires:  xorg-lib-libXvMC-devel
262 BuildRequires:  xorg-lib-libXxf86dga-devel
263 BuildRequires:  xorg-lib-libXxf86vm-devel
264 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
265 BuildRequires:  xz
266 %ifarch %{ix86} %{x8664}
267 BuildRequires:  yasm
268 %endif
269 BuildRequires:  zlib-devel
270 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
271 Requires:       OpenGL
272 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
273
274 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
275 %define         specflags_ia32  -fomit-frame-pointer
276 %if %{with altivec}
277 %define         specflags_ppc   -maltivec
278 %endif
279
280 %description
281 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
282 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
283 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
284 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
285 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
286 optionally with SHM extension, X11 using overlays with the Xvideo
287 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
288 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
289
290 If you want to use win32 codecs install w32codec package.
291
292 %description -l de.UTF-8
293 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
294 Kennzeichnend ist die herausragende Format- und
295 Plattform-Kompatibilität.
296
297 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
298 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
299 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
300 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
301 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
302 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
303 installierte Codecs nicht mit MPlayer kollidieren können.
304
305 %description -l es.UTF-8
306 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
307 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
308 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
309 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
310 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
311 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
312 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
313 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
314 v1.1.7 etc.
315
316 Si quiere usar codecs Win32, instale el paquete w32codec.
317
318 %description -l ko.UTF-8
319 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
320 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
321 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
322 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
323 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
324 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
325 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
326 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
327 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
328
329 %description -l pl.UTF-8
330 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
331 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
332 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
333 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
334 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
335 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
336 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
337
338 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
339
340 %description -l pt_BR.UTF-8
341 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
342 áudio. Diferentes mecanismos de reprodução podem também ser
343 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
344
345 %package -n gmplayer
346 Summary:        MPlayer with GTK+ GUI interface
347 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
348 Group:          X11/Applications/Multimedia
349 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
350 Requires:       %{name}-skin
351
352 %description -n gmplayer
353 MPlayer with GUI GTK+ interface.
354
355 %description -n gmplayer -l pl.UTF-8
356 MPlayer z graficznym interfejsem GTK+.
357
358 %package common
359 Summary:        Configuration files and documentation for MPlayer
360 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
361 Group:          Applications/Multimedia
362 Suggests:       unrar
363 Obsoletes:      mplayer-vidix
364
365 %description common
366 Configuration files, man page and HTML documentation for MPlayer.
367
368 %description common -l pl.UTF-8
369 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
370
371 %package doc
372 Summary:        HTML documentation for MPlayer
373 Summary(pl.UTF-8):      Dokumentacja do MPlayera w formacie HTML
374 Group:          Documentation
375
376 %description doc
377 HTML Documentation for MPlayer.
378
379 %description doc -l pl.UTF-8
380 Dokumentacja do MPlayera w formacie HTML.
381
382 %package -n mencoder
383 Summary:        MEncoder - a movie encoder for Linux
384 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
385 Group:          Applications/Multimedia
386 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
387
388 %description -n mencoder
389 MEncoder is a movie encoder for Linux and is a part of the MPlayer
390 package.
391
392 %description -n mencoder -l pl.UTF-8
393 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
394
395 %prep
396 %setup -q -n %{name}-export-%{snap} -a1 -a3 -a6 -a9
397 cp -f etc/codecs.conf etc/codecs.win32.conf
398
399 # build (configure / Makefile) related:
400 %patch10 -p1
401 %patch11 -p1
402 %patch12 -p1
403 %patch13 -p1
404
405 %patch15 -p1
406 %patch16 -p1
407 %patch17 -p1
408 %patch18 -p1
409 %{?with_shared:%patch19 -p1}
410 %patch20 -p1
411 %patch23 -p0
412
413 # codecs, outputs, demuxers:
414 %patch21 -p1
415 %patch22 -p1
416
417 # goodies:
418 %patch30 -p0
419 %patch31 -p1
420 #%{with_gnomess:%patch32 -p1}
421
422 # on2flix
423 mv mencoder-on2flixenglinux{-*-*-*,}
424 %if %{with on2}
425 #%%patch100 -p1
426 cp -a mencoder-on2flixenglinux/patch/new_files/libmpdemux/* libmpdemux
427 # remove broken patches:
428 # - first set does not apply
429 # - second set beakes build
430 for PATCH in    asf-correct_movielength avi_check_idxflags \
431                 demux_lavf-add_dv_mts_preferred demux_lavf-probe_small_files \
432                 mencoder_07_demux_update_pts mencoder_10_correct_pts \
433                 mpegvideo-revert_r18381 \
434                 \
435                 reduce_spurious_logging
436 do
437         rm mencoder-on2flixenglinux/patch/$PATCH.diff
438 done
439 for a in mencoder-on2flixenglinux/patch/*.diff; do
440         patch -p0 < $a
441 done
442 %endif
443
444 %patch101 -p1
445
446 cat etc/example.conf > etc/mplayer.conf
447 cat <<'CONFIGADD' >> etc/mplayer.conf
448
449 ######################
450 # PLD Linux Defaults #
451 ######################
452 [default]
453
454 # alternate solution for CP1250-encoded subtitles
455 fontconfig = yes
456 subcp = cp1250
457
458 # ...or if you prefer native bitmap fonts shipped with mplayer
459 #fontconfig = no
460 #subcp = iso-8859-1
461
462 # Standard location
463 unrarexec = "%{_bindir}/unrar"
464
465 # Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
466 joystick=no
467
468 CONFIGADD
469
470 %if %{with system_ffmpeg}
471 # using external ffmpeg, but mplayer adds these to includepath
472 %{__rm} -rf ffmpeg
473 %endif
474
475 %build
476 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
477 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb::%{_includedir}/directfb} -DHAVE_GSM_H=1"
478
479 # NOTE:
480 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
481 # - toolame is obsolete predecessor of twolame
482 build() {
483         set -x
484
485         ./configure \
486         %{?debug:--enable-debug=3} \
487         --prefix=%{_prefix} \
488         --codecsdir=%{_libdir}/codecs \
489         --confdir=%{_sysconfdir}/mplayer \
490         --cc="%{__cc}" \
491         --extra-cflags="$CFLAGS" \
492         --real-ldflags="%{rpmldflags}" \
493         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
494         --language=all \
495 %if %{with system_ffmpeg}
496         --disable-ffmpeg_a \
497 %endif
498 %ifnarch %{ix86} %{x8664}
499         --disable-3dnow \
500         --disable-3dnowext \
501         --disable-fastmemcpy \
502         --disable-mmx \
503         --disable-mmxext \
504         --disable-sse \
505         --disable-sse2 \
506 %endif
507         %{__disable ssse3} \
508 %ifarch ppc
509         %{__disable altivec} \
510 %endif
511         %{__disable aalib aa} \
512         %{__enable_disable alsa} \
513         %{__disable arts} \
514         %{__disable bluray} \
515         %{__disable caca} \
516         %{__disable cdparanoia} \
517         --enable-dga1 \
518         --enable-dga2 \
519         %{__enable_disable directfb} \
520         %{__enable_disable dvdnav} \
521         %{__disable system_dvdread dvdread-internal} \
522         %{__disable dxr2} \
523         %{__disable dxr3} \
524         --enable-dynamic-plugins \
525         %{__disable enca} \
526         %{__disable esd} \
527         %{__disable faad} \
528         --enable-fbdev \
529         %{__disable gif} \
530         --enable-gl \
531         %{__disable ggi} \
532         %{__disable jack} \
533         %{__enable joystick} \
534         %{__disable cdio libcdio} \
535         %{__disable ladspa} \
536         %{__disable bs2b libbs2b} \
537         %{__disable libdts libdca} \
538         %{__disable libdv} \
539         %{__disable system_dvdcss libdvdcss-internal} \
540         %{__disable lzo liblzo} \
541         %{__disable system_libmpeg2 libmpeg2-internal} \
542         %{__disable nemesi} \
543         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
544         %{__disable openjpeg} \
545         %{__disable rtmp librtmp} \
546         %{__disable vorbis libvorbis} \
547         %{__enable_disable lirc} \
548         --disable-lircc \
549         %{__disable live} \
550         %{__disable mad} \
551         %{__disable mencoder} \
552         %{__enable osd menu} \
553         --enable-mga \
554         %{__disable mpg123} \
555         %{__enable musepack} \
556         %{__disable nas} \
557         %{__disable pulseaudio pulse} \
558         %{__disable quicktime qtx} \
559         --enable-radio \
560         --enable-radio-capture \
561         %{__disable real} \
562         %{__enable_disable runtime runtime-cpudetection} \
563         %{__enable_disable sdl} \
564         %{__disable select} \
565         --enable-s3fb \
566         %{__disable smb} \
567         %{__disable svga} \
568         --enable-tdfxfb \
569         --enable-tdfxvid \
570         %{__disable theora} \
571         --disable-toolame \
572         --disable-tremor \
573         %{__disable vorbis tremor-internal} \
574         %{__disable_if system_vorbis tremor-internal} \
575         --enable-unrarexec \
576         %{__disable vdpau} \
577         %{__disable vidix} \
578         %{__disable vstream} \
579         --enable-vm \
580 %ifarch ppc
581         --enable-wii \
582 %endif
583         %{__disable win32 win32dll} \
584         --enable-x11 \
585         %{__disable x264} \
586         --enable-xmga \
587         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
588         --enable-xv \
589         %{__disable xvid} \
590         --enable-xvmc --with-xvmclib=XvMCW \
591         %{__enable_disable zr} \
592         "$@"
593
594         %{__make} %{?with_verbose:V=1}
595 }
596
597 %if %{with gui}
598 # build GUI version
599 build --enable-gui --disable-mencoder
600 mv -f mplayer gmplayer
601 %{__make} distclean
602 %endif
603
604 # now build regular version
605 build --disable-gui
606
607 %if %{with doc}
608 %{__make} -j1 doc
609 %endif
610
611 %install
612 rm -rf $RPM_BUILD_ROOT
613 install -d \
614         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
615         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,sv,zh_CN,}/man1 \
616         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
617         $RPM_BUILD_ROOT%{_desktopdir}
618
619 # default config files
620 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
621
622 # executables
623 %if %{with mencoder}
624 install mencoder $RPM_BUILD_ROOT%{_bindir}/mencoder%{binsuf}
625 ln -sf mencoder%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mencoder
626 %endif
627 install mplayer $RPM_BUILD_ROOT%{_bindir}/mplayer%{binsuf}
628 ln -sf mplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/mplayer
629 %if %{with gui}
630 install gmplayer $RPM_BUILD_ROOT%{_bindir}/gmplayer%{binsuf}
631 ln -sf gmplayer%{binsuf} $RPM_BUILD_ROOT%{_bindir}/gmplayer
632 %endif
633
634 %if %{with shared}
635 install -d $RPM_BUILD_ROOT%{_libdir}
636 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
637 %endif
638
639 # fonts
640 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
641 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
642
643 %if %{with gui}
644 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
645 %endif
646 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
647 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
648 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
649
650 # man pages
651 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
652 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
653 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
654 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
655 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
656 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
657 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
658 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
659 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
660 #install DOCS/man/zh/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
661
662 %clean
663 rm -rf $RPM_BUILD_ROOT
664
665 %post -n gmplayer
666 umask 022
667 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
668
669 %postun -n gmplayer
670 umask 022
671 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
672
673 %files
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/mplayer*
676
677 %if %{with gui}
678 %files -n gmplayer
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_bindir}/gmplayer*
681 %{_desktopdir}/gmplayer.desktop
682 %endif
683
684 %if %{with mencoder}
685 %files -n mencoder
686 %defattr(644,root,root,755)
687 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
688 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
689 %doc DOCS/tech/colorspaces.txt
690 %attr(755,root,root) %{_bindir}/mencoder*
691 %endif
692
693 %if %{with doc}
694 %files doc
695 %defattr(644,root,root,755)
696 %doc DOCS/tech
697 # HTML and XML-generated docs
698 %doc DOCS/HTML/en
699 %lang(cs) %doc DOCS/HTML/cs
700 %lang(de) %doc DOCS/HTML/de
701 %lang(es) %doc DOCS/HTML/es
702 %lang(fr) %doc DOCS/HTML/fr
703 %lang(hu) %doc DOCS/HTML/hu
704 %lang(pl) %doc DOCS/HTML/pl
705 %lang(ru) %doc DOCS/HTML/ru
706 #%lang(zh_CN) %doc DOCS/zh
707 %endif
708
709 %files common
710 %defattr(644,root,root,755)
711 %doc AUTHORS README
712 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
713 %if %{with win32}
714 %doc etc/codecs.win32.conf
715 %endif
716
717 %dir %{_sysconfdir}/%{name}
718 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
719 %{_mandir}/man1/*
720 %lang(cs) %{_mandir}/cs/man1/*
721 %lang(de) %{_mandir}/de/man1/*
722 %lang(es) %{_mandir}/es/man1/*
723 %lang(fr) %{_mandir}/fr/man1/*
724 %lang(hu) %{_mandir}/hu/man1/*
725 %lang(it) %{_mandir}/it/man1/*
726 %lang(pl) %{_mandir}/pl/man1/*
727 #%lang(sv) %{_mandir}/sv/man1/*
728 #%lang(zh_CN) %{_mandir}/zh_CN/man1/*
729 %{_desktopdir}/mplayer.desktop
730 %{_pixmapsdir}/mplayer.png
731 %dir %{_datadir}/%{name}
732 %{_datadir}/%{name}/font*
733 %dir %{_datadir}/%{name}/skins
734 %ghost %{_datadir}/%{name}/skins/default
This page took 1.507493 seconds and 3 git commands to generate.