]> git.pld-linux.org Git - packages/mozldap.git/blob - mozldap.spec
- MANY cleanups; I can't see svrcore in pld, build included
[packages/mozldap.git] / mozldap.spec
1 %define nspr_version    4.6
2 %define nspr_evr 1:%{nspr_version}
3 %define nss_version     3.11
4 %define nss_evr 1:%{nss_version}
5 %define svrcore_version 4.0.1
6 %define major           5
7 %define minor           17
8 Summary:        Mozilla LDAP C SDK
9 Summary(pl):    Mozilla LDAP C SDK
10 Name:           mozldap
11 Version:        %{major}.%{minor}
12 Release:        0.1
13 License:        MPL/GPL/LGPL
14 Group:          System
15 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/directory/c-sdk/releases/v%{major}.17/src/ldapcsdk-5.1.7.tar.gz
16 # Source0-md5:  66ddb43e984c0df67e21afb4dc6977b1
17 URL:            http://www.mozilla.org/directory/csdk.html
18 BuildRequires:  gawk
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  nspr-devel >= %{nspr_evr}
21 BuildRequires:  nss-devel >= %{nss_evr}
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 #BuildRequires: svrcore-devel >= %{svrcore_version}
25 Requires:       nspr >= %{nspr_evr}
26 Requires:       nss >= %{nss_evr}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Mozilla LDAP C SDK is a set of libraries that allow applications
31 to communicate with LDAP directory servers. These libraries are
32 derived from the University of Michigan and Netscape LDAP libraries.
33 They use Mozilla NSPR and NSS for crypto.
34
35 %package tools
36 Summary:        Tools for the Mozilla LDAP C SDK
37 Group:          System
38 Requires:       mozldap = %{version}-%{release}
39
40 %description tools
41 The mozldap-tools package provides the ldapsearch, ldapmodify, and
42 ldapdelete tools that use the Mozilla LDAP C SDK libraries.
43
44 %package devel
45 Summary:        Development libraries and examples for Mozilla LDAP C SDK
46 Group:          Development/Libraries
47 Requires:       mozldap = %{version}-%{release}
48
49 %description devel
50 Header and Library files for doing development with the Mozilla LDAP C
51 SDK
52
53 %prep
54 %setup -q -n mozilla
55
56 %build
57 %ifarch x86_64 ppc64 ia64 s390x
58 arg64="--enable-64bit"
59 %endif
60
61 # build local svrcore
62 cd security/coreconf
63 %{__make}
64 cd ../../security/svrcore
65 %{__make} \
66         CFLAGS="%{rpmcflags} -I. -I/usr/include/nspr -I/usr/include/nss"
67 cd ../..
68 # end svrcore
69
70 cd directory/c-sdk
71 %configure $arg64 \
72         --with-nspr \
73         --with-nspr-inc=%{_includedir}/nspr \
74         --with-nspr-lib=%{_libdir} \
75         --with-nss \
76         --with-nss-inc=%{_includedir}/nss \
77         --with-nss-lib=%{_libdir} \
78         --with-svrcore \
79         --with-svrcore-inc=$PWD/../../security/svrcore \
80         --enable-optimize \
81         --disable-debug
82
83 %ifarch x86_64 ppc64 ia64 s390x
84 USE_64=1
85 export USE_64
86 %endif
87
88 %{__make} \
89         BUILDCLU=1 \
90         HAVE_SVRCORE=1 \
91         BUILD_OPT=1 \
92         XCFLAGS="%{rpmcflags}"
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}/mozldap
97
98 install dist/lib/lib*ldap*.so* $RPM_BUILD_ROOT%{_libdir}
99 install dist/bin/ldap* $RPM_BUILD_ROOT%{_libdir}/mozldap
100 install dist/public/ldap/*.h $RPM_BUILD_ROOT%{_includedir}/mozldap
101
102 install -d $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
103 cd directory/c-sdk/ldap
104 cp -r examples $RPM_BUILD_ROOT%{_datadir}/mozldap
105 install examples/xmplflt.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
106 install libraries/libldap/*.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
107 cd ..
108
109 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
110 sed mozldap.pc.in -e "
111         s,%%libdir%%,%{_libdir},g
112         s,%%prefix%%,%{_prefix},g
113         s,%%exec_prefix%%,%{_prefix},g
114         s,%%includedir%%,%{_includedir}/mozldap,g
115         s,%%NSPR_VERSION%%,%{nspr_version},g
116         s,%%NSS_VERSION%%,%{nss_version},g
117         s,%%SVRCORE_VERSION%%,%{svrcore_version},g
118         s,%%MOZLDAP_VERSION%%,%{version},g
119 " > $RPM_BUILD_ROOT%{_pkgconfigdir}/mozldap.pc
120
121 cd $RPM_BUILD_ROOT%{_libdir}
122 for file in libssldap50.so libprldap50.so libldap50.so; do
123         mv $file $file.%{major}.%{minor}
124         ln -s $file.%{major}.%{minor} $file.%{major}
125         ln -s $file.%{major} $file
126 done
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/lib*.so.%{major}.%{minor}
137 %attr(755,root,root) %{_libdir}/lib*.so.%{major}
138
139 %files tools
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/mozldap/ldap*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %{_pkgconfigdir}/mozldap.pc
146 %{_includedir}/mozldap
147 %{_datadir}/mozldap
148 %{_libdir}/lib*.so
This page took 0.082884 seconds and 4 git commands to generate.