]> git.pld-linux.org Git - packages/mozldap.git/blob - mozldap.spec
- remaining pl, adjusted Groups
[packages/mozldap.git] / mozldap.spec
1 %define nspr_version    4.6
2 %define nspr_evr 1:%{nspr_version}
3 %define nss_version     3.11
4 %define nss_evr 1:%{nss_version}
5 %define svrcore_version 4.0.1
6 %define major           5
7 %define minor           17
8 Summary:        Mozilla LDAP C SDK
9 Summary(pl):    Biblioteki Mozilla LDAP C SDK
10 Name:           mozldap
11 Version:        %{major}.%{minor}
12 Release:        0.2
13 License:        MPL/GPL/LGPL
14 Group:          Libraries
15 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/directory/c-sdk/releases/v%{major}.17/src/ldapcsdk-5.1.7.tar.gz
16 # Source0-md5:  66ddb43e984c0df67e21afb4dc6977b1
17 URL:            http://www.mozilla.org/directory/csdk.html
18 BuildRequires:  gawk
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  nspr-devel >= %{nspr_evr}
21 BuildRequires:  nss-devel >= %{nss_evr}
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 #BuildRequires: svrcore-devel >= %{svrcore_version}
25 Requires:       nspr >= %{nspr_evr}
26 Requires:       nss >= %{nss_evr}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Mozilla LDAP C SDK is a set of libraries that allow applications
31 to communicate with LDAP directory servers. These libraries are
32 derived from the University of Michigan and Netscape LDAP libraries.
33 They use Mozilla NSPR and NSS for crypto.
34
35 %description -l pl
36 Mozilla LDAP C SDK to zestaw bibliotek pozwalaj±cych aplikacjom
37 komunikowaæ siê z serwerami us³ug katalogowych LDAP. Biblioteki te
38 wywodz± siê z bibliotek LDAP University of Michigan i Netscape.
39 Wykorzystuj± biblioteki Mozilla NSPR i NSS do kryptografii.
40
41 %package tools
42 Summary:        Tools for the Mozilla LDAP C SDK
43 Summary(pl):    Narzêdzia dla bibliotek Mozilla LDAP C SDK
44 Group:          Applications/System
45 Requires:       mozldap = %{version}-%{release}
46
47 %description tools
48 The mozldap-tools package provides the ldapsearch, ldapmodify, and
49 ldapdelete tools that use the Mozilla LDAP C SDK libraries.
50
51 %description tools -l pl
52 Ten pakiet dostarcza narzêdzia ldapsearch, ldapmodify i ldapdelete
53 wykorzystuj±ce biblioteki Mozilla LDAP C SDK.
54
55 %package devel
56 Summary:        Development files and examples for Mozilla LDAP C SDK
57 Summary(pl):    Pliki programistyczne i przyk³ady dla bibliotek Mozilla LDAP C SDK
58 Group:          Development/Libraries
59 Requires:       mozldap = %{version}-%{release}
60
61 %description devel
62 Header and other files for doing development with the Mozilla LDAP C
63 SDK.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i inne do tworzenia oprogramowania z u¿yciem
67 bibliotek Mozilla LDAP C SDK
68
69 %package static
70 Summary:        Static Mozilla LDAP C SDK libraries
71 Summary(pl):    Statyczne biblioteki Mozilla LDAP C SDK
72 Group:          Development/Libraries
73 Requires:       mozldap-devel = %{version}-%{release}
74
75 %description static
76 Static Mozilla LDAP C SDK libraries.
77
78 %description static -l pl
79 Statyczne biblioteki Mozilla LDAP C SDK.
80
81 %prep
82 %setup -q -n mozilla
83
84 %build
85 # build local svrcore
86 %{__make} -C security/coreconf
87 %{__make} -C security/svrcore \
88         CFLAGS="%{rpmcflags} -I. -I/usr/include/nspr -I/usr/include/nss"
89 # end svrcore
90
91 cd directory/c-sdk
92 %configure \
93 %ifarch %{x8664} ia64 ppc64 s390x
94         --enable-64bit \
95 %endif
96         --disable-debug \
97         --enable-optimize \
98         --with-nspr \
99         --with-nspr-inc=%{_includedir}/nspr \
100         --with-nspr-lib=%{_libdir} \
101         --with-nss \
102         --with-nss-inc=%{_includedir}/nss \
103         --with-nss-lib=%{_libdir} \
104         --with-svrcore \
105         --with-svrcore-inc=$PWD/../../security/svrcore
106
107 %ifarch %{x8664} ppc64 ia64 s390x
108 USE_64=1
109 export USE_64
110 %endif
111
112 %{__make} \
113         BUILDCLU=1 \
114         HAVE_SVRCORE=1 \
115         BUILD_OPT=1 \
116         XCFLAGS="%{rpmcflags}"
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}/mozldap
121
122 install dist/lib/lib*ldap*.so $RPM_BUILD_ROOT%{_libdir}
123 install dist/bin/ldap* $RPM_BUILD_ROOT%{_libdir}/mozldap
124 install dist/public/ldap/*.h $RPM_BUILD_ROOT%{_includedir}/mozldap
125 install directory/c-sdk/ldap/libraries/lib*/lib*50.a $RPM_BUILD_ROOT%{_libdir}
126
127 install -d $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
128 cd directory/c-sdk/ldap
129 cp -r examples $RPM_BUILD_ROOT%{_datadir}/mozldap
130 install examples/xmplflt.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
131 install libraries/libldap/*.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
132 cd ..
133
134 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
135 sed mozldap.pc.in -e "
136         s,%%libdir%%,%{_libdir},g
137         s,%%prefix%%,%{_prefix},g
138         s,%%exec_prefix%%,%{_prefix},g
139         s,%%includedir%%,%{_includedir}/mozldap,g
140         s,%%NSPR_VERSION%%,%{nspr_version},g
141         s,%%NSS_VERSION%%,%{nss_version},g
142         s,%%SVRCORE_VERSION%%,%{svrcore_version},g
143         s,%%MOZLDAP_VERSION%%,%{version},g
144 " > $RPM_BUILD_ROOT%{_pkgconfigdir}/mozldap.pc
145
146 cd $RPM_BUILD_ROOT%{_libdir}
147 for file in libssldap50.so libprldap50.so libldap50.so; do
148         mv $file $file.%{major}.%{minor}
149         ln -s $file.%{major}.%{minor} $file.%{major}
150         ln -s $file.%{major} $file
151 done
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/lib*.so.%{major}.%{minor}
162 %attr(755,root,root) %{_libdir}/lib*.so.%{major}
163
164 %files tools
165 %defattr(644,root,root,755)
166 %dir %{_libdir}/mozldap
167 %attr(755,root,root) %{_libdir}/mozldap/ldap*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/lib*.so
172 %{_includedir}/mozldap
173 %{_pkgconfigdir}/mozldap.pc
174 %{_datadir}/mozldap
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/lib*.a
This page took 0.169453 seconds and 4 git commands to generate.