]> git.pld-linux.org Git - packages/mozldap.git/blob - mozldap.spec
- updated to 6.0.0
[packages/mozldap.git] / mozldap.spec
1 %define nspr_version    4.6
2 %define nspr_evr        1:%{nspr_version}
3 %define nss_version     3.11
4 %define nss_evr         1:%{nss_version}
5 %define svrcore_version 4.0.2
6 Summary:        Mozilla LDAP C SDK
7 Summary(pl):    Biblioteki Mozilla LDAP C SDK
8 Name:           mozldap
9 Version:        6.0.0
10 Release:        1
11 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
12 Group:          Libraries
13 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/directory/c-sdk/releases/v%{version}/src/mozldap6-%{version}.tar.gz
14 # Source0-md5:  d2144e247e11c2a610a3ab044f8ad06c
15 URL:            http://www.mozilla.org/directory/csdk.html
16 BuildRequires:  autoconf >= 2.13
17 BuildRequires:  cyrus-sasl-devel >= 2.0
18 BuildRequires:  gawk
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  nspr-devel >= %{nspr_evr}
21 BuildRequires:  nss-devel >= %{nss_evr}
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 BuildRequires:  svrcore-devel >= %{svrcore_version}
25 Requires:       nspr >= %{nspr_evr}
26 Requires:       nss >= %{nss_evr}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libldap60.so libprldap60.so libssldap60.so
30
31 %description
32 The Mozilla LDAP C SDK is a set of libraries that allow applications
33 to communicate with LDAP directory servers. These libraries are
34 derived from the University of Michigan and Netscape LDAP libraries.
35 They use Mozilla NSPR and NSS for crypto.
36
37 %description -l pl
38 Mozilla LDAP C SDK to zestaw bibliotek pozwalaj±cych aplikacjom
39 komunikowaæ siê z serwerami us³ug katalogowych LDAP. Biblioteki te
40 wywodz± siê z bibliotek LDAP University of Michigan i Netscape.
41 Wykorzystuj± biblioteki Mozilla NSPR i NSS do kryptografii.
42
43 %package devel
44 Summary:        Development files and examples for Mozilla LDAP C SDK
45 Summary(pl):    Pliki programistyczne i przyk³ady dla bibliotek Mozilla LDAP C SDK
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       nspr-devel >= %{nspr_evr}
49 Requires:       nss-devel >= %{nss_evr}
50
51 %description devel
52 Header and other files for doing development with the Mozilla LDAP C
53 SDK.
54
55 %description devel -l pl
56 Pliki nag³ówkowe i inne do tworzenia oprogramowania z u¿yciem
57 bibliotek Mozilla LDAP C SDK
58
59 %package static
60 Summary:        Static Mozilla LDAP C SDK libraries
61 Summary(pl):    Statyczne biblioteki Mozilla LDAP C SDK
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static Mozilla LDAP C SDK libraries.
67
68 %description static -l pl
69 Statyczne biblioteki Mozilla LDAP C SDK.
70
71 %package tools
72 Summary:        Tools for the Mozilla LDAP C SDK
73 Summary(pl):    Narzêdzia dla bibliotek Mozilla LDAP C SDK
74 Group:          Applications/System
75 Requires:       %{name} = %{version}-%{release}
76
77 %description tools
78 The mozldap-tools package provides the ldapsearch, ldapmodify, and
79 ldapdelete tools that use the Mozilla LDAP C SDK libraries.
80
81 %description tools -l pl
82 Ten pakiet dostarcza narzêdzia ldapsearch, ldapmodify i ldapdelete
83 wykorzystuj±ce biblioteki Mozilla LDAP C SDK.
84
85 %prep
86 %setup -q -n mozldap6-%{version}
87
88 %build
89 cd mozilla/directory/c-sdk
90 %{__autoconf}
91 %configure \
92 %ifarch %{x8664} ia64 ppc64 s390x
93         --enable-64bit \
94 %endif
95         --disable-debug \
96         --enable-clu \
97         --enable-optimize \
98         --with-sasl \
99         --with-svrcore \
100         --with-svrcore-inc=%{_includedir}/svrcore \
101         --with-system-nspr \
102         --with-system-nss
103 #       --with-system-svrcore  doesn't work (disables svrcore-inc)
104
105 %ifarch %{x8664} ppc64 ia64 s390x
106 USE_64=1
107 export USE_64
108 %endif
109
110 %{__make} \
111         XCFLAGS="%{rpmcflags}"
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}/mozldap
116
117 cd mozilla
118 install dist/lib/lib*ldap*.so $RPM_BUILD_ROOT%{_libdir}
119 install dist/bin/ldap* $RPM_BUILD_ROOT%{_libdir}/mozldap
120 install dist/public/ldap/*.h $RPM_BUILD_ROOT%{_includedir}/mozldap
121 install directory/c-sdk/ldap/libraries/lib*/lib*60.a $RPM_BUILD_ROOT%{_libdir}
122
123 install -d $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
124 cd directory/c-sdk/ldap
125 cp -r examples $RPM_BUILD_ROOT%{_datadir}/mozldap
126 install examples/xmplflt.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
127 install libraries/libldap/*.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
128 cd -
129
130 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
131 sed directory/c-sdk/mozldap.pc.in -e "
132         s,%%libdir%%,%{_libdir},g
133         s,%%prefix%%,%{_prefix},g
134         s,%%exec_prefix%%,%{_prefix},g
135         s,%%includedir%%,%{_includedir}/mozldap,g
136         s,%%NSPR_VERSION%%,%{nspr_version},g
137         s,%%NSS_VERSION%%,%{nss_version},g
138         s,%%MOZLDAP_VERSION%%,%{version},g
139 " > $RPM_BUILD_ROOT%{_pkgconfigdir}/mozldap.pc
140
141 cd $RPM_BUILD_ROOT%{_libdir}
142 for file in libssldap60.so libprldap60.so libldap60.so; do
143         mv $file $file.%{version}
144         ln -s $file.%{version} $file
145 done
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libldap60.so.*.*
156 %attr(755,root,root) %{_libdir}/libprldap60.so.*.*
157 %attr(755,root,root) %{_libdir}/libssldap60.so.*.*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %{_includedir}/mozldap
162 %{_pkgconfigdir}/mozldap.pc
163 %{_datadir}/mozldap
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libiutil60.a
168 %{_libdir}/liblber60.a
169 %{_libdir}/libldap60.a
170 %{_libdir}/libldif60.a
171
172 %files tools
173 %defattr(644,root,root,755)
174 %dir %{_libdir}/mozldap
175 %attr(755,root,root) %{_libdir}/mozldap/ldap*
This page took 0.149883 seconds and 4 git commands to generate.