]> git.pld-linux.org Git - packages/mozldap.git/blob - mozldap.spec
- noautoreqdep to avoid catching mozilla* deps
[packages/mozldap.git] / mozldap.spec
1 %define nspr_version    4.6
2 %define nspr_evr        1:%{nspr_version}
3 %define nss_version     3.11
4 %define nss_evr         1:%{nss_version}
5 %define svrcore_version 4.0.1
6 %define mozldap_version 5.17
7 Summary:        Mozilla LDAP C SDK
8 Summary(pl):    Biblioteki Mozilla LDAP C SDK
9 Name:           mozldap
10 Version:        %{mozldap_version}
11 Release:        1
12 License:        MPL v1.1 or GPL v2+ or LGPL v2.1+
13 Group:          Libraries
14 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/directory/c-sdk/releases/v%{mozldap_version}/src/ldapcsdk-5.1.7.tar.gz
15 # Source0-md5:  66ddb43e984c0df67e21afb4dc6977b1
16 URL:            http://www.mozilla.org/directory/csdk.html
17 BuildRequires:  gawk
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  nspr-devel >= %{nspr_evr}
20 BuildRequires:  nss-devel >= %{nss_evr}
21 BuildRequires:  perl-base
22 BuildRequires:  pkgconfig
23 #BuildRequires: svrcore-devel >= %{svrcore_version}
24 Requires:       nspr >= %{nspr_evr}
25 Requires:       nss >= %{nss_evr}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreqdep   libldap50.so libprldap50.so libssldap50.so
29
30 %description
31 The Mozilla LDAP C SDK is a set of libraries that allow applications
32 to communicate with LDAP directory servers. These libraries are
33 derived from the University of Michigan and Netscape LDAP libraries.
34 They use Mozilla NSPR and NSS for crypto.
35
36 %description -l pl
37 Mozilla LDAP C SDK to zestaw bibliotek pozwalaj±cych aplikacjom
38 komunikowaæ siê z serwerami us³ug katalogowych LDAP. Biblioteki te
39 wywodz± siê z bibliotek LDAP University of Michigan i Netscape.
40 Wykorzystuj± biblioteki Mozilla NSPR i NSS do kryptografii.
41
42 %package devel
43 Summary:        Development files and examples for Mozilla LDAP C SDK
44 Summary(pl):    Pliki programistyczne i przyk³ady dla bibliotek Mozilla LDAP C SDK
45 Group:          Development/Libraries
46 Requires:       %{name} = %{mozldap_version}-%{release}
47 Requires:       nspr-devel >= %{nspr_evr}
48 Requires:       nss-devel >= %{nss_evr}
49
50 %description devel
51 Header and other files for doing development with the Mozilla LDAP C
52 SDK.
53
54 %description devel -l pl
55 Pliki nag³ówkowe i inne do tworzenia oprogramowania z u¿yciem
56 bibliotek Mozilla LDAP C SDK
57
58 %package static
59 Summary:        Static Mozilla LDAP C SDK libraries
60 Summary(pl):    Statyczne biblioteki Mozilla LDAP C SDK
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{mozldap_version}-%{release}
63
64 %description static
65 Static Mozilla LDAP C SDK libraries.
66
67 %description static -l pl
68 Statyczne biblioteki Mozilla LDAP C SDK.
69
70 %package tools
71 Summary:        Tools for the Mozilla LDAP C SDK
72 Summary(pl):    Narzêdzia dla bibliotek Mozilla LDAP C SDK
73 Group:          Applications/System
74 Requires:       %{name} = %{mozldap_version}-%{release}
75
76 %description tools
77 The mozldap-tools package provides the ldapsearch, ldapmodify, and
78 ldapdelete tools that use the Mozilla LDAP C SDK libraries.
79
80 %description tools -l pl
81 Ten pakiet dostarcza narzêdzia ldapsearch, ldapmodify i ldapdelete
82 wykorzystuj±ce biblioteki Mozilla LDAP C SDK.
83
84 %package -n svrcore-devel
85 Summary:        svrcore - development files for secure PIN handling using NSS crypto
86 Summary(pl):    svrcore - pliki programistyczne do bezpiecznej obs³ugi PIN-ów przy u¿yciu NSS
87 Version:        %{svrcore_version}
88 Group:          Development/Libraries
89 Requires:       nspr-devel >= %{nspr_evr}
90 Requires:       nss-devel >= %{nss_evr}
91
92 %description -n svrcore-devel
93 svrcore provides applications with several ways to handle secure PIN
94 storage e.g. in an application that must be restarted, but needs the
95 PIN to unlock the private key and other crypto material, without user
96 intervention. svrcore uses the facilities provided by NSS.
97
98 %description -n svrcore-devel -l pl
99 svrcore udostêpnia aplikacjom kilka sposobów obs³ugi bezpiecznego
100 przechowywania PIN-ów, np. w aplikacji, która musi byæ zrestartowana,
101 ale wymaga PIN-u do odblokowania klucza prywatnego i innych danych
102 kryptograficznych bez interwencji u¿ytkownika. svrcore wykorzystuje
103 funkcje udostêpniane przez bibliotekê NSS.
104
105 %prep
106 %setup -q -n mozilla
107
108 %build
109 # build local svrcore
110 %{__make} -C security/coreconf \
111         CC="%{__cc}" \
112         CFLAGS="%{rpmcflags}"
113 %{__make} -C security/svrcore \
114         CC="%{__cc}" \
115         CFLAGS="%{rpmcflags} -I. -I/usr/include/nspr -I/usr/include/nss"
116 # end svrcore
117
118 cd directory/c-sdk
119 %configure \
120 %ifarch %{x8664} ia64 ppc64 s390x
121         --enable-64bit \
122 %endif
123         --disable-debug \
124         --enable-optimize \
125         --with-nspr \
126         --with-nspr-inc=%{_includedir}/nspr \
127         --with-nspr-lib=%{_libdir} \
128         --with-nss \
129         --with-nss-inc=%{_includedir}/nss \
130         --with-nss-lib=%{_libdir} \
131         --with-svrcore \
132         --with-svrcore-inc=$PWD/../../security/svrcore
133
134 %ifarch %{x8664} ppc64 ia64 s390x
135 USE_64=1
136 export USE_64
137 %endif
138
139 %{__make} \
140         BUILDCLU=1 \
141         HAVE_SVRCORE=1 \
142         BUILD_OPT=1 \
143         XCFLAGS="%{rpmcflags}"
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir}}/mozldap
148
149 install dist/lib/lib*ldap*.so $RPM_BUILD_ROOT%{_libdir}
150 install dist/bin/ldap* $RPM_BUILD_ROOT%{_libdir}/mozldap
151 install dist/public/ldap/*.h $RPM_BUILD_ROOT%{_includedir}/mozldap
152 install directory/c-sdk/ldap/libraries/lib*/lib*50.a $RPM_BUILD_ROOT%{_libdir}
153
154 install -d $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
155 cd directory/c-sdk/ldap
156 cp -r examples $RPM_BUILD_ROOT%{_datadir}/mozldap
157 install examples/xmplflt.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
158 install libraries/libldap/*.conf $RPM_BUILD_ROOT%{_datadir}/mozldap%{_sysconfdir}
159 cd -
160
161 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
162 sed directory/c-sdk/mozldap.pc.in -e "
163         s,%%libdir%%,%{_libdir},g
164         s,%%prefix%%,%{_prefix},g
165         s,%%exec_prefix%%,%{_prefix},g
166         s,%%includedir%%,%{_includedir}/mozldap,g
167         s,%%NSPR_VERSION%%,%{nspr_version},g
168         s,%%NSS_VERSION%%,%{nss_version},g
169         s,%%MOZLDAP_VERSION%%,%{mozldap_version},g
170 " > $RPM_BUILD_ROOT%{_pkgconfigdir}/mozldap.pc
171
172 cd $RPM_BUILD_ROOT%{_libdir}
173 for file in libssldap50.so libprldap50.so libldap50.so; do
174         mv $file $file.%{mozldap_version}
175         ln -s $file.%{mozldap_version} $file
176 done
177 cd -
178
179 # svrcore
180 install -d $RPM_BUILD_ROOT%{_includedir}/svrcore
181 install dist/public/svrcore/*.h $RPM_BUILD_ROOT%{_includedir}/svrcore
182 install dist/*.OBJ/lib/libsvrcore.a $RPM_BUILD_ROOT%{_libdir}
183 sed security/svrcore/svrcore.pc.in -e "
184         s,%%libdir%%,%{_libdir},g
185         s,%%prefix%%,%{_prefix},g
186         s,%%exec_prefix%%,%{_prefix},g
187         s,%%includedir%%,%{_includedir}/svrcore,g
188         s,%%NSPR_VERSION%%,%{nspr_version},g
189         s,%%NSS_VERSION%%,%{nss_version},g
190         s,%%SVRCORE_VERSION%%,%{svrcore_version},g
191 " > $RPM_BUILD_ROOT%{_pkgconfigdir}/svrcore.pc
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post   -p /sbin/ldconfig
197 %postun -p /sbin/ldconfig
198
199 %files
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libldap50.so.*.*
202 %attr(755,root,root) %{_libdir}/libprldap50.so.*.*
203 %attr(755,root,root) %{_libdir}/libssldap50.so.*.*
204
205 %files devel
206 %defattr(644,root,root,755)
207 %{_includedir}/mozldap
208 %{_pkgconfigdir}/mozldap.pc
209 %{_datadir}/mozldap
210
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/libiutil50.a
214 %{_libdir}/liblber50.a
215 %{_libdir}/libldap50.a
216 %{_libdir}/libldif50.a
217
218 %files tools
219 %defattr(644,root,root,755)
220 %dir %{_libdir}/mozldap
221 %attr(755,root,root) %{_libdir}/mozldap/ldap*
222
223 %files -n svrcore-devel
224 %defattr(644,root,root,755)
225 %doc security/svrcore/README
226 %{_libdir}/libsvrcore.a
227 %{_includedir}/svrcore
228 %{_pkgconfigdir}/svrcore.pc
This page took 0.088789 seconds and 4 git commands to generate.