]> git.pld-linux.org Git - SPECS.git/blob - mouseemu.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / mouseemu.spec
1 Summary:        Emulates middle click and right click
2 Summary(pl.UTF-8):      Emulacja środkowego i prawego przycisku myszy
3 Name:           mouseemu
4 Version:        0.12
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        http://www.geekounet.org/powerbook/files/%{name}.tar.gz
9 # Source0-md5:  768efb6ead83c3ad900d56e7f4e24b79
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-nousb-noadb.patch
13 BuildRequires:  rpmbuild(macros) >= 1.268
14 Requires:       rc-scripts
15 Requires(post,preun):   chkconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Emulates middle click and right click.
20
21 %description -l pl.UTF-8
22 Emulacja środkowego i prawego przycisku myszy.
23
24 %prep
25 %setup -q -n %{name}
26 %patch0 -p1
27
28 %build
29 %{__cc} %{rpmcflags} %{rpmldflags} -o mouseemu mouseemu.c
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_sbindir},/etc/{rc.d/init.d,sysconfig}}
34
35 install mouseemu $RPM_BUILD_ROOT%{_sbindir}
36 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
37 install %{SOURCE2}      $RPM_BUILD_ROOT/etc/sysconfig/%{name}
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 /sbin/chkconfig --add %{name}
44 %service mouseemu restart
45
46 %preun
47 if [ "$1" = "0" ]; then
48         %service mouseemu stop
49         /sbin/chkconfig --del %{name}
50 fi
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README
55 %attr(755,root,root) %{_sbindir}/*
56 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
57 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 1.054401 seconds and 3 git commands to generate.