]> git.pld-linux.org Git - packages/monodevelop.git/blob - monodevelop.spec
- removed obsolete -install.patch and updated -desktop.patch
[packages/monodevelop.git] / monodevelop.spec
1 #
2 # Conditional build:
3 %bcond_without  subversion      # disable subversion backend
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 Summary:        Mono IDE
8 Summary(pl.UTF-8):      IDE dla Mono
9 Name:           monodevelop
10 Version:        2.4
11 Release:        1
12 License:        GPL/MIT
13 Group:          Development/Tools
14 # latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
15 Source0:        http://ftp.novell.com/pub/mono/sources/monodevelop/%{name}-%{version}.tar.bz2
16 # Source0-md5:  14deccd526d640cd38482f7ce7c0cb41
17 Patch0:         %{name}-MOZILLA_FIVE_HOME.patch
18 Patch1:         %{name}-desktop.patch
19 URL:            http://www.monodevelop.com/
20 BuildRequires:  autoconf >= 2.53
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
23 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.12.8
24 BuildRequires:  gettext-devel
25 BuildRequires:  mono-addins-devel >= 0.5
26 BuildRequires:  mono-csharp >= 2.6.1
27 BuildRequires:  monodoc >= 1.0
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.311
30 Requires(post,postun):  desktop-file-utils
31 Requires(post,postun):  gtk+2
32 Requires(post,postun):  shared-mime-info
33 Requires:       hicolor-icon-theme
34 Requires:       mono-addins >= 0.5
35 Requires:       pkgconfig
36 %{?with_subversion:Requires:    subversion-libs}
37 Requires:       xulrunner-libs
38 Suggests:       ctags
39 Suggests:       monodoc
40 Suggests:       mono-compat-links
41 Suggests:       mono-csharp
42 Suggests:       xsp
43 Obsoletes:      MonoDevelop
44 ExcludeArch:    alpha i386 sparc sparc64
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Mono IDE, in the very early stages of development right now, and
49 progressing quickly. MonoDevelop has many features. Some of these
50 include:
51 - Class Management MonoDevelop has a class viewer which allows you to
52   list the classes in your project, their methods, and properties. Your
53   namespaces are also kept track of to keep the classes separated. When
54   you add something to your project, it will automatically be added to
55   the class viewer, even if they're namespaces, classes, methods, or
56   even variables.
57 - Code Completion With the .NET and Gtk# frameworks put together, it
58   can be challenging to remember all the classes, methods, or properties
59   that are at your disposal. MonoDevelop's intelligent code completion
60   attempts to complete what you're typing. If it finds a match, just hit
61   tab and MonoDevelop will do the typing for you.
62 - Project Support MonoDevelop comes with built in projects that help
63   get you started with your console, Gnome# or Gtk# application.
64
65 %description -l pl.UTF-8
66 MonoDevelop to IDE (zintegrowane środowisko programisty) dla Mono we
67 wczesnym, ale szybko postępującym stadium rozwoju. Ma wiele
68 możliwości, a wśród nich:
69 - zarządzanie klasami MonoDevelop ma przeglądarkę klas pozwalającą
70   wyświetlać klasy w projekcie, ich metody oraz własności. Przestrzenie
71   nazw są uwzględniane, aby zachować separację klas. Przy dodawaniu
72   czegoś do projektu jest to automatycznie dodawane do przeglądarki
73   klas, nawet jeśli są to przestrzenie nazw, klasy, metody, a nawet
74   zmienne.
75 - dopełnianie kodu Przy połączeniu szkieletów .NET i Gtk# pamiętanie
76   samemu wszystkich klas, metod i własności mogłoby być nie lada
77   wyzwaniem. MonoDevelop w sposób inteligentny próbuje dopełniać to, co
78   się pisze. Jeśli znajdzie dopasowanie, wystarczy nacisnąć tabulację,
79   aby dokończył pisać za nas.
80 - obsługa projektów MonoDevelop przychodzi z wbudowanymi projektami,
81   pomagającymi zacząć tworzyć aplikacje konsolowe, Gnome# albo Gtk#.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 %build
89 %{__aclocal}
90 %{__autoconf}
91 %{__automake}
92 %configure \
93         --disable-update-mimedb \
94         --disable-update-desktopdb \
95         %{?with_subversion:--enable-subversion}
96
97 %{__make} -j1
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %{__mv} -f $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_pkgconfigdir}
107
108 %find_lang %{name}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 %update_desktop_database_post
115 %update_mime_database
116 %update_icon_cache hicolor
117
118 %postun
119 %update_desktop_database_postun
120 %update_mime_database
121 %update_icon_cache hicolor
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog README
126 %attr(755,root,root) %{_bindir}/mdtool
127 %attr(755,root,root) %{_bindir}/monodevelop
128 %{_prefix}/lib/monodevelop
129 %{_datadir}/mime/packages/monodevelop.xml
130 %{_desktopdir}/monodevelop.desktop
131 %{_pkgconfigdir}/monodevelop-core-addins.pc
132 %{_pkgconfigdir}/monodevelop.pc
133 %{_iconsdir}/hicolor/*/apps/monodevelop.png
134 %{_iconsdir}/hicolor/*/apps/monodevelop.svg
135 %{_mandir}/man1/mdtool.1*
136 %{_mandir}/man1/monodevelop.1*
This page took 0.04106 seconds and 3 git commands to generate.