]> git.pld-linux.org Git - SPECS.git/blob - mono-llvm.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / mono-llvm.spec
1 Summary:        Mono branch of the LLVM optimizing compiler infrastructure
2 Summary(pl.UTF-8):      Gałąź Mono infrastruktury optymalizującego kompilatora LLVM
3 Name:           mono-llvm
4 Version:        2.10
5 Release:        1
6 License:        MIT-like
7 Group:          Development/Tools
8 Source0:        http://download.mono-project.com/sources/mono-llvm/%{name}-%{version}.tar.gz
9 # Source0-md5:  38ffa8f19cca5a063607d2e1f2fb5771
10 URL:            http://www.mono-project.com/Mono_LLVM
11 BuildRequires:  libstdc++-devel >= 5:3.4
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 # use different prefix not to conflict with regular llvm
15 %define         _prefix         /usr/%{_lib}/mono-llvm
16 %define         _libdir         %{_prefix}/lib
17
18 %description
19 Mono branch of the LLVM optimizing compiler infrastructure.
20
21 %description -l pl.UTF-8
22 Gałąź Mono infrastruktury optymalizującego kompilatora LLVM.
23
24 %package devel
25 Summary:        Development files for embedding Mono LLVM
26 Summary(pl.UTF-8):      Pliki programistyczne do osadzania Mono LLVM
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29 Requires:       libstdc++-devel >= 5:3.4
30
31 %description devel
32 Development files for embedding Mono LLVM.
33
34 %description devel -l pl.UTF-8
35 Pliki programistyczne do osadzania Mono LLVM.
36
37 %prep
38 %setup -q -n %{name}-ab69472
39
40 %build
41 install -d obj
42 cd obj
43 bash ../%configure \
44         --disable-assertions \
45         --enable-jit \
46         --enable-optimized \
47         --enable-shared \
48         --disable-static \
49         --enable-bindings=none \
50         --with-pic
51
52 %{__make} \
53         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} -C obj -j1 install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 # see regular llvm
62 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/{docs,share}
63 # example
64 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libLLVMHello.*
65 # there are shared versions
66 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{EnhancedDisassembly,LTO}.a
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CREDITS.TXT LICENSE.TXT README.txt
74 %dir %{_prefix}
75 %dir %{_bindir}
76 %attr(755,root,root) %{_bindir}/bugpoint
77 %attr(755,root,root) %{_bindir}/llc
78 %attr(755,root,root) %{_bindir}/lli
79 %attr(755,root,root) %{_bindir}/llvm-ar
80 %attr(755,root,root) %{_bindir}/llvm-as
81 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
82 %attr(755,root,root) %{_bindir}/llvm-diff
83 %attr(755,root,root) %{_bindir}/llvm-dis
84 %attr(755,root,root) %{_bindir}/llvm-extract
85 %attr(755,root,root) %{_bindir}/llvm-ld
86 %attr(755,root,root) %{_bindir}/llvm-link
87 %attr(755,root,root) %{_bindir}/llvm-mc
88 %attr(755,root,root) %{_bindir}/llvm-nm
89 %attr(755,root,root) %{_bindir}/llvm-prof
90 %attr(755,root,root) %{_bindir}/llvm-ranlib
91 %attr(755,root,root) %{_bindir}/llvm-stub
92 %attr(755,root,root) %{_bindir}/llvmc
93 %attr(755,root,root) %{_bindir}/macho-dump
94 %attr(755,root,root) %{_bindir}/opt
95 %attr(755,root,root) %{_bindir}/tblgen
96 %dir %{_libdir}
97 %attr(755,root,root) %{_libdir}/libEnhancedDisassembly.so
98 %attr(755,root,root) %{_libdir}/libLLVM-2.9svn.so
99 %attr(755,root,root) %{_libdir}/libLTO.so
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/llvm-config
104 %attr(755,root,root) %{_libdir}/libBugpointPasses.so
105 %attr(755,root,root) %{_libdir}/libprofile_rt.so
106 %{_libdir}/libCompilerDriver.a
107 %{_libdir}/libLLVM*.a
108 %{_libdir}/libUnitTestMain.a
109 %dir %{_includedir}
110 %{_includedir}/llvm
111 %{_includedir}/llvm-c
This page took 0.17835 seconds and 3 git commands to generate.