]> git.pld-linux.org Git - packages/monit.git/blob - monit.spec
- permissions required by program
[packages/monit.git] / monit.spec
1 Name:           monit
2 Summary:        Process monitor and restart utility
3 Summary(pl):    Narzêdzie do monitorowania procesów i ich restartowania
4 Version:        3.2
5 Release:        1
6 Source0:        http://www.tildeslash.com/monit/dist/%{name}-%{version}.tar.gz
7 Source1:        %{name}.init
8 Group:          Applications/Console
9 License:        GPL
10 URL:            http://www.tildeslash.com/monit/
11 BuildRequires:  openssl-devel >= 0.9.7
12 BuildRequires:  bison
13 BuildRequires:  flex
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 monit is an utility for monitoring daemons or similar programs running
18 on a Unix system. It will start specified programs if they are not
19 running and restart programs not responding.
20
21 %description -l pl
22 monit jest narzêdziem do monitorowania demonów oraz podonych programów
23 pracuj±cych w systemie Unix. monit zrestartuje podany program w
24 momencie gdy przestaje on pracowaæ lub w momencie gdy program
25 przestaje odpowiadaæ.
26
27 %prep
28 %setup -q
29
30 %build
31 %configure
32 %{__make}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/
37
38 %{__make} install \
39         DESTDIR=$RPM_BUILD_ROOT
40
41 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
42 install monitrc $RPM_BUILD_ROOT%{_sysconfdir}/
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 /sbin/chkconfig --add %{name}
49 if [ -f %{_var}/lock/subsys/%{name} ]; then
50         /etc/rc.d/init.d/%{name} restart 1>&2
51 else
52         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
53 fi
54
55 %preun
56 if [ "$1" = "0" ]; then
57         if [ -f %{_var}/lock/subsys/%{name} ]; then
58                 /etc/rc.d/init.d/%{name} stop 1>&2
59         fi
60         /sbin/chkconfig --del %{name}
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc doc/*.html CHANGES.txt CONTRIBUTORS FAQ.txt README*
66 %attr(755,root,root) %{_bindir}/*
67 %{_mandir}/man?/*
68 %attr(754,root,root) /etc/rc.d/init.d/%{name}
69 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}rc
This page took 0.044661 seconds and 4 git commands to generate.