]> git.pld-linux.org Git - packages/monit.git/blob - monit.spec
- updated to latest cvs version
[packages/monit.git] / monit.spec
1 %define snap    20030609
2 Summary:        Process monitor and restart utility
3 Summary(pl):    Narzêdzie do monitorowania procesów i ich restartowania
4 Name:           monit
5 Version:        3.3
6 Release:        0.%{snap}.1
7 Group:          Applications/Console
8 License:        GPL
9 Source0:        http://www.tildeslash.com/monit/dist/%{name}-%{version}-%{snap}.tar.gz
10 # Source0-md5:  4da587e3d41b07d081678d5c53b2c597
11 Source1:        %{name}.init
12 URL:            http://www.tildeslash.com/monit/
13 BuildRequires:  bison
14 BuildRequires:  flex
15 BuildRequires:  openssl-devel >= 0.9.7
16 PreReq:         rc-scripts
17 Requires(post,preun):   /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 monit is an utility for monitoring daemons or similar programs running
22 on a Unix system. It will start specified programs if they are not
23 running and restart programs not responding.
24
25 %description -l pl
26 monit jest narzêdziem do monitorowania demonów oraz podonych programów
27 pracuj±cych w systemie Unix. monit zrestartuje podany program w
28 momencie gdy przestaje on pracowaæ lub w momencie gdy program
29 przestaje odpowiadaæ.
30
31 %prep
32 %setup -q
33
34 %build
35 ./make_man
36 ./autogen.sh
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
48 install monitrc $RPM_BUILD_ROOT%{_sysconfdir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/chkconfig --add %{name}
55 if [ -f %{_var}/lock/subsys/%{name} ]; then
56         /etc/rc.d/init.d/%{name} restart 1>&2
57 else
58         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
59 fi
60
61 %preun
62 if [ "$1" = "0" ]; then
63         if [ -f %{_var}/lock/subsys/%{name} ]; then
64                 /etc/rc.d/init.d/%{name} stop 1>&2
65         fi
66         /sbin/chkconfig --del %{name}
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc web/*.html CHANGES.txt CONTRIBUTORS FAQ.txt README*
72 %attr(755,root,root) %{_bindir}/*
73 %{_mandir}/man?/*
74 %attr(754,root,root) /etc/rc.d/init.d/%{name}
75 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}rc
This page took 0.111875 seconds and 4 git commands to generate.