]> git.pld-linux.org Git - packages/monit.git/blob - monit.spec
- remove url for distfiles
[packages/monit.git] / monit.spec
1 %define snap    20030609
2 Summary:        Process monitor and restart utility
3 Summary(pl):    Narzêdzie do monitorowania procesów i ich restartowania
4 Name:           monit
5 Version:        3.3
6 Release:        0.%{snap}.1
7 Group:          Applications/Console
8 License:        GPL
9 # http://www.tildeslash.com/monit/dist/
10 Source0:        %{name}-%{version}-%{snap}.tar.gz
11 # Source0-md5:  4da587e3d41b07d081678d5c53b2c597
12 Source1:        %{name}.init
13 URL:            http://www.tildeslash.com/monit/
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  openssl-devel >= 0.9.7
17 PreReq:         rc-scripts
18 Requires(post,preun):   /sbin/chkconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 monit is an utility for monitoring daemons or similar programs running
23 on a Unix system. It will start specified programs if they are not
24 running and restart programs not responding.
25
26 %description -l pl
27 monit jest narzêdziem do monitorowania demonów oraz podonych programów
28 pracuj±cych w systemie Unix. monit zrestartuje podany program w
29 momencie gdy przestaje on pracowaæ lub w momencie gdy program
30 przestaje odpowiadaæ.
31
32 %prep
33 %setup -q
34
35 %build
36 ./make_man
37 ./autogen.sh
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
49 install monitrc $RPM_BUILD_ROOT%{_sysconfdir}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /sbin/chkconfig --add %{name}
56 if [ -f %{_var}/lock/subsys/%{name} ]; then
57         /etc/rc.d/init.d/%{name} restart 1>&2
58 else
59         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
60 fi
61
62 %preun
63 if [ "$1" = "0" ]; then
64         if [ -f %{_var}/lock/subsys/%{name} ]; then
65                 /etc/rc.d/init.d/%{name} stop 1>&2
66         fi
67         /sbin/chkconfig --del %{name}
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc web/*.html CHANGES.txt CONTRIBUTORS FAQ.txt README*
73 %attr(755,root,root) %{_bindir}/*
74 %{_mandir}/man?/*
75 %attr(754,root,root) /etc/rc.d/init.d/%{name}
76 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}rc
This page took 0.031617 seconds and 4 git commands to generate.