]> git.pld-linux.org Git - SPECS.git/blob - mkprintf.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / mkprintf.spec
1 Summary:        Wraps any text file to a C function that outputs the text
2 Summary(pl.UTF-8):      Zamienia plik tekstowy na funkcję C drukującą ten tekst
3 Name:           mkprintf
4 Version:        1.0
5 Release:        1
6 Group:          Development/Tools
7 License:        GPL
8 Source0:        ftp://sunsite.unc.edu/pub/Linux/devel/compiler-tools/%{name}-%{version}.tgz
9 # Source0-md5:  2f8e251ede493aa06ab16501c3241cd6
10 BuildRequires:  flex
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Mkprintf reads the named input file (or standard input if no file is
15 named) and writes a C function that outputs the text of this file.
16 This is what lazy C programmers have been waiting for.
17
18 %description -l pl.UTF-8
19 Mkprintf wczytuje podany plik (lub standardowe wejście) i wypisuje
20 funkcję w C, która wypisze podany tekst. Typowe narzędzie dla leniwych
21 programistów.
22
23 %prep
24 %setup -q
25
26 %build
27 %{__make} \
28         CC="%{__cc}" \
29         CFLAGS="%{rpmcflags} -DVERSION=%{version}"
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man8}
34
35 install mkprintf $RPM_BUILD_ROOT%{_bindir}/mkprintf
36 install mkprintf.8 $RPM_BUILD_ROOT%{_mandir}/man8/mkprintf.8
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc README
44 %attr(755,root,root) %{_bindir}/*
45 %{_mandir}/man8/*
This page took 1.162754 seconds and 3 git commands to generate.