]> git.pld-linux.org Git - SPECS.git/blob - minio-mc.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / minio-mc.spec
1 %define         tag     RELEASE.2016-08-21T03-02-49Z
2 %define         subver  %(echo %{tag} | sed -e 's/[^0-9]//g')
3 Summary:        Minio Client: commands for filesystems and object storage
4 Name:           minio-mc
5 Version:        0.0.%{subver}
6 Release:        1
7 License:        Apache v2.0
8 Group:          Applications
9 Source0:        https://github.com/minio/mc/archive/%{tag}.tar.gz
10 # Source0-md5:  5d8c632198d83735966c62c38094544c
11 URL:            https://github.com/minio/mc
12 BuildRequires:  golang >= 1.3.1
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _enable_debug_packages 0
16 %define         gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
17 %define         import_path     github.com/minio/mc
18
19 %description
20 Minio Client (mc) provides a modern alternative to UNIX commands like
21 ls, cat, cp, mirror, diff etc. It supports filesystems and Amazon S3
22 compatible cloud storage service (AWS Signature v2 and v4).
23
24 %prep
25 %setup -qc
26 mv mc-*/* .
27
28 install -d src/$(dirname %{import_path})
29 ln -s ../../.. src/%{import_path}
30
31 %build
32 export GOPATH=$(pwd)
33
34 %gobuild -o mc
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_bindir}
39 install -p mc $RPM_BUILD_ROOT%{_bindir}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc README.md NOTICE
47 %attr(755,root,root) %{_bindir}/mc
This page took 0.637013 seconds and 3 git commands to generate.