]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- rel 2
[packages/ming.git] / ming.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Ming - an SWF output library
3 Summary(pl.UTF-8):      Ming - biblioteka do produkcji plików SWF
4 Name:           ming
5 Version:        0.3.0
6 Release:        2
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/ming/%{name}-%{version}.tar.gz
10 # Source0-md5:  56b29eeb4fdd0b98c9ee62e25d14841d
11 Source1:        http://dl.sourceforge.net/ming/%{name}-perl-%{version}.tar.gz
12 # Source1-md5:  506acca9ca42066a97fc0b6abad6d57a
13 Source2:        http://dl.sourceforge.net/ming/%{name}-py-%{version}.tar.gz
14 # Source2-md5:  96d3f42f13d020d907287a640b39ec46
15 Patch0:         %{name}-DESTDIR.patch
16 Patch1:         %{name}-build.patch
17 Patch2:         %{name}-perl-shared.patch
18 URL:            http://ming.sourceforge.net/
19 BuildRequires:  giflib-devel
20 BuildRequires:  python-devel >= 1:2.5
21 BuildRequires:  rpm-perlprov >= 4.0.2-24
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Ming is a C library for generating SWF ("Flash") format movies, plus a
28 set of wrappers for using the library from c++ and popular scripting
29 languages like PHP, Python, and Ruby.
30
31 %description -l pl.UTF-8
32 Ming jest biblioteką w C do generowania animacji w formacie SWF
33 ("Flash") wraz z zestawem wrapperów do używania jej z C++ i
34 popularnymi językami skryptowymi, takimi jak PHP, Python i Ruby.
35
36 %package devel
37 Summary:        Ming development files
38 Summary(pl.UTF-8):      Pliki dla programistów Ming
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for ming library (C and C++).
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe dla biblioteki ming (do C i C++).
47
48 %package static
49 Summary:        Ming static library
50 Summary(pl.UTF-8):      Statyczna biblioteka Ming
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static Ming library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka Ming.
59
60 %package utils
61 Summary:        Ming utilities
62 Summary(pl.UTF-8):      Narzędzia Ming
63 Group:          Applications/File
64
65 %description utils
66 Ming utilities:
67 - listswf - swf format disassembler
68 - listfdb - show contents of fdb font file
69 - makefdb - rip fdb font definition files out of a generator template
70   file
71 - swftophp - attempt to make a php/ming script out of an swf file
72
73 %description utils -l pl.UTF-8
74 Narzędzia Ming:
75 - listswf - disasembler plików swf
76 - listfdb - pokazuje zawartość plików fontów fdb
77 - makefdb - wyciąga pliki definicji fontów fdb z pliku generatora
78 - swftophp - próbuje zrobić skrypt php/ming z pliku swf
79
80 %package -n perl-ming
81 Summary:        Ming perl module
82 Summary(pl.UTF-8):      Moduł perla Ming
83 Group:          Development/Languages/Perl
84 Requires:       %{name} = %{version}-%{release}
85 Obsoletes:      ming-perl
86
87 %description -n perl-ming
88 Ming perl module - perl wrapper for Ming library.
89
90 %description -n perl-ming -l pl.UTF-8
91 Moduł perla Ming - perlowy wrapper do biblioteki Ming.
92
93 %package -n python-ming
94 Summary:        Ming Python module
95 Summary(pl.UTF-8):      Moduł biblioteki Ming dla języka Python
96 Group:          Development/Languages/Perl
97 Requires:       %{name} = %{version}-%{release}
98 %pyrequires_eq  python-libs
99
100 %description -n python-ming
101 Ming Python module.
102
103 %description -n python-ming -l pl.UTF-8
104 Moduł biblioteki Ming dla języka Python.
105
106 %prep
107 %setup -q -b1 -b2
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111
112 %build
113 %configure
114 %{__make} -j1
115
116 cd perl_ext
117 %{__perl} Makefile.PL \
118         INSTALLDIRS=vendor
119 %{__make} \
120         OPTIMIZE="%{rpmcflags}"
121 cd ..
122
123 %{__make} -C py_ext \
124         CC="%{__cc}" \
125         CFLAGS="%{rpmcflags}" \
126         PYINCDIR=%{py_incdir}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__make} -C perl_ext pure_install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__make} -C py_ext install \
138         PREFIX="--optimize=2 --root=$RPM_BUILD_ROOT"
139
140 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/SWF/.cvsignore
141 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/.packlist
142 rm -f $RPM_BUILD_ROOT%{py_sitedir}/ming*.py
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc CREDITS README TODO
153 %attr(755,root,root) %{_libdir}/libming.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libming.so.0
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libming.so
159 %{_includedir}/ming.h
160 %{_includedir}/mingpp.h
161 %{_includedir}/ming_config.h
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libming.a
166
167 %files utils
168 %defattr(644,root,root,755)
169 %doc util/{README,TODO}
170 %attr(755,root,root) %{_bindir}/dbl2png
171 %attr(755,root,root) %{_bindir}/gif2dbl
172 %attr(755,root,root) %{_bindir}/gif2mask
173 %attr(755,root,root) %{_bindir}/listaction
174 %attr(755,root,root) %{_bindir}/listaction_d
175 %attr(755,root,root) %{_bindir}/listfdb
176 %attr(755,root,root) %{_bindir}/listjpeg
177 %attr(755,root,root) %{_bindir}/listmp3
178 %attr(755,root,root) %{_bindir}/listswf
179 %attr(755,root,root) %{_bindir}/listswf_d
180 %attr(755,root,root) %{_bindir}/makefdb
181 %attr(755,root,root) %{_bindir}/makeswf
182 %attr(755,root,root) %{_bindir}/ming-config
183 %attr(755,root,root) %{_bindir}/png2dbl
184 %attr(755,root,root) %{_bindir}/png2swf
185 %attr(755,root,root) %{_bindir}/raw2adpcm
186 %attr(755,root,root) %{_bindir}/swftoperl
187 %attr(755,root,root) %{_bindir}/swftophp
188 %attr(755,root,root) %{_bindir}/swftopython
189 %{_mandir}/man1/makeswf.1*
190
191 %files -n perl-ming
192 %defattr(644,root,root,755)
193 %doc perl_ext/{README,TODO}
194 %{perl_vendorarch}/SWF.pm
195 %{perl_vendorarch}/SWF
196 %dir %{perl_vendorarch}/auto/SWF
197 %{perl_vendorarch}/auto/SWF/SWF.bs
198 %attr(755,root,root) %{perl_vendorarch}/auto/SWF/SWF.so
199 %{_mandir}/man3/SWF*
200
201 %files -n python-ming
202 %defattr(644,root,root,755)
203 %doc py_ext/{README,TODO}
204 %attr(755,root,root) %{py_sitedir}/_mingc.so
205 %{py_sitedir}/ming*.py[co]
206 %{py_sitedir}/mingc-*.egg-info
This page took 0.0772 seconds and 3 git commands to generate.