]> git.pld-linux.org Git - packages/mdds.git/blob - mdds.spec
a687ab7e279e57e8dc12251cc52ff227bbe5f44f
[packages/mdds.git] / mdds.spec
1 Summary:        A collection of multi-dimensional data structures and indexing algorithms
2 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
3 Name:           mdds
4 Version:        0.6.0
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 #Source0Download: https://code.google.com/p/multidimalgorithm/downloads/list
9 Source0:        http://multidimalgorithm.googlecode.com/files/%{name}_%{version}.tar.bz2
10 # Source0-md5:  3e89a35f253a4f1c7de68c57d851ef38
11 Patch0:         0001-Fixes-build-breakage-on-Debian.patch
12 Patch1:         0001-fix-linking-error-with-boost-1.50.patch
13 Patch2:         0001-help-compiler-select-the-right-overload-of-vector-in.patch
14 URL:            http://code.google.com/p/multidimalgorithm/
15 BuildRequires:  boost-devel
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 A collection of multi-dimensional data structures and indexing
21 algorithms.
22
23 It implements the following data structures:
24 - segment tree
25 - flat segment tree
26 - rectangle set
27 - point quad tree
28 - mixed type matrix
29
30 %description -l pl.UTF-8
31 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
32 Zaimplementowane są następujące struktury danych:
33 - drzewo segmentowe
34 - płaskie drzewo segmentowe
35 - zbiór prostokątów
36 - drzewo czwórkowe (quadtree) dla punktów
37 - macierz mieszana
38
39 %package devel
40 Summary:        A collection of multi-dimensional data structures and indexing algorithms
41 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
42 Group:          Development/Libraries
43 Requires:       boost-devel
44
45 %description devel
46 A collection of multi-dimensional data structures and indexing
47 algorithms.
48
49 It implements the following data structures:
50 - segment tree
51 - flat segment tree
52 - rectangle set
53 - point quad tree
54 - mixed type matrix
55
56 %description devel -l pl.UTF-8
57 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
58 Zaimplementowane są następujące struktury danych:
59 - drzewo segmentowe
60 - płaskie drzewo segmentowe
61 - zbiór prostokątów
62 - drzewo czwórkowe (quadtree) dla punktów
63 - macierz mieszana
64
65 %prep
66 %setup -q -n %{name}_%{version}
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70
71 # this is only used in tests
72 sed -i -e '/^CPPFLAGS/s/-Wall.*-std/%{rpmcflags} -std/' Makefile.in
73
74 %build
75 # we can switch from boost to c++0x (the default) if sufficiently new C++11 compliant g++ is enforced
76 %configure \
77         --with-hash-container=boost
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{_includedir}/mdds
83 cp -a include/mdds/* $RPM_BUILD_ROOT%{_includedir}/mdds
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files devel
89 %defattr(644,root,root,755)
90 %doc AUTHORS COPYING NEWS README
91 %{_includedir}/mdds
This page took 0.051493 seconds and 2 git commands to generate.