]> git.pld-linux.org Git - packages/mdds.git/blob - mdds.spec
- updated to 0.10.3
[packages/mdds.git] / mdds.spec
1 Summary:        A collection of multi-dimensional data structures and indexing algorithms
2 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
3 Name:           mdds
4 Version:        0.10.3
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 #Source0Download: http://code.google.com/p/multidimalgorithm/wiki/Downloads
9 Source0:        http://kohei.us/files/mdds/src/%{name}_%{version}.tar.bz2
10 # Source0-md5:  aa5ca9d1ed1082890835afab26400a39
11 URL:            http://code.google.com/p/multidimalgorithm/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  boost-devel >= 1.39
14 BuildRequires:  rpmbuild(macros) >= 1.446
15 BuildRequires:  sed >= 4.0
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 A collection of multi-dimensional data structures and indexing
21 algorithms.
22
23 It implements the following data structures:
24 - segment tree
25 - flat segment tree
26 - rectangle set
27 - point quad tree
28 - mixed type matrix
29
30 %description -l pl.UTF-8
31 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
32 Zaimplementowane są następujące struktury danych:
33 - drzewo segmentowe
34 - płaskie drzewo segmentowe
35 - zbiór prostokątów
36 - drzewo czwórkowe (quadtree) dla punktów
37 - macierz mieszana
38
39 %package devel
40 Summary:        A collection of multi-dimensional data structures and indexing algorithms
41 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
42 Group:          Development/Libraries
43 Requires:       boost-devel >= 1.39
44
45 %description devel
46 A collection of multi-dimensional data structures and indexing
47 algorithms.
48
49 It implements the following data structures:
50 - segment tree
51 - flat segment tree
52 - rectangle set
53 - point quad tree
54 - mixed type matrix
55
56 %description devel -l pl.UTF-8
57 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
58 Zaimplementowane są następujące struktury danych:
59 - drzewo segmentowe
60 - płaskie drzewo segmentowe
61 - zbiór prostokątów
62 - drzewo czwórkowe (quadtree) dla punktów
63 - macierz mieszana
64
65 %prep
66 %setup -q -n %{name}_%{version}
67
68 # this is only used in tests
69 sed -i -e '/^CPPFLAGS_NODEBUG/s/-Wall -Os -g/%{rpmcflags} -Wall/' configure.ac
70
71 %build
72 %{__autoconf}
73 # we can switch from boost to c++0x (the default) if sufficiently new C++11 compliant g++ is enforced
74 %configure \
75         --with-hash-container=boost
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_includedir}/mdds
81 cp -a include/mdds/* $RPM_BUILD_ROOT%{_includedir}/mdds
82 install -Dp misc/mdds.pc $RPM_BUILD_ROOT%{_npkgconfigdir}/mdds.pc
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files devel
88 %defattr(644,root,root,755)
89 %doc AUTHORS COPYING NEWS README
90 %{_includedir}/mdds
91 %{_npkgconfigdir}/mdds.pc
This page took 0.047549 seconds and 3 git commands to generate.