]> git.pld-linux.org Git - packages/mdds.git/blob - mdds.spec
fix build without apidocs
[packages/mdds.git] / mdds.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # doxygen/sphinx+breathe API documentation
4 #
5 Summary:        A collection of multi-dimensional data structures and indexing algorithms
6 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
7 Name:           mdds
8 Version:        1.6.0
9 Release:        1
10 License:        MIT
11 Group:          Development/Libraries
12 #Source0Download: https://gitlab.com/mdds/mdds/raw/master/README.md
13 Source0:        http://kohei.us/files/mdds/src/%{name}-%{version}.tar.bz2
14 # Source0-md5:  a9e9704bddfacc27fcde6827b9cef1db
15 Patch0:         %{name}-doc.patch
16 URL:            https://gitlab.com/mdds/mdds
17 BuildRequires:  boost-devel >= 1.39
18 BuildRequires:  libstdc++-devel >= 6:4.7
19 BuildRequires:  rpmbuild(macros) >= 1.446
20 %if %{with apidocs}
21 BuildRequires:  doxygen
22 BuildRequires:  python3-breathe
23 BuildRequires:  sphinx-pdg-3
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 A collection of multi-dimensional data structures and indexing
30 algorithms.
31
32 It implements the following data structures:
33 - segment tree
34 - flat segment tree
35 - rectangle set
36 - point quad tree
37 - mixed type matrix
38
39 %description -l pl.UTF-8
40 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
41 Zaimplementowane są następujące struktury danych:
42 - drzewo segmentowe
43 - płaskie drzewo segmentowe
44 - zbiór prostokątów
45 - drzewo czwórkowe (quadtree) dla punktów
46 - macierz mieszana
47
48 %package devel
49 Summary:        A collection of multi-dimensional data structures and indexing algorithms
50 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
51 Group:          Development/Libraries
52 Requires:       boost-devel >= 1.39
53 Requires:       libstdc++-devel >= 6:4.7
54
55 %description devel
56 A collection of multi-dimensional data structures and indexing
57 algorithms.
58
59 It implements the following data structures:
60 - segment tree
61 - flat segment tree
62 - rectangle set
63 - point quad tree
64 - mixed type matrix
65
66 %description devel -l pl.UTF-8
67 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
68 Zaimplementowane są następujące struktury danych:
69 - drzewo segmentowe
70 - płaskie drzewo segmentowe
71 - zbiór prostokątów
72 - drzewo czwórkowe (quadtree) dla punktów
73 - macierz mieszana
74
75 %package apidocs
76 Summary:        API documentation for MDDS
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki MDDS
78 Group:          Documentation
79
80 %description apidocs
81 API documentation for MDDS.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API biblioteki MDDS.
85
86 %prep
87 %setup -q
88
89 %build
90 %configure \
91         SPHINX=/usr/bin/sphinx-build-3 \
92         %{?with_apidocs:--enable-docs}
93
94 %{__make}
95
96 %if %{with apidocs}
97 %{__make} html-local
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # packaged as %doc
107 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mdds
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files devel
113 %defattr(644,root,root,755)
114 %doc AUTHORS CHANGELOG LICENSE README.md
115 %{_includedir}/mdds-1.5
116 %{_npkgconfigdir}/mdds-1.5.pc
117
118 %if %{with apidocs}
119 %files apidocs
120 %defattr(644,root,root,755)
121 %doc doc/_doxygen/html doc/_build/{_static,*.html,*.js}
122 %endif
This page took 0.07117 seconds and 3 git commands to generate.