]> git.pld-linux.org Git - SPECS.git/blob - matio.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / matio.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs         # build and package API docs (withdrawn in 1.5)
4 %bcond_with     fortran         # Fortran interface (removed from 1.5 sources)
5 %bcond_without  hdf5            # HDF5-based MAT v7.3 files support
6 #
7 Summary:        MATIO - Matlab MAT file I/O library
8 Summary(pl.UTF-8):      MATIO - biblioteka wejścia/wyjścia do plików MAT (Matlaba)
9 Name:           matio
10 Version:        1.5.27
11 Release:        2
12 License:        BSD
13 Group:          Libraries
14 Source0:        https://downloads.sourceforge.net/matio/%{name}-%{version}.tar.gz
15 # Source0-md5:  d9e55f091cbecbe988d4579a51c08776
16 Patch0:         %{name}-hdf5.patch
17 URL:            https://matio.sourceforge.net/
18 BuildRequires:  autoconf >= 2.60
19 BuildRequires:  automake >= 1:1.8
20 %{?with_apidocs:BuildRequires:  doxygen}
21 %{?with_fortran:BuildRequires:  gcc-fortran}
22 %{?with_hdf5:BuildRequires:     hdf5-devel >= 1.10}
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  zlib-devel
26 %if %{with apidocs}
27 BuildRequires:  doxygen
28 BuildRequires:  texlive-format-pdflatex
29 BuildRequires:  texlive-latex-ams
30 BuildRequires:  texlive-makeindex
31 %endif
32 Obsoletes:      matio-apidocs < 1.5
33 Obsoletes:      matio-fortran < 1.5
34 Obsoletes:      matio-fortran-devel < 1.5
35 Obsoletes:      matio-fortran-static < 1.5
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 libmatio is an open-source library for reading/writing Matlab MAT
40 files. This library is designed for use by programs/libraries that do
41 not have access or do not want to rely on Matlab's libmat shared
42 library.
43
44 %description -l pl.UTF-8
45 libmatio to mająca otwarte źródłą biblioteka do odczytu i zapisu
46 plików MAT (z programu Matlab). Jest przeznaczona dla programów i
47 bibliotek nie mających dostępu albo nie chcących polegać na bibliotece
48 współdzielonej libmat z Matlaba.
49
50 %package devel
51 Summary:        Header files for MATIO library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki MATIO
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 %{?with_hdf5:Requires:  hdf5-devel >= 1.10}
56 Requires:       zlib-devel
57
58 %description devel
59 Header files for MATIO library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki MATIO.
63
64 %package static
65 Summary:        Static MATIO library
66 Summary(pl.UTF-8):      Statyczna biblioteka MATIO
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static MATIO library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka MATIO.
75
76 %package fortran
77 Summary:        Fortran interface for MATIO library
78 Summary(pl.UTF-8):      Interfejs Fortranu do biblioteki MATIO
79 Group:          Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description fortran
83 Fortran interface for MATIO library.
84
85 %description fortran -l pl.UTF-8
86 Interfejs Fortranu do biblioteki MATIO.
87
88 %package fortran-devel
89 Summary:        Header file for Fortran interface for MATIO library
90 Summary(pl.UTF-8):      Plik nagłówkowy interfejsu Fortranu do biblioteki MATIO
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93 Requires:       %{name}-fortran = %{version}-%{release}
94
95 %description fortran-devel
96 Header file for Fortran interface for MATIO library.
97
98 %description fortran-devel -l pl.UTF-8
99 Plik nagłówkowy interfejsu Fortranu do biblioteki MATIO.
100
101 %package fortran-static
102 Summary:        Fortran interface for MATIO library - static library
103 Summary(pl.UTF-8):      Interfejs Fortranu do biblioteki MATIO - biblioteka statyczna
104 Group:          Development/Libraries
105 Requires:       %{name}-fortran-devel = %{version}-%{release}
106
107 %description fortran-static
108 Fortran interface for MATIO library - static library.
109
110 %description fortran-static -l pl.UTF-8
111 Interfejs Fortranu do biblioteki MATIO - biblioteka statyczna.
112
113 %package apidocs
114 Summary:        MATIO API documentation
115 Summary(pl.UTF-8):      Dokumentacja API biblioteki MATIO
116 Group:          Documentation
117
118 %description apidocs
119 API and internal documentation for MATIO library.
120
121 %description apidocs -l pl.UTF-8
122 Dokumentacja API biblioteki MATIO.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127
128 %build
129 %{__libtoolize}
130 %{__aclocal} -I config
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         %{?with_fortran:--enable-fortran} \
136         %{!?with_hdf5:--disable-mat73}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmatio.la
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc COPYING NEWS README
157 %attr(755,root,root) %{_bindir}/matdump
158 %attr(755,root,root) %{_libdir}/libmatio.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libmatio.so.13
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libmatio.so
164 %{_includedir}/matio*.h
165 %{_pkgconfigdir}/matio.pc
166 %{_mandir}/man3/Mat_*.3*
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libmatio.a
171
172 %if %{with fortran}
173 %files fortran
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libmatio-fortran.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libmatio-fortran.so.2
177
178 %files fortran-devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libmatio-fortran.so
181 %{_libdir}/libmatio-fortran.la
182 %{_includedir}/matio.mod
183
184 %files fortran-static
185 %defattr(644,root,root,755)
186 %{_libdir}/libmatio-fortran.a
187 %endif
188
189 %if %{with apidocs}
190 %files apidocs
191 %defattr(644,root,root,755)
192 %doc doxygen/latex/libmatio.pdf
193 %endif
This page took 1.761115 seconds and 3 git commands to generate.