]> git.pld-linux.org Git - packages/caja.git/blob - mate-file-manager.spec
4f2b88ea3dad3e4dff802d445ce022ad166922f2
[packages/caja.git] / mate-file-manager.spec
1 # TODO
2 # -extensions not optional:
3 # mate-file-manager-1.5.2-0.2.i686: required "libcaja-extension.so.1" is provided by the following packages:
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # disable gtk-doc
7
8 Summary:        File manager for MATE
9 Name:           mate-file-manager
10 Version:        1.6.0
11 Release:        1
12 License:        GPL v2+ and LGPL v2+
13 Group:          X11/Applications
14 Source0:        http://pub.mate-desktop.org/releases/1.6/%{name}-%{version}.tar.xz
15 # Source0-md5:  bd668ecdfb3de2616bb08420f38df17c
16 URL:            http://wiki.mate-desktop.org/mate-file-manager
17 BuildRequires:  cairo-gobject-devel
18 BuildRequires:  dbus-glib-devel
19 BuildRequires:  desktop-file-utils
20 BuildRequires:  exempi-devel
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel
23 BuildRequires:  libexif-devel
24 BuildRequires:  libselinux-devel
25 BuildRequires:  libunique-devel
26 BuildRequires:  libxml2-devel
27 BuildRequires:  mate-common
28 BuildRequires:  mate-desktop-devel
29 %{?with_apidocs:BuildRequires:  mate-doc-utils >= 1.1.0}
30 BuildRequires:  pangox-compat-devel
31 BuildRequires:  startup-notification-devel
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xorg-lib-libSM-devel
34 BuildRequires:  xz
35 Requires:       %{name}-extensions = %{version}-%{release}
36 Requires:       filesystem
37 Requires:       gamin
38 Requires:       glib2 >= 1:2.28.0
39 Requires:       gsettings-desktop-schemas
40 Requires:       gtk-update-icon-cache
41 Requires:       gvfs
42 Requires:       hicolor-icon-theme
43 Requires:       mate-icon-theme
44 #Requires:      redhat-menus
45 Requires:       shared-mime-info
46 Suggests:       mate-backgrounds
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Caja (mate-file-manager) is the file manager and graphical shell for
51 the MATE desktop, that makes it easy to manage your files and the rest
52 of your system. It allows to browse directories on local and remote
53 file systems, preview files and launch applications associated with
54 them. It is also responsible for handling the icons on the MATE
55 desktop.
56
57 %package extensions
58 Summary:        Mate-file-manager extensions library
59 License:        LGPL v2+
60 Group:          Development/Libraries
61
62 %description extensions
63 This package provides the libraries used by caja extensions.
64
65 %package devel
66 Summary:        Support for developing mate-file-manager extensions
67 License:        LGPL v2+
68 Group:          Development/Libraries
69 Requires:       %{name}-extensions = %{version}-%{release}
70
71 %description devel
72 This package provides libraries and header files needed for developing
73 caja extensions.
74
75 %package apidocs
76 Summary:        libcaja API documentation
77 Summary(pl.UTF-8):      Dokumentacja API libcaja
78 Group:          Documentation
79 Requires:       gtk-doc-common
80
81 %description apidocs
82 libcaja API documentation.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API libcaja.
86
87 %prep
88 %setup -q
89
90 %build
91 NOCONFIGURE=1 ./autogen.sh
92 %configure \
93         --with-html-dir=%{_gtkdocdir} \
94         --disable-static \
95         --enable-unique \
96         --disable-update-mimedb \
97         --disable-schemas-compile \
98         --with-gnu-ld \
99         --with-x \
100         --with-gtk=2.0
101
102 %{__make} \
103         V=1
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 %{__make} install \
108         INSTALL="install -p" \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 find $RPM_BUILD_ROOT -name '*.la' |xargs rm
112
113 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
114 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/caja.convert
115
116 install -d $RPM_BUILD_ROOT%{_libdir}/caja/extensions-2.0
117
118 desktop-file-install \
119         --delete-original \
120         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
121 $RPM_BUILD_ROOT%{_desktopdir}/*.desktop
122
123 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/io
124 %find_lang caja
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post
130 %update_mime_database
131 %update_icon_cache hicolor
132 %glib_compile_schemas
133
134 %postun
135 %update_mime_database
136 %update_icon_cache hicolor
137 %glib_compile_schemas
138
139 %post   extensions -p /sbin/ldconfig
140 %postun extensions -p /sbin/ldconfig
141
142 %files  -f caja.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS NEWS README
145 %attr(755,root,root) %{_bindir}/caja
146 %attr(755,root,root) %{_bindir}/caja-autorun-software
147 %attr(755,root,root) %{_bindir}/caja-connect-server
148 %attr(755,root,root) %{_bindir}/caja-file-management-properties
149 %{_mandir}/man1/caja*.1.*
150 %{_datadir}/caja
151 %dir %{_libdir}/caja
152 %dir %{_libdir}/caja/extensions-2.0
153 %{_pixmapsdir}/caja/
154 %{_desktopdir}/*.desktop
155 %{_iconsdir}/hicolor/*/apps/caja.png
156 %{_iconsdir}/hicolor/scalable/apps/caja.svg
157 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
158 %{_datadir}/dbus-1/services/org.mate.freedesktop.FileManager1.service
159 %{_libexecdir}/caja-convert-metadata
160 %{_datadir}/mime/packages/caja.xml
161
162 %files extensions
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libcaja-extension.so.*.*.*
165 %ghost %{_libdir}/libcaja-extension.so.1
166 %{_libdir}/girepository-1.0/Caja-2.0.typelib
167
168 %files devel
169 %defattr(644,root,root,755)
170 %{_libdir}/libcaja-extension.so
171 %{_includedir}/caja
172 %{_pkgconfigdir}/libcaja-extension.pc
173 %{_datadir}/gir-1.0/Caja-2.0.gir
174
175 %if %{with apidocs}
176 %files apidocs
177 %defattr(644,root,root,755)
178 %{_gtkdocdir}/libcaja-extension
179 %endif
This page took 0.065858 seconds and 3 git commands to generate.