]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
- some fixes
[packages/lxc.git] / lxc.spec
1 Summary:        Linux Container Tools
2 Name:           lxc
3 Version:        0.4.0
4 Release:        1
5 License:        GPL
6 Group:          Base
7 Source0:        http://dl.sourceforge.net/lxc/%{name}-%{version}.tar.gz
8 # Source0-md5:  327f0e700858ab5b916aa36517680256
9 URL:            http://sourceforge.net/projects/lxc
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libtool
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Tools to create and manage containers. It contains a full featured
17 container with the isolation / virtualization of the pids, the ipc,
18 the utsname, the mount points, /proc, /sys, the network and it takes
19 into account the control groups. It is very light, flexible, and
20 provides a set of tools around the container like the monitoring with
21 asynchronous events notification, or the freeze of the container. This
22 package is useful to create Virtual Private Server, or to run isolated
23 applications like bash or sshd.
24
25 %package devel
26 Summary:        Header files and develpment documentation for lxc
27 Group:          Development/Libraries
28 Requires:       %{name} = %{epoch}:%{version}-%{release}
29
30 %description devel
31 lxc development files.
32
33 %package static
34 Summary:        Static lxc library
35 Group:          Development/Libraries
36 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
37
38 %description static
39 Static lxc library.
40
41 %prep
42 %setup -q
43 sed -i -e 's#^lxcpath=.*#lxcpath=/var/lxc#g' src/lxc/Makefile.am
44
45 %build
46 %{__libtoolize}
47 %{__aclocal}
48 %{__autoconf}
49 %{__automake}
50 %configure
51
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT/var/lxc
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS ChangeLog README etc/*.conf etc/*-config
71 %attr(755,root,root) %{_bindir}/*
72 %attr(755,root,root) %{_libdir}/liblxc-*.so
73 %dir %{_sysconfdir}/lxc
74 %dir /var/lxc
75
76 %files devel
77 %defattr(644,root,root,755)
78 %{_includedir}/lxc
79 %attr(755,root,root) %{_libdir}/liblxc.so
80 %{_libdir}/lib*.la
81
82 %files static
83 %defattr(644,root,root,755)
84 %{_libdir}/lib*.a
This page took 0.030011 seconds and 4 git commands to generate.