]> git.pld-linux.org Git - packages/luajit.git/blob - luajit.spec
always pass multilib param
[packages/luajit.git] / luajit.spec
1 Summary:        Just-in-Time compiler for Lua
2 Summary(pl.UTF-8):      Kompilator JIT dla języka Lua
3 Name:           luajit
4 Version:        2.0.3
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 # Source0Download: http://luajit.org/download.html
9 Source0:        http://luajit.org/download/LuaJIT-%{version}.tar.gz
10 # Source0-md5:  f14e9104be513913810cd59c8c658dc0
11 URL:            http://luajit.org/
12 BuildRequires:  sed >= 4.0
13 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         lua_abi         5.1
17
18 %description
19 LuaJIT is a Just-In-Time (JIT) compiler for the Lua programming
20 language.
21
22 %description -l pl.UTF-8
23 LuaJIT to działający w locie (Just-In-Time) kompilator języka Lua.
24
25 %package devel
26 Summary:        Header files for LuaJIT library
27 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LuaJIT
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for LuaJIT library.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe biblioteki LuaJIT.
36
37 %package static
38 Summary:        Static LuaJIT library
39 Summary(pl.UTF-8):      Statyczna biblioteka LuaJIT
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}-%{release}
42
43 %description static
44 Static LuaJIT library.
45
46 %description static -l pl.UTF-8
47 Statyczna biblioteka LuaJIT.
48
49 %prep
50 %setup -q -n LuaJIT-%{version}
51
52 # preserve timestamps
53 sed -i -e '/install -m/s/-m/-p -m/' Makefile
54
55 %build
56 # Q= - enable verbose output
57 # E= @: - disable @echo messages
58 %{__make} \
59         CC="%{__cc}" \
60         CCOPT="%{rpmcflags} -fomit-frame-pointer" \
61         CCOPT_x86= \
62         MULTILIB=%{_lib} \
63         E="@:" \
64         Q=
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT \
70         PREFIX=%{_prefix} \
71         MULTILIB=%{_lib} \
72         LDCONFIG="/sbin/ldconfig -n"
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc COPYRIGHT README
83 %attr(755,root,root) %{_bindir}/luajit
84 %attr(755,root,root) %{_bindir}/luajit-%{version}
85 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libluajit-%{lua_abi}.so.2
87 %{_datadir}/luajit-%{version}
88 %{_mandir}/man1/luajit.1*
89 # lua module dirs (shared with lua interpreters)
90 %dir %{_libdir}/lua
91 %dir %{_libdir}/lua/%{lua_abi}
92 %dir %{_datadir}/lua
93 %dir %{_datadir}/lua/%{lua_abi}
94
95 %files devel
96 %defattr(644,root,root,755)
97 %doc doc/*
98 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so
99 %{_includedir}/luajit-2.0
100 %{_pkgconfigdir}/luajit.pc
101
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libluajit-%{lua_abi}.a
This page took 0.072829 seconds and 4 git commands to generate.