]> git.pld-linux.org Git - SPECS.git/blob - lua-luaXML.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / lua-luaXML.spec
1 %define luadir  /lua/5.1
2 Summary:        LuaXML provides a minimal set of functions for the processing of XML data in Lua
3 Name:           lua-luaXML
4 Version:        1.7.2
5 Release:        0.1
6 License:        BSD-like
7 Group:          Development/Languages
8 Source0:        http://www.viremo.de/LuaXML/LuaXML_090910.zip
9 # Source0-md5:  de690d73a34bdc7d3b4f0307a40afd87
10 URL:            http://www.viremo.de/LuaXML/
11 BuildRequires:  lua51-devel
12 BuildRequires:  pkgconfig
13 BuildRequires:  unzip
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         specflags       -fPIC
17
18 %description
19 LuaXML provides a minimal set of functions for the processing of XML
20 data in Lua.
21
22 %prep
23 %setup -q -c
24
25 %build
26 %{__make} \
27         CC="%{__cc}" \
28         CFLAGS="%{rpmcppflags} %{rpmcflags} $(pkg-config --cflags lua51)" \
29         LIBS="%{rpmcflags} %{rpmldflags} $(pkg-config --libs lua51)"
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT%{_datadir}%{luadir}
34 install -d $RPM_BUILD_ROOT%{_libdir}%{luadir}
35
36 install LuaXML_lib.so $RPM_BUILD_ROOT%{_libdir}%{luadir}
37 install LuaXml.lua $RPM_BUILD_ROOT%{_datadir}%{luadir}
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc readme.txt test.lua test.xml
45 %{_datadir}%{luadir}/LuaXml.lua
46 %attr(755,root,root) %{_libdir}%{luadir}/LuaXML_lib.so
This page took 0.404968 seconds and 3 git commands to generate.