]> git.pld-linux.org Git - SPECS.git/blob - longomatch.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / longomatch.spec
1 Summary:        LongoMatch - video analysis tool oriented to sports and coaches
2 Summary(pl.UTF-8):      LongoMatch - narzędzie do analizy obrazu zorientowane na sport i treningi
3 Name:           longomatch
4 Version:        1.0.2
5 Release:        1
6 License:        GPL v2+
7 Group:          X11/Applications/Video
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/longomatch/1.0/%{name}-%{version}.tar.xz
9 # Source0-md5:  f73267559c704e7505e9423af383269f
10 Patch0:         %{name}-missing.patch
11 URL:            http://www.longomatch.com/open-source/
12 BuildRequires:  autoconf >= 2.54
13 BuildRequires:  automake >= 1:1.11
14 #TODO: pkgconfig(db4o) ???
15 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.0
16 BuildRequires:  dotnet-newtonsoft-json-devel
17 BuildRequires:  gettext-tools
18 BuildRequires:  glib2-devel >= 2.0
19 BuildRequires:  gstreamer0.10-devel >= 0.10
20 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10
21 BuildRequires:  gtk+2-devel >= 2:2.8
22 BuildRequires:  intltool >= 0.40.0
23 BuildRequires:  libtool
24 BuildRequires:  mono-addins-devel
25 BuildRequires:  mono-devel >= 2.8
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires(post,postun):  /sbin/ldconfig
30 Requires(post,postun):  gtk-update-icon-cache
31 Requires:       gtk+2 >= 2:2.8
32 Requires:       hicolor-icon-theme
33 Requires:       mono >= 2.8
34 Requires:       mono-addins
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 LongoMatch is a video analysis tool oriented to sports and coaches, to
39 assist them on making game video analysis. It simplifies video
40 analysis by providing a set of intuitive tools to tag, review and edit
41 the most important plays of the game. It allows to group plays by
42 categories and adjust the lead and lag time of each play frame by
43 frame through a timeline. It also has support for playlists, an easy
44 way to create presentations with plays from different games and
45 provides a video editor to create new videos from your favorite plays.
46 Even if primary focused to sports, LongoMatch can be used for any task
47 that requires tagging and reviewing segments of a video file, and can
48 be applied to fields like cinema, medics or conferences.
49
50 %description -l pl.UTF-8
51 LongoMatch to narzędzie do analizy obrazu zorientowane na sporty i
52 treningi, mające pomagać w analizie nagrań z rozgrywek. Upraszcza
53 analizę obrazu dostarczając zbiór intuicyjnych narzędzi do oznaczania,
54 przeglądania i edycji najważniejszych partii rozgrywek. Pozwala na
55 grupowanie rozgrywek po kategoriach i regulować czas trwania akcji i
56 oczekiwania ramka po ramce. LongoMatch ma także obsługę list
57 odtwarzania, łatwy sposób tworzenia prezentacji z partiami z różnych
58 rozgrywek oraz edytor obrazu do tworzenia nowych filmów z ulubionymi
59 rozgrywkami. Mimo że LongoMatch jest pomyślany głównie z myślą o
60 sporcie, może być używany do dowolnych zadań wymagających oznaczania
61 oraz przeglądania fragmentów pliku wideo; może mieć zastosowanie w
62 kinie, medycynie czy przy konferencjach.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal} -I build/m4 -I build/m4/shamrock
71 %{__autoconf}
72 %{__automake}
73 %configure \
74         --disable-silent-rules \
75         --disable-static
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 # C API not exported
86 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcesarplayer.{la,so}
87
88 %find_lang %{name}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 /sbin/ldconfig
95 %update_icon_cache hicolor
96
97 %postun
98 /sbin/ldconfig
99 %update_icon_cache hicolor
100
101 %files -f %{name}.lang
102 %defattr(644,root,root,755)
103 %doc AUTHORS COPYING ChangeLog NEWS README
104 %attr(755,root,root) %{_bindir}/longomatch
105 %attr(755,root,root) %{_libdir}/libcesarplayer.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libcesarplayer.so.0
107 %dir %{_libdir}/longomatch
108 %{_libdir}/longomatch/LongoMatch.exe
109 %{_libdir}/longomatch/LongoMatch.exe.mdb
110 %{_libdir}/longomatch/LongoMatch.*.dll
111 %{_libdir}/longomatch/LongoMatch.*.dll.config
112 %{_libdir}/longomatch/LongoMatch.*.dll.mdb
113 %{_libdir}/longomatch/OxyPlotMono.dll
114 %{_libdir}/longomatch/OxyPlotMono.dll.mdb
115 %dir %{_libdir}/longomatch/plugins
116 %{_libdir}/longomatch/plugins/LongoMatch.Plugins.dll
117 %{_libdir}/longomatch/plugins/LongoMatch.Plugins.dll.mdb
118 %{_libdir}/longomatch/plugins/LongoMatch.Plugins.*.dll
119 %{_libdir}/longomatch/plugins/LongoMatch.Plugins.*.dll.mdb
120 %{_datadir}/longomatch
121 %{_desktopdir}/longomatch.desktop
122 %{_iconsdir}/hicolor/48x48/apps/longomatch.png
123 %{_iconsdir}/hicolor/scalable/apps/longomatch.svg
124
125 %if 0
126 %package devel
127 # not needed for now; when packaging, use:
128 #Requires:      dotnet-gtk-sharp2-devel >= 2.0
129 #Requires:      dotnet-newtonsoft-json-devel
130 #Requires:      mono-addins-devel
131 %{_pkgconfigdir}/longomatch-addins.pc
132 %{_pkgconfigdir}/longomatch-core.pc
133 %{_pkgconfigdir}/longomatch-drawing.pc
134 %{_pkgconfigdir}/longomatch-drawing-cairo.pc
135 %{_pkgconfigdir}/longomatch-gui.pc
136 %{_pkgconfigdir}/longomatch-gui-helpers.pc
137 %{_pkgconfigdir}/longomatch-oxyplot.pc
138 %endif
This page took 0.107692 seconds and 3 git commands to generate.