]> git.pld-linux.org Git - SPECS.git/blob - logg.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / logg.spec
1 # TODO:
2 # - binary files play_ogg and stream_ogg don't work properly - check it
3
4 Summary:        Library for playing Ogg/Vorbis audio files
5 Summary(pl.UTF-8):      Biblioteka do odtwarzania plików dźwiękowych Ogg/Vorbis
6 Name:           logg
7 Version:        2.9
8 Release:        0.1
9 License:        MIT
10 Group:          Development/Tools
11 Source0:        http://trent.gamblin.ca/logg/%{name}-%{version}.zip
12 # Source0-md5:  9bf15529a30624ed13a81cd7c4249ca0
13 Patch0:         %{name}-Makefile.patch
14 URL:            http://trent.gamblin.ca/logg/
15 BuildRequires:  allegro-devel >= 4.4.0
16 BuildRequires:  libvorbis-devel
17 BuildRequires:  unzip
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 LOGG is an Allegro add-on library for playing Ogg/Vorbis audio files.
22 It can load Ogg/Vorbis files as Allegro SAMPLEs, or it can stream them
23 from disk to save memory.
24
25 %description -l pl.UTF-8
26 LOGG jest dodatkową biblioteką do odtwarzania plików dźwiękowych
27 Ogg/Vorbis. Potrafi ona wczytywać pliki Ogg/Vorbis jako SAMPLE Allegro
28 lub przesyłać je strumieniem z dysku w celu zaoszczędzenia pamięci.
29
30 %package devel
31 Summary:        Header files for LOGG
32 Summary(pl.UTF-8):      Pliki nagłówkowe LOGG
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       allegro-devel
36 Requires:       libstdc++-devel
37 Requires:       libvorbis-devel
38
39 %description devel
40 Header files for LOGG.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe LOGG.
44
45 %package static
46 Summary:        logg static library
47 Summary(pl.UTF-8):      Biblioteka statyczna LOGG
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 LOGG static library.
53
54 %description static -l pl.UTF-8
55 Biblioteka statyczna LOGG.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 %{__make} -j1 -f Makefile.unix \
63         CC="%{__cc}" \
64         FLAGS="%{rpmcflags}" \
65         LDFLAGS="%{rpmldflags}"
66
67 %{__cc} %{rpmcflags} -fPIC -c logg.c
68 %{__cc} -shared %{rpmldflags} %{rpmcflags} -o liblogg.so logg.o -lvorbisfile `allegro-config --libs`
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
73
74 %{__make} -f Makefile.unix install \
75         DESTDIR=$RPM_BUILD_ROOT \
76         LIBDIR="%{_libdir}"
77
78 install *_ogg $RPM_BUILD_ROOT%{_bindir}
79 install liblogg.so $RPM_BUILD_ROOT%{_libdir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/liblogg.so
87 %attr(755,root,root) %{_bindir}/play_ogg
88 %attr(755,root,root) %{_bindir}/stream_ogg
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/logg.h
93
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/liblogg.a
This page took 0.176529 seconds and 3 git commands to generate.