]> git.pld-linux.org Git - packages/logcheck.git/blob - logcheck.spec
- updated to 1.3.1
[packages/logcheck.git] / logcheck.spec
1 Summary:        Mails anomalies in the system logfiles to the administrator
2 Summary(pl.UTF-8):      Wysyłanie anomalii w logach systemowych pocztą do administratora
3 Name:           logcheck
4 Version:        1.3.1
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        http://ftp.debian.org/debian/pool/main/l/logcheck/%{name}_%{version}.tar.gz
9 # Source0-md5:  1b000602ef86eebc30a60340484d79d7
10 Patch0:         %{name}-pld.patch
11 Patch1:         %{name}-command_correct.patch
12 Source1:        %{name}.cron
13 URL:            http://logcheck.alioth.debian.org/
14 BuildRequires:  rpmbuild(macros) >= 1.202
15 Requires(postun):       /usr/sbin/groupdel
16 Requires(postun):       /usr/sbin/userdel
17 Requires(pre):  /bin/id
18 Requires(pre):  /usr/bin/getgid
19 Requires(pre):  /usr/sbin/groupadd
20 Requires(pre):  /usr/sbin/useradd
21 Requires:       %{name}-database = %{version}-%{release}
22 Requires:       /bin/mail
23 Requires:       crondaemon
24 Requires:       lockfile-progs
25 Requires:       logtail = %{version}-%{release}
26 Requires:       mktemp
27 #Suggests:      /usr/bin/syslog-summary
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _sysconfdir     /etc/logcheck
32
33 %description
34 Logcheck is a simple utility which is designed to allow a system
35 administrator to view the logfiles which are produced upon hosts under
36 their control.
37
38 It does this by mailing summaries of the logfiles to them, after first
39 filtering out "normal" entries.
40
41 Normal entries are entries which match one of the many included
42 regular expression files contain in the database.
43
44 Logcheck was part of the Abacus Project of security tools, but this
45 version has been rewritten.
46
47 %description -l pl.UTF-8
48 logcheck to proste narzędzie zaprojektowane aby umożliwić
49 administratorowi systemu oglądanie plików logów tworzonych przez
50 maszyny, które ma pod kontrolą.
51
52 Wykonuje to poprzez wysyłanie pocztą elektroniczną do administratora
53 podsumowań plików logów po odfiltrowaniu "zwykłych" wpisów.
54
55 Zwykłe wpisy to wpisy pasujące do jednego z wielu załączonych plików
56 wyrażeń regularnych zawartych w bazie danych.
57
58 logcheck był częścią projektu Abacus z narzędziami związanymi z 
59 bezpieczeństwem, ale ta wersja została przepisana.
60
61 %package database
62 Summary:        Database of system log rules for the use of log checkers
63 Summary(pl.UTF-8):      Baza danych reguł loga systemowego do używania z narzędziami sprawdzającymi logi
64 Group:          Applications/System
65
66 %description database
67 This database is part of the Logcheck package, but might be used by
68 others. It brings a database of regular expressions for matching
69 system log entries after various criteria.
70
71 %description database -l pl.UTF-8
72 Ta baza danych jest częścią pakietu logcheck, ale może być używana
73 przez inne programy. Zawiera wyrażenia regularne do dopasowywania
74 wpisów logów systemowych z użyciem różnych kryteriów.
75
76 %package -n logtail
77 Summary:        Print log file lines that have not been read
78 Summary(pl.UTF-8):      Wypisywanie nieprzeczytanych linii pliku loga
79 Group:          Applications/System
80 Obsoletes:      retail
81
82 %description -n logtail
83 This program will read in a standard text file and create an offset
84 marker when it reads the end. The offset marker is read the next time
85 logtail is run and the text file pointer is moved to the offset
86 location. This allows logtail to read in the next lines of data
87 following the marker. This is good for marking log files for automatic
88 log file checkers to monitor system events.
89
90 This program is mainly used by logcheck, because it returns only parts
91 of the system logfiles that have not already been checked.
92
93 %description -n logtail -l pl.UTF-8
94 Ten program czyta standardowy plik tekstowy, a po doczytaniu do końca
95 tworzy znacznik offsetu. Przy następnym uruchomieniu logtaila
96 odczytywany jest znacznik offsetu i wskaźnik tekstu jest przesuwany do
97 tego offsetu. Pozwala to logtailowi czytać kolejne linie danych za
98 znacznikiem. Jest to dobre narzędzie do oznaczania plików logów dla
99 narzędzi do automatycznego sprawdzania plików logów i monitorowania
100 zdarzeń systemowych.
101
102 Ten program jest używany głównie przez logcheck, ponieważ zwraca tylko
103 te części plików logów systemowych, które nie zostały jeszcze
104 przeczytane.
105
106 %prep
107 %setup -q -n %{name}
108 %patch0 -p1
109 %patch1 -p1
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/cron.d,%{_sbindir},%{_bindir}}
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/%{name}
119
120 mv $RPM_BUILD_ROOT{%{_sbindir},%{_bindir}}/logtail
121 mv $RPM_BUILD_ROOT{%{_sbindir},%{_bindir}}/logtail2
122
123 cat <<'EOF'> $RPM_BUILD_ROOT%{_sysconfdir}/header.txt
124 This email is sent by logcheck. If you wish to no-longer receive it,
125 you can either deinstall the logcheck package or modify its
126 configuration file (%{_sysconfdir}/logcheck.conf).
127 EOF
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %pre
133 %groupadd -g 173 %{name}
134 %useradd -u 173 -d /var/lib/%{name} -g logcheck -c "Logcheck User" %{name}
135
136 %postun
137 if [ "$1" = "0" ]; then
138         %userremove %{name}
139         %groupremove %{name}
140 fi
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS CHANGES CREDITS TODO
145 %doc docs/README.{how.to.interpret,keywords,logcheck,Maintainer} docs/tools/log-summary-ssh
146 %attr(710,root,logcheck) %dir %{_sysconfdir}
147 %dir %attr(2750,root,logcheck) %{_sysconfdir}/cracking.d
148 %dir %attr(2750,root,logcheck) %{_sysconfdir}/cracking.ignore.d
149 %dir %attr(2750,root,logcheck) %{_sysconfdir}/violations.d
150 %dir %attr(2750,root,logcheck) %{_sysconfdir}/violations.ignore.d
151 %dir %attr(2750,root,logcheck) %{_sysconfdir}/ignore.d.workstation
152 %dir %attr(2750,root,logcheck) %{_sysconfdir}/ignore.d.server
153 %dir %attr(2750,root,logcheck) %{_sysconfdir}/ignore.d.paranoid
154 %attr(640,root,logcheck) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/logcheck.conf
155 %attr(640,root,logcheck) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/logcheck.logfiles
156 %attr(640,root,logcheck) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/header.txt
157 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
158 %attr(755,root,root) %{_sbindir}/logcheck
159 %dir %attr(770,root,logcheck) /var/lib/logcheck
160 %dir %attr(770,root,logcheck) /var/lock/logcheck
161
162 %files database
163 %defattr(644,root,root,755)
164 %config %verify(not md5 mtime size) %{_sysconfdir}/cracking.d/*
165 %config %verify(not md5 mtime size) %{_sysconfdir}/violations.d/*
166 %config %verify(not md5 mtime size) %{_sysconfdir}/violations.ignore.d/*
167 %config %verify(not md5 mtime size) %{_sysconfdir}/ignore.d.workstation/*
168 %config %verify(not md5 mtime size) %{_sysconfdir}/ignore.d.server/*
169 %config %verify(not md5 mtime size) %{_sysconfdir}/ignore.d.paranoid/*
170
171 %files -n logtail
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/logtail*
174 %{_datadir}/logtail
This page took 0.036437 seconds and 3 git commands to generate.