]> git.pld-linux.org Git - SPECS.git/blob - lmms.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / lmms.spec
1
2 %define         rpmalloc_version 1.3.0
3 %define         qt5_x11embed_version 022b39a1d496d72eb3e5b5188e5559f66afca957
4
5 %define         _rc     rc7
6 %define         rel     1
7
8 Summary:        Linux MultiMedia Studio
9 Summary(pl.UTF-8):      MultiMedialne Studio Linuksa
10 Name:           lmms
11 Version:        1.2.0
12 Release:        0.%{_rc}.%{rel}
13 License:        GPL V2
14 Group:          X11/Applications/Sound
15 Source0:        https://github.com/LMMS/lmms/archive/v%{version}-%{_rc}/%{name}-%{version}-%{_rc}.tar.gz
16 # Source0-md5:  4d527a7f4fc38b105eac55fbd49cf2bb
17 Source1:        https://github.com/rampantpixels/rpmalloc/archive/%{rpmalloc_version}/rpmalloc-%{rpmalloc_version}.tar.gz
18 # Source1-md5:  95109beaddeaafd20345ebe4e10c76ba
19 Source2:        https://github.com/Lukas-W/qt5-x11embed/archive/%{qt5_x11embed_version}/qt5-x11embed-%{qt5_x11embed_version}.tar.gz
20 # Source2-md5:  193f7a94d1af51c2f85628fcbbf2bf49
21 Patch0:         fluidsynth2.patch
22 Patch1:         bash_completion_install.patch
23 URL:            https://lmms.io/
24 BuildRequires:  Carla-devel >= 2.0-0.rc2.3
25 BuildRequires:  Mesa-libGL-devel
26 BuildRequires:  Qt5Core-devel
27 BuildRequires:  Qt5Gui-devel
28 BuildRequires:  Qt5Xml-devel
29 BuildRequires:  Qt5X11Extras-devel
30 BuildRequires:  SDL-devel
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  cmake
33 BuildRequires:  fftw3-single-devel >= 3.0.0
34 BuildRequires:  fluidsynth-devel >= 1.0.7
35 BuildRequires:  jack-audio-connection-kit-devel
36 BuildRequires:  kf5-extra-cmake-modules
37 BuildRequires:  lame-libs-devel
38 BuildRequires:  libgig-devel
39 BuildRequires:  libogg-devel
40 BuildRequires:  libsamplerate-devel >= 0.1.8
41 BuildRequires:  libsndfile-devel >= 1.0.11
42 BuildRequires:  libvorbis-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  portaudio-devel
45 BuildRequires:  pulseaudio-devel
46 BuildRequires:  qt5-build
47 BuildRequires:  qt5-qmake
48 BuildRequires:  xorg-lib-libXft-devel
49 # the VSD loader requires 32-bit devel files
50 #BuildRequires: wine-devel
51 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 LMMS is a free cross-platform program, which allow you to produce
56 music with your computer.
57
58 %description -l pl.UTF-8
59 LMMS to wolny, międzyplatformowy program, który pozwoli Tobie tworzyć
60 muzykę na komputerze.
61
62 %package devel
63 Summary:        LMMS header files
64 Summary(pl.UTF-8):      Pliki nagłówkowe LMMS
65 Group:          Development/Libraries
66 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
67
68 %description devel
69 The header files for LMMS.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe dla LMMS.
73
74 %package libs
75 Summary:        LMMS library
76 Summary(pl.UTF-8):      Biblioteka LMMS
77 Group:          X11/Applications/Sound
78
79 %description libs
80 LMMS library.
81
82 %description libs -l pl.UTF-8
83 Biblioteka LMMS.
84
85 %prep
86 %setup -q -n %{name}-%{version}-%{_rc} -a1 -a2
87
88 rmdir src/3rdparty/rpmalloc/rpmalloc
89 ln -s ../../../rpmalloc-%{rpmalloc_version} src/3rdparty/rpmalloc/rpmalloc
90
91 rmdir src/3rdparty/qt5-x11embed
92 ln -s ../../qt5-x11embed-%{qt5_x11embed_version} src/3rdparty/qt5-x11embed
93
94 rmdir qt5-x11embed-%{qt5_x11embed_version}/3rdparty/ECM
95 ln -s %{_datadir}/ECM qt5-x11embed-%{qt5_x11embed_version}/3rdparty/ECM
96
97 %patch0 -p1
98 %patch1 -p1
99
100 %build
101 install -d build
102 cd build
103 %cmake .. \
104         -DWANT_QT5=ON \
105         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
106         -DWANT_VST_NOWINE=ON \
107 %if "%{_lib}" == "lib64"
108         -DLIB_SUFFIX=64
109 %endif
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} -C build install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 rm -r $RPM_BUILD_ROOT%{_iconsdir}/hicolor/*@2/*/*
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   libs -p /sbin/ldconfig
125 %postun libs -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %attr(755,root,root)%{_bindir}/lmms
130 %{_desktopdir}/lmms.desktop
131 %{_mandir}/man1/lmms.1*
132 %{_datadir}/mime/packages/lmms.xml
133 %{_datadir}/lmms
134 %{_iconsdir}/hicolor/*/apps/lmms.png
135 %{_iconsdir}/hicolor/*/mimetypes/application-x-lmms-project.png
136 %{_iconsdir}/hicolor/*/apps/lmms.svg
137 %{_iconsdir}/hicolor/*/mimetypes/application-x-lmms-project.svg
138 %{bash_compdir}/lmms
139
140 %files devel
141 %defattr(644,root,root,755)
142 %{_includedir}/lmms
143 %{_libdir}/libqx11embedcontainer.a
144
145 %files libs
146 %defattr(644,root,root,755)
147 %dir %{_libdir}/lmms
148 %attr(755,root,root)%{_libdir}/lmms/*.so
149 %attr(755,root,root)%{_libdir}/lmms/RemoteZynAddSubFx
150 %dir %{_libdir}/lmms/ladspa
151 %attr(755,root,root)%{_libdir}/lmms/ladspa/*.so
This page took 0.212081 seconds and 3 git commands to generate.