]> git.pld-linux.org Git - SPECS.git/blob - llvm-libunwind.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / llvm-libunwind.spec
1 Summary:        LLVM libunwind implementation
2 Summary(pl.UTF-8):      Implementacja biblioteki libunwind z projektu LLVM
3 Name:           llvm-libunwind
4 Version:        11.0.1
5 Release:        1
6 License:        BSD-like or MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/llvm/llvm-project/releases/
9 Source0:        https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/libunwind-%{version}.src.tar.xz
10 # Source0-md5:  b030a6d5807d797e505e4fbd32a36c2a
11 URL:            http://llvm.org/
12 BuildRequires:  cmake >= 3.4.3
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  llvm-devel >= %{version}
15 BuildRequires:  rpmbuild(macros) >= 1.605
16 BuildRequires:  tar >= 1:1.22
17 BuildRequires:  xz
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 LLVM libunwind implementation.
22
23 %description -l pl.UTF-8
24 Implementacja biblioteki libunwind z projektu LLVM.
25
26 %package devel
27 Summary:        Header file for LLVM libunwind implementation
28 Summary(pl.UTF-8):      Plik nagłówkowy implementacji LLVM libunwind
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 Header file for LLVM libunwind implementation.
34
35 %description devel -l pl.UTF-8
36 Plik nagłówkowy implementacji LLVM libunwind.
37
38 %package static
39 Summary:        Static LLVM libunwind library
40 Summary(pl.UTF-8):      Statyczna biblioteka LLVM libunwind
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description static
45 Static LLVM libunwind library.
46
47 %description static -l pl.UTF-8
48 Statyczna biblioteka LLVM libunwind.
49
50 %prep
51 %setup -q -n libunwind-%{version}.src
52
53 %build
54 install -d build
55 cd build
56 %cmake ..
57
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} -C build install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 install -d $RPM_BUILD_ROOT%{_includedir}/llvm-libunwind
67 cp -p include/*.h $RPM_BUILD_ROOT%{_includedir}/llvm-libunwind
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_libdir}/libunwind.so.*.*
78 %attr(755,root,root) %ghost %{_libdir}/libunwind.so.1
79
80 %files devel
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %{_libdir}/libunwind.so
83 %{_includedir}/llvm-libunwind
84
85 %files static
86 %defattr(644,root,root,755)
87 %{_libdir}/libunwind.a
This page took 1.189898 seconds and 3 git commands to generate.