]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
- release 36
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 #
7 # Conditional build:
8 %bcond_without  dist_kernel     # without sources of distribution kernel
9 %bcond_without  kernel          # don't build kernel modules, only library+programs
10 %bcond_without  userspace       # build only packages with kernel modules
11 %bcond_with     svga            # without svgalib-based utility
12 %bcond_without  x               # without X11-based utilitied
13
14 %if %{without kernel}
15 %undefine       with_dist_kernel
16 %endif
17
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21
22 %define         pname   lirc
23 %define         rel     36
24
25 #
26 # main package
27 #
28 # lirc_gpio fails to build under kernel >= 2.6.23
29 #
30 %if "%{_kernel_ver}" >= "2.6.23"
31 %if "%{_kernel_ver}" >= "3.0.0"
32 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
33 %else
34 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
35 %endif
36 %else
37 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
38 %endif
39 Summary:        Linux Infrared Remote Control daemons
40 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
41 Name:           %{pname}%{_alt_kernel}
42 Version:        0.9.0
43 Release:        %{rel}
44 License:        GPL v2+
45 Group:          Daemons
46 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
47 # Source0-md5:  b232aef26f23fe33ea8305d276637086
48 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
49 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
50 Source2:        %{pname}d.sysconfig
51 Source3:        %{pname}d.init
52 Source4:        %{pname}md.init
53 Source5:        %{pname}.tmpfiles
54 Patch0:         %{pname}-opt.patch
55 Patch1:         %{pname}-tmp.patch
56 Patch2:         %{pname}-no-svgalib.patch
57 Patch3:         %{pname}-kernel.patch
58 Patch4:         %{pname}-sparc.patch
59 Patch5:         %{pname}-remotes.patch
60 Patch6:         %{pname}-kernelcc.patch
61 URL:            http://www.lirc.org/
62 BuildRequires:  alsa-lib-devel
63 BuildRequires:  autoconf >= 2.50
64 BuildRequires:  automake
65 BuildRequires:  iguanaIR-devel
66 BuildRequires:  libftdi-devel >= 0.12
67 BuildRequires:  libirman-devel >= 0.4.5
68 BuildRequires:  libtool
69 BuildRequires:  libusb-compat-devel >= 0.1.0
70 %if %{with kernel}
71 BuildRequires:  kernel%{_alt_kernel}-module-build
72 BuildRequires:  kernel%{_alt_kernel}-headers
73 %endif
74 %{?with_kernel:BuildRequires:   %{kgcc_package}}
75 BuildRequires:  rpm-pythonprov
76 BuildRequires:  rpmbuild(macros) >= 1.379
77 %{?with_svga:BuildRequires:     svgalib-devel}
78 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
79 Requires(post,preun):   /sbin/chkconfig
80 Requires:       %{pname}-libs = %{version}-%{release}
81 Requires:       libftdi >= 0.12
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %if %{without userspace}
85 %define         no_spec_install_post_check_tmpfiles     1
86 %endif
87
88 %description
89 LIRC is a package that allows you to decode and send infra-red signals
90 of many (but not all) commonly used remote controls.
91
92 %description -l pl.UTF-8
93 LIRC to program pozwalający na dekodowanie nadchodzących oraz
94 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie
95 wszystkich) popularnych urządzeń do zdalnego sterowania.
96
97 %package remotes
98 Summary:        Lirc remotes database
99 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
100 Group:          Documentation
101 Requires:       %{pname} = %{version}-%{rel}
102
103 %description remotes
104 This package contains configuration files for many remotes supported
105 by lirc.
106
107 %description remotes -l pl.UTF-8
108 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
109 obsługiwanych przez lirc.
110
111 %package X11
112 Summary:        Linux Infrared Remote Control - X11 utilities
113 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
114 Group:          X11/Applications
115 Requires:       %{pname}-libs = %{version}-%{release}
116
117 %description X11
118 Linux Infrared Remote Control - X11 utilities.
119
120 %description X11 -l pl.UTF-8
121 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
122
123 %package svga
124 Summary:        Linux Infrared Remote Control - svgalib utilities
125 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
126 Group:          Applications
127 Requires:       %{pname}-libs = %{version}-%{release}
128
129 %description svga
130 Linux Infrared Remote Control - svgalib-based utilities.
131
132 %description svga -l pl.UTF-8
133 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
134 na svgalibie.
135
136 %package libs
137 Summary:        LIRC libraries
138 Summary(pl.UTF-8):      Biblioteki LIRC
139 Group:          Libraries
140 Conflicts:      lirc < 0.6.3-3
141 # didn't use /tmp/.lircd
142
143 %description libs
144 This package provides the libraries necessary to run lirc client
145 programs.
146
147 %description libs -l pl.UTF-8
148 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
149
150 %package devel
151 Summary:        Header files for LIRC development
152 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
153 Group:          Development/Libraries
154 Requires:       %{pname}-libs = %{version}-%{release}
155
156 %description devel
157 This package provides the files necessary to develop LIRC-based
158 programs.
159
160 %description devel -l pl.UTF-8
161 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych
162 na LIRC.
163
164 %package static
165 Summary:        Static library for LIRC development
166 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
167 Group:          Development/Libraries
168 Requires:       %{pname}-devel = %{version}-%{release}
169
170 %description static
171 The files necessary for development of statically-linked lirc-based
172 programs.
173
174 %description static -l pl.UTF-8
175 Pliki potrzebne do tworzenia łączonych statycznie programów
176 opartych na LIRC.
177
178 %package -n kernel%{_alt_kernel}-char-lirc-atiusb
179 Summary:        Kernel modules for Linux Infrared Remote Control
180 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
181 Release:        %{rel}@%{_kernel_ver_str}
182 Group:          Base/Kernel
183 %if %{with dist_kernel}
184 %requires_releq_kernel
185 Requires(postun):       %releq_kernel
186 %endif
187 Requires(post,postun):  /sbin/depmod
188 Requires:       %{pname} = %{version}-%{rel}
189 Conflicts:      dev < 2.8.0-3
190
191 %description -n kernel%{_alt_kernel}-char-lirc-atiusb
192 This package contains the kernel modules necessary to operate some
193 infrared remote control devices (such as the ones bundled with TV
194 cards).
195
196 lirc_atiusb module.
197
198 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8
199 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
200 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
201
202 Moduł lirc_atiusb.
203
204 %package -n kernel%{_alt_kernel}-char-lirc-bt829
205 Summary:        Kernel modules for Linux Infrared Remote Control
206 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
207 Release:        %{rel}@%{_kernel_ver_str}
208 Group:          Base/Kernel
209 %if %{with dist_kernel}
210 %requires_releq_kernel
211 Requires(postun):       %releq_kernel
212 %endif
213 Requires(post,postun):  /sbin/depmod
214 Requires:       %{pname} = %{version}-%{rel}
215 Conflicts:      dev < 2.8.0-3
216
217 %description -n kernel%{_alt_kernel}-char-lirc-bt829
218 This package contains the kernel modules necessary to operate some
219 infrared remote control devices (such as the ones bundled with TV
220 cards).
221
222 lirc_bt829 module.
223
224 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8
225 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
226 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
227
228 Moduł lirc_bt829.
229
230 %package -n kernel%{_alt_kernel}-char-lirc-dev
231 Summary:        Kernel modules for Linux Infrared Remote Control
232 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
233 Release:        %{rel}@%{_kernel_ver_str}
234 Group:          Base/Kernel
235 %if %{with dist_kernel}
236 %requires_releq_kernel
237 Requires(postun):       %releq_kernel
238 %endif
239 Requires(post,postun):  /sbin/depmod
240 Requires:       %{pname} = %{version}-%{rel}
241 Obsoletes:      lirc-modules
242 Obsoletes:      lirc-modules-dev
243 Conflicts:      dev < 2.8.0-3
244
245 %description -n kernel%{_alt_kernel}-char-lirc-dev
246 This package contains the kernel modules necessary to operate some
247 infrared remote control devices (such as the ones bundled with TV
248 cards).
249
250 lirc_dev module.
251
252 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8
253 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
254 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
255
256 Moduł lirc_dev.
257
258 %package -n kernel%{_alt_kernel}-char-lirc-ene0100
259 Summary:        Kernel modules for Linux Infrared Remote Control
260 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
261 Release:        %{rel}@%{_kernel_ver_str}
262 Group:          Base/Kernel
263 %if %{with dist_kernel}
264 %requires_releq_kernel
265 Requires(postun):       %releq_kernel
266 %endif
267 Requires(post,postun):  /sbin/depmod
268 Requires:       %{pname} = %{version}-%{rel}
269 Obsoletes:      lirc-modules
270 Conflicts:      dev < 2.8.0-3
271
272 %description -n kernel%{_alt_kernel}-char-lirc-ene0100
273 This package contains the kernel modules necessary to operate some
274 infrared remote control ene0100ices (such as the ones bundled with TV
275 cards).
276
277 lirc_ene0100 module.
278
279 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8
280 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
281 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
282
283 Moduł lirc_ene0100.
284
285 %package -n kernel%{_alt_kernel}-char-lirc-gpio
286 Summary:        Kernel modules for Linux Infrared Remote Control
287 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
288 Release:        %{rel}@%{_kernel_ver_str}
289 Group:          Base/Kernel
290 %if %{with dist_kernel}
291 %requires_releq_kernel
292 Requires(postun):       %releq_kernel
293 %endif
294 Requires(post,postun):  /sbin/depmod
295 Requires:       %{pname} = %{version}-%{rel}
296 Obsoletes:      lirc-modules
297 Obsoletes:      lirc-modules-gpio
298 Conflicts:      dev < 2.8.0-3
299
300 %description -n kernel%{_alt_kernel}-char-lirc-gpio
301 This package contains the kernel modules necessary to operate some
302 infrared remote control devices (such as the ones bundled with TV
303 cards).
304
305 lirc_gpio module.
306
307 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8
308 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
309 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
310
311 Moduł lirc_gpio.
312
313 %package -n kernel%{_alt_kernel}-char-lirc-i2c
314 Summary:        Kernel modules for Linux Infrared Remote Control
315 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
316 Release:        %{rel}@%{_kernel_ver_str}
317 Group:          Base/Kernel
318 %if %{with dist_kernel}
319 %requires_releq_kernel
320 Requires(postun):       %releq_kernel
321 %endif
322 Requires(post,postun):  /sbin/depmod
323 Requires:       %{pname} = %{version}-%{rel}
324 Obsoletes:      lirc-modules
325 Obsoletes:      lirc-modules-i2c
326 Conflicts:      dev < 2.8.0-3
327
328 %description -n kernel%{_alt_kernel}-char-lirc-i2c
329 This package contains the kernel modules necessary to operate some
330 infrared remote control devices (such as the ones bundled with TV
331 cards).
332
333 lirc_i2c module.
334
335 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8
336 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
337 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
338
339 Moduł lirc_i2c.
340
341 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb
342 Summary:        Kernel modules for Linux Infrared Remote Control
343 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
344 Release:        %{rel}@%{_kernel_ver_str}
345 Group:          Base/Kernel
346 %if %{with dist_kernel}
347 %requires_releq_kernel
348 Requires(postun):       %releq_kernel
349 %endif
350 Requires(post,postun):  /sbin/depmod
351 Requires:       %{pname} = %{version}-%{rel}
352 Obsoletes:      lirc-modules
353 Obsoletes:      lirc-modules-igorplugusb
354 Conflicts:      dev < 2.8.0-3
355
356 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb
357 This package contains the kernel modules necessary to operate some
358 infrared remote control devices (such as the ones bundled with TV
359 cards).
360
361 lirc_igorplugusb module.
362
363 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8
364 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
365 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
366
367 Moduł lirc_igorplugusb.
368
369 %package -n kernel%{_alt_kernel}-char-lirc-imon
370 Summary:        Kernel modules for Linux Infrared Remote Control
371 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
372 Release:        %{rel}@%{_kernel_ver_str}
373 Group:          Base/Kernel
374 %if %{with dist_kernel}
375 %requires_releq_kernel
376 Requires(postun):       %releq_kernel
377 %endif
378 Requires(post,postun):  /sbin/depmod
379 Requires:       %{pname} = %{version}-%{rel}
380 Obsoletes:      lirc-modules
381 Obsoletes:      lirc-modules-imon
382 Conflicts:      dev < 2.8.0-3
383
384 %description -n kernel%{_alt_kernel}-char-lirc-imon
385 This package contains the kernel modules necessary to operate some
386 infrared remote control devices (such as the ones bundled with TV
387 cards).
388
389 lirc_imon module.
390
391 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8
392 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
393 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
394
395 Moduł lirc_imon.
396
397 %package -n kernel%{_alt_kernel}-char-lirc-sasem
398 Summary:        Kernel modules for Linux Infrared Remote Control
399 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
400 Release:        %{rel}@%{_kernel_ver_str}
401 Group:          Base/Kernel
402 %if %{with dist_kernel}
403 %requires_releq_kernel
404 Requires(postun):       %releq_kernel
405 %endif
406 Requires(post,postun):  /sbin/depmod
407 Requires:       %{pname} = %{version}-%{rel}
408 Conflicts:      dev < 2.8.0-3
409
410 %description -n kernel%{_alt_kernel}-char-lirc-sasem
411 This package contains the kernel modules necessary to operate some
412 infrared remote control devices (such as the ones bundled with TV
413 cards).
414
415 lirc_sasem module.
416
417 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8
418 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
419 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
420
421 Moduł lirc_sasem.
422
423 %package -n kernel%{_alt_kernel}-char-lirc-serial
424 Summary:        Kernel modules for Linux Infrared Remote Control
425 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
426 Release:        %{rel}@%{_kernel_ver_str}
427 Group:          Base/Kernel
428 %if %{with dist_kernel}
429 %requires_releq_kernel
430 Requires(postun):       %releq_kernel
431 %endif
432 Requires(post,postun):  /sbin/depmod
433 Requires:       %{pname} = %{version}-%{rel}
434 %{?with_dist_kernel:Requires:   setserial}
435 Obsoletes:      lirc-modules
436 Obsoletes:      lirc-modules-serial
437 Conflicts:      dev < 2.8.0-3
438
439 %description -n kernel%{_alt_kernel}-char-lirc-serial
440 This package contains the kernel modules necessary to operate some
441 infrared remote control devices (such as the ones bundled with TV
442 cards).
443
444 lirc_serial module for devices connected to serial port.
445
446 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8
447 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
448 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
449
450 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.
451
452 %package -n kernel%{_alt_kernel}-char-lirc-sir
453 Summary:        Kernel modules for Linux Infrared Remote Control
454 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
455 Release:        %{rel}@%{_kernel_ver_str}
456 Group:          Base/Kernel
457 %if %{with dist_kernel}
458 %requires_releq_kernel
459 Requires(postun):       %releq_kernel
460 %endif
461 Requires(post,postun):  /sbin/depmod
462 Requires:       %{pname} = %{version}-%{rel}
463 Obsoletes:      lirc-modules
464 Obsoletes:      lirc-modules-sir
465 Conflicts:      dev < 2.8.0-3
466
467 %description -n kernel%{_alt_kernel}-char-lirc-sir
468 This package contains the kernel modules necessary to operate some
469 infrared remote control devices (such as the ones bundled with TV
470 cards).
471
472 lirc_sir module.
473
474 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8
475 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
476 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
477
478 Moduł lirc_sir.
479
480 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir
481 Summary:        Kernel modules for Linux Infrared Remote Control
482 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
483 Release:        %{rel}@%{_kernel_ver_str}
484 Group:          Base/Kernel
485 %if %{with dist_kernel}
486 %requires_releq_kernel
487 Requires(postun):       %releq_kernel
488 %endif
489 Requires(post,postun):  /sbin/depmod
490 Requires:       %{pname} = %{version}-%{rel}
491 Obsoletes:      lirc-modules
492 Obsoletes:      lirc-modules-ttusbir
493 Conflicts:      dev < 2.8.0-3
494
495 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir
496 This package contains the kernel modules necessary to operate
497 TechnoTrend USB IR Receiver.
498
499 lirc_ttusbir module.
500
501 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8
502 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
503 TechnoTrend USB IR Receiver.
504
505 Moduł lirc_ttusbir.
506
507 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691
508 Summary:        Kernel modules for Linux Infrared Remote Control
509 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
510 Release:        %{rel}@%{_kernel_ver_str}
511 Group:          Base/Kernel
512 %if %{with dist_kernel}
513 %requires_releq_kernel
514 Requires(postun):       %releq_kernel
515 %endif
516 Requires(post,postun):  /sbin/depmod
517 Requires:       %{pname} = %{version}-%{rel}
518 Conflicts:      dev < 2.8.0-3
519
520 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691
521 This package contains the kernel modules necessary to operate
522 TechnoTrend USB IR Receiver.
523
524 lirc_wpc87691 module.
525
526 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8
527 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
528 TechnoTrend USB IR Receiver.
529
530 Moduł lirc_wpc87691.
531
532 %package -n kernel%{_alt_kernel}-char-lirc-parallel
533 Summary:        Kernel modules for Linux Infrared Remote Control
534 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
535 Release:        %{rel}@%{_kernel_ver_str}
536 Group:          Base/Kernel
537 %if %{with dist_kernel}
538 %requires_releq_kernel
539 Requires(postun):       %releq_kernel
540 %endif
541 Requires(post,postun):  /sbin/depmod
542 Requires:       %{pname} = %{version}-%{rel}
543 Obsoletes:      lirc-modules
544 Obsoletes:      lirc-modules-parallel
545 Conflicts:      dev < 2.8.0-3
546
547 %description -n kernel%{_alt_kernel}-char-lirc-parallel
548 This package contains the kernel modules necessary to operate some
549 infrared remote control devices (such as the ones bundled with TV
550 cards).
551
552 lirc-parallel module for devices connected to parallel port.
553
554 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8
555 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
556 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
557
558 Moduł lirc_parallel dla urządzeń podłączanych do portu
559 równoległego.
560
561 %prep
562 %setup -q -n %{pname}-%{version} -a 1
563 %patch0 -p1
564 %patch1 -p1
565 %if !%{with svga}
566 %patch2 -p1
567 %endif
568 %patch3 -p1
569 %patch4 -p1
570 %patch5 -p1
571 %patch6 -p1
572
573 %build
574 echo '#' > drivers/Makefile.am
575 %{__libtoolize}
576 %{__aclocal}
577 %{__automake}
578 %{__autoheader}
579 %{__autoconf}
580
581 %configure \
582         ac_cv_header_portaudio_h=no \
583 %if %{with kernel}
584         KERNELCC="%{kgcc}" \
585 %else
586         ac_cv_have_kernel="no_kernel=yes" \
587 %endif
588         --with-kerneldir=%{_kernelsrcdir} \
589         %{?with_x:--with-x} \
590         --with-port=0x2f8 \
591         --with-irq=3 \
592         --without-soft-carrier \
593         --with-driver=userspace \
594         --with-igor
595
596 %if %{with userspace}
597 %{__make} -j1
598 %endif
599
600 %if %{with kernel}
601 cd drivers
602
603 drivers=%{drivers}
604
605 for drv in $drivers; do
606         cd $drv
607         %{__make} clean \
608                 LIRC_DEVDIR=`pwd` \
609                 RCS_FIND_IGNORE="-name '*.ko' -o" \
610                 %{?with_verbose:V=1}
611
612         %{__make} -j1 \
613                 LIRC_DEVDIR=`pwd` \
614                 CONSTIFY_PLUGIN="" \
615                 KBUILD_MODPOST_WARN=1 \
616                 %{?with_verbose:V=1}
617         cd ..
618 done
619
620 cd ..
621
622 %endif
623
624 %install
625 rm -rf $RPM_BUILD_ROOT
626
627 %if %{with kernel}
628 drivers=%{drivers}
629 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
630 for drv in $drivers; do
631         install drivers/$drv/$drv.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/$drv.ko
632 done
633 %endif
634
635 %if %{with userspace}
636 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
637         $RPM_BUILD_ROOT/etc/{lirc,rc.d/init.d,sysconfig} \
638         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
639
640 %{__make} -j1 install \
641         DESTDIR=$RPM_BUILD_ROOT \
642         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
643
644 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
645 #
646 # This is a placeholder for your configuration file.
647 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
648 #
649 END
650 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
651 install contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
652 :> $RPM_BUILD_ROOT/var/log/lircd
653
654 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
655 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
656 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
657 install %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
658 %endif
659
660 %clean
661 rm -rf $RPM_BUILD_ROOT
662
663 %post   libs -p /sbin/ldconfig
664 %postun libs -p /sbin/ldconfig
665
666 %post
667 /sbin/chkconfig --add lircd
668 if [ -f /var/lock/subsys/lircd ]; then
669         /etc/rc.d/init.d/lircd restart >&2
670 else
671         echo "Run \"/etc/rc.d/init.d/lircd start\" to start lircd." >&2
672 fi
673 /sbin/chkconfig --add lircmd
674 if [ -f /var/lock/subsys/lircmd ]; then
675         /etc/rc.d/init.d/lircmd restart >&2
676 else
677         echo "Run \"/etc/rc.d/init.d/lircmd start\" to start lircmd." >&2
678 fi
679 echo "If you are using a kernel-module-based driver, don't forget to"
680 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> or"
681 echo "kernel%{_alt_kernel}-smp-char-lirc-<your_driver> package."
682
683 %preun
684 if [ "$1" = "0" ]; then
685         if [ -f /var/lock/subsys/lircd ]; then
686                 /etc/rc.d/init.d/lircd stop >&2
687         fi
688         /sbin/chkconfig --del lircd
689 fi
690 if [ "$1" = "0" ]; then
691         if [ -f /var/lock/subsys/lircmd ]; then
692                 /etc/rc.d/init.d/lircmd stop >&2
693         fi
694         /sbin/chkconfig --del lircmd
695 fi
696
697 %triggerpostun -- %{name} < 0.8.6-8
698 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
699         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
700 fi
701 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
702         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
703 fi
704
705 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb
706 %depmod %{_kernel_ver}
707 if [ "$1" = "1" ]; then
708         echo "Don't forget to add an 'alias lirc lirc_atiusb' line"
709         echo "to your /etc/modules.conf."
710 fi
711
712 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb
713 %depmod %{_kernel_ver}
714
715 %post   -n kernel%{_alt_kernel}-char-lirc-bt829
716 %depmod %{_kernel_ver}
717 if [ "$1" = "1" ]; then
718         echo "Don't forget to add an 'alias lirc lirc_bt829' line"
719         echo "to your /etc/modules.conf."
720 fi
721
722 %postun -n kernel%{_alt_kernel}-char-lirc-bt829
723 %depmod %{_kernel_ver}
724
725 %post   -n kernel%{_alt_kernel}-char-lirc-dev
726 %depmod %{_kernel_ver}
727
728 %postun -n kernel%{_alt_kernel}-char-lirc-dev
729 %depmod %{_kernel_ver}
730
731 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100
732 %depmod %{_kernel_ver}
733
734 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100
735 %depmod %{_kernel_ver}
736
737 %post   -n kernel%{_alt_kernel}-char-lirc-gpio
738 %depmod %{_kernel_ver}
739 if [ "$1" = "1" ]; then
740         echo "Don't forget to add an 'alias lirc lirc_gpio' line"
741         echo "to your /etc/modules.conf."
742 fi
743
744 %postun -n kernel%{_alt_kernel}-char-lirc-gpio
745 %depmod %{_kernel_ver}
746
747 %post   -n kernel%{_alt_kernel}-char-lirc-i2c
748 %depmod %{_kernel_ver}
749 if [ "$1" = "1" ]; then
750         echo "Don't forget to add an 'alias lirc lirc_i2c' line"
751         echo "to your /etc/modules.conf."
752 fi
753
754 %postun -n kernel%{_alt_kernel}-char-lirc-i2c
755 %depmod %{_kernel_ver}
756
757 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb
758 %depmod %{_kernel_ver}
759 if [ "$1" = "1" ]; then
760         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' line"
761         echo "to your /etc/modules.conf."
762 fi
763
764 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb
765 %depmod %{_kernel_ver}
766
767 %post   -n kernel%{_alt_kernel}-char-lirc-imon
768 %depmod %{_kernel_ver}
769 if [ "$1" = "1" ]; then
770         echo "Don't forget to add an 'alias lirc lirc_imon' line"
771         echo "to your /etc/modules.conf."
772 fi
773
774 %postun -n kernel%{_alt_kernel}-char-lirc-imon
775 %depmod %{_kernel_ver}
776
777 %post   -n kernel%{_alt_kernel}-char-lirc-sasem
778 %depmod %{_kernel_ver}
779 if [ "$1" = "1" ]; then
780         echo "Don't forget to add an 'alias lirc lirc_sasem' line"
781         echo "to your /etc/modules.conf."
782 fi
783
784 %postun -n kernel%{_alt_kernel}-char-lirc-sasem
785 %depmod %{_kernel_ver}
786
787 %post   -n kernel%{_alt_kernel}-char-lirc-serial
788 %depmod %{_kernel_ver}
789 if [ "$1" = "1" ]; then
790         echo "Don't forget to add an 'alias lirc lirc_serial' line"
791         echo "to your /etc/modules.conf."
792 fi
793
794 %postun -n kernel%{_alt_kernel}-char-lirc-serial
795 %depmod %{_kernel_ver}
796
797 %post   -n kernel%{_alt_kernel}-char-lirc-parallel
798 %depmod %{_kernel_ver}
799 if [ "$1" = "1" ]; then
800         echo "Don't forget to add an 'alias lirc lirc_parallel' line"
801         echo "to your /etc/modules.conf."
802 fi
803
804 %postun -n kernel%{_alt_kernel}-char-lirc-parallel
805 %depmod %{_kernel_ver}
806
807 %post   -n kernel%{_alt_kernel}-char-lirc-sir
808 %depmod %{_kernel_ver}
809 if [ "$1" = "1" ]; then
810         echo "Don't forget to add an 'alias lirc lirc_sir' line"
811         echo "to your /etc/modules.conf."
812 fi
813
814 %postun -n kernel%{_alt_kernel}-char-lirc-sir
815 %depmod %{_kernel_ver}
816
817 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir
818 %depmod %{_kernel_ver}
819 if [ "$1" = "1" ]; then
820         echo "Don't forget to add an 'alias lirc lirc_ttusbir' line"
821         echo "to your /etc/modules.conf."
822 fi
823
824 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir
825 %depmod %{_kernel_ver}
826
827 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691
828 %depmod %{_kernel_ver}
829 if [ "$1" = "1" ]; then
830         echo "Don't forget to add an 'alias lirc lirc_wpc87691' line"
831         echo "to your /etc/modules.conf."
832 fi
833
834 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691
835 %depmod %{_kernel_ver}
836
837 %if %{with userspace}
838 %files
839 %defattr(644,root,root,755)
840 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
841 %doc contrib/lircrc doc/{html,images,lirc.css}
842 %attr(755,root,root) %{_bindir}/ircat
843 %attr(755,root,root) %{_bindir}/irexec
844 %attr(755,root,root) %{_bindir}/irpty
845 %attr(755,root,root) %{_bindir}/irrecord
846 %attr(755,root,root) %{_bindir}/irsend
847 %attr(755,root,root) %{_bindir}/irw
848 %attr(755,root,root) %{_bindir}/mode2
849 %attr(755,root,root) %{_bindir}/lircrcd
850 %attr(755,root,root) %{_bindir}/pronto2lirc
851 %attr(755,root,root) %{_sbindir}/lircd
852 %attr(755,root,root) %{_sbindir}/lircmd
853 %attr(754,root,root) /etc/rc.d/init.d/lircd
854 %attr(754,root,root) /etc/rc.d/init.d/lircmd
855 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
856 %dir %{_sysconfdir}/lirc
857 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
858 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
859 %{_mandir}/man1/ircat.1*
860 %{_mandir}/man1/irexec.1*
861 %{_mandir}/man1/irpty.1*
862 %{_mandir}/man1/irrecord.1*
863 %{_mandir}/man1/irsend.1*
864 %{_mandir}/man1/irw.1*
865 %{_mandir}/man1/lircrcd.1*
866 %{_mandir}/man1/mode2.1*
867 %{_mandir}/man8/lircd.8*
868 %{_mandir}/man8/lircmd.8*
869 %attr(600,root,root) %ghost /var/log/lircd
870 %dir /var/run/lirc
871 /usr/lib/tmpfiles.d/%{name}.conf
872
873 %files remotes
874 %defattr(644,root,root,755)
875 # XXX: are jpegs in docs (remotes) a good idea?
876 %doc remotes
877
878 %if %{with x}
879 %files X11
880 %defattr(644,root,root,755)
881 %doc doc/irxevent.keys
882 %attr(755,root,root) %{_bindir}/irxevent
883 %attr(755,root,root) %{_bindir}/xmode2
884 %{_mandir}/man1/irxevent.1*
885 %{_mandir}/man1/xmode2.1*
886 %endif
887
888 %if %{with svga}
889 %files svga
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_bindir}/smode2
892 %{_mandir}/man1/smode2.1*
893 %endif
894
895 %files libs
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
898 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
899
900 %files devel
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/liblirc_client.so
903 %{_libdir}/liblirc_client.la
904 %{_includedir}/lirc
905 %{_aclocaldir}/lirc.m4
906
907 %files static
908 %defattr(644,root,root,755)
909 %{_libdir}/liblirc_client.a
910 %endif
911
912 %if %{with kernel}
913 %files -n kernel%{_alt_kernel}-char-lirc-atiusb
914 %defattr(644,root,root,755)
915 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*
916
917 %files -n kernel%{_alt_kernel}-char-lirc-bt829
918 %defattr(644,root,root,755)
919 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*
920
921 %files -n kernel%{_alt_kernel}-char-lirc-dev
922 %defattr(644,root,root,755)
923 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*
924
925 %if "%{_kernel_ver}" < "3.0.0"
926 %files -n kernel%{_alt_kernel}-char-lirc-ene0100
927 %defattr(644,root,root,755)
928 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*
929 %endif
930
931 %if "%{_kernel_ver}" < "2.6.23"
932 %files -n kernel%{_alt_kernel}-char-lirc-gpio
933 %defattr(644,root,root,755)
934 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*
935 %endif
936
937 %files -n kernel%{_alt_kernel}-char-lirc-i2c
938 %defattr(644,root,root,755)
939 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*
940
941 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb
942 %defattr(644,root,root,755)
943 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*
944
945 %files -n kernel%{_alt_kernel}-char-lirc-imon
946 %defattr(644,root,root,755)
947 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*
948
949 %files -n kernel%{_alt_kernel}-char-lirc-sasem
950 %defattr(644,root,root,755)
951 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*
952
953 %files -n kernel%{_alt_kernel}-char-lirc-serial
954 %defattr(644,root,root,755)
955 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*
956
957 %files -n kernel%{_alt_kernel}-char-lirc-sir
958 %defattr(644,root,root,755)
959 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*
960
961 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir
962 %defattr(644,root,root,755)
963 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*
964
965 %if "%{_kernel_ver}" < "3.0.0"
966 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691
967 %defattr(644,root,root,755)
968 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*
969 %endif
970
971 %files -n kernel%{_alt_kernel}-char-lirc-parallel
972 %defattr(644,root,root,755)
973 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*
974 %endif
This page took 0.105148 seconds and 3 git commands to generate.