]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
e0d014c570e985a2b6a404324e36f63b15f7e8a3
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 # - create modprobe alias files instead of reminding in post scriptlets
7 #
8 # Conditional build:
9 %bcond_without  kernel          # don't build kernel modules, only library+programs
10 %bcond_without  userspace       # build only packages with kernel modules
11 %bcond_with     svga            # without svgalib-based utility
12 %bcond_without  x               # without X11-based utilitied
13
14 # The goal here is to have main, userspace, package built once with
15 # simple release number, and only rebuild kernel packages with kernel
16 # version as part of release number, without the need to bump release
17 # with every kernel change.
18 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
19 %{error:kernel and userspace cannot be built at the same time on PLD builders}
20 exit 1
21 %endif
22
23 %if "%{_alt_kernel}" != "%{nil}"
24 %if 0%{?build_kernels:1}
25 %{error:alt_kernel and build_kernels are mutually exclusive}
26 exit 1
27 %endif
28 %undefine       with_userspace
29 %global         _build_kernels          %{alt_kernel}
30 %else
31 %global         _build_kernels          %{?build_kernels:,%{?build_kernels}}
32 %endif
33
34 %if %{without userspace}
35 # nothing to be placed to debuginfo package
36 %define         _enable_debug_packages  0
37 %endif
38
39 %define         kbrs    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo "BuildRequires:kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2" ; done)
40 %define         kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; echo %%kernel_pkg_scriptlets ; done)
41 %define         bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
42
43 %define         pname   lirc
44 %define         rel     104
45
46 #
47 # main package
48 #
49 # lirc_gpio fails to build under kernel >= 2.6.23
50 #
51 %if %{with kernel}
52 %if %{_kernel_version_code} >= %{_kernel_version_magic 2 6 23}
53 %if %{_kernel_version_code} >= %{_kernel_version_magic 3 0 0}
54 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
55 %else
56 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
57 %endif
58 %else
59 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
60 %endif
61 %endif
62 Summary:        Linux Infrared Remote Control daemons
63 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
64 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
65 Version:        0.9.0
66 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
67 License:        GPL v2+
68 Group:          Daemons
69 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
70 # Source0-md5:  b232aef26f23fe33ea8305d276637086
71 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
72 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
73 Source2:        %{pname}d.sysconfig
74 Source3:        %{pname}d.init
75 Source4:        %{pname}md.init
76 Source5:        %{pname}.tmpfiles
77 Patch0:         %{pname}-opt.patch
78 Patch1:         %{pname}-tmp.patch
79 Patch2:         %{pname}-no-svgalib.patch
80 Patch3:         %{pname}-kernel.patch
81 Patch4:         %{pname}-sparc.patch
82 Patch5:         %{pname}-remotes.patch
83 Patch6:         %{pname}-kernelcc.patch
84 Patch7:         format-security.patch
85 Patch8:         %{pname}-am.patch
86 URL:            http://www.lirc.org/
87 BuildRequires:  alsa-lib-devel
88 BuildRequires:  autoconf >= 2.50
89 BuildRequires:  automake
90 BuildRequires:  iguanaIR-devel
91 BuildRequires:  libftdi-devel >= 0.12
92 BuildRequires:  libirman-devel >= 0.4.5
93 BuildRequires:  libtool
94 BuildRequires:  libusb-compat-devel >= 0.1.0
95 BuildRequires:  rpmbuild(macros) >= 1.679
96 %{?with_kernel:%{expand:%kbrs}}
97 BuildRequires:  rpm-pythonprov
98 %{?with_svga:BuildRequires:     svgalib-devel}
99 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
100 Requires(post,preun):   /sbin/chkconfig
101 BuildRequires:  rpmbuild(macros) >= 1.268
102 Requires:       %{pname}-libs = %{version}-%{release}
103 Requires:       libftdi >= 0.12
104 Requires:       rc-scripts
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %if %{without userspace}
108 %define         no_spec_install_post_check_tmpfiles     1
109 %endif
110
111 %description
112 LIRC is a package that allows you to decode and send infra-red signals
113 of many (but not all) commonly used remote controls.
114
115 %description -l pl.UTF-8
116 LIRC to program pozwalający na dekodowanie nadchodzących oraz
117 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie wszystkich)
118 popularnych urządzeń do zdalnego sterowania.
119
120 %package remotes
121 Summary:        Lirc remotes database
122 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
123 Group:          Documentation
124 Requires:       %{pname} = %{version}-%{rel}
125
126 %description remotes
127 This package contains configuration files for many remotes supported
128 by lirc.
129
130 %description remotes -l pl.UTF-8
131 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
132 obsługiwanych przez lirc.
133
134 %package X11
135 Summary:        Linux Infrared Remote Control - X11 utilities
136 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
137 Group:          X11/Applications
138 Requires:       %{pname}-libs = %{version}-%{release}
139
140 %description X11
141 Linux Infrared Remote Control - X11 utilities.
142
143 %description X11 -l pl.UTF-8
144 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
145
146 %package svga
147 Summary:        Linux Infrared Remote Control - svgalib utilities
148 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
149 Group:          Applications
150 Requires:       %{pname}-libs = %{version}-%{release}
151
152 %description svga
153 Linux Infrared Remote Control - svgalib-based utilities.
154
155 %description svga -l pl.UTF-8
156 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
157 na svgalibie.
158
159 %package libs
160 Summary:        LIRC libraries
161 Summary(pl.UTF-8):      Biblioteki LIRC
162 Group:          Libraries
163 Conflicts:      lirc < 0.6.3-3
164 # didn't use /tmp/.lircd
165
166 %description libs
167 This package provides the libraries necessary to run lirc client
168 programs.
169
170 %description libs -l pl.UTF-8
171 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
172
173 %package devel
174 Summary:        Header files for LIRC development
175 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
176 Group:          Development/Libraries
177 Requires:       %{pname}-libs = %{version}-%{release}
178
179 %description devel
180 This package provides the files necessary to develop LIRC-based
181 programs.
182
183 %description devel -l pl.UTF-8
184 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych na
185 LIRC.
186
187 %package static
188 Summary:        Static library for LIRC development
189 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
190 Group:          Development/Libraries
191 Requires:       %{pname}-devel = %{version}-%{release}
192
193 %description static
194 The files necessary for development of statically-linked lirc-based
195 programs.
196
197 %description static -l pl.UTF-8
198 Pliki potrzebne do tworzenia łączonych statycznie programów opartych
199 na LIRC.
200
201 %define kernel_pkg()\
202 %package -n kernel%{_alt_kernel}-char-lirc-atiusb\
203 Summary:        Kernel modules for Linux Infrared Remote Control\
204 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
205 Release:        %{rel}@%{_kernel_ver_str}\
206 Group:          Base/Kernel\
207 %requires_releq_kernel\
208 Requires(postun):       %releq_kernel\
209 Requires(post,postun):  /sbin/depmod\
210 Requires:       %{pname} = %{version}\
211 Conflicts:      dev < 2.8.0-3\
212 \
213 %description -n kernel%{_alt_kernel}-char-lirc-atiusb\
214 This package contains the kernel modules necessary to operate some\
215 infrared remote control devices (such as the ones bundled with TV\
216 cards).\
217 \
218 lirc_atiusb module.\
219 \
220 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8\
221 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
222 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
223 \
224 Moduł lirc_atiusb.\
225 \
226 %package -n kernel%{_alt_kernel}-char-lirc-bt829\
227 Summary:        Kernel modules for Linux Infrared Remote Control\
228 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
229 Release:        %{rel}@%{_kernel_ver_str}\
230 Group:          Base/Kernel\
231 %requires_releq_kernel\
232 Requires(postun):       %releq_kernel\
233 Requires(post,postun):  /sbin/depmod\
234 Requires:       %{pname} = %{version}\
235 Conflicts:      dev < 2.8.0-3\
236 \
237 %description -n kernel%{_alt_kernel}-char-lirc-bt829\
238 This package contains the kernel modules necessary to operate some\
239 infrared remote control devices (such as the ones bundled with TV\
240 cards).\
241 \
242 lirc_bt829 module.\
243 \
244 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8\
245 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
246 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
247 \
248 Moduł lirc_bt829.\
249 \
250 %package -n kernel%{_alt_kernel}-char-lirc-dev\
251 Summary:        Kernel modules for Linux Infrared Remote Control\
252 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
253 Release:        %{rel}@%{_kernel_ver_str}\
254 Group:          Base/Kernel\
255 %requires_releq_kernel\
256 Requires(postun):       %releq_kernel\
257 Requires(post,postun):  /sbin/depmod\
258 Requires:       %{pname} = %{version}\
259 Obsoletes:      lirc-modules\
260 Obsoletes:      lirc-modules-dev\
261 Conflicts:      dev < 2.8.0-3\
262 \
263 %description -n kernel%{_alt_kernel}-char-lirc-dev\
264 This package contains the kernel modules necessary to operate some\
265 infrared remote control devices (such as the ones bundled with TV\
266 cards).\
267 \
268 lirc_dev module.\
269 \
270 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8\
271 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
272 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
273 \
274 Moduł lirc_dev.\
275 \
276 %package -n kernel%{_alt_kernel}-char-lirc-ene0100\
277 Summary:        Kernel modules for Linux Infrared Remote Control\
278 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
279 Release:        %{rel}@%{_kernel_ver_str}\
280 Group:          Base/Kernel\
281 %requires_releq_kernel\
282 Requires(postun):       %releq_kernel\
283 Requires(post,postun):  /sbin/depmod\
284 Requires:       %{pname} = %{version}\
285 Obsoletes:      lirc-modules\
286 Conflicts:      dev < 2.8.0-3\
287 \
288 %description -n kernel%{_alt_kernel}-char-lirc-ene0100\
289 This package contains the kernel modules necessary to operate some\
290 infrared remote control ene0100ices (such as the ones bundled with TV\
291 cards).\
292 \
293 lirc_ene0100 module.\
294 \
295 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8\
296 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
297 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
298 \
299 Moduł lirc_ene0100.\
300 \
301 %package -n kernel%{_alt_kernel}-char-lirc-gpio\
302 Summary:        Kernel modules for Linux Infrared Remote Control\
303 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
304 Release:        %{rel}@%{_kernel_ver_str}\
305 Group:          Base/Kernel\
306 %requires_releq_kernel\
307 Requires(postun):       %releq_kernel\
308 Requires(post,postun):  /sbin/depmod\
309 Requires:       %{pname} = %{version}\
310 Obsoletes:      lirc-modules\
311 Obsoletes:      lirc-modules-gpio\
312 Conflicts:      dev < 2.8.0-3\
313 \
314 %description -n kernel%{_alt_kernel}-char-lirc-gpio\
315 This package contains the kernel modules necessary to operate some\
316 infrared remote control devices (such as the ones bundled with TV\
317 cards).\
318 \
319 lirc_gpio module.\
320 \
321 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8\
322 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
323 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
324 \
325 Moduł lirc_gpio.\
326 \
327 %package -n kernel%{_alt_kernel}-char-lirc-i2c\
328 Summary:        Kernel modules for Linux Infrared Remote Control\
329 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
330 Release:        %{rel}@%{_kernel_ver_str}\
331 Group:          Base/Kernel\
332 %requires_releq_kernel\
333 Requires(postun):       %releq_kernel\
334 Requires(post,postun):  /sbin/depmod\
335 Requires:       %{pname} = %{version}\
336 Obsoletes:      lirc-modules\
337 Obsoletes:      lirc-modules-i2c\
338 Conflicts:      dev < 2.8.0-3\
339 \
340 %description -n kernel%{_alt_kernel}-char-lirc-i2c\
341 This package contains the kernel modules necessary to operate some\
342 infrared remote control devices (such as the ones bundled with TV\
343 cards).\
344 \
345 lirc_i2c module.\
346 \
347 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8\
348 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
349 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
350 \
351 Moduł lirc_i2c.\
352 \
353 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
354 Summary:        Kernel modules for Linux Infrared Remote Control\
355 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
356 Release:        %{rel}@%{_kernel_ver_str}\
357 Group:          Base/Kernel\
358 %requires_releq_kernel\
359 Requires(postun):       %releq_kernel\
360 Requires(post,postun):  /sbin/depmod\
361 Requires:       %{pname} = %{version}\
362 Obsoletes:      lirc-modules\
363 Obsoletes:      lirc-modules-igorplugusb\
364 Conflicts:      dev < 2.8.0-3\
365 \
366 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
367 This package contains the kernel modules necessary to operate some\
368 infrared remote control devices (such as the ones bundled with TV\
369 cards).\
370 \
371 lirc_igorplugusb module.\
372 \
373 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8\
374 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
375 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
376 \
377 Moduł lirc_igorplugusb.\
378 \
379 %package -n kernel%{_alt_kernel}-char-lirc-imon\
380 Summary:        Kernel modules for Linux Infrared Remote Control\
381 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
382 Release:        %{rel}@%{_kernel_ver_str}\
383 Group:          Base/Kernel\
384 %requires_releq_kernel\
385 Requires(postun):       %releq_kernel\
386 Requires(post,postun):  /sbin/depmod\
387 Requires:       %{pname} = %{version}\
388 Obsoletes:      lirc-modules\
389 Obsoletes:      lirc-modules-imon\
390 Conflicts:      dev < 2.8.0-3\
391 \
392 %description -n kernel%{_alt_kernel}-char-lirc-imon\
393 This package contains the kernel modules necessary to operate some\
394 infrared remote control devices (such as the ones bundled with TV\
395 cards).\
396 \
397 lirc_imon module.\
398 \
399 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8\
400 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
401 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
402 \
403 Moduł lirc_imon.\
404 \
405 %package -n kernel%{_alt_kernel}-char-lirc-sasem\
406 Summary:        Kernel modules for Linux Infrared Remote Control\
407 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
408 Release:        %{rel}@%{_kernel_ver_str}\
409 Group:          Base/Kernel\
410 %requires_releq_kernel\
411 Requires(postun):       %releq_kernel\
412 Requires(post,postun):  /sbin/depmod\
413 Requires:       %{pname} = %{version}\
414 Conflicts:      dev < 2.8.0-3\
415 \
416 %description -n kernel%{_alt_kernel}-char-lirc-sasem\
417 This package contains the kernel modules necessary to operate some\
418 infrared remote control devices (such as the ones bundled with TV\
419 cards).\
420 \
421 lirc_sasem module.\
422 \
423 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8\
424 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
425 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
426 \
427 Moduł lirc_sasem.\
428 \
429 %package -n kernel%{_alt_kernel}-char-lirc-serial\
430 Summary:        Kernel modules for Linux Infrared Remote Control\
431 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
432 Release:        %{rel}@%{_kernel_ver_str}\
433 Group:          Base/Kernel\
434 %requires_releq_kernel\
435 Requires(postun):       %releq_kernel\
436 Requires(post,postun):  /sbin/depmod\
437 Requires:       %{pname} = %{version}\
438 Requires:       setserial\
439 Obsoletes:      lirc-modules\
440 Obsoletes:      lirc-modules-serial\
441 Conflicts:      dev < 2.8.0-3\
442 \
443 %description -n kernel%{_alt_kernel}-char-lirc-serial\
444 This package contains the kernel modules necessary to operate some\
445 infrared remote control devices (such as the ones bundled with TV\
446 cards).\
447 \
448 lirc_serial module for devices connected to serial port.\
449 \
450 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8\
451 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
452 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
453 \
454 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.\
455 \
456 %package -n kernel%{_alt_kernel}-char-lirc-sir\
457 Summary:        Kernel modules for Linux Infrared Remote Control\
458 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
459 Release:        %{rel}@%{_kernel_ver_str}\
460 Group:          Base/Kernel\
461 %requires_releq_kernel\
462 Requires(postun):       %releq_kernel\
463 Requires(post,postun):  /sbin/depmod\
464 Requires:       %{pname} = %{version}\
465 Obsoletes:      lirc-modules\
466 Obsoletes:      lirc-modules-sir\
467 Conflicts:      dev < 2.8.0-3\
468 \
469 %description -n kernel%{_alt_kernel}-char-lirc-sir\
470 This package contains the kernel modules necessary to operate some\
471 infrared remote control devices (such as the ones bundled with TV\
472 cards).\
473 \
474 lirc_sir module.\
475 \
476 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8\
477 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
478 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
479 \
480 Moduł lirc_sir.\
481 \
482 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir\
483 Summary:        Kernel modules for Linux Infrared Remote Control\
484 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
485 Release:        %{rel}@%{_kernel_ver_str}\
486 Group:          Base/Kernel\
487 %requires_releq_kernel\
488 Requires(postun):       %releq_kernel\
489 Requires(post,postun):  /sbin/depmod\
490 Requires:       %{pname} = %{version}\
491 Obsoletes:      lirc-modules\
492 Obsoletes:      lirc-modules-ttusbir\
493 Conflicts:      dev < 2.8.0-3\
494 \
495 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir\
496 This package contains the kernel modules necessary to operate\
497 TechnoTrend USB IR Receiver.\
498 \
499 lirc_ttusbir module.\
500 \
501 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8\
502 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia\
503 TechnoTrend USB IR Receiver.\
504 \
505 Moduł lirc_ttusbir.\
506 \
507 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691\
508 Summary:        Kernel modules for Linux Infrared Remote Control\
509 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
510 Release:        %{rel}@%{_kernel_ver_str}\
511 Group:          Base/Kernel\
512 %requires_releq_kernel\
513 Requires(postun):       %releq_kernel\
514 Requires(post,postun):  /sbin/depmod\
515 Requires:       %{pname} = %{version}\
516 Conflicts:      dev < 2.8.0-3\
517 \
518 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691\
519 This package contains the kernel modules necessary to operate\
520 TechnoTrend USB IR Receiver.\
521 \
522 lirc_wpc87691 module.\
523 \
524 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8\
525 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia\
526 TechnoTrend USB IR Receiver.\
527 \
528 Moduł lirc_wpc87691.\
529 \
530 %package -n kernel%{_alt_kernel}-char-lirc-parallel\
531 Summary:        Kernel modules for Linux Infrared Remote Control\
532 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
533 Release:        %{rel}@%{_kernel_ver_str}\
534 Group:          Base/Kernel\
535 %requires_releq_kernel\
536 Requires(postun):       %releq_kernel\
537 Requires(post,postun):  /sbin/depmod\
538 Requires:       %{pname} = %{version}\
539 Obsoletes:      lirc-modules\
540 Obsoletes:      lirc-modules-parallel\
541 Conflicts:      dev < 2.8.0-3\
542 \
543 %description -n kernel%{_alt_kernel}-char-lirc-parallel\
544 This package contains the kernel modules necessary to operate some\
545 infrared remote control devices (such as the ones bundled with TV\
546 cards).\
547 \
548 lirc-parallel module for devices connected to parallel port.\
549 \
550 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8\
551 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
552 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
553 \
554 Moduł lirc_parallel dla urządzeń podłączanych do portu równoległego.\
555 \
556 %if %{with kernel}\
557 %files -n kernel%{_alt_kernel}-char-lirc-atiusb\
558 %defattr(644,root,root,755)\
559 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*\
560 \
561 %files -n kernel%{_alt_kernel}-char-lirc-bt829\
562 %defattr(644,root,root,755)\
563 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*\
564 \
565 %files -n kernel%{_alt_kernel}-char-lirc-dev\
566 %defattr(644,root,root,755)\
567 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*\
568 \
569 %if %{_kernel_version_code} < %{_kernel_version_magic 3 0 0}\
570 %files -n kernel%{_alt_kernel}-char-lirc-ene0100\
571 %defattr(644,root,root,755)\
572 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*\
573 %endif\
574 \
575 %if %{_kernel_version_code} < %{_kernel_version_magic 2 6 23}\
576 %files -n kernel%{_alt_kernel}-char-lirc-gpio\
577 %defattr(644,root,root,755)\
578 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*\
579 %endif\
580 \
581 %files -n kernel%{_alt_kernel}-char-lirc-i2c\
582 %defattr(644,root,root,755)\
583 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*\
584 \
585 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
586 %defattr(644,root,root,755)\
587 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*\
588 \
589 %files -n kernel%{_alt_kernel}-char-lirc-imon\
590 %defattr(644,root,root,755)\
591 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*\
592 \
593 %files -n kernel%{_alt_kernel}-char-lirc-sasem\
594 %defattr(644,root,root,755)\
595 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*\
596 \
597 %files -n kernel%{_alt_kernel}-char-lirc-serial\
598 %defattr(644,root,root,755)\
599 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*\
600 \
601 %files -n kernel%{_alt_kernel}-char-lirc-sir\
602 %defattr(644,root,root,755)\
603 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*\
604 \
605 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir\
606 %defattr(644,root,root,755)\
607 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*\
608 \
609 %if %{_kernel_version_code} < %{_kernel_version_magic 3 0 0}\
610 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691\
611 %defattr(644,root,root,755)\
612 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*\
613 %endif\
614 \
615 %files -n kernel%{_alt_kernel}-char-lirc-parallel\
616 %defattr(644,root,root,755)\
617 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*\
618 %endif\
619 %{nil}
620
621 %define kernel_pkg_scriptlets()\
622 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb\
623 %depmod %{_kernel_ver}\
624 if [ "$1" = "1" ]; then\
625         echo "Don't forget to add an 'alias lirc lirc_atiusb' to modprobe config"\
626 fi\
627 \
628 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb\
629 %depmod %{_kernel_ver}\
630 \
631 %post   -n kernel%{_alt_kernel}-char-lirc-bt829\
632 %depmod %{_kernel_ver}\
633 if [ "$1" = "1" ]; then\
634         echo "Don't forget to add an 'alias lirc lirc_bt829' to modprobe config"\
635 fi\
636 \
637 %postun -n kernel%{_alt_kernel}-char-lirc-bt829\
638 %depmod %{_kernel_ver}\
639 \
640 %post   -n kernel%{_alt_kernel}-char-lirc-dev\
641 %depmod %{_kernel_ver}\
642 \
643 %postun -n kernel%{_alt_kernel}-char-lirc-dev\
644 %depmod %{_kernel_ver}\
645 \
646 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100\
647 %depmod %{_kernel_ver}\
648 \
649 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100\
650 %depmod %{_kernel_ver}\
651 \
652 %post   -n kernel%{_alt_kernel}-char-lirc-gpio\
653 %depmod %{_kernel_ver}\
654 if [ "$1" = "1" ]; then\
655         echo "Don't forget to add an 'alias lirc lirc_gpio' to modprobe config"\
656 fi\
657 \
658 %postun -n kernel%{_alt_kernel}-char-lirc-gpio\
659 %depmod %{_kernel_ver}\
660 \
661 %post   -n kernel%{_alt_kernel}-char-lirc-i2c\
662 %depmod %{_kernel_ver}\
663 if [ "$1" = "1" ]; then\
664         echo "Don't forget to add an 'alias lirc lirc_i2c' to modprobe config"\
665 fi\
666 \
667 %postun -n kernel%{_alt_kernel}-char-lirc-i2c\
668 %depmod %{_kernel_ver}\
669 \
670 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
671 %depmod %{_kernel_ver}\
672 if [ "$1" = "1" ]; then\
673         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' to modprobe config"\
674 fi\
675 \
676 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
677 %depmod %{_kernel_ver}\
678 \
679 %post   -n kernel%{_alt_kernel}-char-lirc-imon\
680 %depmod %{_kernel_ver}\
681 if [ "$1" = "1" ]; then\
682         echo "Don't forget to add an 'alias lirc lirc_imon' to modprobe config"\
683 fi\
684 \
685 %postun -n kernel%{_alt_kernel}-char-lirc-imon\
686 %depmod %{_kernel_ver}\
687 \
688 %post   -n kernel%{_alt_kernel}-char-lirc-sasem\
689 %depmod %{_kernel_ver}\
690 if [ "$1" = "1" ]; then\
691         echo "Don't forget to add an 'alias lirc lirc_sasem' to modprobe config"\
692 fi\
693 \
694 %postun -n kernel%{_alt_kernel}-char-lirc-sasem\
695 %depmod %{_kernel_ver}\
696 \
697 %post   -n kernel%{_alt_kernel}-char-lirc-serial\
698 %depmod %{_kernel_ver}\
699 if [ "$1" = "1" ]; then\
700         echo "Don't forget to add an 'alias lirc lirc_serial' to modprobe config"\
701 fi\
702 \
703 %postun -n kernel%{_alt_kernel}-char-lirc-serial\
704 %depmod %{_kernel_ver}\
705 \
706 %post   -n kernel%{_alt_kernel}-char-lirc-parallel\
707 %depmod %{_kernel_ver}\
708 if [ "$1" = "1" ]; then\
709         echo "Don't forget to add an 'alias lirc lirc_parallel' modprobe config"\
710 fi\
711 \
712 %postun -n kernel%{_alt_kernel}-char-lirc-parallel\
713 %depmod %{_kernel_ver}\
714 \
715 %post   -n kernel%{_alt_kernel}-char-lirc-sir\
716 %depmod %{_kernel_ver}\
717 if [ "$1" = "1" ]; then\
718         echo "Don't forget to add an 'alias lirc lirc_sir' to modprobe config"\
719 fi\
720 \
721 %postun -n kernel%{_alt_kernel}-char-lirc-sir\
722 %depmod %{_kernel_ver}\
723 \
724 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir\
725 %depmod %{_kernel_ver}\
726 if [ "$1" = "1" ]; then\
727         echo "Don't forget to add an 'alias lirc lirc_ttusbir' to modprobe config"\
728 fi\
729 \
730 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir\
731 %depmod %{_kernel_ver}\
732 \
733 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691\
734 %depmod %{_kernel_ver}\
735 if [ "$1" = "1" ]; then\
736         echo "Don't forget to add an 'alias lirc lirc_wpc87691' to modprobe config"\
737 fi\
738 \
739 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691\
740 %depmod %{_kernel_ver}\
741 %{nil}
742
743 %define build_kernel_pkg()\
744 %configure \\\
745         ac_cv_header_portaudio_h=no \\\
746         --with-kerneldir=%{_kernelsrcdir} \\\
747         %{?with_x:--with-x} \\\
748         --with-port=0x2f8 \\\
749         --with-irq=3 \\\
750         --without-soft-carrier \\\
751         --with-driver=userspace \\\
752         --with-igor\
753 \
754 drivers=%{drivers}\
755 for drv in $drivers; do\
756         cd drivers/$drv\
757         %{__make} clean \\\
758                 LIRC_DEVDIR=`pwd` \\\
759                 RCS_FIND_IGNORE="-name '*.ko' -o" \\\
760                 %{?with_verbose:V=1}\
761 \
762         %{__make} -j1 \\\
763                 LIRC_DEVDIR=`pwd` \\\
764                 CONSTIFY_PLUGIN="" \\\
765                 KBUILD_MODPOST_WARN=1 \\\
766                 %{?with_verbose:V=1}\
767         cd ../..\
768         %install_kernel_modules -D installed -m drivers/$drv/$drv -d misc\
769 done\
770 %{nil}
771
772 %{?with_kernel:%{expand:%kpkg}}
773
774 %prep
775 %setup -q -n %{pname}-%{version} -a 1
776 %patch0 -p1
777 %patch1 -p1
778 %if !%{with svga}
779 %patch2 -p1
780 %endif
781 %patch3 -p1
782 %patch4 -p1
783 %patch5 -p1
784 %patch6 -p1
785 %patch7 -p1
786 %patch8 -p1
787
788 %build
789 echo '#' > drivers/Makefile.am
790 %{__libtoolize}
791 %{__aclocal}
792 %{__automake}
793 %{__autoheader}
794 %{__autoconf}
795
796 %if %{with userspace}
797 %configure \
798         ac_cv_header_portaudio_h=no \
799 %if %{without kernel}
800         ac_cv_have_kernel="no_kernel=yes" \
801 %endif
802         --with-kerneldir=%{_kernelsrcdir} \
803         %{?with_x:--with-x} \
804         --with-port=0x2f8 \
805         --with-irq=3 \
806         --without-soft-carrier \
807         --with-driver=userspace \
808         --with-igor
809
810 %{__make} -j1
811 %endif
812
813 %{?with_kernel:%{expand:%bkpkg}}
814
815 %install
816 rm -rf $RPM_BUILD_ROOT
817 install -d $RPM_BUILD_ROOT
818
819 %if %{with kernel}
820 cp -a installed/* $RPM_BUILD_ROOT
821 %endif
822
823 %if %{with userspace}
824 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
825         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,lirc} \
826         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
827
828 %{__make} -j1 install \
829         DESTDIR=$RPM_BUILD_ROOT \
830         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
831
832 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
833 #
834 # This is a placeholder for your configuration file.
835 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
836 #
837 END
838 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
839 cp -p contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
840 :> $RPM_BUILD_ROOT/var/log/lircd
841
842 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
843 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
844 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
845 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
846 %endif
847
848 %clean
849 rm -rf $RPM_BUILD_ROOT
850
851 %post   libs -p /sbin/ldconfig
852 %postun libs -p /sbin/ldconfig
853
854 %post
855 /sbin/chkconfig --add lircd
856 /sbin/chkconfig --add lircmd
857 %service lircd restart
858 %service lircmd restart
859
860 echo "If you are using a kernel-module-based driver, don't forget to"
861 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> package."
862
863 %preun
864 if [ "$1" = "0" ]; then
865         %service lircd stop
866         %service lircmd stop
867         /sbin/chkconfig --del lircd
868         /sbin/chkconfig --del lircmd
869 fi
870
871 %triggerpostun -- %{name} < 0.8.6-8
872 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
873         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
874 fi
875 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
876         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
877 fi
878
879 %if %{with userspace}
880 %files
881 %defattr(644,root,root,755)
882 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
883 %doc contrib/lircrc doc/{html,images,lirc.css}
884 %attr(755,root,root) %{_bindir}/ircat
885 %attr(755,root,root) %{_bindir}/irexec
886 %attr(755,root,root) %{_bindir}/irpty
887 %attr(755,root,root) %{_bindir}/irrecord
888 %attr(755,root,root) %{_bindir}/irsend
889 %attr(755,root,root) %{_bindir}/irw
890 %attr(755,root,root) %{_bindir}/mode2
891 %attr(755,root,root) %{_bindir}/lircrcd
892 %attr(755,root,root) %{_bindir}/pronto2lirc
893 %attr(755,root,root) %{_sbindir}/lircd
894 %attr(755,root,root) %{_sbindir}/lircmd
895 %attr(754,root,root) /etc/rc.d/init.d/lircd
896 %attr(754,root,root) /etc/rc.d/init.d/lircmd
897 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
898 %dir %{_sysconfdir}/lirc
899 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
900 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
901 %{_mandir}/man1/ircat.1*
902 %{_mandir}/man1/irexec.1*
903 %{_mandir}/man1/irpty.1*
904 %{_mandir}/man1/irrecord.1*
905 %{_mandir}/man1/irsend.1*
906 %{_mandir}/man1/irw.1*
907 %{_mandir}/man1/lircrcd.1*
908 %{_mandir}/man1/mode2.1*
909 %{_mandir}/man8/lircd.8*
910 %{_mandir}/man8/lircmd.8*
911 %attr(600,root,root) %ghost /var/log/lircd
912 %dir /var/run/lirc
913 %{systemdtmpfilesdir}/%{name}.conf
914
915 %files remotes
916 %defattr(644,root,root,755)
917 # XXX: are jpegs in docs (remotes) a good idea?
918 %doc remotes
919
920 %if %{with x}
921 %files X11
922 %defattr(644,root,root,755)
923 %doc doc/irxevent.keys
924 %attr(755,root,root) %{_bindir}/irxevent
925 %attr(755,root,root) %{_bindir}/xmode2
926 %{_mandir}/man1/irxevent.1*
927 %{_mandir}/man1/xmode2.1*
928 %endif
929
930 %if %{with svga}
931 %files svga
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_bindir}/smode2
934 %{_mandir}/man1/smode2.1*
935 %endif
936
937 %files libs
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
940 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
941
942 %files devel
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/liblirc_client.so
945 %{_libdir}/liblirc_client.la
946 %{_includedir}/lirc
947 %{_aclocaldir}/lirc.m4
948
949 %files static
950 %defattr(644,root,root,755)
951 %{_libdir}/liblirc_client.a
952 %endif
This page took 0.088164 seconds and 2 git commands to generate.