]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
- rebuild for kernel-3.7.9-2
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 # - create modprobe alias files instead of reminding in post scriptlets
7 #
8 # Conditional build:
9 %bcond_without  dist_kernel     # without sources of distribution kernel
10 %bcond_without  kernel          # don't build kernel modules, only library+programs
11 %bcond_without  userspace       # build only packages with kernel modules
12 %bcond_with     svga            # without svgalib-based utility
13 %bcond_without  x               # without X11-based utilitied
14
15 %if %{without kernel}
16 %undefine       with_dist_kernel
17 %endif
18
19 %if "%{_alt_kernel}" != "%{nil}"
20 %undefine       with_userspace
21 %endif
22
23 %define         pname   lirc
24 %define         rel     75
25
26 #
27 # main package
28 #
29 # lirc_gpio fails to build under kernel >= 2.6.23
30 #
31 %if "%{_kernel_ver}" >= "2.6.23"
32 %if "%{_kernel_ver}" >= "3.0.0"
33 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
34 %else
35 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
36 %endif
37 %else
38 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
39 %endif
40 Summary:        Linux Infrared Remote Control daemons
41 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
42 Name:           %{pname}%{_alt_kernel}
43 Version:        0.9.0
44 Release:        %{rel}
45 License:        GPL v2+
46 Group:          Daemons
47 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
48 # Source0-md5:  b232aef26f23fe33ea8305d276637086
49 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
50 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
51 Source2:        %{pname}d.sysconfig
52 Source3:        %{pname}d.init
53 Source4:        %{pname}md.init
54 Source5:        %{pname}.tmpfiles
55 Patch0:         %{pname}-opt.patch
56 Patch1:         %{pname}-tmp.patch
57 Patch2:         %{pname}-no-svgalib.patch
58 Patch3:         %{pname}-kernel.patch
59 Patch4:         %{pname}-sparc.patch
60 Patch5:         %{pname}-remotes.patch
61 Patch6:         %{pname}-kernelcc.patch
62 Patch7:         format-security.patch
63 URL:            http://www.lirc.org/
64 BuildRequires:  alsa-lib-devel
65 BuildRequires:  autoconf >= 2.50
66 BuildRequires:  automake
67 BuildRequires:  iguanaIR-devel
68 BuildRequires:  libftdi-devel >= 0.12
69 BuildRequires:  libirman-devel >= 0.4.5
70 BuildRequires:  libtool
71 BuildRequires:  libusb-compat-devel >= 0.1.0
72 %if %{with kernel}
73 BuildRequires:  kernel%{_alt_kernel}-headers
74 BuildRequires:  kernel%{_alt_kernel}-module-build
75 %endif
76 %{?with_kernel:BuildRequires:   %{kgcc_package}}
77 BuildRequires:  rpm-pythonprov
78 BuildRequires:  rpmbuild(macros) >= 1.379
79 %{?with_svga:BuildRequires:     svgalib-devel}
80 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
81 Requires(post,preun):   /sbin/chkconfig
82 BuildRequires:  rpmbuild(macros) >= 1.268
83 Requires:       %{pname}-libs = %{version}-%{release}
84 Requires:       libftdi >= 0.12
85 Requires:       rc-scripts
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %if %{without userspace}
89 %define         no_spec_install_post_check_tmpfiles     1
90 %endif
91
92 %description
93 LIRC is a package that allows you to decode and send infra-red signals
94 of many (but not all) commonly used remote controls.
95
96 %description -l pl.UTF-8
97 LIRC to program pozwalający na dekodowanie nadchodzących oraz
98 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie wszystkich)
99 popularnych urządzeń do zdalnego sterowania.
100
101 %package remotes
102 Summary:        Lirc remotes database
103 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
104 Group:          Documentation
105 Requires:       %{pname} = %{version}-%{rel}
106
107 %description remotes
108 This package contains configuration files for many remotes supported
109 by lirc.
110
111 %description remotes -l pl.UTF-8
112 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
113 obsługiwanych przez lirc.
114
115 %package X11
116 Summary:        Linux Infrared Remote Control - X11 utilities
117 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
118 Group:          X11/Applications
119 Requires:       %{pname}-libs = %{version}-%{release}
120
121 %description X11
122 Linux Infrared Remote Control - X11 utilities.
123
124 %description X11 -l pl.UTF-8
125 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
126
127 %package svga
128 Summary:        Linux Infrared Remote Control - svgalib utilities
129 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
130 Group:          Applications
131 Requires:       %{pname}-libs = %{version}-%{release}
132
133 %description svga
134 Linux Infrared Remote Control - svgalib-based utilities.
135
136 %description svga -l pl.UTF-8
137 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
138 na svgalibie.
139
140 %package libs
141 Summary:        LIRC libraries
142 Summary(pl.UTF-8):      Biblioteki LIRC
143 Group:          Libraries
144 Conflicts:      lirc < 0.6.3-3
145 # didn't use /tmp/.lircd
146
147 %description libs
148 This package provides the libraries necessary to run lirc client
149 programs.
150
151 %description libs -l pl.UTF-8
152 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
153
154 %package devel
155 Summary:        Header files for LIRC development
156 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
157 Group:          Development/Libraries
158 Requires:       %{pname}-libs = %{version}-%{release}
159
160 %description devel
161 This package provides the files necessary to develop LIRC-based
162 programs.
163
164 %description devel -l pl.UTF-8
165 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych na
166 LIRC.
167
168 %package static
169 Summary:        Static library for LIRC development
170 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
171 Group:          Development/Libraries
172 Requires:       %{pname}-devel = %{version}-%{release}
173
174 %description static
175 The files necessary for development of statically-linked lirc-based
176 programs.
177
178 %description static -l pl.UTF-8
179 Pliki potrzebne do tworzenia łączonych statycznie programów opartych
180 na LIRC.
181
182 %package -n kernel%{_alt_kernel}-char-lirc-atiusb
183 Summary:        Kernel modules for Linux Infrared Remote Control
184 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
185 Release:        %{rel}@%{_kernel_ver_str}
186 Group:          Base/Kernel
187 %if %{with dist_kernel}
188 %requires_releq_kernel
189 Requires(postun):       %releq_kernel
190 %endif
191 Requires(post,postun):  /sbin/depmod
192 Requires:       %{pname} = %{version}
193 Conflicts:      dev < 2.8.0-3
194
195 %description -n kernel%{_alt_kernel}-char-lirc-atiusb
196 This package contains the kernel modules necessary to operate some
197 infrared remote control devices (such as the ones bundled with TV
198 cards).
199
200 lirc_atiusb module.
201
202 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8
203 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
204 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
205
206 Moduł lirc_atiusb.
207
208 %package -n kernel%{_alt_kernel}-char-lirc-bt829
209 Summary:        Kernel modules for Linux Infrared Remote Control
210 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
211 Release:        %{rel}@%{_kernel_ver_str}
212 Group:          Base/Kernel
213 %if %{with dist_kernel}
214 %requires_releq_kernel
215 Requires(postun):       %releq_kernel
216 %endif
217 Requires(post,postun):  /sbin/depmod
218 Requires:       %{pname} = %{version}
219 Conflicts:      dev < 2.8.0-3
220
221 %description -n kernel%{_alt_kernel}-char-lirc-bt829
222 This package contains the kernel modules necessary to operate some
223 infrared remote control devices (such as the ones bundled with TV
224 cards).
225
226 lirc_bt829 module.
227
228 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8
229 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
230 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
231
232 Moduł lirc_bt829.
233
234 %package -n kernel%{_alt_kernel}-char-lirc-dev
235 Summary:        Kernel modules for Linux Infrared Remote Control
236 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
237 Release:        %{rel}@%{_kernel_ver_str}
238 Group:          Base/Kernel
239 %if %{with dist_kernel}
240 %requires_releq_kernel
241 Requires(postun):       %releq_kernel
242 %endif
243 Requires(post,postun):  /sbin/depmod
244 Requires:       %{pname} = %{version}
245 Obsoletes:      lirc-modules
246 Obsoletes:      lirc-modules-dev
247 Conflicts:      dev < 2.8.0-3
248
249 %description -n kernel%{_alt_kernel}-char-lirc-dev
250 This package contains the kernel modules necessary to operate some
251 infrared remote control devices (such as the ones bundled with TV
252 cards).
253
254 lirc_dev module.
255
256 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8
257 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
258 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
259
260 Moduł lirc_dev.
261
262 %package -n kernel%{_alt_kernel}-char-lirc-ene0100
263 Summary:        Kernel modules for Linux Infrared Remote Control
264 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
265 Release:        %{rel}@%{_kernel_ver_str}
266 Group:          Base/Kernel
267 %if %{with dist_kernel}
268 %requires_releq_kernel
269 Requires(postun):       %releq_kernel
270 %endif
271 Requires(post,postun):  /sbin/depmod
272 Requires:       %{pname} = %{version}
273 Obsoletes:      lirc-modules
274 Conflicts:      dev < 2.8.0-3
275
276 %description -n kernel%{_alt_kernel}-char-lirc-ene0100
277 This package contains the kernel modules necessary to operate some
278 infrared remote control ene0100ices (such as the ones bundled with TV
279 cards).
280
281 lirc_ene0100 module.
282
283 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8
284 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
285 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
286
287 Moduł lirc_ene0100.
288
289 %package -n kernel%{_alt_kernel}-char-lirc-gpio
290 Summary:        Kernel modules for Linux Infrared Remote Control
291 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
292 Release:        %{rel}@%{_kernel_ver_str}
293 Group:          Base/Kernel
294 %if %{with dist_kernel}
295 %requires_releq_kernel
296 Requires(postun):       %releq_kernel
297 %endif
298 Requires(post,postun):  /sbin/depmod
299 Requires:       %{pname} = %{version}
300 Obsoletes:      lirc-modules
301 Obsoletes:      lirc-modules-gpio
302 Conflicts:      dev < 2.8.0-3
303
304 %description -n kernel%{_alt_kernel}-char-lirc-gpio
305 This package contains the kernel modules necessary to operate some
306 infrared remote control devices (such as the ones bundled with TV
307 cards).
308
309 lirc_gpio module.
310
311 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8
312 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
313 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
314
315 Moduł lirc_gpio.
316
317 %package -n kernel%{_alt_kernel}-char-lirc-i2c
318 Summary:        Kernel modules for Linux Infrared Remote Control
319 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
320 Release:        %{rel}@%{_kernel_ver_str}
321 Group:          Base/Kernel
322 %if %{with dist_kernel}
323 %requires_releq_kernel
324 Requires(postun):       %releq_kernel
325 %endif
326 Requires(post,postun):  /sbin/depmod
327 Requires:       %{pname} = %{version}
328 Obsoletes:      lirc-modules
329 Obsoletes:      lirc-modules-i2c
330 Conflicts:      dev < 2.8.0-3
331
332 %description -n kernel%{_alt_kernel}-char-lirc-i2c
333 This package contains the kernel modules necessary to operate some
334 infrared remote control devices (such as the ones bundled with TV
335 cards).
336
337 lirc_i2c module.
338
339 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8
340 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
341 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
342
343 Moduł lirc_i2c.
344
345 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb
346 Summary:        Kernel modules for Linux Infrared Remote Control
347 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
348 Release:        %{rel}@%{_kernel_ver_str}
349 Group:          Base/Kernel
350 %if %{with dist_kernel}
351 %requires_releq_kernel
352 Requires(postun):       %releq_kernel
353 %endif
354 Requires(post,postun):  /sbin/depmod
355 Requires:       %{pname} = %{version}
356 Obsoletes:      lirc-modules
357 Obsoletes:      lirc-modules-igorplugusb
358 Conflicts:      dev < 2.8.0-3
359
360 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb
361 This package contains the kernel modules necessary to operate some
362 infrared remote control devices (such as the ones bundled with TV
363 cards).
364
365 lirc_igorplugusb module.
366
367 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8
368 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
369 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
370
371 Moduł lirc_igorplugusb.
372
373 %package -n kernel%{_alt_kernel}-char-lirc-imon
374 Summary:        Kernel modules for Linux Infrared Remote Control
375 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
376 Release:        %{rel}@%{_kernel_ver_str}
377 Group:          Base/Kernel
378 %if %{with dist_kernel}
379 %requires_releq_kernel
380 Requires(postun):       %releq_kernel
381 %endif
382 Requires(post,postun):  /sbin/depmod
383 Requires:       %{pname} = %{version}
384 Obsoletes:      lirc-modules
385 Obsoletes:      lirc-modules-imon
386 Conflicts:      dev < 2.8.0-3
387
388 %description -n kernel%{_alt_kernel}-char-lirc-imon
389 This package contains the kernel modules necessary to operate some
390 infrared remote control devices (such as the ones bundled with TV
391 cards).
392
393 lirc_imon module.
394
395 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8
396 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
397 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
398
399 Moduł lirc_imon.
400
401 %package -n kernel%{_alt_kernel}-char-lirc-sasem
402 Summary:        Kernel modules for Linux Infrared Remote Control
403 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
404 Release:        %{rel}@%{_kernel_ver_str}
405 Group:          Base/Kernel
406 %if %{with dist_kernel}
407 %requires_releq_kernel
408 Requires(postun):       %releq_kernel
409 %endif
410 Requires(post,postun):  /sbin/depmod
411 Requires:       %{pname} = %{version}
412 Conflicts:      dev < 2.8.0-3
413
414 %description -n kernel%{_alt_kernel}-char-lirc-sasem
415 This package contains the kernel modules necessary to operate some
416 infrared remote control devices (such as the ones bundled with TV
417 cards).
418
419 lirc_sasem module.
420
421 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8
422 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
423 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
424
425 Moduł lirc_sasem.
426
427 %package -n kernel%{_alt_kernel}-char-lirc-serial
428 Summary:        Kernel modules for Linux Infrared Remote Control
429 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
430 Release:        %{rel}@%{_kernel_ver_str}
431 Group:          Base/Kernel
432 %if %{with dist_kernel}
433 %requires_releq_kernel
434 Requires(postun):       %releq_kernel
435 %endif
436 Requires(post,postun):  /sbin/depmod
437 Requires:       %{pname} = %{version}
438 %{?with_dist_kernel:Requires:   setserial}
439 Obsoletes:      lirc-modules
440 Obsoletes:      lirc-modules-serial
441 Conflicts:      dev < 2.8.0-3
442
443 %description -n kernel%{_alt_kernel}-char-lirc-serial
444 This package contains the kernel modules necessary to operate some
445 infrared remote control devices (such as the ones bundled with TV
446 cards).
447
448 lirc_serial module for devices connected to serial port.
449
450 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8
451 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
452 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
453
454 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.
455
456 %package -n kernel%{_alt_kernel}-char-lirc-sir
457 Summary:        Kernel modules for Linux Infrared Remote Control
458 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
459 Release:        %{rel}@%{_kernel_ver_str}
460 Group:          Base/Kernel
461 %if %{with dist_kernel}
462 %requires_releq_kernel
463 Requires(postun):       %releq_kernel
464 %endif
465 Requires(post,postun):  /sbin/depmod
466 Requires:       %{pname} = %{version}
467 Obsoletes:      lirc-modules
468 Obsoletes:      lirc-modules-sir
469 Conflicts:      dev < 2.8.0-3
470
471 %description -n kernel%{_alt_kernel}-char-lirc-sir
472 This package contains the kernel modules necessary to operate some
473 infrared remote control devices (such as the ones bundled with TV
474 cards).
475
476 lirc_sir module.
477
478 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8
479 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
480 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
481
482 Moduł lirc_sir.
483
484 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir
485 Summary:        Kernel modules for Linux Infrared Remote Control
486 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
487 Release:        %{rel}@%{_kernel_ver_str}
488 Group:          Base/Kernel
489 %if %{with dist_kernel}
490 %requires_releq_kernel
491 Requires(postun):       %releq_kernel
492 %endif
493 Requires(post,postun):  /sbin/depmod
494 Requires:       %{pname} = %{version}
495 Obsoletes:      lirc-modules
496 Obsoletes:      lirc-modules-ttusbir
497 Conflicts:      dev < 2.8.0-3
498
499 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir
500 This package contains the kernel modules necessary to operate
501 TechnoTrend USB IR Receiver.
502
503 lirc_ttusbir module.
504
505 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8
506 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
507 TechnoTrend USB IR Receiver.
508
509 Moduł lirc_ttusbir.
510
511 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691
512 Summary:        Kernel modules for Linux Infrared Remote Control
513 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
514 Release:        %{rel}@%{_kernel_ver_str}
515 Group:          Base/Kernel
516 %if %{with dist_kernel}
517 %requires_releq_kernel
518 Requires(postun):       %releq_kernel
519 %endif
520 Requires(post,postun):  /sbin/depmod
521 Requires:       %{pname} = %{version}
522 Conflicts:      dev < 2.8.0-3
523
524 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691
525 This package contains the kernel modules necessary to operate
526 TechnoTrend USB IR Receiver.
527
528 lirc_wpc87691 module.
529
530 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8
531 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
532 TechnoTrend USB IR Receiver.
533
534 Moduł lirc_wpc87691.
535
536 %package -n kernel%{_alt_kernel}-char-lirc-parallel
537 Summary:        Kernel modules for Linux Infrared Remote Control
538 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
539 Release:        %{rel}@%{_kernel_ver_str}
540 Group:          Base/Kernel
541 %if %{with dist_kernel}
542 %requires_releq_kernel
543 Requires(postun):       %releq_kernel
544 %endif
545 Requires(post,postun):  /sbin/depmod
546 Requires:       %{pname} = %{version}
547 Obsoletes:      lirc-modules
548 Obsoletes:      lirc-modules-parallel
549 Conflicts:      dev < 2.8.0-3
550
551 %description -n kernel%{_alt_kernel}-char-lirc-parallel
552 This package contains the kernel modules necessary to operate some
553 infrared remote control devices (such as the ones bundled with TV
554 cards).
555
556 lirc-parallel module for devices connected to parallel port.
557
558 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8
559 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
560 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
561
562 Moduł lirc_parallel dla urządzeń podłączanych do portu równoległego.
563
564 %prep
565 %setup -q -n %{pname}-%{version} -a 1
566 %patch0 -p1
567 %patch1 -p1
568 %if !%{with svga}
569 %patch2 -p1
570 %endif
571 %patch3 -p1
572 %patch4 -p1
573 %patch5 -p1
574 %patch6 -p1
575 %patch7 -p1
576
577 %build
578 echo '#' > drivers/Makefile.am
579 %{__libtoolize}
580 %{__aclocal}
581 %{__automake}
582 %{__autoheader}
583 %{__autoconf}
584
585 %configure \
586         ac_cv_header_portaudio_h=no \
587 %if %{with kernel}
588         KERNELCC="%{kgcc}" \
589 %else
590         ac_cv_have_kernel="no_kernel=yes" \
591 %endif
592         --with-kerneldir=%{_kernelsrcdir} \
593         %{?with_x:--with-x} \
594         --with-port=0x2f8 \
595         --with-irq=3 \
596         --without-soft-carrier \
597         --with-driver=userspace \
598         --with-igor
599
600 %if %{with userspace}
601 %{__make} -j1
602 %endif
603
604 %if %{with kernel}
605 cd drivers
606
607 drivers=%{drivers}
608
609 for drv in $drivers; do
610         cd $drv
611         %{__make} clean \
612                 LIRC_DEVDIR=`pwd` \
613                 RCS_FIND_IGNORE="-name '*.ko' -o" \
614                 %{?with_verbose:V=1}
615
616         %{__make} -j1 \
617                 LIRC_DEVDIR=`pwd` \
618                 CONSTIFY_PLUGIN="" \
619                 KBUILD_MODPOST_WARN=1 \
620                 %{?with_verbose:V=1}
621         cd ..
622 done
623
624 cd ..
625
626 %endif
627
628 %install
629 rm -rf $RPM_BUILD_ROOT
630
631 %if %{with kernel}
632 drivers=%{drivers}
633 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
634 for drv in $drivers; do
635         install -p drivers/$drv/$drv.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/$drv.ko
636 done
637 %endif
638
639 %if %{with userspace}
640 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
641         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,lirc} \
642         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
643
644 %{__make} -j1 install \
645         DESTDIR=$RPM_BUILD_ROOT \
646         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
647
648 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
649 #
650 # This is a placeholder for your configuration file.
651 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
652 #
653 END
654 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
655 cp -p contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
656 :> $RPM_BUILD_ROOT/var/log/lircd
657
658 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
659 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
660 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
661 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
662 %endif
663
664 %clean
665 rm -rf $RPM_BUILD_ROOT
666
667 %post   libs -p /sbin/ldconfig
668 %postun libs -p /sbin/ldconfig
669
670 %post
671 /sbin/chkconfig --add lircd
672 /sbin/chkconfig --add lircmd
673 %service lircd restart
674 %service lircmd restart
675
676 echo "If you are using a kernel-module-based driver, don't forget to"
677 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> package."
678
679 %preun
680 if [ "$1" = "0" ]; then
681         %service lircd stop
682         %service lircmd stop
683         /sbin/chkconfig --del lircd
684         /sbin/chkconfig --del lircmd
685 fi
686
687 %triggerpostun -- %{name} < 0.8.6-8
688 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
689         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
690 fi
691 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
692         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
693 fi
694
695 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb
696 %depmod %{_kernel_ver}
697 if [ "$1" = "1" ]; then
698         echo "Don't forget to add an 'alias lirc lirc_atiusb' to modprobe config"
699 fi
700
701 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb
702 %depmod %{_kernel_ver}
703
704 %post   -n kernel%{_alt_kernel}-char-lirc-bt829
705 %depmod %{_kernel_ver}
706 if [ "$1" = "1" ]; then
707         echo "Don't forget to add an 'alias lirc lirc_bt829' to modprobe config"
708 fi
709
710 %postun -n kernel%{_alt_kernel}-char-lirc-bt829
711 %depmod %{_kernel_ver}
712
713 %post   -n kernel%{_alt_kernel}-char-lirc-dev
714 %depmod %{_kernel_ver}
715
716 %postun -n kernel%{_alt_kernel}-char-lirc-dev
717 %depmod %{_kernel_ver}
718
719 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100
720 %depmod %{_kernel_ver}
721
722 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100
723 %depmod %{_kernel_ver}
724
725 %post   -n kernel%{_alt_kernel}-char-lirc-gpio
726 %depmod %{_kernel_ver}
727 if [ "$1" = "1" ]; then
728         echo "Don't forget to add an 'alias lirc lirc_gpio' to modprobe config"
729 fi
730
731 %postun -n kernel%{_alt_kernel}-char-lirc-gpio
732 %depmod %{_kernel_ver}
733
734 %post   -n kernel%{_alt_kernel}-char-lirc-i2c
735 %depmod %{_kernel_ver}
736 if [ "$1" = "1" ]; then
737         echo "Don't forget to add an 'alias lirc lirc_i2c' to modprobe config"
738 fi
739
740 %postun -n kernel%{_alt_kernel}-char-lirc-i2c
741 %depmod %{_kernel_ver}
742
743 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb
744 %depmod %{_kernel_ver}
745 if [ "$1" = "1" ]; then
746         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' to modprobe config"
747 fi
748
749 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb
750 %depmod %{_kernel_ver}
751
752 %post   -n kernel%{_alt_kernel}-char-lirc-imon
753 %depmod %{_kernel_ver}
754 if [ "$1" = "1" ]; then
755         echo "Don't forget to add an 'alias lirc lirc_imon' to modprobe config"
756 fi
757
758 %postun -n kernel%{_alt_kernel}-char-lirc-imon
759 %depmod %{_kernel_ver}
760
761 %post   -n kernel%{_alt_kernel}-char-lirc-sasem
762 %depmod %{_kernel_ver}
763 if [ "$1" = "1" ]; then
764         echo "Don't forget to add an 'alias lirc lirc_sasem' to modprobe config"
765 fi
766
767 %postun -n kernel%{_alt_kernel}-char-lirc-sasem
768 %depmod %{_kernel_ver}
769
770 %post   -n kernel%{_alt_kernel}-char-lirc-serial
771 %depmod %{_kernel_ver}
772 if [ "$1" = "1" ]; then
773         echo "Don't forget to add an 'alias lirc lirc_serial' to modprobe config"
774 fi
775
776 %postun -n kernel%{_alt_kernel}-char-lirc-serial
777 %depmod %{_kernel_ver}
778
779 %post   -n kernel%{_alt_kernel}-char-lirc-parallel
780 %depmod %{_kernel_ver}
781 if [ "$1" = "1" ]; then
782         echo "Don't forget to add an 'alias lirc lirc_parallel' modprobe config"
783 fi
784
785 %postun -n kernel%{_alt_kernel}-char-lirc-parallel
786 %depmod %{_kernel_ver}
787
788 %post   -n kernel%{_alt_kernel}-char-lirc-sir
789 %depmod %{_kernel_ver}
790 if [ "$1" = "1" ]; then
791         echo "Don't forget to add an 'alias lirc lirc_sir' to modprobe config"
792 fi
793
794 %postun -n kernel%{_alt_kernel}-char-lirc-sir
795 %depmod %{_kernel_ver}
796
797 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir
798 %depmod %{_kernel_ver}
799 if [ "$1" = "1" ]; then
800         echo "Don't forget to add an 'alias lirc lirc_ttusbir' to modprobe config"
801 fi
802
803 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir
804 %depmod %{_kernel_ver}
805
806 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691
807 %depmod %{_kernel_ver}
808 if [ "$1" = "1" ]; then
809         echo "Don't forget to add an 'alias lirc lirc_wpc87691' to modprobe config"
810 fi
811
812 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691
813 %depmod %{_kernel_ver}
814
815 %if %{with userspace}
816 %files
817 %defattr(644,root,root,755)
818 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
819 %doc contrib/lircrc doc/{html,images,lirc.css}
820 %attr(755,root,root) %{_bindir}/ircat
821 %attr(755,root,root) %{_bindir}/irexec
822 %attr(755,root,root) %{_bindir}/irpty
823 %attr(755,root,root) %{_bindir}/irrecord
824 %attr(755,root,root) %{_bindir}/irsend
825 %attr(755,root,root) %{_bindir}/irw
826 %attr(755,root,root) %{_bindir}/mode2
827 %attr(755,root,root) %{_bindir}/lircrcd
828 %attr(755,root,root) %{_bindir}/pronto2lirc
829 %attr(755,root,root) %{_sbindir}/lircd
830 %attr(755,root,root) %{_sbindir}/lircmd
831 %attr(754,root,root) /etc/rc.d/init.d/lircd
832 %attr(754,root,root) /etc/rc.d/init.d/lircmd
833 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
834 %dir %{_sysconfdir}/lirc
835 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
836 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
837 %{_mandir}/man1/ircat.1*
838 %{_mandir}/man1/irexec.1*
839 %{_mandir}/man1/irpty.1*
840 %{_mandir}/man1/irrecord.1*
841 %{_mandir}/man1/irsend.1*
842 %{_mandir}/man1/irw.1*
843 %{_mandir}/man1/lircrcd.1*
844 %{_mandir}/man1/mode2.1*
845 %{_mandir}/man8/lircd.8*
846 %{_mandir}/man8/lircmd.8*
847 %attr(600,root,root) %ghost /var/log/lircd
848 %dir /var/run/lirc
849 %{systemdtmpfilesdir}/%{name}.conf
850
851 %files remotes
852 %defattr(644,root,root,755)
853 # XXX: are jpegs in docs (remotes) a good idea?
854 %doc remotes
855
856 %if %{with x}
857 %files X11
858 %defattr(644,root,root,755)
859 %doc doc/irxevent.keys
860 %attr(755,root,root) %{_bindir}/irxevent
861 %attr(755,root,root) %{_bindir}/xmode2
862 %{_mandir}/man1/irxevent.1*
863 %{_mandir}/man1/xmode2.1*
864 %endif
865
866 %if %{with svga}
867 %files svga
868 %defattr(644,root,root,755)
869 %attr(755,root,root) %{_bindir}/smode2
870 %{_mandir}/man1/smode2.1*
871 %endif
872
873 %files libs
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
876 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
877
878 %files devel
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/liblirc_client.so
881 %{_libdir}/liblirc_client.la
882 %{_includedir}/lirc
883 %{_aclocaldir}/lirc.m4
884
885 %files static
886 %defattr(644,root,root,755)
887 %{_libdir}/liblirc_client.a
888 %endif
889
890 %if %{with kernel}
891 %files -n kernel%{_alt_kernel}-char-lirc-atiusb
892 %defattr(644,root,root,755)
893 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*
894
895 %files -n kernel%{_alt_kernel}-char-lirc-bt829
896 %defattr(644,root,root,755)
897 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*
898
899 %files -n kernel%{_alt_kernel}-char-lirc-dev
900 %defattr(644,root,root,755)
901 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*
902
903 %if "%{_kernel_ver}" < "3.0.0"
904 %files -n kernel%{_alt_kernel}-char-lirc-ene0100
905 %defattr(644,root,root,755)
906 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*
907 %endif
908
909 %if "%{_kernel_ver}" < "2.6.23"
910 %files -n kernel%{_alt_kernel}-char-lirc-gpio
911 %defattr(644,root,root,755)
912 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*
913 %endif
914
915 %files -n kernel%{_alt_kernel}-char-lirc-i2c
916 %defattr(644,root,root,755)
917 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*
918
919 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb
920 %defattr(644,root,root,755)
921 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*
922
923 %files -n kernel%{_alt_kernel}-char-lirc-imon
924 %defattr(644,root,root,755)
925 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*
926
927 %files -n kernel%{_alt_kernel}-char-lirc-sasem
928 %defattr(644,root,root,755)
929 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*
930
931 %files -n kernel%{_alt_kernel}-char-lirc-serial
932 %defattr(644,root,root,755)
933 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*
934
935 %files -n kernel%{_alt_kernel}-char-lirc-sir
936 %defattr(644,root,root,755)
937 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*
938
939 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir
940 %defattr(644,root,root,755)
941 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*
942
943 %if "%{_kernel_ver}" < "3.0.0"
944 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691
945 %defattr(644,root,root,755)
946 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*
947 %endif
948
949 %files -n kernel%{_alt_kernel}-char-lirc-parallel
950 %defattr(644,root,root,755)
951 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*
952 %endif
This page took 0.143495 seconds and 3 git commands to generate.