]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
482625f433e7c93370935483c3684acd4705c0f6
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 # - create modprobe alias files instead of reminding in post scriptlets
7 #
8 # Conditional build:
9 %bcond_without  dist_kernel     # without sources of distribution kernel
10 %bcond_without  kernel          # don't build kernel modules, only library+programs
11 %bcond_without  userspace       # build only packages with kernel modules
12 %bcond_with     svga            # without svgalib-based utility
13 %bcond_without  x               # without X11-based utilitied
14
15 %if %{without kernel}
16 %undefine       with_dist_kernel
17 %endif
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %if "%{_alt_kernel}" != "%{nil}"
29 %if 0%{?build_kernels:1}
30 %{error:alt_kernel and build_kernels are mutually exclusive}
31 exit 1
32 %endif
33 %undefine       with_userspace
34 %global         _build_kernels          %{alt_kernel}
35 %else
36 %global         _build_kernels          %{?build_kernels:,%{?build_kernels}}
37 %endif
38
39 %if %{without userspace}
40 # nothing to be placed to debuginfo package
41 %define         _enable_debug_packages  0
42 %endif
43
44 %define         kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; echo %%kernel_pkg_scriptlets ; done)
45 %define         bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
46
47 %define         pname   lirc
48 %define         rel     103
49
50 #
51 # main package
52 #
53 # lirc_gpio fails to build under kernel >= 2.6.23
54 #
55 %if "%{_kernel_ver}" >= "2.6.23"
56 %if "%{_kernel_ver}" >= "3.0.0"
57 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
58 %else
59 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
60 %endif
61 %else
62 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
63 %endif
64 Summary:        Linux Infrared Remote Control daemons
65 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
66 Name:           %{pname}%{_alt_kernel}
67 Version:        0.9.0
68 Release:        %{rel}%{?with_kernel:@%{_kernel_ver_str}}
69 License:        GPL v2+
70 Group:          Daemons
71 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
72 # Source0-md5:  b232aef26f23fe33ea8305d276637086
73 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
74 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
75 Source2:        %{pname}d.sysconfig
76 Source3:        %{pname}d.init
77 Source4:        %{pname}md.init
78 Source5:        %{pname}.tmpfiles
79 Patch0:         %{pname}-opt.patch
80 Patch1:         %{pname}-tmp.patch
81 Patch2:         %{pname}-no-svgalib.patch
82 Patch3:         %{pname}-kernel.patch
83 Patch4:         %{pname}-sparc.patch
84 Patch5:         %{pname}-remotes.patch
85 Patch6:         %{pname}-kernelcc.patch
86 Patch7:         format-security.patch
87 Patch8:         %{pname}-am.patch
88 URL:            http://www.lirc.org/
89 BuildRequires:  alsa-lib-devel
90 BuildRequires:  autoconf >= 2.50
91 BuildRequires:  automake
92 BuildRequires:  iguanaIR-devel
93 BuildRequires:  libftdi-devel >= 0.12
94 BuildRequires:  libirman-devel >= 0.4.5
95 BuildRequires:  libtool
96 BuildRequires:  libusb-compat-devel >= 0.1.0
97 BuildRequires:  rpmbuild(macros) >= 1.678
98 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
99 BuildRequires:  rpm-pythonprov
100 %{?with_svga:BuildRequires:     svgalib-devel}
101 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
102 Requires(post,preun):   /sbin/chkconfig
103 BuildRequires:  rpmbuild(macros) >= 1.268
104 Requires:       %{pname}-libs = %{version}-%{release}
105 Requires:       libftdi >= 0.12
106 Requires:       rc-scripts
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %if %{without userspace}
110 %define         no_spec_install_post_check_tmpfiles     1
111 %endif
112
113 %description
114 LIRC is a package that allows you to decode and send infra-red signals
115 of many (but not all) commonly used remote controls.
116
117 %description -l pl.UTF-8
118 LIRC to program pozwalający na dekodowanie nadchodzących oraz
119 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie wszystkich)
120 popularnych urządzeń do zdalnego sterowania.
121
122 %package remotes
123 Summary:        Lirc remotes database
124 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
125 Group:          Documentation
126 Requires:       %{pname} = %{version}-%{rel}
127
128 %description remotes
129 This package contains configuration files for many remotes supported
130 by lirc.
131
132 %description remotes -l pl.UTF-8
133 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
134 obsługiwanych przez lirc.
135
136 %package X11
137 Summary:        Linux Infrared Remote Control - X11 utilities
138 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
139 Group:          X11/Applications
140 Requires:       %{pname}-libs = %{version}-%{release}
141
142 %description X11
143 Linux Infrared Remote Control - X11 utilities.
144
145 %description X11 -l pl.UTF-8
146 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
147
148 %package svga
149 Summary:        Linux Infrared Remote Control - svgalib utilities
150 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
151 Group:          Applications
152 Requires:       %{pname}-libs = %{version}-%{release}
153
154 %description svga
155 Linux Infrared Remote Control - svgalib-based utilities.
156
157 %description svga -l pl.UTF-8
158 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
159 na svgalibie.
160
161 %package libs
162 Summary:        LIRC libraries
163 Summary(pl.UTF-8):      Biblioteki LIRC
164 Group:          Libraries
165 Conflicts:      lirc < 0.6.3-3
166 # didn't use /tmp/.lircd
167
168 %description libs
169 This package provides the libraries necessary to run lirc client
170 programs.
171
172 %description libs -l pl.UTF-8
173 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
174
175 %package devel
176 Summary:        Header files for LIRC development
177 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
178 Group:          Development/Libraries
179 Requires:       %{pname}-libs = %{version}-%{release}
180
181 %description devel
182 This package provides the files necessary to develop LIRC-based
183 programs.
184
185 %description devel -l pl.UTF-8
186 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych na
187 LIRC.
188
189 %package static
190 Summary:        Static library for LIRC development
191 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
192 Group:          Development/Libraries
193 Requires:       %{pname}-devel = %{version}-%{release}
194
195 %description static
196 The files necessary for development of statically-linked lirc-based
197 programs.
198
199 %description static -l pl.UTF-8
200 Pliki potrzebne do tworzenia łączonych statycznie programów opartych
201 na LIRC.
202
203 %define kernel_pkg()\
204 %package -n kernel%{_alt_kernel}-char-lirc-atiusb\
205 Summary:        Kernel modules for Linux Infrared Remote Control\
206 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
207 Release:        %{rel}@%{_kernel_ver_str}\
208 Group:          Base/Kernel\
209 %if %{with dist_kernel}\
210 %requires_releq_kernel\
211 Requires(postun):       %releq_kernel\
212 %endif\
213 Requires(post,postun):  /sbin/depmod\
214 Requires:       %{pname} = %{version}\
215 Conflicts:      dev < 2.8.0-3\
216 \
217 %description -n kernel%{_alt_kernel}-char-lirc-atiusb\
218 This package contains the kernel modules necessary to operate some\
219 infrared remote control devices (such as the ones bundled with TV\
220 cards).\
221 \
222 lirc_atiusb module.\
223 \
224 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8\
225 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
226 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
227 \
228 Moduł lirc_atiusb.\
229 \
230 %package -n kernel%{_alt_kernel}-char-lirc-bt829\
231 Summary:        Kernel modules for Linux Infrared Remote Control\
232 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
233 Release:        %{rel}@%{_kernel_ver_str}\
234 Group:          Base/Kernel\
235 %if %{with dist_kernel}\
236 %requires_releq_kernel\
237 Requires(postun):       %releq_kernel\
238 %endif\
239 Requires(post,postun):  /sbin/depmod\
240 Requires:       %{pname} = %{version}\
241 Conflicts:      dev < 2.8.0-3\
242 \
243 %description -n kernel%{_alt_kernel}-char-lirc-bt829\
244 This package contains the kernel modules necessary to operate some\
245 infrared remote control devices (such as the ones bundled with TV\
246 cards).\
247 \
248 lirc_bt829 module.\
249 \
250 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8\
251 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
252 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
253 \
254 Moduł lirc_bt829.\
255 \
256 %package -n kernel%{_alt_kernel}-char-lirc-dev\
257 Summary:        Kernel modules for Linux Infrared Remote Control\
258 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
259 Release:        %{rel}@%{_kernel_ver_str}\
260 Group:          Base/Kernel\
261 %if %{with dist_kernel}\
262 %requires_releq_kernel\
263 Requires(postun):       %releq_kernel\
264 %endif\
265 Requires(post,postun):  /sbin/depmod\
266 Requires:       %{pname} = %{version}\
267 Obsoletes:      lirc-modules\
268 Obsoletes:      lirc-modules-dev\
269 Conflicts:      dev < 2.8.0-3\
270 \
271 %description -n kernel%{_alt_kernel}-char-lirc-dev\
272 This package contains the kernel modules necessary to operate some\
273 infrared remote control devices (such as the ones bundled with TV\
274 cards).\
275 \
276 lirc_dev module.\
277 \
278 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8\
279 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
280 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
281 \
282 Moduł lirc_dev.\
283 \
284 %package -n kernel%{_alt_kernel}-char-lirc-ene0100\
285 Summary:        Kernel modules for Linux Infrared Remote Control\
286 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
287 Release:        %{rel}@%{_kernel_ver_str}\
288 Group:          Base/Kernel\
289 %if %{with dist_kernel}\
290 %requires_releq_kernel\
291 Requires(postun):       %releq_kernel\
292 %endif\
293 Requires(post,postun):  /sbin/depmod\
294 Requires:       %{pname} = %{version}\
295 Obsoletes:      lirc-modules\
296 Conflicts:      dev < 2.8.0-3\
297 \
298 %description -n kernel%{_alt_kernel}-char-lirc-ene0100\
299 This package contains the kernel modules necessary to operate some\
300 infrared remote control ene0100ices (such as the ones bundled with TV\
301 cards).\
302 \
303 lirc_ene0100 module.\
304 \
305 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8\
306 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
307 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
308 \
309 Moduł lirc_ene0100.\
310 \
311 %package -n kernel%{_alt_kernel}-char-lirc-gpio\
312 Summary:        Kernel modules for Linux Infrared Remote Control\
313 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
314 Release:        %{rel}@%{_kernel_ver_str}\
315 Group:          Base/Kernel\
316 %if %{with dist_kernel}\
317 %requires_releq_kernel\
318 Requires(postun):       %releq_kernel\
319 %endif\
320 Requires(post,postun):  /sbin/depmod\
321 Requires:       %{pname} = %{version}\
322 Obsoletes:      lirc-modules\
323 Obsoletes:      lirc-modules-gpio\
324 Conflicts:      dev < 2.8.0-3\
325 \
326 %description -n kernel%{_alt_kernel}-char-lirc-gpio\
327 This package contains the kernel modules necessary to operate some\
328 infrared remote control devices (such as the ones bundled with TV\
329 cards).\
330 \
331 lirc_gpio module.\
332 \
333 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8\
334 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
335 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
336 \
337 Moduł lirc_gpio.\
338 \
339 %package -n kernel%{_alt_kernel}-char-lirc-i2c\
340 Summary:        Kernel modules for Linux Infrared Remote Control\
341 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
342 Release:        %{rel}@%{_kernel_ver_str}\
343 Group:          Base/Kernel\
344 %if %{with dist_kernel}\
345 %requires_releq_kernel\
346 Requires(postun):       %releq_kernel\
347 %endif\
348 Requires(post,postun):  /sbin/depmod\
349 Requires:       %{pname} = %{version}\
350 Obsoletes:      lirc-modules\
351 Obsoletes:      lirc-modules-i2c\
352 Conflicts:      dev < 2.8.0-3\
353 \
354 %description -n kernel%{_alt_kernel}-char-lirc-i2c\
355 This package contains the kernel modules necessary to operate some\
356 infrared remote control devices (such as the ones bundled with TV\
357 cards).\
358 \
359 lirc_i2c module.\
360 \
361 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8\
362 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
363 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
364 \
365 Moduł lirc_i2c.\
366 \
367 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
368 Summary:        Kernel modules for Linux Infrared Remote Control\
369 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
370 Release:        %{rel}@%{_kernel_ver_str}\
371 Group:          Base/Kernel\
372 %if %{with dist_kernel}\
373 %requires_releq_kernel\
374 Requires(postun):       %releq_kernel\
375 %endif\
376 Requires(post,postun):  /sbin/depmod\
377 Requires:       %{pname} = %{version}\
378 Obsoletes:      lirc-modules\
379 Obsoletes:      lirc-modules-igorplugusb\
380 Conflicts:      dev < 2.8.0-3\
381 \
382 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
383 This package contains the kernel modules necessary to operate some\
384 infrared remote control devices (such as the ones bundled with TV\
385 cards).\
386 \
387 lirc_igorplugusb module.\
388 \
389 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8\
390 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
391 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
392 \
393 Moduł lirc_igorplugusb.\
394 \
395 %package -n kernel%{_alt_kernel}-char-lirc-imon\
396 Summary:        Kernel modules for Linux Infrared Remote Control\
397 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
398 Release:        %{rel}@%{_kernel_ver_str}\
399 Group:          Base/Kernel\
400 %if %{with dist_kernel}\
401 %requires_releq_kernel\
402 Requires(postun):       %releq_kernel\
403 %endif\
404 Requires(post,postun):  /sbin/depmod\
405 Requires:       %{pname} = %{version}\
406 Obsoletes:      lirc-modules\
407 Obsoletes:      lirc-modules-imon\
408 Conflicts:      dev < 2.8.0-3\
409 \
410 %description -n kernel%{_alt_kernel}-char-lirc-imon\
411 This package contains the kernel modules necessary to operate some\
412 infrared remote control devices (such as the ones bundled with TV\
413 cards).\
414 \
415 lirc_imon module.\
416 \
417 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8\
418 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
419 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
420 \
421 Moduł lirc_imon.\
422 \
423 %package -n kernel%{_alt_kernel}-char-lirc-sasem\
424 Summary:        Kernel modules for Linux Infrared Remote Control\
425 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
426 Release:        %{rel}@%{_kernel_ver_str}\
427 Group:          Base/Kernel\
428 %if %{with dist_kernel}\
429 %requires_releq_kernel\
430 Requires(postun):       %releq_kernel\
431 %endif\
432 Requires(post,postun):  /sbin/depmod\
433 Requires:       %{pname} = %{version}\
434 Conflicts:      dev < 2.8.0-3\
435 \
436 %description -n kernel%{_alt_kernel}-char-lirc-sasem\
437 This package contains the kernel modules necessary to operate some\
438 infrared remote control devices (such as the ones bundled with TV\
439 cards).\
440 \
441 lirc_sasem module.\
442 \
443 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8\
444 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
445 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
446 \
447 Moduł lirc_sasem.\
448 \
449 %package -n kernel%{_alt_kernel}-char-lirc-serial\
450 Summary:        Kernel modules for Linux Infrared Remote Control\
451 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
452 Release:        %{rel}@%{_kernel_ver_str}\
453 Group:          Base/Kernel\
454 %if %{with dist_kernel}\
455 %requires_releq_kernel\
456 Requires(postun):       %releq_kernel\
457 %endif\
458 Requires(post,postun):  /sbin/depmod\
459 Requires:       %{pname} = %{version}\
460 %{?with_dist_kernel:Requires:   setserial}\
461 Obsoletes:      lirc-modules\
462 Obsoletes:      lirc-modules-serial\
463 Conflicts:      dev < 2.8.0-3\
464 \
465 %description -n kernel%{_alt_kernel}-char-lirc-serial\
466 This package contains the kernel modules necessary to operate some\
467 infrared remote control devices (such as the ones bundled with TV\
468 cards).\
469 \
470 lirc_serial module for devices connected to serial port.\
471 \
472 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8\
473 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
474 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
475 \
476 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.\
477 \
478 %package -n kernel%{_alt_kernel}-char-lirc-sir\
479 Summary:        Kernel modules for Linux Infrared Remote Control\
480 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
481 Release:        %{rel}@%{_kernel_ver_str}\
482 Group:          Base/Kernel\
483 %if %{with dist_kernel}\
484 %requires_releq_kernel\
485 Requires(postun):       %releq_kernel\
486 %endif\
487 Requires(post,postun):  /sbin/depmod\
488 Requires:       %{pname} = %{version}\
489 Obsoletes:      lirc-modules\
490 Obsoletes:      lirc-modules-sir\
491 Conflicts:      dev < 2.8.0-3\
492 \
493 %description -n kernel%{_alt_kernel}-char-lirc-sir\
494 This package contains the kernel modules necessary to operate some\
495 infrared remote control devices (such as the ones bundled with TV\
496 cards).\
497 \
498 lirc_sir module.\
499 \
500 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8\
501 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
502 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
503 \
504 Moduł lirc_sir.\
505 \
506 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir\
507 Summary:        Kernel modules for Linux Infrared Remote Control\
508 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
509 Release:        %{rel}@%{_kernel_ver_str}\
510 Group:          Base/Kernel\
511 %if %{with dist_kernel}\
512 %requires_releq_kernel\
513 Requires(postun):       %releq_kernel\
514 %endif\
515 Requires(post,postun):  /sbin/depmod\
516 Requires:       %{pname} = %{version}\
517 Obsoletes:      lirc-modules\
518 Obsoletes:      lirc-modules-ttusbir\
519 Conflicts:      dev < 2.8.0-3\
520 \
521 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir\
522 This package contains the kernel modules necessary to operate\
523 TechnoTrend USB IR Receiver.\
524 \
525 lirc_ttusbir module.\
526 \
527 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8\
528 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia\
529 TechnoTrend USB IR Receiver.\
530 \
531 Moduł lirc_ttusbir.\
532 \
533 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691\
534 Summary:        Kernel modules for Linux Infrared Remote Control\
535 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
536 Release:        %{rel}@%{_kernel_ver_str}\
537 Group:          Base/Kernel\
538 %if %{with dist_kernel}\
539 %requires_releq_kernel\
540 Requires(postun):       %releq_kernel\
541 %endif\
542 Requires(post,postun):  /sbin/depmod\
543 Requires:       %{pname} = %{version}\
544 Conflicts:      dev < 2.8.0-3\
545 \
546 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691\
547 This package contains the kernel modules necessary to operate\
548 TechnoTrend USB IR Receiver.\
549 \
550 lirc_wpc87691 module.\
551 \
552 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8\
553 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia\
554 TechnoTrend USB IR Receiver.\
555 \
556 Moduł lirc_wpc87691.\
557 \
558 %package -n kernel%{_alt_kernel}-char-lirc-parallel\
559 Summary:        Kernel modules for Linux Infrared Remote Control\
560 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
561 Release:        %{rel}@%{_kernel_ver_str}\
562 Group:          Base/Kernel\
563 %if %{with dist_kernel}\
564 %requires_releq_kernel\
565 Requires(postun):       %releq_kernel\
566 %endif\
567 Requires(post,postun):  /sbin/depmod\
568 Requires:       %{pname} = %{version}\
569 Obsoletes:      lirc-modules\
570 Obsoletes:      lirc-modules-parallel\
571 Conflicts:      dev < 2.8.0-3\
572 \
573 %description -n kernel%{_alt_kernel}-char-lirc-parallel\
574 This package contains the kernel modules necessary to operate some\
575 infrared remote control devices (such as the ones bundled with TV\
576 cards).\
577 \
578 lirc-parallel module for devices connected to parallel port.\
579 \
580 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8\
581 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
582 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
583 \
584 Moduł lirc_parallel dla urządzeń podłączanych do portu równoległego.\
585 \
586 %if %{with kernel}\
587 %files -n kernel%{_alt_kernel}-char-lirc-atiusb\
588 %defattr(644,root,root,755)\
589 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*\
590 \
591 %files -n kernel%{_alt_kernel}-char-lirc-bt829\
592 %defattr(644,root,root,755)\
593 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*\
594 \
595 %files -n kernel%{_alt_kernel}-char-lirc-dev\
596 %defattr(644,root,root,755)\
597 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*\
598 \
599 %if "%{_kernel_ver}" < "3.0.0"\
600 %files -n kernel%{_alt_kernel}-char-lirc-ene0100\
601 %defattr(644,root,root,755)\
602 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*\
603 %endif\
604 \
605 %if "%{_kernel_ver}" < "2.6.23"\
606 %files -n kernel%{_alt_kernel}-char-lirc-gpio\
607 %defattr(644,root,root,755)\
608 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*\
609 %endif\
610 \
611 %files -n kernel%{_alt_kernel}-char-lirc-i2c\
612 %defattr(644,root,root,755)\
613 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*\
614 \
615 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
616 %defattr(644,root,root,755)\
617 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*\
618 \
619 %files -n kernel%{_alt_kernel}-char-lirc-imon\
620 %defattr(644,root,root,755)\
621 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*\
622 \
623 %files -n kernel%{_alt_kernel}-char-lirc-sasem\
624 %defattr(644,root,root,755)\
625 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*\
626 \
627 %files -n kernel%{_alt_kernel}-char-lirc-serial\
628 %defattr(644,root,root,755)\
629 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*\
630 \
631 %files -n kernel%{_alt_kernel}-char-lirc-sir\
632 %defattr(644,root,root,755)\
633 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*\
634 \
635 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir\
636 %defattr(644,root,root,755)\
637 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*\
638 \
639 %if "%{_kernel_ver}" < "3.0.0"\
640 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691\
641 %defattr(644,root,root,755)\
642 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*\
643 %endif\
644 \
645 %files -n kernel%{_alt_kernel}-char-lirc-parallel\
646 %defattr(644,root,root,755)\
647 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*\
648 %endif\
649 %{nil}
650
651 %define kernel_pkg_scriptlets()\
652 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb\
653 %depmod %{_kernel_ver}\
654 if [ "$1" = "1" ]; then\
655         echo "Don't forget to add an 'alias lirc lirc_atiusb' to modprobe config"\
656 fi\
657 \
658 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb\
659 %depmod %{_kernel_ver}\
660 \
661 %post   -n kernel%{_alt_kernel}-char-lirc-bt829\
662 %depmod %{_kernel_ver}\
663 if [ "$1" = "1" ]; then\
664         echo "Don't forget to add an 'alias lirc lirc_bt829' to modprobe config"\
665 fi\
666 \
667 %postun -n kernel%{_alt_kernel}-char-lirc-bt829\
668 %depmod %{_kernel_ver}\
669 \
670 %post   -n kernel%{_alt_kernel}-char-lirc-dev\
671 %depmod %{_kernel_ver}\
672 \
673 %postun -n kernel%{_alt_kernel}-char-lirc-dev\
674 %depmod %{_kernel_ver}\
675 \
676 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100\
677 %depmod %{_kernel_ver}\
678 \
679 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100\
680 %depmod %{_kernel_ver}\
681 \
682 %post   -n kernel%{_alt_kernel}-char-lirc-gpio\
683 %depmod %{_kernel_ver}\
684 if [ "$1" = "1" ]; then\
685         echo "Don't forget to add an 'alias lirc lirc_gpio' to modprobe config"\
686 fi\
687 \
688 %postun -n kernel%{_alt_kernel}-char-lirc-gpio\
689 %depmod %{_kernel_ver}\
690 \
691 %post   -n kernel%{_alt_kernel}-char-lirc-i2c\
692 %depmod %{_kernel_ver}\
693 if [ "$1" = "1" ]; then\
694         echo "Don't forget to add an 'alias lirc lirc_i2c' to modprobe config"\
695 fi\
696 \
697 %postun -n kernel%{_alt_kernel}-char-lirc-i2c\
698 %depmod %{_kernel_ver}\
699 \
700 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
701 %depmod %{_kernel_ver}\
702 if [ "$1" = "1" ]; then\
703         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' to modprobe config"\
704 fi\
705 \
706 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
707 %depmod %{_kernel_ver}\
708 \
709 %post   -n kernel%{_alt_kernel}-char-lirc-imon\
710 %depmod %{_kernel_ver}\
711 if [ "$1" = "1" ]; then\
712         echo "Don't forget to add an 'alias lirc lirc_imon' to modprobe config"\
713 fi\
714 \
715 %postun -n kernel%{_alt_kernel}-char-lirc-imon\
716 %depmod %{_kernel_ver}\
717 \
718 %post   -n kernel%{_alt_kernel}-char-lirc-sasem\
719 %depmod %{_kernel_ver}\
720 if [ "$1" = "1" ]; then\
721         echo "Don't forget to add an 'alias lirc lirc_sasem' to modprobe config"\
722 fi\
723 \
724 %postun -n kernel%{_alt_kernel}-char-lirc-sasem\
725 %depmod %{_kernel_ver}\
726 \
727 %post   -n kernel%{_alt_kernel}-char-lirc-serial\
728 %depmod %{_kernel_ver}\
729 if [ "$1" = "1" ]; then\
730         echo "Don't forget to add an 'alias lirc lirc_serial' to modprobe config"\
731 fi\
732 \
733 %postun -n kernel%{_alt_kernel}-char-lirc-serial\
734 %depmod %{_kernel_ver}\
735 \
736 %post   -n kernel%{_alt_kernel}-char-lirc-parallel\
737 %depmod %{_kernel_ver}\
738 if [ "$1" = "1" ]; then\
739         echo "Don't forget to add an 'alias lirc lirc_parallel' modprobe config"\
740 fi\
741 \
742 %postun -n kernel%{_alt_kernel}-char-lirc-parallel\
743 %depmod %{_kernel_ver}\
744 \
745 %post   -n kernel%{_alt_kernel}-char-lirc-sir\
746 %depmod %{_kernel_ver}\
747 if [ "$1" = "1" ]; then\
748         echo "Don't forget to add an 'alias lirc lirc_sir' to modprobe config"\
749 fi\
750 \
751 %postun -n kernel%{_alt_kernel}-char-lirc-sir\
752 %depmod %{_kernel_ver}\
753 \
754 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir\
755 %depmod %{_kernel_ver}\
756 if [ "$1" = "1" ]; then\
757         echo "Don't forget to add an 'alias lirc lirc_ttusbir' to modprobe config"\
758 fi\
759 \
760 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir\
761 %depmod %{_kernel_ver}\
762 \
763 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691\
764 %depmod %{_kernel_ver}\
765 if [ "$1" = "1" ]; then\
766         echo "Don't forget to add an 'alias lirc lirc_wpc87691' to modprobe config"\
767 fi\
768 \
769 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691\
770 %depmod %{_kernel_ver}\
771 %{nil}
772
773 %define build_kernel_pkg()\
774 %configure \\\
775         ac_cv_header_portaudio_h=no \\\
776         --with-kerneldir=%{_kernelsrcdir} \\\
777         %{?with_x:--with-x} \\\
778         --with-port=0x2f8 \\\
779         --with-irq=3 \\\
780         --without-soft-carrier \\\
781         --with-driver=userspace \\\
782         --with-igor\
783 \
784 drivers=%{drivers}\
785 for drv in $drivers; do\
786         cd drivers/$drv\
787         %{__make} clean \\\
788                 LIRC_DEVDIR=`pwd` \\\
789                 RCS_FIND_IGNORE="-name '*.ko' -o" \\\
790                 %{?with_verbose:V=1}\
791 \
792         %{__make} -j1 \\\
793                 LIRC_DEVDIR=`pwd` \\\
794                 CONSTIFY_PLUGIN="" \\\
795                 KBUILD_MODPOST_WARN=1 \\\
796                 %{?with_verbose:V=1}\
797         cd ../..\
798         %install_kernel_modules -D installed -m drivers/$drv/$drv -d misc\
799 done\
800 %{nil}
801
802 %{?with_kernel:%{expand:%kpkg}}
803
804 %prep
805 %setup -q -n %{pname}-%{version} -a 1
806 %patch0 -p1
807 %patch1 -p1
808 %if !%{with svga}
809 %patch2 -p1
810 %endif
811 %patch3 -p1
812 %patch4 -p1
813 %patch5 -p1
814 %patch6 -p1
815 %patch7 -p1
816 %patch8 -p1
817
818 %build
819 echo '#' > drivers/Makefile.am
820 %{__libtoolize}
821 %{__aclocal}
822 %{__automake}
823 %{__autoheader}
824 %{__autoconf}
825
826 %if %{with userspace}
827 %configure \
828         ac_cv_header_portaudio_h=no \
829 %if %{without kernel}
830         ac_cv_have_kernel="no_kernel=yes" \
831 %endif
832         --with-kerneldir=%{_kernelsrcdir} \
833         %{?with_x:--with-x} \
834         --with-port=0x2f8 \
835         --with-irq=3 \
836         --without-soft-carrier \
837         --with-driver=userspace \
838         --with-igor
839
840 %{__make} -j1
841 %endif
842
843 %{?with_kernel:%{expand:%bkpkg}}
844
845 %install
846 rm -rf $RPM_BUILD_ROOT
847 install -d $RPM_BUILD_ROOT
848
849 %if %{with kernel}
850 cp -a installed/* $RPM_BUILD_ROOT
851 %endif
852
853 %if %{with userspace}
854 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
855         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,lirc} \
856         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
857
858 %{__make} -j1 install \
859         DESTDIR=$RPM_BUILD_ROOT \
860         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
861
862 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
863 #
864 # This is a placeholder for your configuration file.
865 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
866 #
867 END
868 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
869 cp -p contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
870 :> $RPM_BUILD_ROOT/var/log/lircd
871
872 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
873 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
874 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
875 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
876 %endif
877
878 %clean
879 rm -rf $RPM_BUILD_ROOT
880
881 %post   libs -p /sbin/ldconfig
882 %postun libs -p /sbin/ldconfig
883
884 %post
885 /sbin/chkconfig --add lircd
886 /sbin/chkconfig --add lircmd
887 %service lircd restart
888 %service lircmd restart
889
890 echo "If you are using a kernel-module-based driver, don't forget to"
891 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> package."
892
893 %preun
894 if [ "$1" = "0" ]; then
895         %service lircd stop
896         %service lircmd stop
897         /sbin/chkconfig --del lircd
898         /sbin/chkconfig --del lircmd
899 fi
900
901 %triggerpostun -- %{name} < 0.8.6-8
902 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
903         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
904 fi
905 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
906         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
907 fi
908
909 %if %{with userspace}
910 %files
911 %defattr(644,root,root,755)
912 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
913 %doc contrib/lircrc doc/{html,images,lirc.css}
914 %attr(755,root,root) %{_bindir}/ircat
915 %attr(755,root,root) %{_bindir}/irexec
916 %attr(755,root,root) %{_bindir}/irpty
917 %attr(755,root,root) %{_bindir}/irrecord
918 %attr(755,root,root) %{_bindir}/irsend
919 %attr(755,root,root) %{_bindir}/irw
920 %attr(755,root,root) %{_bindir}/mode2
921 %attr(755,root,root) %{_bindir}/lircrcd
922 %attr(755,root,root) %{_bindir}/pronto2lirc
923 %attr(755,root,root) %{_sbindir}/lircd
924 %attr(755,root,root) %{_sbindir}/lircmd
925 %attr(754,root,root) /etc/rc.d/init.d/lircd
926 %attr(754,root,root) /etc/rc.d/init.d/lircmd
927 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
928 %dir %{_sysconfdir}/lirc
929 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
930 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
931 %{_mandir}/man1/ircat.1*
932 %{_mandir}/man1/irexec.1*
933 %{_mandir}/man1/irpty.1*
934 %{_mandir}/man1/irrecord.1*
935 %{_mandir}/man1/irsend.1*
936 %{_mandir}/man1/irw.1*
937 %{_mandir}/man1/lircrcd.1*
938 %{_mandir}/man1/mode2.1*
939 %{_mandir}/man8/lircd.8*
940 %{_mandir}/man8/lircmd.8*
941 %attr(600,root,root) %ghost /var/log/lircd
942 %dir /var/run/lirc
943 %{systemdtmpfilesdir}/%{name}.conf
944
945 %files remotes
946 %defattr(644,root,root,755)
947 # XXX: are jpegs in docs (remotes) a good idea?
948 %doc remotes
949
950 %if %{with x}
951 %files X11
952 %defattr(644,root,root,755)
953 %doc doc/irxevent.keys
954 %attr(755,root,root) %{_bindir}/irxevent
955 %attr(755,root,root) %{_bindir}/xmode2
956 %{_mandir}/man1/irxevent.1*
957 %{_mandir}/man1/xmode2.1*
958 %endif
959
960 %if %{with svga}
961 %files svga
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_bindir}/smode2
964 %{_mandir}/man1/smode2.1*
965 %endif
966
967 %files libs
968 %defattr(644,root,root,755)
969 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
970 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
971
972 %files devel
973 %defattr(644,root,root,755)
974 %attr(755,root,root) %{_libdir}/liblirc_client.so
975 %{_libdir}/liblirc_client.la
976 %{_includedir}/lirc
977 %{_aclocaldir}/lirc.m4
978
979 %files static
980 %defattr(644,root,root,755)
981 %{_libdir}/liblirc_client.a
982 %endif
This page took 0.098358 seconds and 2 git commands to generate.