]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
- x32 rebuild
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 # - create modprobe alias files instead of reminding in post scriptlets
7 #
8 # Conditional build:
9 %bcond_without  kernel          # don't build kernel modules, only library+programs
10 %bcond_without  userspace       # build only packages with kernel modules
11 %bcond_with     svga            # without svgalib-based utility
12 %bcond_without  x               # without X11-based utilitied
13
14 # The goal here is to have main, userspace, package built once with
15 # simple release number, and only rebuild kernel packages with kernel
16 # version as part of release number, without the need to bump release
17 # with every kernel change.
18 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
19 %{error:kernel and userspace cannot be built at the same time on PLD builders}
20 exit 1
21 %endif
22
23 %if %{without userspace}
24 # nothing to be placed to debuginfo package
25 %define         _enable_debug_packages  0
26 %endif
27
28 %define         pname   lirc
29 %define         rel     106
30 #
31 # main package
32 #
33 # lirc_gpio fails to build under kernel >= 2.6.23
34 #
35 %if %{with kernel}
36 %if %{_kernel_version_code} >= %{_kernel_version_magic 2 6 23}
37 %if %{_kernel_version_code} >= %{_kernel_version_magic 3 0 0}
38 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
39 %else
40 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
41 %endif
42 %else
43 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
44 %endif
45 %endif
46 Summary:        Linux Infrared Remote Control daemons
47 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
48 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
49 Version:        0.9.0
50 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
51 License:        GPL v2+
52 Group:          Daemons
53 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
54 # Source0-md5:  b232aef26f23fe33ea8305d276637086
55 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
56 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
57 Source2:        %{pname}d.sysconfig
58 Source3:        %{pname}d.init
59 Source4:        %{pname}md.init
60 Source5:        %{pname}.tmpfiles
61 Patch0:         %{pname}-opt.patch
62 Patch1:         %{pname}-tmp.patch
63 Patch2:         %{pname}-no-svgalib.patch
64 Patch3:         %{pname}-kernel.patch
65 Patch4:         %{pname}-sparc.patch
66 Patch5:         %{pname}-remotes.patch
67 Patch6:         %{pname}-kernelcc.patch
68 Patch7:         format-security.patch
69 Patch8:         %{pname}-am.patch
70 URL:            http://www.lirc.org/
71 BuildRequires:  alsa-lib-devel
72 BuildRequires:  autoconf >= 2.50
73 BuildRequires:  automake
74 BuildRequires:  iguanaIR-devel
75 BuildRequires:  libftdi-devel >= 0.12
76 BuildRequires:  libirman-devel >= 0.4.5
77 BuildRequires:  libtool
78 BuildRequires:  libusb-compat-devel >= 0.1.0
79 BuildRequires:  rpmbuild(macros) >= 1.701
80 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
81 BuildRequires:  rpm-pythonprov
82 %{?with_svga:BuildRequires:     svgalib-devel}
83 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
84 Requires(post,preun):   /sbin/chkconfig
85 BuildRequires:  rpmbuild(macros) >= 1.268
86 Requires:       %{pname}-libs = %{version}-%{release}
87 Requires:       libftdi >= 0.12
88 Requires:       rc-scripts
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %if %{without userspace}
92 %define         no_spec_install_post_check_tmpfiles     1
93 %endif
94
95 %description
96 LIRC is a package that allows you to decode and send infra-red signals
97 of many (but not all) commonly used remote controls.
98
99 %description -l pl.UTF-8
100 LIRC to program pozwalający na dekodowanie nadchodzących oraz
101 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie wszystkich)
102 popularnych urządzeń do zdalnego sterowania.
103
104 %package remotes
105 Summary:        Lirc remotes database
106 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
107 Group:          Documentation
108 Requires:       %{pname} = %{version}-%{rel}
109
110 %description remotes
111 This package contains configuration files for many remotes supported
112 by lirc.
113
114 %description remotes -l pl.UTF-8
115 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
116 obsługiwanych przez lirc.
117
118 %package X11
119 Summary:        Linux Infrared Remote Control - X11 utilities
120 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
121 Group:          X11/Applications
122 Requires:       %{pname}-libs = %{version}-%{release}
123
124 %description X11
125 Linux Infrared Remote Control - X11 utilities.
126
127 %description X11 -l pl.UTF-8
128 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
129
130 %package svga
131 Summary:        Linux Infrared Remote Control - svgalib utilities
132 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
133 Group:          Applications
134 Requires:       %{pname}-libs = %{version}-%{release}
135
136 %description svga
137 Linux Infrared Remote Control - svgalib-based utilities.
138
139 %description svga -l pl.UTF-8
140 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
141 na svgalibie.
142
143 %package libs
144 Summary:        LIRC libraries
145 Summary(pl.UTF-8):      Biblioteki LIRC
146 Group:          Libraries
147 Conflicts:      lirc < 0.6.3-3
148 # didn't use /tmp/.lircd
149
150 %description libs
151 This package provides the libraries necessary to run lirc client
152 programs.
153
154 %description libs -l pl.UTF-8
155 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
156
157 %package devel
158 Summary:        Header files for LIRC development
159 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
160 Group:          Development/Libraries
161 Requires:       %{pname}-libs = %{version}-%{release}
162
163 %description devel
164 This package provides the files necessary to develop LIRC-based
165 programs.
166
167 %description devel -l pl.UTF-8
168 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych na
169 LIRC.
170
171 %package static
172 Summary:        Static library for LIRC development
173 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
174 Group:          Development/Libraries
175 Requires:       %{pname}-devel = %{version}-%{release}
176
177 %description static
178 The files necessary for development of statically-linked lirc-based
179 programs.
180
181 %description static -l pl.UTF-8
182 Pliki potrzebne do tworzenia łączonych statycznie programów opartych
183 na LIRC.
184
185 %define kernel_pkg()\
186 %package -n kernel%{_alt_kernel}-char-lirc-atiusb\
187 Summary:        Kernel modules for Linux Infrared Remote Control\
188 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
189 Release:        %{rel}@%{_kernel_ver_str}\
190 Group:          Base/Kernel\
191 %requires_releq_kernel\
192 Requires(postun):       %releq_kernel\
193 Requires(post,postun):  /sbin/depmod\
194 Requires:       %{pname} = %{version}\
195 Conflicts:      dev < 2.8.0-3\
196 \
197 %description -n kernel%{_alt_kernel}-char-lirc-atiusb\
198 This package contains the kernel modules necessary to operate some\
199 infrared remote control devices (such as the ones bundled with TV\
200 cards).\
201 \
202 lirc_atiusb module.\
203 \
204 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8\
205 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
206 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
207 \
208 Moduł lirc_atiusb.\
209 \
210 %package -n kernel%{_alt_kernel}-char-lirc-bt829\
211 Summary:        Kernel modules for Linux Infrared Remote Control\
212 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
213 Release:        %{rel}@%{_kernel_ver_str}\
214 Group:          Base/Kernel\
215 %requires_releq_kernel\
216 Requires(postun):       %releq_kernel\
217 Requires(post,postun):  /sbin/depmod\
218 Requires:       %{pname} = %{version}\
219 Conflicts:      dev < 2.8.0-3\
220 \
221 %description -n kernel%{_alt_kernel}-char-lirc-bt829\
222 This package contains the kernel modules necessary to operate some\
223 infrared remote control devices (such as the ones bundled with TV\
224 cards).\
225 \
226 lirc_bt829 module.\
227 \
228 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8\
229 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
230 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
231 \
232 Moduł lirc_bt829.\
233 \
234 %package -n kernel%{_alt_kernel}-char-lirc-dev\
235 Summary:        Kernel modules for Linux Infrared Remote Control\
236 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
237 Release:        %{rel}@%{_kernel_ver_str}\
238 Group:          Base/Kernel\
239 %requires_releq_kernel\
240 Requires(postun):       %releq_kernel\
241 Requires(post,postun):  /sbin/depmod\
242 Requires:       %{pname} = %{version}\
243 Obsoletes:      lirc-modules\
244 Obsoletes:      lirc-modules-dev\
245 Conflicts:      dev < 2.8.0-3\
246 \
247 %description -n kernel%{_alt_kernel}-char-lirc-dev\
248 This package contains the kernel modules necessary to operate some\
249 infrared remote control devices (such as the ones bundled with TV\
250 cards).\
251 \
252 lirc_dev module.\
253 \
254 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8\
255 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
256 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
257 \
258 Moduł lirc_dev.\
259 \
260 %package -n kernel%{_alt_kernel}-char-lirc-ene0100\
261 Summary:        Kernel modules for Linux Infrared Remote Control\
262 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
263 Release:        %{rel}@%{_kernel_ver_str}\
264 Group:          Base/Kernel\
265 %requires_releq_kernel\
266 Requires(postun):       %releq_kernel\
267 Requires(post,postun):  /sbin/depmod\
268 Requires:       %{pname} = %{version}\
269 Obsoletes:      lirc-modules\
270 Conflicts:      dev < 2.8.0-3\
271 \
272 %description -n kernel%{_alt_kernel}-char-lirc-ene0100\
273 This package contains the kernel modules necessary to operate some\
274 infrared remote control ene0100ices (such as the ones bundled with TV\
275 cards).\
276 \
277 lirc_ene0100 module.\
278 \
279 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8\
280 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
281 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
282 \
283 Moduł lirc_ene0100.\
284 \
285 %package -n kernel%{_alt_kernel}-char-lirc-gpio\
286 Summary:        Kernel modules for Linux Infrared Remote Control\
287 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
288 Release:        %{rel}@%{_kernel_ver_str}\
289 Group:          Base/Kernel\
290 %requires_releq_kernel\
291 Requires(postun):       %releq_kernel\
292 Requires(post,postun):  /sbin/depmod\
293 Requires:       %{pname} = %{version}\
294 Obsoletes:      lirc-modules\
295 Obsoletes:      lirc-modules-gpio\
296 Conflicts:      dev < 2.8.0-3\
297 \
298 %description -n kernel%{_alt_kernel}-char-lirc-gpio\
299 This package contains the kernel modules necessary to operate some\
300 infrared remote control devices (such as the ones bundled with TV\
301 cards).\
302 \
303 lirc_gpio module.\
304 \
305 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8\
306 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
307 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
308 \
309 Moduł lirc_gpio.\
310 \
311 %package -n kernel%{_alt_kernel}-char-lirc-i2c\
312 Summary:        Kernel modules for Linux Infrared Remote Control\
313 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
314 Release:        %{rel}@%{_kernel_ver_str}\
315 Group:          Base/Kernel\
316 %requires_releq_kernel\
317 Requires(postun):       %releq_kernel\
318 Requires(post,postun):  /sbin/depmod\
319 Requires:       %{pname} = %{version}\
320 Obsoletes:      lirc-modules\
321 Obsoletes:      lirc-modules-i2c\
322 Conflicts:      dev < 2.8.0-3\
323 \
324 %description -n kernel%{_alt_kernel}-char-lirc-i2c\
325 This package contains the kernel modules necessary to operate some\
326 infrared remote control devices (such as the ones bundled with TV\
327 cards).\
328 \
329 lirc_i2c module.\
330 \
331 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8\
332 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
333 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
334 \
335 Moduł lirc_i2c.\
336 \
337 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
338 Summary:        Kernel modules for Linux Infrared Remote Control\
339 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
340 Release:        %{rel}@%{_kernel_ver_str}\
341 Group:          Base/Kernel\
342 %requires_releq_kernel\
343 Requires(postun):       %releq_kernel\
344 Requires(post,postun):  /sbin/depmod\
345 Requires:       %{pname} = %{version}\
346 Obsoletes:      lirc-modules\
347 Obsoletes:      lirc-modules-igorplugusb\
348 Conflicts:      dev < 2.8.0-3\
349 \
350 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
351 This package contains the kernel modules necessary to operate some\
352 infrared remote control devices (such as the ones bundled with TV\
353 cards).\
354 \
355 lirc_igorplugusb module.\
356 \
357 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8\
358 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
359 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
360 \
361 Moduł lirc_igorplugusb.\
362 \
363 %package -n kernel%{_alt_kernel}-char-lirc-imon\
364 Summary:        Kernel modules for Linux Infrared Remote Control\
365 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
366 Release:        %{rel}@%{_kernel_ver_str}\
367 Group:          Base/Kernel\
368 %requires_releq_kernel\
369 Requires(postun):       %releq_kernel\
370 Requires(post,postun):  /sbin/depmod\
371 Requires:       %{pname} = %{version}\
372 Obsoletes:      lirc-modules\
373 Obsoletes:      lirc-modules-imon\
374 Conflicts:      dev < 2.8.0-3\
375 \
376 %description -n kernel%{_alt_kernel}-char-lirc-imon\
377 This package contains the kernel modules necessary to operate some\
378 infrared remote control devices (such as the ones bundled with TV\
379 cards).\
380 \
381 lirc_imon module.\
382 \
383 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8\
384 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
385 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
386 \
387 Moduł lirc_imon.\
388 \
389 %package -n kernel%{_alt_kernel}-char-lirc-sasem\
390 Summary:        Kernel modules for Linux Infrared Remote Control\
391 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
392 Release:        %{rel}@%{_kernel_ver_str}\
393 Group:          Base/Kernel\
394 %requires_releq_kernel\
395 Requires(postun):       %releq_kernel\
396 Requires(post,postun):  /sbin/depmod\
397 Requires:       %{pname} = %{version}\
398 Conflicts:      dev < 2.8.0-3\
399 \
400 %description -n kernel%{_alt_kernel}-char-lirc-sasem\
401 This package contains the kernel modules necessary to operate some\
402 infrared remote control devices (such as the ones bundled with TV\
403 cards).\
404 \
405 lirc_sasem module.\
406 \
407 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8\
408 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
409 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
410 \
411 Moduł lirc_sasem.\
412 \
413 %package -n kernel%{_alt_kernel}-char-lirc-serial\
414 Summary:        Kernel modules for Linux Infrared Remote Control\
415 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
416 Release:        %{rel}@%{_kernel_ver_str}\
417 Group:          Base/Kernel\
418 %requires_releq_kernel\
419 Requires(postun):       %releq_kernel\
420 Requires(post,postun):  /sbin/depmod\
421 Requires:       %{pname} = %{version}\
422 Requires:       setserial\
423 Obsoletes:      lirc-modules\
424 Obsoletes:      lirc-modules-serial\
425 Conflicts:      dev < 2.8.0-3\
426 \
427 %description -n kernel%{_alt_kernel}-char-lirc-serial\
428 This package contains the kernel modules necessary to operate some\
429 infrared remote control devices (such as the ones bundled with TV\
430 cards).\
431 \
432 lirc_serial module for devices connected to serial port.\
433 \
434 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8\
435 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
436 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
437 \
438 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.\
439 \
440 %package -n kernel%{_alt_kernel}-char-lirc-sir\
441 Summary:        Kernel modules for Linux Infrared Remote Control\
442 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
443 Release:        %{rel}@%{_kernel_ver_str}\
444 Group:          Base/Kernel\
445 %requires_releq_kernel\
446 Requires(postun):       %releq_kernel\
447 Requires(post,postun):  /sbin/depmod\
448 Requires:       %{pname} = %{version}\
449 Obsoletes:      lirc-modules\
450 Obsoletes:      lirc-modules-sir\
451 Conflicts:      dev < 2.8.0-3\
452 \
453 %description -n kernel%{_alt_kernel}-char-lirc-sir\
454 This package contains the kernel modules necessary to operate some\
455 infrared remote control devices (such as the ones bundled with TV\
456 cards).\
457 \
458 lirc_sir module.\
459 \
460 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8\
461 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
462 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
463 \
464 Moduł lirc_sir.\
465 \
466 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir\
467 Summary:        Kernel modules for Linux Infrared Remote Control\
468 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
469 Release:        %{rel}@%{_kernel_ver_str}\
470 Group:          Base/Kernel\
471 %requires_releq_kernel\
472 Requires(postun):       %releq_kernel\
473 Requires(post,postun):  /sbin/depmod\
474 Requires:       %{pname} = %{version}\
475 Obsoletes:      lirc-modules\
476 Obsoletes:      lirc-modules-ttusbir\
477 Conflicts:      dev < 2.8.0-3\
478 \
479 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir\
480 This package contains the kernel modules necessary to operate\
481 TechnoTrend USB IR Receiver.\
482 \
483 lirc_ttusbir module.\
484 \
485 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8\
486 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia\
487 TechnoTrend USB IR Receiver.\
488 \
489 Moduł lirc_ttusbir.\
490 \
491 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691\
492 Summary:        Kernel modules for Linux Infrared Remote Control\
493 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
494 Release:        %{rel}@%{_kernel_ver_str}\
495 Group:          Base/Kernel\
496 %requires_releq_kernel\
497 Requires(postun):       %releq_kernel\
498 Requires(post,postun):  /sbin/depmod\
499 Requires:       %{pname} = %{version}\
500 Conflicts:      dev < 2.8.0-3\
501 \
502 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691\
503 This package contains the kernel modules necessary to operate\
504 TechnoTrend USB IR Receiver.\
505 \
506 lirc_wpc87691 module.\
507 \
508 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8\
509 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia\
510 TechnoTrend USB IR Receiver.\
511 \
512 Moduł lirc_wpc87691.\
513 \
514 %package -n kernel%{_alt_kernel}-char-lirc-parallel\
515 Summary:        Kernel modules for Linux Infrared Remote Control\
516 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni\
517 Release:        %{rel}@%{_kernel_ver_str}\
518 Group:          Base/Kernel\
519 %requires_releq_kernel\
520 Requires(postun):       %releq_kernel\
521 Requires(post,postun):  /sbin/depmod\
522 Requires:       %{pname} = %{version}\
523 Obsoletes:      lirc-modules\
524 Obsoletes:      lirc-modules-parallel\
525 Conflicts:      dev < 2.8.0-3\
526 \
527 %description -n kernel%{_alt_kernel}-char-lirc-parallel\
528 This package contains the kernel modules necessary to operate some\
529 infrared remote control devices (such as the ones bundled with TV\
530 cards).\
531 \
532 lirc-parallel module for devices connected to parallel port.\
533 \
534 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8\
535 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych\
536 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).\
537 \
538 Moduł lirc_parallel dla urządzeń podłączanych do portu równoległego.\
539 \
540 %if %{with kernel}\
541 %files -n kernel%{_alt_kernel}-char-lirc-atiusb\
542 %defattr(644,root,root,755)\
543 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*\
544 \
545 %files -n kernel%{_alt_kernel}-char-lirc-bt829\
546 %defattr(644,root,root,755)\
547 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*\
548 \
549 %files -n kernel%{_alt_kernel}-char-lirc-dev\
550 %defattr(644,root,root,755)\
551 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*\
552 \
553 %if %{_kernel_version_code} < %{_kernel_version_magic 3 0 0}\
554 %files -n kernel%{_alt_kernel}-char-lirc-ene0100\
555 %defattr(644,root,root,755)\
556 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*\
557 %endif\
558 \
559 %if %{_kernel_version_code} < %{_kernel_version_magic 2 6 23}\
560 %files -n kernel%{_alt_kernel}-char-lirc-gpio\
561 %defattr(644,root,root,755)\
562 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*\
563 %endif\
564 \
565 %files -n kernel%{_alt_kernel}-char-lirc-i2c\
566 %defattr(644,root,root,755)\
567 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*\
568 \
569 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
570 %defattr(644,root,root,755)\
571 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*\
572 \
573 %files -n kernel%{_alt_kernel}-char-lirc-imon\
574 %defattr(644,root,root,755)\
575 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*\
576 \
577 %files -n kernel%{_alt_kernel}-char-lirc-sasem\
578 %defattr(644,root,root,755)\
579 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*\
580 \
581 %files -n kernel%{_alt_kernel}-char-lirc-serial\
582 %defattr(644,root,root,755)\
583 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*\
584 \
585 %files -n kernel%{_alt_kernel}-char-lirc-sir\
586 %defattr(644,root,root,755)\
587 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*\
588 \
589 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir\
590 %defattr(644,root,root,755)\
591 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*\
592 \
593 %if %{_kernel_version_code} < %{_kernel_version_magic 3 0 0}\
594 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691\
595 %defattr(644,root,root,755)\
596 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*\
597 %endif\
598 \
599 %files -n kernel%{_alt_kernel}-char-lirc-parallel\
600 %defattr(644,root,root,755)\
601 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*\
602 %endif\
603 %{nil}
604
605 %define kernel_pkg_scriptlets()\
606 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb\
607 %depmod %{_kernel_ver}\
608 if [ "$1" = "1" ]; then\
609         echo "Don't forget to add an 'alias lirc lirc_atiusb' to modprobe config"\
610 fi\
611 \
612 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb\
613 %depmod %{_kernel_ver}\
614 \
615 %post   -n kernel%{_alt_kernel}-char-lirc-bt829\
616 %depmod %{_kernel_ver}\
617 if [ "$1" = "1" ]; then\
618         echo "Don't forget to add an 'alias lirc lirc_bt829' to modprobe config"\
619 fi\
620 \
621 %postun -n kernel%{_alt_kernel}-char-lirc-bt829\
622 %depmod %{_kernel_ver}\
623 \
624 %post   -n kernel%{_alt_kernel}-char-lirc-dev\
625 %depmod %{_kernel_ver}\
626 \
627 %postun -n kernel%{_alt_kernel}-char-lirc-dev\
628 %depmod %{_kernel_ver}\
629 \
630 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100\
631 %depmod %{_kernel_ver}\
632 \
633 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100\
634 %depmod %{_kernel_ver}\
635 \
636 %post   -n kernel%{_alt_kernel}-char-lirc-gpio\
637 %depmod %{_kernel_ver}\
638 if [ "$1" = "1" ]; then\
639         echo "Don't forget to add an 'alias lirc lirc_gpio' to modprobe config"\
640 fi\
641 \
642 %postun -n kernel%{_alt_kernel}-char-lirc-gpio\
643 %depmod %{_kernel_ver}\
644 \
645 %post   -n kernel%{_alt_kernel}-char-lirc-i2c\
646 %depmod %{_kernel_ver}\
647 if [ "$1" = "1" ]; then\
648         echo "Don't forget to add an 'alias lirc lirc_i2c' to modprobe config"\
649 fi\
650 \
651 %postun -n kernel%{_alt_kernel}-char-lirc-i2c\
652 %depmod %{_kernel_ver}\
653 \
654 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
655 %depmod %{_kernel_ver}\
656 if [ "$1" = "1" ]; then\
657         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' to modprobe config"\
658 fi\
659 \
660 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb\
661 %depmod %{_kernel_ver}\
662 \
663 %post   -n kernel%{_alt_kernel}-char-lirc-imon\
664 %depmod %{_kernel_ver}\
665 if [ "$1" = "1" ]; then\
666         echo "Don't forget to add an 'alias lirc lirc_imon' to modprobe config"\
667 fi\
668 \
669 %postun -n kernel%{_alt_kernel}-char-lirc-imon\
670 %depmod %{_kernel_ver}\
671 \
672 %post   -n kernel%{_alt_kernel}-char-lirc-sasem\
673 %depmod %{_kernel_ver}\
674 if [ "$1" = "1" ]; then\
675         echo "Don't forget to add an 'alias lirc lirc_sasem' to modprobe config"\
676 fi\
677 \
678 %postun -n kernel%{_alt_kernel}-char-lirc-sasem\
679 %depmod %{_kernel_ver}\
680 \
681 %post   -n kernel%{_alt_kernel}-char-lirc-serial\
682 %depmod %{_kernel_ver}\
683 if [ "$1" = "1" ]; then\
684         echo "Don't forget to add an 'alias lirc lirc_serial' to modprobe config"\
685 fi\
686 \
687 %postun -n kernel%{_alt_kernel}-char-lirc-serial\
688 %depmod %{_kernel_ver}\
689 \
690 %post   -n kernel%{_alt_kernel}-char-lirc-parallel\
691 %depmod %{_kernel_ver}\
692 if [ "$1" = "1" ]; then\
693         echo "Don't forget to add an 'alias lirc lirc_parallel' modprobe config"\
694 fi\
695 \
696 %postun -n kernel%{_alt_kernel}-char-lirc-parallel\
697 %depmod %{_kernel_ver}\
698 \
699 %post   -n kernel%{_alt_kernel}-char-lirc-sir\
700 %depmod %{_kernel_ver}\
701 if [ "$1" = "1" ]; then\
702         echo "Don't forget to add an 'alias lirc lirc_sir' to modprobe config"\
703 fi\
704 \
705 %postun -n kernel%{_alt_kernel}-char-lirc-sir\
706 %depmod %{_kernel_ver}\
707 \
708 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir\
709 %depmod %{_kernel_ver}\
710 if [ "$1" = "1" ]; then\
711         echo "Don't forget to add an 'alias lirc lirc_ttusbir' to modprobe config"\
712 fi\
713 \
714 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir\
715 %depmod %{_kernel_ver}\
716 \
717 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691\
718 %depmod %{_kernel_ver}\
719 if [ "$1" = "1" ]; then\
720         echo "Don't forget to add an 'alias lirc lirc_wpc87691' to modprobe config"\
721 fi\
722 \
723 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691\
724 %depmod %{_kernel_ver}\
725 %{nil}
726
727 %define build_kernel_pkg()\
728 %configure \\\
729         ac_cv_header_portaudio_h=no \\\
730         --with-kerneldir=%{_kernelsrcdir} \\\
731         %{?with_x:--with-x} \\\
732         --with-port=0x2f8 \\\
733         --with-irq=3 \\\
734         --without-soft-carrier \\\
735         --with-driver=userspace \\\
736         --with-igor\
737 \
738 drivers=%{drivers}\
739 for drv in $drivers; do\
740         cd drivers/$drv\
741         %{__make} clean \\\
742                 LIRC_DEVDIR=`pwd` \\\
743                 RCS_FIND_IGNORE="-name '*.ko' -o" \\\
744                 %{?with_verbose:V=1}\
745 \
746         %{__make} -j1 \\\
747                 LIRC_DEVDIR=`pwd` \\\
748                 CONSTIFY_PLUGIN="" \\\
749                 KBUILD_MODPOST_WARN=1 \\\
750                 %{?with_verbose:V=1}\
751         cd ../..\
752         %install_kernel_modules -D installed -m drivers/$drv/$drv -d misc\
753 done\
754 %{nil}
755
756 %{?with_kernel:%{expand:%create_kernel_packages}}
757
758 %prep
759 %setup -q -n %{pname}-%{version} -a 1
760 %patch0 -p1
761 %patch1 -p1
762 %if !%{with svga}
763 %patch2 -p1
764 %endif
765 %patch3 -p1
766 %patch4 -p1
767 %patch5 -p1
768 %patch6 -p1
769 %patch7 -p1
770 %patch8 -p1
771
772 %build
773 echo '#' > drivers/Makefile.am
774 %{__libtoolize}
775 %{__aclocal}
776 %{__automake}
777 %{__autoheader}
778 %{__autoconf}
779
780 %if %{with userspace}
781 %configure \
782         ac_cv_header_portaudio_h=no \
783 %if %{without kernel}
784         ac_cv_have_kernel="no_kernel=yes" \
785 %endif
786         --with-kerneldir=%{_kernelsrcdir} \
787         %{?with_x:--with-x} \
788         --with-port=0x2f8 \
789         --with-irq=3 \
790         --without-soft-carrier \
791         --with-driver=userspace \
792         --with-igor
793
794 %{__make} -j1
795 %endif
796
797 %{?with_kernel:%{expand:%build_kernel_packages}}
798
799 %install
800 rm -rf $RPM_BUILD_ROOT
801 install -d $RPM_BUILD_ROOT
802
803 %if %{with kernel}
804 cp -a installed/* $RPM_BUILD_ROOT
805 %endif
806
807 %if %{with userspace}
808 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
809         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,lirc} \
810         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
811
812 %{__make} -j1 install \
813         DESTDIR=$RPM_BUILD_ROOT \
814         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
815
816 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
817 #
818 # This is a placeholder for your configuration file.
819 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
820 #
821 END
822 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
823 cp -p contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
824 :> $RPM_BUILD_ROOT/var/log/lircd
825
826 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
827 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
828 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
829 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
830 %endif
831
832 %clean
833 rm -rf $RPM_BUILD_ROOT
834
835 %post   libs -p /sbin/ldconfig
836 %postun libs -p /sbin/ldconfig
837
838 %post
839 /sbin/chkconfig --add lircd
840 /sbin/chkconfig --add lircmd
841 %service lircd restart
842 %service lircmd restart
843
844 echo "If you are using a kernel-module-based driver, don't forget to"
845 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> package."
846
847 %preun
848 if [ "$1" = "0" ]; then
849         %service lircd stop
850         %service lircmd stop
851         /sbin/chkconfig --del lircd
852         /sbin/chkconfig --del lircmd
853 fi
854
855 %triggerpostun -- %{name} < 0.8.6-8
856 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
857         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
858 fi
859 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
860         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
861 fi
862
863 %if %{with userspace}
864 %files
865 %defattr(644,root,root,755)
866 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
867 %doc contrib/lircrc doc/{html,images,lirc.css}
868 %attr(755,root,root) %{_bindir}/ircat
869 %attr(755,root,root) %{_bindir}/irexec
870 %attr(755,root,root) %{_bindir}/irpty
871 %attr(755,root,root) %{_bindir}/irrecord
872 %attr(755,root,root) %{_bindir}/irsend
873 %attr(755,root,root) %{_bindir}/irw
874 %attr(755,root,root) %{_bindir}/mode2
875 %attr(755,root,root) %{_bindir}/lircrcd
876 %attr(755,root,root) %{_bindir}/pronto2lirc
877 %attr(755,root,root) %{_sbindir}/lircd
878 %attr(755,root,root) %{_sbindir}/lircmd
879 %attr(754,root,root) /etc/rc.d/init.d/lircd
880 %attr(754,root,root) /etc/rc.d/init.d/lircmd
881 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
882 %dir %{_sysconfdir}/lirc
883 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
884 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
885 %{_mandir}/man1/ircat.1*
886 %{_mandir}/man1/irexec.1*
887 %{_mandir}/man1/irpty.1*
888 %{_mandir}/man1/irrecord.1*
889 %{_mandir}/man1/irsend.1*
890 %{_mandir}/man1/irw.1*
891 %{_mandir}/man1/lircrcd.1*
892 %{_mandir}/man1/mode2.1*
893 %{_mandir}/man8/lircd.8*
894 %{_mandir}/man8/lircmd.8*
895 %attr(600,root,root) %ghost /var/log/lircd
896 %dir /var/run/lirc
897 %{systemdtmpfilesdir}/%{name}.conf
898
899 %files remotes
900 %defattr(644,root,root,755)
901 # XXX: are jpegs in docs (remotes) a good idea?
902 %doc remotes
903
904 %if %{with x}
905 %files X11
906 %defattr(644,root,root,755)
907 %doc doc/irxevent.keys
908 %attr(755,root,root) %{_bindir}/irxevent
909 %attr(755,root,root) %{_bindir}/xmode2
910 %{_mandir}/man1/irxevent.1*
911 %{_mandir}/man1/xmode2.1*
912 %endif
913
914 %if %{with svga}
915 %files svga
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_bindir}/smode2
918 %{_mandir}/man1/smode2.1*
919 %endif
920
921 %files libs
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
924 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
925
926 %files devel
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/liblirc_client.so
929 %{_libdir}/liblirc_client.la
930 %{_includedir}/lirc
931 %{_aclocaldir}/lirc.m4
932
933 %files static
934 %defattr(644,root,root,755)
935 %{_libdir}/liblirc_client.a
936 %endif
This page took 0.08291 seconds and 3 git commands to generate.