]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
- rebuild for kernel-3.5.7-1
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 #
7 # Conditional build:
8 %bcond_without  dist_kernel     # without sources of distribution kernel
9 %bcond_without  kernel          # don't build kernel modules, only library+programs
10 %bcond_without  userspace       # build only packages with kernel modules
11 %bcond_with     svga            # without svgalib-based utility
12 %bcond_without  x               # without X11-based utilitied
13
14 %if %{without kernel}
15 %undefine       with_dist_kernel
16 %endif
17
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21
22 %define         pname   lirc
23 %define         rel     59
24
25 #
26 # main package
27 #
28 # lirc_gpio fails to build under kernel >= 2.6.23
29 #
30 %if "%{_kernel_ver}" >= "2.6.23"
31 %if "%{_kernel_ver}" >= "3.0.0"
32 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
33 %else
34 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
35 %endif
36 %else
37 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
38 %endif
39 Summary:        Linux Infrared Remote Control daemons
40 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
41 Name:           %{pname}%{_alt_kernel}
42 Version:        0.9.0
43 Release:        %{rel}
44 License:        GPL v2+
45 Group:          Daemons
46 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
47 # Source0-md5:  b232aef26f23fe33ea8305d276637086
48 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
49 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
50 Source2:        %{pname}d.sysconfig
51 Source3:        %{pname}d.init
52 Source4:        %{pname}md.init
53 Source5:        %{pname}.tmpfiles
54 Patch0:         %{pname}-opt.patch
55 Patch1:         %{pname}-tmp.patch
56 Patch2:         %{pname}-no-svgalib.patch
57 Patch3:         %{pname}-kernel.patch
58 Patch4:         %{pname}-sparc.patch
59 Patch5:         %{pname}-remotes.patch
60 Patch6:         %{pname}-kernelcc.patch
61 Patch7:         format-security.patch
62 URL:            http://www.lirc.org/
63 BuildRequires:  alsa-lib-devel
64 BuildRequires:  autoconf >= 2.50
65 BuildRequires:  automake
66 BuildRequires:  iguanaIR-devel
67 BuildRequires:  libftdi-devel >= 0.12
68 BuildRequires:  libirman-devel >= 0.4.5
69 BuildRequires:  libtool
70 BuildRequires:  libusb-compat-devel >= 0.1.0
71 %if %{with kernel}
72 BuildRequires:  kernel%{_alt_kernel}-module-build
73 BuildRequires:  kernel%{_alt_kernel}-headers
74 %endif
75 %{?with_kernel:BuildRequires:   %{kgcc_package}}
76 BuildRequires:  rpm-pythonprov
77 BuildRequires:  rpmbuild(macros) >= 1.379
78 %{?with_svga:BuildRequires:     svgalib-devel}
79 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
80 Requires(post,preun):   /sbin/chkconfig
81 Requires:       %{pname}-libs = %{version}-%{release}
82 Requires:       libftdi >= 0.12
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %if %{without userspace}
86 %define         no_spec_install_post_check_tmpfiles     1
87 %endif
88
89 %description
90 LIRC is a package that allows you to decode and send infra-red signals
91 of many (but not all) commonly used remote controls.
92
93 %description -l pl.UTF-8
94 LIRC to program pozwalający na dekodowanie nadchodzących oraz
95 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie
96 wszystkich) popularnych urządzeń do zdalnego sterowania.
97
98 %package remotes
99 Summary:        Lirc remotes database
100 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
101 Group:          Documentation
102 Requires:       %{pname} = %{version}-%{rel}
103
104 %description remotes
105 This package contains configuration files for many remotes supported
106 by lirc.
107
108 %description remotes -l pl.UTF-8
109 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
110 obsługiwanych przez lirc.
111
112 %package X11
113 Summary:        Linux Infrared Remote Control - X11 utilities
114 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
115 Group:          X11/Applications
116 Requires:       %{pname}-libs = %{version}-%{release}
117
118 %description X11
119 Linux Infrared Remote Control - X11 utilities.
120
121 %description X11 -l pl.UTF-8
122 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
123
124 %package svga
125 Summary:        Linux Infrared Remote Control - svgalib utilities
126 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
127 Group:          Applications
128 Requires:       %{pname}-libs = %{version}-%{release}
129
130 %description svga
131 Linux Infrared Remote Control - svgalib-based utilities.
132
133 %description svga -l pl.UTF-8
134 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
135 na svgalibie.
136
137 %package libs
138 Summary:        LIRC libraries
139 Summary(pl.UTF-8):      Biblioteki LIRC
140 Group:          Libraries
141 Conflicts:      lirc < 0.6.3-3
142 # didn't use /tmp/.lircd
143
144 %description libs
145 This package provides the libraries necessary to run lirc client
146 programs.
147
148 %description libs -l pl.UTF-8
149 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
150
151 %package devel
152 Summary:        Header files for LIRC development
153 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
154 Group:          Development/Libraries
155 Requires:       %{pname}-libs = %{version}-%{release}
156
157 %description devel
158 This package provides the files necessary to develop LIRC-based
159 programs.
160
161 %description devel -l pl.UTF-8
162 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych
163 na LIRC.
164
165 %package static
166 Summary:        Static library for LIRC development
167 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
168 Group:          Development/Libraries
169 Requires:       %{pname}-devel = %{version}-%{release}
170
171 %description static
172 The files necessary for development of statically-linked lirc-based
173 programs.
174
175 %description static -l pl.UTF-8
176 Pliki potrzebne do tworzenia łączonych statycznie programów
177 opartych na LIRC.
178
179 %package -n kernel%{_alt_kernel}-char-lirc-atiusb
180 Summary:        Kernel modules for Linux Infrared Remote Control
181 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
182 Release:        %{rel}@%{_kernel_ver_str}
183 Group:          Base/Kernel
184 %if %{with dist_kernel}
185 %requires_releq_kernel
186 Requires(postun):       %releq_kernel
187 %endif
188 Requires(post,postun):  /sbin/depmod
189 Requires:       %{pname} = %{version}-%{rel}
190 Conflicts:      dev < 2.8.0-3
191
192 %description -n kernel%{_alt_kernel}-char-lirc-atiusb
193 This package contains the kernel modules necessary to operate some
194 infrared remote control devices (such as the ones bundled with TV
195 cards).
196
197 lirc_atiusb module.
198
199 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8
200 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
201 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
202
203 Moduł lirc_atiusb.
204
205 %package -n kernel%{_alt_kernel}-char-lirc-bt829
206 Summary:        Kernel modules for Linux Infrared Remote Control
207 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
208 Release:        %{rel}@%{_kernel_ver_str}
209 Group:          Base/Kernel
210 %if %{with dist_kernel}
211 %requires_releq_kernel
212 Requires(postun):       %releq_kernel
213 %endif
214 Requires(post,postun):  /sbin/depmod
215 Requires:       %{pname} = %{version}-%{rel}
216 Conflicts:      dev < 2.8.0-3
217
218 %description -n kernel%{_alt_kernel}-char-lirc-bt829
219 This package contains the kernel modules necessary to operate some
220 infrared remote control devices (such as the ones bundled with TV
221 cards).
222
223 lirc_bt829 module.
224
225 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8
226 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
227 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
228
229 Moduł lirc_bt829.
230
231 %package -n kernel%{_alt_kernel}-char-lirc-dev
232 Summary:        Kernel modules for Linux Infrared Remote Control
233 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
234 Release:        %{rel}@%{_kernel_ver_str}
235 Group:          Base/Kernel
236 %if %{with dist_kernel}
237 %requires_releq_kernel
238 Requires(postun):       %releq_kernel
239 %endif
240 Requires(post,postun):  /sbin/depmod
241 Requires:       %{pname} = %{version}-%{rel}
242 Obsoletes:      lirc-modules
243 Obsoletes:      lirc-modules-dev
244 Conflicts:      dev < 2.8.0-3
245
246 %description -n kernel%{_alt_kernel}-char-lirc-dev
247 This package contains the kernel modules necessary to operate some
248 infrared remote control devices (such as the ones bundled with TV
249 cards).
250
251 lirc_dev module.
252
253 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8
254 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
255 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
256
257 Moduł lirc_dev.
258
259 %package -n kernel%{_alt_kernel}-char-lirc-ene0100
260 Summary:        Kernel modules for Linux Infrared Remote Control
261 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
262 Release:        %{rel}@%{_kernel_ver_str}
263 Group:          Base/Kernel
264 %if %{with dist_kernel}
265 %requires_releq_kernel
266 Requires(postun):       %releq_kernel
267 %endif
268 Requires(post,postun):  /sbin/depmod
269 Requires:       %{pname} = %{version}-%{rel}
270 Obsoletes:      lirc-modules
271 Conflicts:      dev < 2.8.0-3
272
273 %description -n kernel%{_alt_kernel}-char-lirc-ene0100
274 This package contains the kernel modules necessary to operate some
275 infrared remote control ene0100ices (such as the ones bundled with TV
276 cards).
277
278 lirc_ene0100 module.
279
280 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8
281 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
282 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
283
284 Moduł lirc_ene0100.
285
286 %package -n kernel%{_alt_kernel}-char-lirc-gpio
287 Summary:        Kernel modules for Linux Infrared Remote Control
288 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
289 Release:        %{rel}@%{_kernel_ver_str}
290 Group:          Base/Kernel
291 %if %{with dist_kernel}
292 %requires_releq_kernel
293 Requires(postun):       %releq_kernel
294 %endif
295 Requires(post,postun):  /sbin/depmod
296 Requires:       %{pname} = %{version}-%{rel}
297 Obsoletes:      lirc-modules
298 Obsoletes:      lirc-modules-gpio
299 Conflicts:      dev < 2.8.0-3
300
301 %description -n kernel%{_alt_kernel}-char-lirc-gpio
302 This package contains the kernel modules necessary to operate some
303 infrared remote control devices (such as the ones bundled with TV
304 cards).
305
306 lirc_gpio module.
307
308 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8
309 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
310 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
311
312 Moduł lirc_gpio.
313
314 %package -n kernel%{_alt_kernel}-char-lirc-i2c
315 Summary:        Kernel modules for Linux Infrared Remote Control
316 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
317 Release:        %{rel}@%{_kernel_ver_str}
318 Group:          Base/Kernel
319 %if %{with dist_kernel}
320 %requires_releq_kernel
321 Requires(postun):       %releq_kernel
322 %endif
323 Requires(post,postun):  /sbin/depmod
324 Requires:       %{pname} = %{version}-%{rel}
325 Obsoletes:      lirc-modules
326 Obsoletes:      lirc-modules-i2c
327 Conflicts:      dev < 2.8.0-3
328
329 %description -n kernel%{_alt_kernel}-char-lirc-i2c
330 This package contains the kernel modules necessary to operate some
331 infrared remote control devices (such as the ones bundled with TV
332 cards).
333
334 lirc_i2c module.
335
336 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8
337 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
338 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
339
340 Moduł lirc_i2c.
341
342 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb
343 Summary:        Kernel modules for Linux Infrared Remote Control
344 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
345 Release:        %{rel}@%{_kernel_ver_str}
346 Group:          Base/Kernel
347 %if %{with dist_kernel}
348 %requires_releq_kernel
349 Requires(postun):       %releq_kernel
350 %endif
351 Requires(post,postun):  /sbin/depmod
352 Requires:       %{pname} = %{version}-%{rel}
353 Obsoletes:      lirc-modules
354 Obsoletes:      lirc-modules-igorplugusb
355 Conflicts:      dev < 2.8.0-3
356
357 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb
358 This package contains the kernel modules necessary to operate some
359 infrared remote control devices (such as the ones bundled with TV
360 cards).
361
362 lirc_igorplugusb module.
363
364 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8
365 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
366 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
367
368 Moduł lirc_igorplugusb.
369
370 %package -n kernel%{_alt_kernel}-char-lirc-imon
371 Summary:        Kernel modules for Linux Infrared Remote Control
372 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
373 Release:        %{rel}@%{_kernel_ver_str}
374 Group:          Base/Kernel
375 %if %{with dist_kernel}
376 %requires_releq_kernel
377 Requires(postun):       %releq_kernel
378 %endif
379 Requires(post,postun):  /sbin/depmod
380 Requires:       %{pname} = %{version}-%{rel}
381 Obsoletes:      lirc-modules
382 Obsoletes:      lirc-modules-imon
383 Conflicts:      dev < 2.8.0-3
384
385 %description -n kernel%{_alt_kernel}-char-lirc-imon
386 This package contains the kernel modules necessary to operate some
387 infrared remote control devices (such as the ones bundled with TV
388 cards).
389
390 lirc_imon module.
391
392 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8
393 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
394 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
395
396 Moduł lirc_imon.
397
398 %package -n kernel%{_alt_kernel}-char-lirc-sasem
399 Summary:        Kernel modules for Linux Infrared Remote Control
400 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
401 Release:        %{rel}@%{_kernel_ver_str}
402 Group:          Base/Kernel
403 %if %{with dist_kernel}
404 %requires_releq_kernel
405 Requires(postun):       %releq_kernel
406 %endif
407 Requires(post,postun):  /sbin/depmod
408 Requires:       %{pname} = %{version}-%{rel}
409 Conflicts:      dev < 2.8.0-3
410
411 %description -n kernel%{_alt_kernel}-char-lirc-sasem
412 This package contains the kernel modules necessary to operate some
413 infrared remote control devices (such as the ones bundled with TV
414 cards).
415
416 lirc_sasem module.
417
418 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8
419 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
420 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
421
422 Moduł lirc_sasem.
423
424 %package -n kernel%{_alt_kernel}-char-lirc-serial
425 Summary:        Kernel modules for Linux Infrared Remote Control
426 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
427 Release:        %{rel}@%{_kernel_ver_str}
428 Group:          Base/Kernel
429 %if %{with dist_kernel}
430 %requires_releq_kernel
431 Requires(postun):       %releq_kernel
432 %endif
433 Requires(post,postun):  /sbin/depmod
434 Requires:       %{pname} = %{version}-%{rel}
435 %{?with_dist_kernel:Requires:   setserial}
436 Obsoletes:      lirc-modules
437 Obsoletes:      lirc-modules-serial
438 Conflicts:      dev < 2.8.0-3
439
440 %description -n kernel%{_alt_kernel}-char-lirc-serial
441 This package contains the kernel modules necessary to operate some
442 infrared remote control devices (such as the ones bundled with TV
443 cards).
444
445 lirc_serial module for devices connected to serial port.
446
447 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8
448 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
449 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
450
451 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.
452
453 %package -n kernel%{_alt_kernel}-char-lirc-sir
454 Summary:        Kernel modules for Linux Infrared Remote Control
455 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
456 Release:        %{rel}@%{_kernel_ver_str}
457 Group:          Base/Kernel
458 %if %{with dist_kernel}
459 %requires_releq_kernel
460 Requires(postun):       %releq_kernel
461 %endif
462 Requires(post,postun):  /sbin/depmod
463 Requires:       %{pname} = %{version}-%{rel}
464 Obsoletes:      lirc-modules
465 Obsoletes:      lirc-modules-sir
466 Conflicts:      dev < 2.8.0-3
467
468 %description -n kernel%{_alt_kernel}-char-lirc-sir
469 This package contains the kernel modules necessary to operate some
470 infrared remote control devices (such as the ones bundled with TV
471 cards).
472
473 lirc_sir module.
474
475 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8
476 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
477 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
478
479 Moduł lirc_sir.
480
481 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir
482 Summary:        Kernel modules for Linux Infrared Remote Control
483 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
484 Release:        %{rel}@%{_kernel_ver_str}
485 Group:          Base/Kernel
486 %if %{with dist_kernel}
487 %requires_releq_kernel
488 Requires(postun):       %releq_kernel
489 %endif
490 Requires(post,postun):  /sbin/depmod
491 Requires:       %{pname} = %{version}-%{rel}
492 Obsoletes:      lirc-modules
493 Obsoletes:      lirc-modules-ttusbir
494 Conflicts:      dev < 2.8.0-3
495
496 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir
497 This package contains the kernel modules necessary to operate
498 TechnoTrend USB IR Receiver.
499
500 lirc_ttusbir module.
501
502 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8
503 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
504 TechnoTrend USB IR Receiver.
505
506 Moduł lirc_ttusbir.
507
508 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691
509 Summary:        Kernel modules for Linux Infrared Remote Control
510 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
511 Release:        %{rel}@%{_kernel_ver_str}
512 Group:          Base/Kernel
513 %if %{with dist_kernel}
514 %requires_releq_kernel
515 Requires(postun):       %releq_kernel
516 %endif
517 Requires(post,postun):  /sbin/depmod
518 Requires:       %{pname} = %{version}-%{rel}
519 Conflicts:      dev < 2.8.0-3
520
521 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691
522 This package contains the kernel modules necessary to operate
523 TechnoTrend USB IR Receiver.
524
525 lirc_wpc87691 module.
526
527 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8
528 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
529 TechnoTrend USB IR Receiver.
530
531 Moduł lirc_wpc87691.
532
533 %package -n kernel%{_alt_kernel}-char-lirc-parallel
534 Summary:        Kernel modules for Linux Infrared Remote Control
535 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
536 Release:        %{rel}@%{_kernel_ver_str}
537 Group:          Base/Kernel
538 %if %{with dist_kernel}
539 %requires_releq_kernel
540 Requires(postun):       %releq_kernel
541 %endif
542 Requires(post,postun):  /sbin/depmod
543 Requires:       %{pname} = %{version}-%{rel}
544 Obsoletes:      lirc-modules
545 Obsoletes:      lirc-modules-parallel
546 Conflicts:      dev < 2.8.0-3
547
548 %description -n kernel%{_alt_kernel}-char-lirc-parallel
549 This package contains the kernel modules necessary to operate some
550 infrared remote control devices (such as the ones bundled with TV
551 cards).
552
553 lirc-parallel module for devices connected to parallel port.
554
555 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8
556 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
557 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
558
559 Moduł lirc_parallel dla urządzeń podłączanych do portu
560 równoległego.
561
562 %prep
563 %setup -q -n %{pname}-%{version} -a 1
564 %patch0 -p1
565 %patch1 -p1
566 %if !%{with svga}
567 %patch2 -p1
568 %endif
569 %patch3 -p1
570 %patch4 -p1
571 %patch5 -p1
572 %patch6 -p1
573 %patch7 -p1
574
575 %build
576 echo '#' > drivers/Makefile.am
577 %{__libtoolize}
578 %{__aclocal}
579 %{__automake}
580 %{__autoheader}
581 %{__autoconf}
582
583 %configure \
584         ac_cv_header_portaudio_h=no \
585 %if %{with kernel}
586         KERNELCC="%{kgcc}" \
587 %else
588         ac_cv_have_kernel="no_kernel=yes" \
589 %endif
590         --with-kerneldir=%{_kernelsrcdir} \
591         %{?with_x:--with-x} \
592         --with-port=0x2f8 \
593         --with-irq=3 \
594         --without-soft-carrier \
595         --with-driver=userspace \
596         --with-igor
597
598 %if %{with userspace}
599 %{__make} -j1
600 %endif
601
602 %if %{with kernel}
603 cd drivers
604
605 drivers=%{drivers}
606
607 for drv in $drivers; do
608         cd $drv
609         %{__make} clean \
610                 LIRC_DEVDIR=`pwd` \
611                 RCS_FIND_IGNORE="-name '*.ko' -o" \
612                 %{?with_verbose:V=1}
613
614         %{__make} -j1 \
615                 LIRC_DEVDIR=`pwd` \
616                 CONSTIFY_PLUGIN="" \
617                 KBUILD_MODPOST_WARN=1 \
618                 %{?with_verbose:V=1}
619         cd ..
620 done
621
622 cd ..
623
624 %endif
625
626 %install
627 rm -rf $RPM_BUILD_ROOT
628
629 %if %{with kernel}
630 drivers=%{drivers}
631 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
632 for drv in $drivers; do
633         install drivers/$drv/$drv.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/$drv.ko
634 done
635 %endif
636
637 %if %{with userspace}
638 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
639         $RPM_BUILD_ROOT/etc/{lirc,rc.d/init.d,sysconfig} \
640         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
641
642 %{__make} -j1 install \
643         DESTDIR=$RPM_BUILD_ROOT \
644         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
645
646 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
647 #
648 # This is a placeholder for your configuration file.
649 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
650 #
651 END
652 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
653 install contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
654 :> $RPM_BUILD_ROOT/var/log/lircd
655
656 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
657 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
658 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
659 install %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
660 %endif
661
662 %clean
663 rm -rf $RPM_BUILD_ROOT
664
665 %post   libs -p /sbin/ldconfig
666 %postun libs -p /sbin/ldconfig
667
668 %post
669 /sbin/chkconfig --add lircd
670 if [ -f /var/lock/subsys/lircd ]; then
671         /etc/rc.d/init.d/lircd restart >&2
672 else
673         echo "Run \"/etc/rc.d/init.d/lircd start\" to start lircd." >&2
674 fi
675 /sbin/chkconfig --add lircmd
676 if [ -f /var/lock/subsys/lircmd ]; then
677         /etc/rc.d/init.d/lircmd restart >&2
678 else
679         echo "Run \"/etc/rc.d/init.d/lircmd start\" to start lircmd." >&2
680 fi
681 echo "If you are using a kernel-module-based driver, don't forget to"
682 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> or"
683 echo "kernel%{_alt_kernel}-smp-char-lirc-<your_driver> package."
684
685 %preun
686 if [ "$1" = "0" ]; then
687         if [ -f /var/lock/subsys/lircd ]; then
688                 /etc/rc.d/init.d/lircd stop >&2
689         fi
690         /sbin/chkconfig --del lircd
691 fi
692 if [ "$1" = "0" ]; then
693         if [ -f /var/lock/subsys/lircmd ]; then
694                 /etc/rc.d/init.d/lircmd stop >&2
695         fi
696         /sbin/chkconfig --del lircmd
697 fi
698
699 %triggerpostun -- %{name} < 0.8.6-8
700 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
701         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
702 fi
703 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
704         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
705 fi
706
707 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb
708 %depmod %{_kernel_ver}
709 if [ "$1" = "1" ]; then
710         echo "Don't forget to add an 'alias lirc lirc_atiusb' line"
711         echo "to your /etc/modules.conf."
712 fi
713
714 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb
715 %depmod %{_kernel_ver}
716
717 %post   -n kernel%{_alt_kernel}-char-lirc-bt829
718 %depmod %{_kernel_ver}
719 if [ "$1" = "1" ]; then
720         echo "Don't forget to add an 'alias lirc lirc_bt829' line"
721         echo "to your /etc/modules.conf."
722 fi
723
724 %postun -n kernel%{_alt_kernel}-char-lirc-bt829
725 %depmod %{_kernel_ver}
726
727 %post   -n kernel%{_alt_kernel}-char-lirc-dev
728 %depmod %{_kernel_ver}
729
730 %postun -n kernel%{_alt_kernel}-char-lirc-dev
731 %depmod %{_kernel_ver}
732
733 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100
734 %depmod %{_kernel_ver}
735
736 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100
737 %depmod %{_kernel_ver}
738
739 %post   -n kernel%{_alt_kernel}-char-lirc-gpio
740 %depmod %{_kernel_ver}
741 if [ "$1" = "1" ]; then
742         echo "Don't forget to add an 'alias lirc lirc_gpio' line"
743         echo "to your /etc/modules.conf."
744 fi
745
746 %postun -n kernel%{_alt_kernel}-char-lirc-gpio
747 %depmod %{_kernel_ver}
748
749 %post   -n kernel%{_alt_kernel}-char-lirc-i2c
750 %depmod %{_kernel_ver}
751 if [ "$1" = "1" ]; then
752         echo "Don't forget to add an 'alias lirc lirc_i2c' line"
753         echo "to your /etc/modules.conf."
754 fi
755
756 %postun -n kernel%{_alt_kernel}-char-lirc-i2c
757 %depmod %{_kernel_ver}
758
759 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb
760 %depmod %{_kernel_ver}
761 if [ "$1" = "1" ]; then
762         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' line"
763         echo "to your /etc/modules.conf."
764 fi
765
766 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb
767 %depmod %{_kernel_ver}
768
769 %post   -n kernel%{_alt_kernel}-char-lirc-imon
770 %depmod %{_kernel_ver}
771 if [ "$1" = "1" ]; then
772         echo "Don't forget to add an 'alias lirc lirc_imon' line"
773         echo "to your /etc/modules.conf."
774 fi
775
776 %postun -n kernel%{_alt_kernel}-char-lirc-imon
777 %depmod %{_kernel_ver}
778
779 %post   -n kernel%{_alt_kernel}-char-lirc-sasem
780 %depmod %{_kernel_ver}
781 if [ "$1" = "1" ]; then
782         echo "Don't forget to add an 'alias lirc lirc_sasem' line"
783         echo "to your /etc/modules.conf."
784 fi
785
786 %postun -n kernel%{_alt_kernel}-char-lirc-sasem
787 %depmod %{_kernel_ver}
788
789 %post   -n kernel%{_alt_kernel}-char-lirc-serial
790 %depmod %{_kernel_ver}
791 if [ "$1" = "1" ]; then
792         echo "Don't forget to add an 'alias lirc lirc_serial' line"
793         echo "to your /etc/modules.conf."
794 fi
795
796 %postun -n kernel%{_alt_kernel}-char-lirc-serial
797 %depmod %{_kernel_ver}
798
799 %post   -n kernel%{_alt_kernel}-char-lirc-parallel
800 %depmod %{_kernel_ver}
801 if [ "$1" = "1" ]; then
802         echo "Don't forget to add an 'alias lirc lirc_parallel' line"
803         echo "to your /etc/modules.conf."
804 fi
805
806 %postun -n kernel%{_alt_kernel}-char-lirc-parallel
807 %depmod %{_kernel_ver}
808
809 %post   -n kernel%{_alt_kernel}-char-lirc-sir
810 %depmod %{_kernel_ver}
811 if [ "$1" = "1" ]; then
812         echo "Don't forget to add an 'alias lirc lirc_sir' line"
813         echo "to your /etc/modules.conf."
814 fi
815
816 %postun -n kernel%{_alt_kernel}-char-lirc-sir
817 %depmod %{_kernel_ver}
818
819 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir
820 %depmod %{_kernel_ver}
821 if [ "$1" = "1" ]; then
822         echo "Don't forget to add an 'alias lirc lirc_ttusbir' line"
823         echo "to your /etc/modules.conf."
824 fi
825
826 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir
827 %depmod %{_kernel_ver}
828
829 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691
830 %depmod %{_kernel_ver}
831 if [ "$1" = "1" ]; then
832         echo "Don't forget to add an 'alias lirc lirc_wpc87691' line"
833         echo "to your /etc/modules.conf."
834 fi
835
836 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691
837 %depmod %{_kernel_ver}
838
839 %if %{with userspace}
840 %files
841 %defattr(644,root,root,755)
842 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
843 %doc contrib/lircrc doc/{html,images,lirc.css}
844 %attr(755,root,root) %{_bindir}/ircat
845 %attr(755,root,root) %{_bindir}/irexec
846 %attr(755,root,root) %{_bindir}/irpty
847 %attr(755,root,root) %{_bindir}/irrecord
848 %attr(755,root,root) %{_bindir}/irsend
849 %attr(755,root,root) %{_bindir}/irw
850 %attr(755,root,root) %{_bindir}/mode2
851 %attr(755,root,root) %{_bindir}/lircrcd
852 %attr(755,root,root) %{_bindir}/pronto2lirc
853 %attr(755,root,root) %{_sbindir}/lircd
854 %attr(755,root,root) %{_sbindir}/lircmd
855 %attr(754,root,root) /etc/rc.d/init.d/lircd
856 %attr(754,root,root) /etc/rc.d/init.d/lircmd
857 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
858 %dir %{_sysconfdir}/lirc
859 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
860 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
861 %{_mandir}/man1/ircat.1*
862 %{_mandir}/man1/irexec.1*
863 %{_mandir}/man1/irpty.1*
864 %{_mandir}/man1/irrecord.1*
865 %{_mandir}/man1/irsend.1*
866 %{_mandir}/man1/irw.1*
867 %{_mandir}/man1/lircrcd.1*
868 %{_mandir}/man1/mode2.1*
869 %{_mandir}/man8/lircd.8*
870 %{_mandir}/man8/lircmd.8*
871 %attr(600,root,root) %ghost /var/log/lircd
872 %dir /var/run/lirc
873 /usr/lib/tmpfiles.d/%{name}.conf
874
875 %files remotes
876 %defattr(644,root,root,755)
877 # XXX: are jpegs in docs (remotes) a good idea?
878 %doc remotes
879
880 %if %{with x}
881 %files X11
882 %defattr(644,root,root,755)
883 %doc doc/irxevent.keys
884 %attr(755,root,root) %{_bindir}/irxevent
885 %attr(755,root,root) %{_bindir}/xmode2
886 %{_mandir}/man1/irxevent.1*
887 %{_mandir}/man1/xmode2.1*
888 %endif
889
890 %if %{with svga}
891 %files svga
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_bindir}/smode2
894 %{_mandir}/man1/smode2.1*
895 %endif
896
897 %files libs
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
900 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
901
902 %files devel
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/liblirc_client.so
905 %{_libdir}/liblirc_client.la
906 %{_includedir}/lirc
907 %{_aclocaldir}/lirc.m4
908
909 %files static
910 %defattr(644,root,root,755)
911 %{_libdir}/liblirc_client.a
912 %endif
913
914 %if %{with kernel}
915 %files -n kernel%{_alt_kernel}-char-lirc-atiusb
916 %defattr(644,root,root,755)
917 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*
918
919 %files -n kernel%{_alt_kernel}-char-lirc-bt829
920 %defattr(644,root,root,755)
921 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*
922
923 %files -n kernel%{_alt_kernel}-char-lirc-dev
924 %defattr(644,root,root,755)
925 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*
926
927 %if "%{_kernel_ver}" < "3.0.0"
928 %files -n kernel%{_alt_kernel}-char-lirc-ene0100
929 %defattr(644,root,root,755)
930 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*
931 %endif
932
933 %if "%{_kernel_ver}" < "2.6.23"
934 %files -n kernel%{_alt_kernel}-char-lirc-gpio
935 %defattr(644,root,root,755)
936 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*
937 %endif
938
939 %files -n kernel%{_alt_kernel}-char-lirc-i2c
940 %defattr(644,root,root,755)
941 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*
942
943 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb
944 %defattr(644,root,root,755)
945 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*
946
947 %files -n kernel%{_alt_kernel}-char-lirc-imon
948 %defattr(644,root,root,755)
949 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*
950
951 %files -n kernel%{_alt_kernel}-char-lirc-sasem
952 %defattr(644,root,root,755)
953 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*
954
955 %files -n kernel%{_alt_kernel}-char-lirc-serial
956 %defattr(644,root,root,755)
957 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*
958
959 %files -n kernel%{_alt_kernel}-char-lirc-sir
960 %defattr(644,root,root,755)
961 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*
962
963 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir
964 %defattr(644,root,root,755)
965 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*
966
967 %if "%{_kernel_ver}" < "3.0.0"
968 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691
969 %defattr(644,root,root,755)
970 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*
971 %endif
972
973 %files -n kernel%{_alt_kernel}-char-lirc-parallel
974 %defattr(644,root,root,755)
975 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*
976 %endif
This page took 0.219144 seconds and 3 git commands to generate.