]> git.pld-linux.org Git - SPECS.git/blob - linux-libc-headers.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / linux-libc-headers.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define basever 5.13
6 %define postver 0
7 Summary:        Linux kernel headers for use with C libraries
8 Summary(pl.UTF-8):      Nagłówki jądra Linuksa do użytku z bibliotekami C
9 Name:           linux-libc-headers
10 Version:        %{basever}.%{postver}
11 Release:        1
12 Epoch:          7
13 License:        GPL v2
14 Group:          Development
15 Source0:        https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{basever}.tar.xz
16 # Source0-md5:  76c60fb304510a7bbd9c838790bc5fe4
17 %if "%{postver}" > "0"
18 Source1:        https://www.kernel.org/pub/linux/kernel/v5.x/patch-%{version}.xz
19 # Source1-md5:  d8273731ed72ed885ab815d3805ecd67
20 %endif
21 Patch0:         %{name}-esfq.patch
22 Patch1:         %{name}-wrr.patch
23 Patch2:         %{name}-fbsplash.patch
24 Patch3:         %{name}-imq.patch
25 Patch4:         %{name}-pom-set.patch
26 Patch5:         %{name}-atm-vbr.patch
27 Patch6:         vserver.patch
28 AutoReqProv:    no
29 BuildRequires:  perl-base
30 BuildRequires:  rpmbuild(macros) >= 1.568
31 BuildRequires:  rsync
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires(pretrans):     coreutils
35 Obsoletes:      alsa-driver-devel
36 Obsoletes:      glibc-kernel-headers
37 Obsoletes:      glibc-kernheaders
38 Conflicts:      lm_sensors-devel < 2.8.2-2
39 ExclusiveOS:    Linux
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %ifarch ppc ppc64
43 %define target_arch powerpc
44 %else
45 %ifarch x32
46 %define target_arch x86_64
47 %else
48 %ifarch aarch64
49 %define target_arch arm64
50 %else
51 %define target_arch %{_target_base_arch}
52 %endif
53 %endif
54 %endif
55
56 # no objects to extract debug info from
57 %define         _enable_debug_packages  0
58
59 %description
60 This package includes the C header files that specify the interface
61 between the Linux kernel and userspace libraries and programs. The
62 header files define structures and constants that are needed for
63 building most standard programs and are also needed for rebuilding the
64 glibc package.
65
66 %description -l pl.UTF-8
67 Ten pakiet zawiera pliki nagłówkowe C, które definiują interfejs
68 między jądrem Linuksa a bibliotekami i programami działającymi w
69 przestrzeni użytkownika. Pliki nagłówkowe definiują struktury i stałe
70 potrzebne do zbudowania większości standardowych programów, są także
71 potrzebne do przebudowania pakietu glibc.
72
73 %prep
74 %setup -q -c
75 cd linux-%{basever}
76 %if "%{postver}" > "0"
77 bzip2 -dc %{SOURCE1} | patch -p1
78 %endif
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82 %patch3 -p1
83 %patch4 -p1
84 %patch5 -p1
85 %patch6 -p1
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} -C linux-%{basever} headers_install \
90         INSTALL_HDR_PATH=$RPM_BUILD_ROOT%{_prefix} \
91         ARCH=%{target_arch}
92
93 %if %{with tests}
94 %{__make} -C linux-%{basever} headers_check \
95         INSTALL_HDR_PATH=$RPM_BUILD_ROOT%{_prefix} \
96         ARCH=%{target_arch}
97 %endif
98
99 # provided by glibc-headers
100 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/scsi
101
102 # currently provided by libdrm-devel
103 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/drm
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %pretrans
109 [ ! -L /usr/include/linux ] || rm -f /usr/include/linux
110 [ ! -L /usr/include/asm ] || rm -f /usr/include/asm
111 [ ! -L /usr/include/sound ] || rm -f /usr/include/sound
112
113 %files
114 %defattr(644,root,root,755)
115 %{_includedir}/asm
116 %{_includedir}/asm-generic
117 %{_includedir}/linux
118 %{_includedir}/misc
119 %{_includedir}/mtd
120 %{_includedir}/rdma
121 %{_includedir}/sound
122 %{_includedir}/video
123 %{_includedir}/xen
This page took 1.191648 seconds and 3 git commands to generate.