]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
- fix patching
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_pcmcia  # PCMCIA support in kernel drivers
6 %bcond_without  drivers_usb     # USB kernel drivers
7 %bcond_without  userspace       # userspace packages
8 %bcond_without  verbose         # verbose modules build (V=1)
9
10 %bcond_without  docs            # documentation build
11 %bcond_with     hotplug         # legacy hotplug support
12 %bcond_without  static_libs     # static library
13 %bcond_without  guile           # guile binding
14 %bcond_without  perl            # Perl binding
15 %bcond_with     php             # PHP binding
16 %bcond_without  python          # Python binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %ifnarch %{ix86}
29 %undefine       with_drivers_isa
30 %undefine       with_drivers_pcmcia
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34 %define         php_name        php%{?php_suffix}
35
36 %define         rel     1
37 %define         pname   linux-gpib
38 Summary:        GPIB (IEEE 488) Linux support
39 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
40 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
41 Version:        4.3.0
42 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
43 License:        GPL v2+
44 Group:          Applications/System
45 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
46 # Source0-md5:  3085422695baf210b866601db6108860
47 Patch2:         %{pname}-python.patch
48 Patch3:         %{pname}-perl.patch
49 Patch4:         %{pname}-firmwaredir.patch
50 Patch5:         %{pname}-guile2.patch
51 Patch6:         %{pname}-php7.patch
52 Patch8:         kernel-5.2.patch
53 URL:            http://linux-gpib.sourceforge.net/
54 BuildRequires:  autoconf >= 2.50
55 BuildRequires:  automake
56 BuildRequires:  libtool
57 BuildRequires:  rpmbuild(macros) >= 1.614
58 %if %{with kernel}
59 BuildRequires:  kernel-module-build >= 3:2.6.8
60 %endif
61 %if %{with userspace}
62 BuildRequires:  bison
63 %{?with_docs:BuildRequires:     docbook-utils}
64 BuildRequires:  flex
65 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
66 %{?with_perl:BuildRequires:     perl-devel}
67 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
68 %{?with_python:BuildRequires:   python-devel >= 2}
69 BuildRequires:  readline-devel
70 %{?with_tcl:BuildRequires:      tcl-devel}
71 %endif
72 Requires:       %{pname}-libs = %{version}-%{release}
73 # for agilent_82357a and ni_usb_gpib
74 Suggests:       fxload
75 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
76 Suggests:       linux-gpib-firmware
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %description
80 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
81
82 %description -l pl.UTF-8
83 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
84
85 %package hotplug
86 Summary:        Linux GPIB support for legacy USB hotplug
87 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
88 Group:          Applications/System
89 Requires:       %{pname} = %{version}-%{release}
90 Requires:       hotplug
91
92 %description hotplug
93 Linux GPIB support for legacy USB hotplug.
94
95 %description hotplug -l pl.UTF-8
96 Obsługa Linux GPIB dla starego systemu hotplug USB.
97
98 %package libs
99 Summary:        Shared GPIB library
100 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
101 Group:          Libraries
102
103 %description libs
104 Shared GPIB library.
105
106 %description libs -l pl.UTF-8
107 Biblioteka współdzielona GPIB.
108
109 %package devel
110 Summary:        Header file for GPIB library
111 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
112 Group:          Development/Libraries
113 Requires:       %{pname}-libs = %{version}-%{release}
114
115 %description devel
116 Header file for GPIB library.
117
118 %description devel -l pl.UTF-8
119 Plik nagłówkowy biblioteki GPIB.
120
121 %package static
122 Summary:        Static GPIB library
123 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
124 Group:          Development/Libraries
125 Requires:       %{pname}-devel = %{version}-%{release}
126
127 %description static
128 Static GPIB library.
129
130 %description static -l pl.UTF-8
131 Biblioteka statyczna GPIB.
132
133 %package -n guile-gpib
134 Summary:        Guile bindings for GPIB library
135 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
136 Group:          Development/Languages/Perl
137 Requires:       %{pname}-libs = %{version}-%{release}
138 Requires:       guile-libs
139
140 %description -n guile-gpib
141 Guile bindings for GPIB library.
142
143 %description -n guile-gpib -l pl.UTF-8
144 Wiązania Guile do biblioteki GPIB.
145
146 %package -n perl-gpib
147 Summary:        Perl bindings for GPIB library
148 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
149 Group:          Development/Languages/Perl
150 Requires:       %{pname}-libs = %{version}-%{release}
151
152 %description -n perl-gpib
153 Perl bindings for GPIB library.
154
155 %description -n perl-gpib -l pl.UTF-8
156 Wiązania Perla do biblioteki GPIB.
157
158 %package -n %{php_name}-gpib
159 Summary:        PHP bindings for GPIB library
160 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
161 Group:          Development/Languages/PHP
162 Provides:       php(gpib) = %{version}
163 Requires:       %{pname}-libs = %{version}-%{release}
164 %{?requires_php_extension}
165
166 %description -n %{php_name}-gpib
167 PHP bindings for GPIB library.
168
169 %description -n %{php_name}-gpib -l pl.UTF-8
170 Wiązania PHP do biblioteki GPIB.
171
172 %package -n python-gpib
173 Summary:        Python bindings for GPIB library
174 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GPIB
175 Group:          Libraries/Python
176 Requires:       %{pname}-libs = %{version}-%{release}
177 Requires:       python-libs
178
179 %description -n python-gpib
180 Python bindings for GPIB library.
181
182 %description -n python-gpib -l pl.UTF-8
183 Wiązania Pythona do biblioteki GPIB.
184
185 %package -n tcl-gpib
186 Summary:        Tcl bindings for GPIB library
187 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
188 Group:          Libraries
189 Requires:       %{pname}-libs = %{version}-%{release}
190 Requires:       tcl
191
192 %description -n tcl-gpib
193 Tcl bindings for GPIB library.
194
195 %description -n tcl-gpib -l pl.UTF-8
196 Wiązania Tcl-a do biblioteki GPIB.
197
198 %package doc
199 Summary:        Linux-GPIB tools and library documentation
200 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
201 License:        GFDL v1.2+ or GPL v2+
202 Group:          Documentation
203
204 %description doc
205 Linux-GPIB tools and library documentation.
206
207 %description doc -l pl.UTF-8
208 Dokumentacja narzędzi i biblioteki Linux-GPIB.
209
210 %define kernel_pkg()\
211 %package -n kernel%{_alt_kernel}-gpib\
212 Summary:        Linux GPIB drivers\
213 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
214 Release:        %{rel}@%{_kernel_ver_str}\
215 Group:          Base/Kernel\
216 Requires(post,postun):  /sbin/depmod\
217 %requires_releq_kernel\
218 Requires(postun):       %releq_kernel\
219 \
220 %description -n kernel%{_alt_kernel}-gpib\
221 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
222 \
223 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
224 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
225 \
226 %if %{with kernel}\
227 %files -n kernel%{_alt_kernel}-gpib\
228 %defattr(644,root,root,755)\
229 /lib/modules/%{_kernel_ver}/kernel/gpib\
230 %endif\
231 \
232 %post -n kernel%{_alt_kernel}-gpib\
233 %depmod %{_kernel_ver}\
234 \
235 %postun -n kernel%{_alt_kernel}-gpib\
236 %depmod %{_kernel_ver}\
237 %{nil}
238
239 %define build_kernel_pkg()\
240 %{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
241 cd drivers/gpib\
242 %ifarch %{ix86}\
243 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
244 %else\
245 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
246 %endif\
247 cd ../..\
248 %{nil}
249
250 %define install_kernel_pkg()\
251 %{nil}
252
253 %{?with_kernel:%{expand:%create_kernel_packages}}
254
255 %prep
256 %setup -q -n %{pname}-%{version}
257 %if %{with userspace}
258 tar xzf linux-gpib-user-%{version}.tar.gz
259 cd linux-gpib-user-%{version}
260 %patch2 -p1
261 %patch3 -p1
262 %patch4 -p1
263 %patch5 -p1
264 #%patch6 -p1
265 cd ..
266 %endif
267
268 %if %{with kernel}
269 tar xzf linux-gpib-kernel-%{version}.tar.gz
270 cd linux-gpib-kernel-%{version}
271 %ifarch %{ix86}
272 %patch8 -p1
273 %endif
274 %endif
275
276 %build
277 %if %{with userspace}
278 cd linux-gpib-user-%{version}
279 %{__libtoolize}
280 %{__aclocal}
281 %{__autoconf}
282 %{__autoheader}
283 %{__automake}
284 %if %{with guile}
285 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
286 %endif
287 %configure \
288         --with-udev-libdir=/lib/udev \
289         %{?with_drivers_isa:--enable-isa} \
290         %{?with_drivers_pcmcia:--enable-pcmcia} \
291         %{!?with_docs:--disable-documentation} \
292         %{!?with_guile:--disable-guile-binding} \
293         %{!?with_perl:--disable-perl-binding} \
294         %{!?with_php:--disable-php-binding} \
295         %{!?with_python:--disable-python-binding} \
296         %{?with_static_libs:--enable-static} \
297         %{!?with_tcl:--disable-tcl-binding}
298
299 %{__make}
300 cd ..
301 %endif
302
303 %if %{with kernel}
304 cd linux-gpib-kernel-%{version}
305 %{expand:%build_kernel_packages}
306 %endif
307
308 %install
309 rm -rf $RPM_BUILD_ROOT
310 install -d $RPM_BUILD_ROOT%{_examplesdir}
311
312 %if %{with kernel}
313 cd linux-gpib-kernel-%{version}
314 %{expand:%install_kernel_packages}
315 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
316 cd ..
317 %endif
318
319 %if %{with userspace}
320 cd linux-gpib-user-%{version}
321 %{__make} install \
322         DESTDIR=$RPM_BUILD_ROOT \
323         HOTPLUG_USB_CONF_DIR=/lib/udev \
324         UDEV_RULES_DIR=/lib/udev/rules.d \
325         USB_FIRMWARE_DIR=/lib/firmware
326
327 %if %{with hotplug}
328 # use udev paths as base and legacy hotplug as addon (not the opposite)
329 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
330 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
331 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
332 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
333 %endif
334
335 # obsoleted by pkg-config
336 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
337
338 %if %{with guile}
339 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
340 %if %{with static_libs}
341 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
342 %endif
343 %endif
344
345 %if %{with perl}
346 %{__make} -C language/perl pure_install \
347         DESTDIR=$RPM_BUILD_ROOT
348
349 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
350
351 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
352 %endif
353
354 %if %{with php}
355 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
356 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
357 ; Enable gpib extension module
358 extension=gpib_php.so
359 EOF
360
361 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
362 %if %{with static_libs}
363 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
364 %endif
365 %endif
366
367 %if %{with python}
368 %py_postclean
369 %endif
370
371 %if %{with tcl}
372 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
373
374 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
375 %if %{with static_libs}
376 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
377 %endif
378 %endif
379
380 %if %{with docs}
381 # packaged as %doc
382 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
383 %endif
384 %endif
385
386 %clean
387 rm -rf $RPM_BUILD_ROOT
388
389 %post   libs -p /sbin/ldconfig
390 %postun libs -p /sbin/ldconfig
391
392 %post   -n guile-gpib -p /sbin/ldconfig
393 %postun -n guile-gpib -p /sbin/ldconfig
394
395 %post   -n tcl-gpib -p /sbin/ldconfig
396 %postun -n tcl-gpib -p /sbin/ldconfig
397
398 %post   -n %{php_name}-gpib
399 %php_webserver_restart
400
401 %postun -n %{php_name}-gpib
402 if [ "$1" = 0 ]; then
403         %php_webserver_restart
404 fi
405
406 %if %{with userspace}
407 %files
408 %defattr(644,root,root,755)
409 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
410 %attr(755,root,root) %{_bindir}/ibterm
411 %attr(755,root,root) %{_bindir}/ibtest
412 %attr(755,root,root) %{_sbindir}/gpib_config
413 /lib/udev/rules.d/98-gpib-generic.rules
414 /lib/udev/rules.d/99-agilent_82357a.rules
415 /lib/udev/rules.d/99-ni_usb_gpib.rules
416 %attr(755,root,root) /lib/udev/gpib_udev_config
417 %attr(755,root,root) /lib/udev/gpib_udev_fxloader
418 %attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
419
420 %if %{with hotplug}
421 %files hotplug
422 %defattr(644,root,root,755)
423 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
424 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
425 /etc/hotplug/usb/agilent_82357a.usermap
426 /etc/hotplug/usb/ni_usb_gpib.usermap
427 %endif
428
429 %files libs
430 %defattr(644,root,root,755)
431 %doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
432 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
433 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
434
435 %files devel
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/libgpib.so
438 %{_includedir}/gpib
439 %{_pkgconfigdir}/libgpib.pc
440
441 %if %{with static_libs}
442 %files static
443 %defattr(644,root,root,755)
444 %{_libdir}/libgpib.a
445 %endif
446
447 %if %{with guile}
448 %files -n guile-gpib
449 %defattr(644,root,root,755)
450 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
451 %attr(755,root,root) %{_libdir}/libgpib-guile.so
452 %endif
453
454 %if %{with perl}
455 %files -n perl-gpib
456 %defattr(644,root,root,755)
457 %doc linux-gpib-user-%{version}/language/perl/{Changes,README}
458 %{perl_vendorarch}/LinuxGpib.pm
459 %dir %{perl_vendorarch}/auto/LinuxGpib
460 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
461 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
462 %{_mandir}/man3/LinuxGpib.3pm*
463 %{_examplesdir}/perl-gpib-%{version}
464 %endif
465
466 %if %{with php}
467 %files -n %{php_name}-gpib
468 %defattr(644,root,root,755)
469 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
470 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
471 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
472 %endif
473
474 %if %{with python}
475 %files -n python-gpib
476 %defattr(644,root,root,755)
477 %doc linux-gpib-user-%{version}/language/python/README
478 %attr(755,root,root) %{py_sitedir}/gpib.so
479 %{py_sitedir}/Gpib.py[co]
480 %{py_sitedir}/gpib-1.0-py*.egg-info
481 %endif
482
483 %if %{with tcl}
484 %files -n tcl-gpib
485 %defattr(644,root,root,755)
486 %doc linux-gpib-user-%{version}/language/tcl/README
487 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
488 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
489 %{_examplesdir}/tcl-gpib-%{version}
490 %endif
491
492 %if %{with docs}
493 %files doc
494 %defattr(644,root,root,755)
495 %doc linux-gpib-user-%{version}/doc/doc_html/*
496 %endif
497 %endif
This page took 0.05661 seconds and 4 git commands to generate.